Come correggere un errore #VALORE! nella funzione MATR.SOMMA.PRODOTTO

Questo argomento descrive gli scenari comuni dell'errore #VALORE! durante l'uso della funzione MATR.SOMMA.PRODOTTO.

Problema: Gli argomenti della matrice non hanno le stesse dimensioni

Tutti gli argomenti della matrice devono avere le stesse dimensioni, in caso contrario viene restituito l'errore #VALORE!. Ad esempio, se la matrice 1 fa riferimento a un intervallo di 3 righe e 2 colonne, anche la matrice 2 deve corrispondere a un intervallo simile.

La formula MATR.SOMMA.PRODOTTO che causa un errore è =MATR.SOMMA.PRODOTTO(D2:D13,E2:E10). E10 deve essere sostituito con E13 per corrispondere al primo intervallo.
  • =MATR.SOMMA.PRODOTTO(D2:D13,E2:E10)

Non riesce perché gli intervalli a cui si fa riferimento non hanno lo stesso numero di righe: 13 del primo intervallo, ma solo 10 nel secondo.

Soluzione: Cambiare la formula in:

  • =MATR.SOMMA.PRODOTTO(D2:D13,E2:E13)

In modo che entrambi gli intervalli abbiano gli stessi numeri di riga iniziali e finali, quindi riprovare la formula.

Risolvere l'errore #VALORE! nei dati per risolvere l'errore MATR.SOMMA.PRODOTTO

Problema: Una o più celle nell'intervallo contengono testo

Se una o più celle nell'intervallo a cui viene fatto riferimento contengono testo o sono formattate come tipo di dati Testo, viene restituito l'errore #VALORE!. Il testo potrebbe essere il risultato di un calcolo in un'altra formula oppure, semplicemente, la cella non è formattata correttamente.

La formula nella cella E15 mostra un errore #VALORE! perché è presente un errore #VALORE! nella colonna E.

Soluzione: Cercare le celle che contengono testo o sono formattate come testo e impostarle sul tipo di dati corretto.

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Si hanno suggerimenti su come migliorare la prossima versione di Excel? In questo caso, guardare gli argomenti in Excel User Voice.

Vedere anche

Correggere un errore #VALORE!

Funzione MATR.SOMMA.PRODOTTO

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per correggere errori comuni nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Tutte le funzioni di Excel (per categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×