Come correggere un errore #VALORE! nella funzione CONCATENA

Importante : In Excel 2016, Excel Mobile e Excel Online CONCATENA è stato sostituito dalla funzione CONCAT. Anche se la funzione CONCATENA è ancora disponibile per assicurare la compatibilità con le versioni precedenti, è consigliabile usare la funzione CONCAT perché è più solida.

Uno degli scenari più comuni in cui viene restituito l'errore #VALORE! con CONCATENA è quando si prova a creare una stringa che include un riferimento di cella con un errore, ad esempio #VALORE!.

Nell'esempio seguente si proverà a concatenare D2, E2 e F2, in cui E2 ha un errore #VALORE!.

Errore #VALORE! in CONCATENA

L'errore in E2 comporta la visualizzazione dell'errore #VALORE! nella funzione. Per funzionare correttamente, è necessario sostituire l'errore con un valore diverso da quello dell'errore. È possibile creare una formula che verifica la presenza di un errore nel riferimento di cella e, se lo trova, visualizza la stringa di testo in cui compare 0 al posto dell'errore. In alternativa, è possibile sostituire 0 con testo personalizzato, ma è necessario disporre il testo tra virgolette, ad esempio "Testo personalizzato".

La formula seguente funzionerà correttamente:

=SE(VAL.ERRORE(E2),CONCATENA(D2," ",0," ",F2))

Funzioni SE e VAL.ERRORE usate come soluzione alternativa per concatenare una stringa con errore #VALORE!

Come funziona? La funzione usa la funzione SE.ERRORE per determinare se è presente un errore in E2 e lo trova, la funzione CONCATENA combina i valori in D2, E2 e F2, sostituendo l'errore con uno 0, e visualizza la stringa di testo risultante. Notare che la formula usa anche alcuni spazi (" ") per separare i valori.

Correggere l'errore #VALORE! con CONCATENA in Excel 2003 e versioni precedenti

Se viene restituito l'errore #VALORE! in Office Excel 2003 o in versioni precedenti, è necessario deselezionare l'opzione Valutazione alternativa delle espressioni in Excel. Seguire i passaggi descritti in Errore #VALORE! durante la concatenazione delle celle per risolvere il problema.

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Si hanno suggerimenti su come migliorare la prossima versione di Excel? In questo caso, guardare gli argomenti in Excel User Voice.

Vedere anche

Correggere un errore #VALORE!

Funzione CONCATENA

Funzione CONCAT

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per correggere errori comuni nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Tutte le funzioni di Excel (per categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×