Come correggere un errore #RIF!

Come correggere un errore #RIF!

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Il #REF! errore viene visualizzato quando una formula fa riferimento a una cella che non è valida. Si verifica questo evento più spesso quando le celle che sono state riferimento in formule ottenere eliminate o incollate sopra.

Esempio: errore #RIF! causato dall'eliminazione di una colonna

L'esempio seguente usa la formula =SOMMA(B2,C2,D2) nella colonna E.

Una formula che usa riferimenti di cella espliciti come =SOMMA(B2,C2,D2) può causare un errore #RIF! se una colonna viene eliminata.

Se si elimina la colonna B, C e D comporterebbe #REF! errore. In questo caso è necessario eliminare la colonna C (2007 Sales) e la formula è ora =SUM(B2,#REF!,C2). Quando si utilizzano riferimenti di cella espliciti … (in cui si fa riferimento singolarmente ogni cella, separati da un punto e virgola) ed eliminare una riga di riferimento o una colonna, Excel non è possibile risolvere il problema, in modo che restituisca la #REF! errore. Questo è il motivo principale perché usando i riferimenti di cella espliciti nelle funzioni non è consigliabile.

Esempio di errore #RIF! causato dall'eliminazione di una colonna.

Soluzione

  • Se si eliminano accidentalmente righe o colonne, è possibile ripristinarle facendo subito clic sul pulsante Annulla nella barra di accesso rapido o premendo CTRL+Z.

  • Modificare la formula in modo che utilizzi un riferimento a un intervallo anziché singole celle, ad esempio =SUM(B2:D2). A questo punto è possibile eliminare qualsiasi colonna all'interno dell'intervallo di somma ed Excel viene regolata automaticamente la formula. È anche possibile utilizzare =SUM(B2:B5) per un totale di righe.

Esempio: CERCA.VERT con riferimenti a un intervallo non corretti

Nell'esempio seguente =CERCA.VERT(A8,A2:D5,5,FALSO) restituisce un errore #RIF! perché cerca un valore da restituire per la colonna 5, ma l'intervallo di riferimento è A:D, che contiene solo 4 colonne.

Esempio di formula CERCA.VERT con un intervallo non corretto.  La formula è =CERCA.VERT(A8,A2:D5,5,FALSO).  L'intervallo CERCA.VERT non contiene una quinta colonna, quindi 5 restituisce un errore #RIF!.

Soluzione

Regolare l'intervallo per essere maggiore o ridurre il valore di ricerca di colonna in modo che corrisponda l'intervallo di riferimento. =VLOOKUP(a8,a2:E5,5,false) è un intervallo di riferimento valido, seguendo la procedura = VLOOKUP(A8,A2:D5,4,FALSE).

Esempio: INDICE con riferimento di riga o di colonna non corretto

In questo esempio la formula =INDICE(B2:E5,5,5) restituisce un errore #RIF! perché l'intervallo INDICE è di 4 righe per 4 colonne, mentre la formula chiede di restituire il contenuto della quinta riga e della quinta colonna.

Esempio di formula INDICE con un riferimento a un intervallo non valido.  La formula è =INDICE(B2:E5,5,5), ma l'intervallo è solo 4 righe per 4 colonne.

Soluzione

Aggiornare i riferimenti di riga o colonna in modo che siano compresa nell'intervallo di ricerca indice. =Index(B2:E5,4,4) restituisce un risultato valido.

Esempio: riferimento a una cartella di lavoro chiusa con INDIRETTO

Nell'esempio seguente una funzione INDIRETTO prova a fare riferimento a una cartella di lavoro chiusa, causando un errore #RIF!.

Esempio di errore #RIF! causato da un riferimento INDIRETTO a una cartella di lavoro chiusa.

Soluzione

Aprire la cartella di lavoro a cui si fa riferimento

Problemi OLE

Se si usa un collegamento OLE (Object Linking and Embedding) che restituisce un errore #RIF!, avviare il programma chiamato dal collegamento.

Nota: OLE è una tecnologia che consente di condividere informazioni tra i programmi.

Problemi DDE

Se si utilizzano un argomento di Exchange DDE (Dynamic Data) che restituisce #REF! errore, verificare prima che si sta facendo riferimento l'argomento corretto. Se si ricevono ancora #REF! errore, verificare le Impostazioni Centro protezione per il contenuto esterno come delineata blocco o sblocco di contenuti esterni nei documenti di Office.

Nota: Exchange DDE (Dynamic Data)è un protocollo stabilito per lo scambio di dati tra i programmi Microsoft basato su Windows.

Problemi con le macro

Se una macro immette una funzione del foglio di lavoro che fa riferimento a una cella sopra la funzione e la cella contenente la funzione trova nella riga 1, la funzione restituirà #REF! perché non sono presenti celle sopra la riga 1. Controllare la funzione per verificare se un argomento fa riferimento a una cella o intervallo di celle che non è valido. Potrebbe essere necessario modificare la macro in Visual Basic Editor (VBE) per eseguire tale situazione in considerazione.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per trovare gli errori nelle formule

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×