Come correggere un errore #N/D

Come correggere un errore #N/D

In genere l'errore #N/D indica che una formula non riesce a trovare un valore richiesto.

Soluzione principale

La causa più comune dell'errore #N/D con le funzioni CERCA.VERT, CERCA.ORIZZ, CERCA o CONFRONTA è che una formula non riesce a trovare un valore a cui si fa riferimento. Ad esempio, il valore di ricerca non esiste nei dati di origine.

Il valore di ricerca non esiste.  La formula nella cella E2 è = CERCA.VERT(D2,$D$6:$E$8,2,FALSO).  Il valore Banana non viene trovato, quindi la formula restituisce un errore #N/D.
Elemento non trovato nei dati di origine

In questo caso nella tabella di ricerca non è presente il valore "Banane", pertanto CERCA.VERT restituisce un errore #N/D.

Soluzione: verificare che il valore di ricerca esista nei dati di origine o usare un gestore di errori nella formula, ad esempio SE.ERRORE. Ad esempio, =SE.ERRORE(FORMULA(),0), che significa:

  • =SE(la formula restituisce un errore, restituire 0, in caso contrario restituire il risultato della formula)

Si può usare "" per non visualizzare nulla oppure visualizzare un testo personalizzato: SE.ERRORE(FORMULA(),"Messaggio di errore")

Se non si sa cosa fare a questo punto o quale tipo di assistenza è necessario, è consigliabile cercare domande simili nel forum della community di Excel o pubblicarne una nuova.

Collegamento al forum della community di Excel

Per andare avanti, l'elenco di controllo seguente offre alcune procedure di risoluzione dei problemi utili per identificare gli errori nelle formule.

Il valore di ricerca e i dati di origine hanno tipi di dati diversi. Ad esempio, si prova a fare in modo che CERCA.VERT faccia riferimento a un numero, ma i dati di origine sono archiviati come testo.

Tipi di valore non corretti.  Esempio di formula CERCA.VERT che restituisce un errore #N/D perché l'elemento di ricerca è formattato come numero, mentre la tabella di ricerca come testo.
Errore #N/D causato da tipi di dati diversi

Soluzione: Assicurarsi che i tipi di dati siano identici. Per controllare i formati delle celle, selezionare una cella o intervallo di celle, fare clic con il pulsante destro del mouse e scegliere Formato celle > Numero (o premere CTRL+1) e cambiare il formato numero, se necessario.

Finestra di dialogo Formato celle che visualizza la scheda Numero e l'opzione Testo selezionate

Suggerimento : Se è necessario forzare una modifica del formato su un'intera colonna, applicare il formato desiderato, quindi usare Dati > Testo in colonne > Fine.

È possibile usare la funzione ANNULLA.SPAZI per rimuovere gli eventuali spazi iniziali o finali. L'esempio seguente usa ANNULLA.SPAZI annidata all'interno di una funzione CERCA.VERT per rimuovere gli spazi iniziali dai nomi in A2:A7 e restituire il nome del reparto.

Usare CERCA.VERT con ANNULLA.SPAZI in una formula di matrice per rimuovere gli spazi iniziali o finali.  La formula nella cella E3 è {=CERCA.VERT(D2,ANNULLA.SPAZI(A2:B7),2,FALSO)} e deve essere immessa con CTRL+MAIUSC+INVIO.

{=CERCA.VERT(D2;ANNULLA.SPAZI(A2:B7);2;FALSO)}

Nota : Si tratta di una formula di matrice e quindi deve essere immessa con CTRL+MAIUSC+INVIO. Excel inserisce automaticamente la formula tra parentesi graffe {}. Se si prova a immettere la formula manualmente, Excel la visualizza come testo.

Per impostazione predefinita, le funzioni che cercano informazioni nelle tabelle devono essere disposte in ordine crescente. Le funzioni del foglio di lavoro CERCA.VERT e CERCA.ORIZZ, tuttavia, contengono un argomento intervallo che indica alla funzione di trovare una corrispondenza esatta anche se la tabella non è ordinata. Per trovare una corrispondenza esatta, impostare l'argomento intervallo su FALSO. Si noti che l'uso di VERO, che indica alla funzione di cercare una corrispondenza approssimativa, può non solo causare un errore #N/D, ma anche restituire risultati errati, come illustrato nell'esempio seguente.

Esempio dell'uso di CERCA.VERT con l'argomento intervallo VERO che può restituire risultati non validi.
CERCA.VERT ha esito negativo a causa dell'uso dell'argomento Corrispondenza approssimativa in una tabella non ordinata

In questo esempio, non solo "Banane" restituisce un errore #N/D, ma "Pere" restituisce il prezzo sbagliato. Il motivo è l'uso dell'argomento VERO, che indica alla funzione CERCA.VERT di cercare una corrispondenza approssimativa anziché una corrispondenza esatta. Non esiste una corrispondenza simile per "Banane" e "Pere" precede "Pesche" nell'ordine alfabetico. In questo caso, usare CERCA.VERT con l'argomento FALSO restituirebbe il prezzo corretto per "Pere", ma "Banane" restituirebbe comunque un errore #N/D, perché nell'elenco di ricerca non esiste alcun valore "Banane" corrispondente.

Se si usa la funzione CONFRONTA, modificare il valore dell'argomento corrisp per specificare l'ordinamento della tabella. Per trovare una corrispondenza esatta, impostare l'argomento corrisp su 0 (zero).

Per risolvere questo problema, verificare che l'intervallo a cui fa riferimento la formula di matrice abbia lo stesso numero di righe e colonne dell'intervallo di celle in cui è stata immessa la formula di matrice. In alternativa, immettere la formula di matrice in un numero maggiore o minore di celle corrispondente al riferimento all'intervallo presente nella formula.

In questo esempio, la cella E2 fa riferimento a intervalli non corrispondenti:

Esempio di formula di matrice con riferimenti a intervalli non corrispondenti che causano un errore #N/D.  La formula nella cella E2 è {=SOMMA(SE(A2:A11=D2,B2:B5))} e deve essere immessa con CTRL+MAIUSC+INVIO.

{=SOMMA(SE(A2:A11=D2,B2:B5))}

Affinché la formula esegua correttamente il calcolo, occorre modificarla in modo che entrambi gli intervalli riflettano le righe 2-11.

{=SOMMA(SE(A2:A11=D2,B2:B11))}

Nota : Si tratta di una formula di matrice e quindi deve essere immessa con CTRL+MAIUSC+INVIO. Excel inserisce automaticamente la formula tra parentesi graffe {}. Se si prova a immettere la formula manualmente, Excel la visualizza come testo.

Esempio di #N/D immesso nelle celle che impedisce il calcolo corretto di una formula SOMMA.

In questo caso, maggio e dicembre contengono valori #N/D, quindi non è possibile calcolare il totale e viene restituito un errore #N/D.

Per risolvere il problema, verificare la sintassi della formula della funzione in uso e immettere tutti gli argomenti obbligatori nella formula che restituisce l'errore. Può essere necessario passare a Visual Basic Editor (VBE) per controllare la funzione. Si può accedere a VBE dalla scheda Sviluppo oppure con ALT+F11.

Per risolvere il problema, verificare che la cartella di lavoro contenente la funzione definita dall'utente sia aperta e che la funzione effettui il calcolo correttamente.

Per risolvere questo problema, verificare che gli argomenti della funzione siano corretti e usati nella posizione appropriata.

Per risolvere questo errore, premere CTRL+ALT+F9 per ricalcolare il foglio.

In caso di dubbi sugli argomenti da usare, è possibile usare la Creazione guidata funzione. Selezionare la cella contenente la formula in questione, passare alla scheda Formula sulla barra multifunzione e fare clic su Inserisci funzione.

Pulsante Inserisci funzione.

Excel caricherà automaticamente la procedura guidata:

Esempio della finestra di dialogo della procedura guidata Formula.

Facendo clic su ogni argomento, Excel presenterà le informazioni appropriate.

#N/D può essere utile. È prassi comune usare #N/D quando si usano dati come nell'esempio seguente, perché i valori #N/D non vengono tracciati nei grafici. Ecco un esempio dell'aspetto di un grafico con valori 0 e con valori #N/D.

Esempio di un grafico a linee che traccia i valori 0.

Nell'esempio precedente i valori 0 sono stati tracciati e vengono visualizzati sotto forma di una linea piatta nella parte inferiore del grafico, che quindi risale per mostrare il totale. Nell'esempio i valori 0 sono stati sostituiti con #N/D.

Esempio di un grafico a linee che non traccia i valori #N/D.

Per altre informazioni su un errore #N/D visualizzato in una specifica funzione, vedere gli argomenti seguenti:

Inizio pagina

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Convertire in numeri i numeri memorizzati come testo

Funzione CERCA.VERT

Funzione CERCA.ORIZZ

Funzione CERCA

Funzione CONFRONTA

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per correggere errori comuni nelle formule

Scelte rapide da tastiera in Excel per Windows

Scelte rapide da tastiera in Excel per Mac

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×