Come correggere un errore #DIV/0!

In Microsoft Excel viene visualizzato l'errore #DIV/0! quando un numero viene diviso per zero (0). Ciò si verifica quando viene immessa una semplice formula come =5/0 o quando una formula fa riferimento a una cella che contiene 0 o a una cella vuota, come illustrato nell'immagine.

Esempi di formule che causano errori #DIV/0!.

Per correggere l'errore, eseguire una delle operazioni seguenti:

  • Verificare che il divisore della funzione o della formula non sia zero o una cella vuota.

  • Modificare il riferimento di cella nella formula in modo che sia relativo a un'altra cella non contenente uno zero (0) o un valore vuoto.

  • Immettere #N/A nella cella a cui viene fatto riferimento come divisore della formula. In questo modo il risultato della formula diventerà #N/A per indicare che il valore del divisore non è disponibile.

Molto spesso non è possibile evitare l'errore #DIV/0! perché le formule sono in attesa di input da parte dell'utente o di qualcun altro. In questo caso, non si vuole visualizzare affatto il messaggio di errore, dunque esistono alcuni metodi di gestione degli errori che consentono di eliminare il messaggio di errore durante l'attesa di input.

Calcolare il valore 0 o nullo del denominatore

Il modo più semplice per eliminare l'errore #DIV/0! consiste nell'usare la funzione SE per calcolare l'esistenza del denominatore. Se è 0 o nessun valore, mostrare uno 0 o nessun valore come risultato della formula, anziché l'errore #DIV/0!; in caso contrario calcolare la formula.

Se ad esempio la formula che restituisce l'errore è =A2/A3, usare =SE(A3;A2/A3;0) per restituire 0 oppure =SE(A3;A2/A3;"") per restituire una stringa vuota. È anche possibile visualizzare un messaggio personalizzato simile al seguente: =SE(A3;A2/A3,, "Input obbligatorio"). Con la funzione QUOZIENTE dal primo esempio si usa =SE(A3;QUOZIENTE(A2;A3);0). Ciò indica a Excel SE(A3 esiste, restituire il risultato della formula, in caso contrario ignorarlo).

Esempi di risoluzione di errori #DIV/0!.

Usare SE.ERRORE per eliminare l'errore #DIV/0!

È possibile eliminare questo errore anche annidando l'operazione di divisione all'interno della funzione SE.ERRORE. Di nuovo, usando A2/A3, è possibile usare =SE.ERRORE(A2/A3,0) Ciò indica a Excel se la formula restituisce un errore, restituire 0, altrimenti restituire il risultato della formula.

Per le versioni di Excel anteriori a Excel 2007, è possibile usare il metodo SE(VAL.ERRORE()): =SE(VAL.ERRORE(A2/A3),0,A2/A3) (vedere funzioni VAL).

Nota: entrambi i metodi SE.ERRORE e SE(VAL.ERRORE()) rimuovono la visualizzazione di tutti gli errori, non solo l'errore #DIV/0!. È necessario assicurarsi che la formula funzioni correttamente prima di applicare la gestione degli errori, in caso contrario si potrebbe non rendersi conto che la formula non funziona come previsto.

Suggerimento :  Se in Excel è attivato il controllo degli errori, fare clic su Icona del pulsante accanto alla cella contenente l'errore. Fare clic su Mostra passaggi del calcolo se disponibile e quindi sulla soluzione appropriata per i dati in uso.

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Si hanno suggerimenti su come migliorare la prossima versione di Excel? In questo caso, guardare gli argomenti in Excel User Voice.

Vedere anche

Funzione SE

Funzione SE.ERRORE

Funzioni VAL

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per correggere errori comuni nelle formule

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×