Collegare progetti per creare un progetto principale

Collegare progetti per creare un progetto principale

Per organizzare al meglio un progetto di grandi dimensioni, è possibile collegare tra loro più file di progetto in modo da ottenere una struttura basata su un progetto principale e più sottoprogetti (nota anche come relazioni esterne). Un progetto principale relativo alla costruzione di un edificio può ad esempio includere file di sottoprogetti diversi per gli impianti idraulico ed elettrico e per i lavori di falegnameria.

Queste istruzioni sono specifiche per Microsoft Project 2016, 2013 e 2010.

Collegamento dei file di Project

  1. Creare file di progetto distinti per ogni sottoprogetto e quindi aprire o creare il progetto da utilizzare come progetto principale.

  2. Nel progetto principale fare clic su Visualizza > Diagramma di Gantt.

  3. Nel campo Nome attività fare clic sulla riga sotto la quale si desidera inserire il sottoprogetto. È possibile inserire un sottoprogetto in un punto qualsiasi dell'elenco attività del progetto principale.

  4. Fare clic su Progetto > Sottoprogetto.

    Scheda della barra multifunzione di Progetto con il comando Inserisci sottoprogetto.

  5. Nella casella Inserisci sottoprogetto selezionare il sottoprogetto che si desidera inserire.

    • Per inserire più sottoprogetti, tenere premuto CTRL e fare clic sui sottoprogetti nell'ordine in cui si vuole inserirli.

    • Nella maggior parte dei casi è consigliabile lasciare selezionata la casella Collega a progetto in modo che le modifiche apportate al sottoprogetto risultino visibili nel progetto principale e viceversa. Se invece si vuole solo copiare il sottoprogetto nel progetto principale senza che i file risultino collegati dinamicamente, deselezionare la casella.

  6. Fare clic su Inserisci oppure, per inserire un progetto in formato di sola lettura, fare clic sulla freccia sul pulsante Inserisci e quindi su Inserisci in sola lettura. L'inserimento di un progetto in sola lettura consente di creare un collegamento tra i due progetti, ma impedisce che il sottoprogetto venga aggiornato dall'interno del progetto principale. Se il file di sottoprogetto viene aggiornato direttamente, le relative modifiche risulteranno tuttavia visibili nel progetto principale. L'opzione Inserisci in sola lettura è disponibile solo quando la casella Collega a progetto è selezionata.

Come evitare nomi di risorsa duplicati nei progetti collegati

Se si collegano progetti contenenti risorse con lo stesso nome, sarà necessario creare nomi di risorsa duplicati, che potrebbe creare confusione. Per evitarlo, deselezionare la casella Collega a progetto nella finestra di dialogo Inserisci progetto. In questo modo che verranno applicate le informazioni sulle risorse nel progetto principale (ad esempio le tariffe e i calendari delle risorse) invece delle informazioni sulle risorse del sottoprogetto.

Nota :  Quando si aggiorna un sottoprogetto non collegato dall'interno del progetto principale, le modifiche non sono visibili nel file di sottoprogetto originale.

Queste istruzioni sono specifiche per Microsoft Project 2007.

Quando usare i collegamenti tra progetti, invece delle dipendenze tra progetti?

Se il progetto ha un'attività specifica che dipende da un'attività specifica di un altro progetto, usare i collegamenti tra progetti per associare le date di attività tra loro. In questo modo, se l'attività da cui si è dipendenti slitta, le nuove date vengono riflesse nella propria attività. Se il progetto dipende alcuni aspetti di un altro progetto, e la dipendenza non è necessariamente correlata a un'attività specifica, usare le dipendenze tra progetti per identificare esattamente che cosa ciascun progetto apporta alla relazione.

  1. Aprire entrambi i progetti: quello che contiene l'attività a cui si vuole creare un collegamento e quello che contiene l'attività da cui si vuole creare un collegamento.

    Nel menu Finestra di uno dei progetti, fare clic su Disponi tutto.

  2. Fare clic sull'attività per cui si vuole creare una dipendenza a un predecessore esterno.

  3. Fare clic su Informazioni attività Icona del pulsante , quindi scegliere la scheda Predecessori.

  4. Nella colonna ID, digitare il nome del progetto e il numero di ID attività del predecessore esterno, separati da una barra rovesciata. Ad esempio, digitare Project1\1 per ID attività 1 in un file denominato Progetto1.

Per impostazione predefinita, si riceve una notifica se i dati in un progetto collegato all'esterno sono stati modificati. I predecessori e successori esterni e l'impatto sulla programmazione vengono visualizzati quando si apre un progetto con collegamenti esterni, ed è possibile scegliere di accettare una o tutte le modifiche.

  • Entrambi i progetti devono essere salvati prima che sia possibile collegare a un'attività esterna.

  • Quando si collegano attività in diversi progetti archiviati in Microsoft Office Project Server, l'ID attività del predecessore deve essere formattato correttamente. Nella colonna ID della scheda Predecessori della finestra di dialogo Informazioni attività l'ID attività deve essere formattato come nel seguente esempio: <>\progetto1\42. In questo esempio progetto 1 è il nome del progetto che contiene l'attività predecessore e 42 è l'ID attività dell'attività predecessore.

  • Le attività collegate esternamente vengono visualizzate in grigio nell'elenco attività. Fare doppio clic su un'attività con un successore esterno o un predecessore esterno per aprire il progetto che contiene l'attività esterna, se il progetto è disponibile.

Sono state collegate le attività tra progetti, ma i dati non corrispondono.

Quando si usa l'opzione Incolla collegamento nella finestra di dialogo Incolla speciale del menu Modifica per collegare le attività, Project usa il collegamento ed incorporamento di oggetti (OLE) per eseguire la connessione. Solo i campi selezionati vengono collegati. Tuttavia, un'attività può contenere molti più campi di informazioni associati che influiscono sulla programmazione dell'attività, e questi campi potrebbero risultare nascosti in caso di visualizzazione a schermo diviso.

Se è necessario creare una dipendenza tra le attività in diversi progetti, creare dipendenze esterne (invece di incollare un collegamento) per mantenere una programmazione accurata.

Quando si usa l'opzione Incolla collegamento, selezionare i singoli campi anziché intere righe e creare un collegamento solo alle informazioni necessarie per evitare quelle in conflitto di programmazione.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×