Che cos'è il salvataggio automatico?

Interruttore del salvataggio automatico in Office

Il salvataggio automatico è una nuova funzionalità disponibile in Excel, Word e PowerPoint per gli abbonati a Office 365, che salva automaticamente un file a intervalli di pochi secondi mentre si lavora. 

Il salvataggio automatico viene abilitato per impostazione predefinita in Office 365 quando un file viene archiviato in OneDrive, OneDrive for Business o SharePoint Online. 

Importante: Si usa File > Salva con nome dopo aver apportato modifiche a un documento originale o un modello? Provare invece a usare File > Salva una copia prima di apportare le modifiche. Si eviterà così che il salvataggio automatico sovrascriva il file originale con le modifiche. Nel caso in cui il salvataggio automatico abbia sovrascritto il file con le modifiche, vedere la sezione "Come si annullano le modifiche salvate ma non desiderate?" di seguito.

Il salvataggio automatico in Windows è disponibile in Excel, Word e PowerPoint per gli abbonati a Office 365. Ecco alcune domande frequenti sull'argomento.

È possibile ripristinare una versione precedente del file con Cronologia versioni. 

Cursore posizionato sul nome file, Visualizza tutte le versioni

Nella parte superiore della finestra fare clic sul nome file, quindi fare clic su Cronologia versioni. Esaminare le date e le ore per trovare la versione da ripristinare e quindi fare clic su Apri versione. Verrà aperta una seconda finestra con questa versione del file. Per ripristinare questa versione, fare clic sul pulsante Ripristina. Per altre informazioni sulla cronologia delle versioni, vedere Visualizzare le versioni storiche dei file di Office.

Quando si apre un file e si apportano le prime modifiche, il salvataggio automatico salva le modifiche e alla cronologia versioni viene aggiunta una nuova versione del file. Dopo tale operazione, anche se il salvataggio automatico salva regolarmente le modifiche apportate al file, per il resto della sessione di modifica vengono aggiunte nuove versioni alla cronologia versioni solo periodicamente (all'incirca ogni 10 minuti).

Il proprietario del file può impostare il file in modo che venga aperto sempre in sola lettura. Quando un utente apre un file con questa impostazione, non potrà salvare le modifiche al file, a meno che non ne venga abilitata specificamente la modifica. Per attivare questa impostazione per un file, passare a File > Informazioni > Proteggi documento > Apri sempre in sola lettura. Per disattivarla di nuovo in un secondo momento, ripetere semplicemente la procedura.

Il controllo Proteggi documento è stato selezionato visualizzando l'opzione Apri sempre in sola lettura.

Ci sono altri modi per proteggere il file dalla modifica. Se il file si trova in OneDrive, è possibile modificare le autorizzazioni per il file. Se il file si trova in SharePoint, è possibile configurare una raccolta per l'estrazione obbligatoria.

File > Salva una copia

Il comando Salva con nome è assente nel menu File quando si apre un documento da OneDrive, OneDrive for Business o SharePoint Online. In questi casi, nel menu File viene visualizzato il comando Salva una copia.

Si usa molto il comando Salva con nome? Quando elaborano un file, molti utenti sono abituati a scegliere File > Salva con nome per mantenere le modifiche nella copia ma non nell'originale. Tuttavia, quando il salvataggio automatico è attivato, le modifiche vengono salvate continuamente nell'originale. È quindi consigliabile usare File > Salva una copia prima di apportare qualsiasi modifica se si vuole che le modifiche vengano applicate alla copia e non all'originale.

Il pulsante del salvataggio automatico viene visualizzato nell'angolo in alto a sinistra sulla barra del titolo se si è abbonati a Office 365 e sono state installate le versioni più recenti di Excel, Word e PowerPoint per Windows. Se si ha un account aziendale o dell'istituto di istruzione, l'amministratore può controllare quale versione di Office può essere installata, che potrebbe non corrispondere all'ultima versione. Per altre informazioni, vedere Quando si ottengono le funzionalità più recenti di Office 365?.

Se non si è abbonati, non è necessario preoccuparsi: è comunque disponibile una funzionalità di salvataggio automatico che aiuta a proteggere i file in caso di arresto anomalo del sistema. Se si riapre il file dopo un arresto anomalo, viene visualizzata una versione del file con le ultime modifiche apportate in un riquadro Ripristino documenti. Per altre informazioni su come attivarlo, vedere Proteggere i file in caso di arresto anomalo del sistema.

E, naturalmente, è sempre possibile salvare i file manualmente come si è sempre fatto, premendo CTRL+S, facendo clic sul pulsante Salva o passando a File > Salva.

Il salvataggio automatico viene abilitato quando si lavora su un file salvato in OneDrive, OneDrive for Business o SharePoint Online. Se il file viene salvato in un altro percorso (o se non è stato ancora salvato), il salvataggio automatico sarà disabilitato. Questo succede se il file si trova in un sito di SharePoint in locale, un file server, un altro servizio di archiviazione nel cloud o se viene salvato in un percorso locale come C:\.

Ci sono anche altri motivi per cui il salvataggio automatico potrebbe essere disabilitato. Ecco un elenco di quelli più comuni:

  • Il file è in un formato meno recente, ad esempio XLS, PPT o DOC.

  • Il file si trova in una cartella di OneDrive locale e la sincronizzazione di OneDrive è sospesa.

  • Il file viene sincronizzato tramite una versione precedente del client di sincronizzazione di OneDrive. Per altre informazioni sull'aggiornamento di OneDrive, vedere Guida introduttiva al nuovo client di sincronizzazione di OneDrive in Windows.

  • Il file è incorporato in un altro file di Office.

  • La presentazione è in modalità presentazione.

Se si usa Excel ed è stata provata la procedura precedente, il file potrebbe contenere funzionalità non supportate dal salvataggio automatico. Eseguire una o più delle operazioni seguenti per abilitarlo:

  • Disattivare la funzionalità Cartella di lavoro condivisa. Questa funzionalità è un metodo di condivisione precedente. Ha molti limiti ed è stata sostituita dalla creazione condivisa.

  • Se possibile, rimuovere la crittografia password dal file: Passare a File > Informazioni > Proteggi cartella di lavoro. Eliminare la password e fare clic su OK.

  • Se possibile, rimuovere l'accesso limitato: Passare a File > Informazioni > Proteggi cartella di lavoro > Accesso limitato e fare clic su Accesso illimitato.

  • Se si sta aprendo lo snapshot di una cartella di lavoro da SharePoint, aprire il file invece dello snapshot.

  • Disattivare l'opzione Aggiorna dati all'apertura del file per tutte le tabelle e le tabelle pivot del file. Selezionare la tabella o la tabella pivot, quindi passare alla scheda Progettazione di Strumenti tabella > Aggiorna > Proprietà connessione. Infine deselezionare Aggiorna dati all'apertura del file.

  • Disattivare il componente aggiuntivo che causa la disabilitazione del salvataggio automatico. Selezionare File > Opzioni > Componenti aggiuntivi > Componenti aggiuntivi di Excel > Vai, quindi deselezionare la casella di controllo relativa al componente aggiuntivo.

Il modo più semplice consiste nel disattivare l'opzione Salvataggio automatico prima di procedere con le modifiche. Se le modifiche sono temporanee e non devono essere salvate, chiudere il file. Quindi fare clic su No quando viene richiesto di salvare. Se si decide di voler salvare le modifiche, è sufficiente riattivare il salvataggio automatico.

Se non si vogliono che le modifiche siano salvate di continuo e che siano visibili ad altri utenti, è possibile disattivare il salvataggio automatico. Quindi, quando si è pronti, fare clic su Salva (o premere CTRL+S) per salvare le modifiche al file su cui si sta lavorando e consentire agli altri utenti di visualizzarle. In alternativa, è anche possibile riattivare l'opzione Salvataggio automatico per salvare e condividere le modifiche.

L'impostazione predefinita per il salvataggio automatico è sempre Attivato per i file presenti in Microsoft Cloud. Tuttavia, se si disattiva il salvataggio automatico per un singolo file, il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se lo si riattiva per un file, il programma memorizza l'impostazione per lo specifico file.

Quando il salvataggio automatico è disattivato, continua a funzionare il ripristino automatico in caso di arresto anomalo del sistema mentre il file è aperto. Per altre informazioni, vedere Proteggere i file in caso di arresto anomalo del sistema.

Se si disattiva il salvataggio automatico per un singolo file, il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se lo si riattiva per un singolo file, il programma memorizza l'impostazione per lo specifico file.

Se si vuole disattivare il salvataggio automatico per impostazione predefinita per tutti i file, passare a File > Opzioni > Salva e deselezionare la casella accanto a Salva automaticamente i file di OneDrive e SharePoint Online per impostazione predefinita in <applicazione>.

Finestra di dialogo File > Opzioni > Salva con la casella di controllo per abilitare o disabilitare il salvataggio automatico

Riavviare Word (o qualsiasi applicazione aperta) per applicare le modifiche.

Note: 

  • Se si vuole disattivare il salvataggio automatico per impostazione predefinita per tutte le applicazioni di Office, ad esempio PowerPoint ed Excel, è necessario ripetere questa procedura per ognuna di queste applicazioni.

  • Se si vuole che alcuni file singoli vengano comunque salvati automaticamente, aprire i file e riattivare manualmente il salvataggio automatico per i file.

Il salvataggio automatico in Mac è disponibile in Excel, Word e PowerPoint per gli abbonati a Office 365. Ecco alcune domande frequenti sull'argomento.

È possibile ripristinare una versione precedente del file, che verrà impostata come versione corrente. Fare clic su File > Sfoglia cronologia versioni. Nel riquadro Cronologia versioni esaminare le date e le ore per trovare la versione da ripristinare, quindi fare clic su Apri versione. Verrà aperta una seconda finestra. Per ripristinare questa versione, fare clic sul pulsante Ripristina.

Se il file si trova in OneDrive, è possibile modificare le autorizzazioni per il file. Se il file si trova in SharePoint, è possibile configurare una raccolta per l'estrazione obbligatoria.

Il comando Salva con nome è assente nel menu File quando si apre un documento da OneDrive, OneDrive for Business o SharePoint Online. In questi casi, nel menu File viene visualizzato il comando Salva una copia.

Si usa molto il comando Salva con nome? Quando elaborano un file, molti utenti sono abituati a scegliere File > Salva con nome per mantenere le modifiche nella copia ma non nell'originale. Tuttavia, quando il salvataggio automatico è attivato, le modifiche vengono salvate continuamente nell'originale. È consigliabile quindi usare File > Salva una copiaimmediatamente se si vuole che le modifiche siano applicate alla copia e non all'originale.

Il pulsante del salvataggio automatico viene visualizzato nell'angolo in alto a sinistra se si è abbonati a Office 365 ed è stata installata la versione più recente di Excel, Word e PowerPoint per Mac. Se si ha un account aziendale o dell'istituto di istruzione, l'amministratore può controllare quale versione di Office può essere installata, che potrebbe non corrispondere all'ultima versione. Per altre informazioni, vedere Quando si ottengono le funzionalità più recenti di Office 365?.

Se non si è abbonati, non è necessario preoccuparsi: è comunque disponibile una funzionalità di salvataggio automatico che aiuta a proteggere i file in caso di arresto anomalo del sistema. Se si riapre il file dopo un arresto anomalo, viene visualizzata una versione del file con le ultime modifiche apportate in un riquadro Ripristino documenti. Per altre informazioni su come attivarlo, vedere Ripristinare i file in Office per Mac.

Il salvataggio automatico viene abilitato quando si lavora su un file salvato in OneDrive, OneDrive for Business o SharePoint Online. Se il file viene salvato in un altro percorso (o se non è stato ancora salvato), il salvataggio automatico sarà disabilitato. Questo succede se il file si trova in un sito di SharePoint in locale, un file server o se viene salvato in una cartella locale del computer.

Inoltre, per attivare il salvataggio automatico, è necessario aprire il file dal menu File in Word, Excel o PowerPoint.

Nota: Se il percorso File > Apri è simile all'immagine seguente, è necessario fare clic sul pulsante Percorsi online, quindi selezionare il file OneDrive o SharePoint da questa posizione per attivare il salvataggio automatico. Menu File > Apri aperto sulla visualizzazione "Nel mio Mac".

Ci sono anche altri motivi per cui il salvataggio automatico potrebbe essere disabilitato. Ecco un elenco di quelli più comuni:

  • Il file è in un formato meno recente, ad esempio XLS, PPT o DOC.

  • Il file si trova in una cartella di OneDrive locale e la sincronizzazione di OneDrive è sospesa.

  • Il file è incorporato in un altro file di Office.

  • La presentazione è in modalità presentazione.

Se si usa Excel ed è stata provata la procedura precedente, il file potrebbe contenere funzionalità non supportate dal salvataggio automatico. Eseguire una o più delle operazioni seguenti per abilitarlo:

  • Disattivare la funzionalità Cartella di lavoro condivisa. Questa funzionalità è un metodo di condivisione precedente. Ha molti limiti ed è stata sostituita dalla creazione condivisa.

  • Se possibile, rimuovere la crittografia password dal file: nella scheda Revisione fare clic su Proteggi cartella di lavoro. Eliminare la password e fare clic su OK.

  • Se possibile, rimuovere l'accesso limitato: Passare a File > Limita autorizzazioni > Nessuna restrizione.

  • Se si sta aprendo lo snapshot di una cartella di lavoro da SharePoint, aprire il file invece dello snapshot.

  • Disattivare l'impostazione Aggiorna dati all'apertura del file per tutte le tabelle e le tabelle pivot del file. Selezionare la tabella o la tabella pivot, quindi passare alla scheda Tabella. Fare clic su Aggiorna > Proprietà connessione e deselezionare Aggiorna dati all'apertura del file.

  • Disattivare il componente aggiuntivo che causa la disabilitazione del salvataggio automatico. Selezionare Strumenti > Componenti aggiuntivi di Excel, quindi deselezionare la casella di controllo relativa al componente aggiuntivo.

Il modo più semplice consiste nel disattivare l'opzione Salvataggio automatico prima di procedere con le modifiche. Se si decide di salvare le modifiche, è sufficiente riattivare il salvataggio automatico. Se non si vuole salvare le modifiche, chiudere il file. Quindi fare clic su No quando viene richiesto di salvare.

Se non si vogliono che le modifiche siano salvate di continuo e che siano visibili ad altri utenti, è possibile disattivare il salvataggio automatico. Quindi, quando si è pronti, fare clic su Salva per consentire agli altri utenti di visualizzare le modifiche al file su cui si sta lavorando. In alternativa, è anche possibile riattivare l'opzione Salvataggio automatico per salvare e condividere le modifiche.

L'impostazione predefinita per il salvataggio automatico è sempre Attivato per i file presenti nel cloud. Tuttavia, se si disattiva il salvataggio automatico per un file, il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se si torna nuovamente su Attivato per un file, il programma memorizza l'impostazione per lo specifico file.

Quando il salvataggio automatico è disattivato, continua a funzionare il ripristino automatico in caso di arresto anomalo del sistema mentre il file è aperto. Per altre informazioni, vedere Salvare e ripristinare automaticamente i file.

Se si disattiva il salvataggio automatico per un singolo file, il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se lo si riattiva per un singolo file, il programma memorizza l'impostazione per lo specifico file.

Se si vuole disattivare il salvataggio automatico per impostazione predefinita per tutti i file, passare a Preferenze > Salva e deselezionare la casella accanto a Attiva salvataggio automatico per impostazione predefinita.

No. Tuttavia, è possibile disattivare il salvataggio automatico per un file; il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se si lo si riattiva per un solo file, il programma memorizza l'impostazione per lo specifico file.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×