Cercare valori con CERCA.VERT, INDICE o CONFRONTA

Per trovare un valore in un elenco di grandi dimensioni, è possibile usare una funzione di ricerca. La funzione CERCA.VERT è molto usata, ma anche la funzione CERCA.ORIZZ usata insieme alle funzioni INDICE e CONFRONTA può essere molto utile.

Di seguito è illustrata la funzione CERCA.VERT, insieme agli argomenti che usa:

=CERCA.VERT(<valore ricerca>,<intervallo ricerca>,<colonna>,<corrispondenza approssimativa>)

Ad esempio: =CERCA.VERT(21500,C2:E7,3,FALSO)

  • Il primo argomento, il singolo dato che la funzione deve elaborare, è il valore che si vuole cercare. Può trattarsi di un riferimento di cella, ad esempio B2, o di un valore come "ruspini" o 21500.

  • Il secondo argomento è l'intervallo di celle che dovrebbe contenere il valore da trovare.

    Importante : Con la funzione CERCA.VERT la colonna che contiene il valore o il riferimento di cella da cercare deve trovarsi all'estrema sinistra nell'intervallo.

  • Il terzo argomento è la colonna nell'intervallo di ricerca delle celle che contiene il valore che si vuole visualizzare.

Il quarto argomento è facoltativo, tuttavia molti utenti immettono FALSO (oppure 0). Perché? Perché questo valore impone alla funzione di trovare una corrispondenza esatta nella ricerca. È possibile non immettere argomenti o immettere VERO, ma in questo caso, se non viene trovata una corrispondenza esatta, la funzione restituisce la corrispondenzapiù simile, che non è in genere il risultato desiderato.

Per far comprendere i problemi che può comportare una corrispondenza approssimativa, supponiamo di voler trovare il prezzo di un prodotto con ID 2345768, ma di scambiare due numeri digitando l'ID in modo errato nella formula, ad esempio: =CERCA.VERT(2345678,A1:E7,5). La formula restituisce il prezzo del prodotto sbagliato, perché CERCA.VERT ha trovato il numero più prossimo al numero specificato (2345678). A causa di questo errore, si rischia di inviare a un cliente una fattura errata.

Se si specifica FALSO o 0 per l'argomento Corrispondenza approssimativa e non esiste una corrispondenza esatta, la formula restituisce #N/D nella cella invece del valore errato, risultato decisamente preferibile. In questo caso, #N/D non significa che la formula è stata immessa in modo errato (ad eccezione del numero scambiato di posizione), bensì che 2345678 non è stato trovato. Di fatto, si voleva trovare 2345768.

Di seguito è illustrato un esempio di questa funzione. Quando si immette un valore nella cella B2 (il primo argomento), CERCA.VERT cerca nelle celle C2:E7 (il secondo argomento) e restituisce la corrispondenza più simile dalla terza colonna dell'intervallo, la colonna E (il terzo argomento).

Uso tipico della funzione CERCA.VERT

In questo esempio il quarto argomento è stato lasciato vuoto, pertanto la funzione restituisce una corrispondenza approssimativa.

Uso della funzione CERCA.ORIZZ

Una volta acquisita familiarità con CERCA.VERT, la funzione CERCA.ORIZZ non dovrebbe presentare problemi. Si immettono gli stessi argomenti, ma la ricerca avviene nelle righe e non nelle colonne.

Uso di INDICE e CONFRONTA insieme

Se non si vuole limitare la ricerca alla colonna all'estrema sinistra, è possibile usare una combinazione delle funzioni INDICE e CONFRONTA. Una formula che usa queste funzioni insieme è un po' più complessa di una formula che usa solo la funzione CERCA.VERT, ma può essere più potente, e molti utenti preferiscono usare la combinazione di INDICE e CONFRONTA rispetto alla sola funzione CERCA.VERT.

Questo esempio mostra un elenco in cui il valore da cercare, Chicago, non è nella colonna all'estrema sinistra. Pertanto, non è possibile usare CERCA.VERT. Si userà invece la funzione CONFRONTA per trovare Chicago nell'intervallo B1:B11. Il nome della città viene trovato nella riga 4. La funzione INDICE usa quindi questo valore come argomento di ricerca e trova la popolazione di Chicago nella 4a colonna (colonna D). La formula usata è visualizzata nella cella A14.

Uso di INDICE e CONFRONTA per cercare un valore

Ulteriori informazioni sulle funzioni di ricerca

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×