Accedi

Attività di base in Access 2010

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Ecco alcune attività di base sul database che è possibile eseguire per imparare a utilizzare Microsoft Access 2010.

 

In questo articolo

Che cos'è l'accesso?

Database relazionali di Access

Apertura di Access

Trovare e applicare un modello

Creare un database partendo da zero

Aprire un database di Access esistente

Per iniziare a utilizzare il nuovo database

Aggiunta di una tabella

Incollare dati da un'altra origine in una tabella di Access

Importare o collegare dati di un'altra origine

Passaggi successivi

Importare dati da un foglio di calcolo o da un altro programma

Importare un foglio di lavoro di Excel in Access

Importare un foglio di lavoro di Excel sotto forma di tabella in un nuovo database

Utilizzare la Creazione guidata Analizzatore tabelle per organizzare i dati

Utilizzare dati di altri programmi

Utilizzare un database di una versione precedente con versioni diverse di Access

Utilizzare un file di database di Access in diverse versioni di Access

Passaggio 1: Creare una copia del database esistente e salvarlo in un nuovo formato

Passaggio 2: Dividere il database copiato e utilizzare il file originale come database back-end

Passaggio 3: Collegare il nuovo database front-end al database originale

Utilizzare un'applicazione front-end/back-end in diverse versioni di Access

Che cos'è l'accesso?

Access 2010 è uno strumento di progettazione e la distribuzione di applicazione database che è possibile utilizzare per tenere traccia delle informazioni importanti. È possibile mantenere i dati nel computer oppure è possibile pubblicare sul Web, in modo che altri utenti potranno usare il database in un web browser.

Molti utenti iniziano a utilizzare Access quando l'applicazione utilizzata per tenere traccia di determinati dati diventa meno adatta per i propri scopi. Si supponga ad esempio di essere un organizzatore di eventi e di voler tenere traccia di tutti i dettagli necessari per organizzare eventi di successo. Se a tale scopo si utilizza un elaboratore di testo o un foglio di calcolo, in breve tempo ci si ritroverà con dati duplicati e incoerenti. I programmi per la gestione dei calendari, inizialmente adatti allo scopo, non consentono invece di tenere traccia delle informazioni finanziarie in modo adeguato.

Database relazionali di Access

Per tenere traccia di tali informazioni, è talvolta necessario utilizzare un database relazionale, ovvero un archivio di dati che sono stati suddivisi in insiemi di dati di dimensioni inferiori, denominati tabelle, allo scopo di eliminare la ridondanza e quindi messi in relazione tra loro sulla base di informazioni comuni, denominati campi. Un database relazionale per l'organizzazione di eventi può ad esempio contenere una tabella con le informazioni sui clienti, una tabella con le informazioni sui fornitori e una tabella con le informazioni sugli eventi. La tabella contenente le informazioni sugli eventi può includere un campo che consente di correlarla alla tabella dei clienti e un campo che consente di correlarla alla tabella dei fornitori. In tal modo, ad esempio, se il numero di telefono di un fornitore cambia, è sufficiente modificare tale informazione una sola volta nella tabella dei fornitori anziché in ogni evento che interessa il fornitore.

Access è uno strumento che può essere utilizzato per sviluppare in modo semplice e rapido applicazioni di database relazionali per la gestione delle informazioni. È possibile creare un database per tenere traccia di qualsiasi tipo di informazioni, ad esempio inventario, contatti professionali o processi aziendali. Access include infatti modelli che è possibile utilizzare per tenere traccia di una vasta gamma di informazioni e che semplificano notevolmente il lavoro anche per un principiante.

Apertura di Access

Quando si avvia Access 2010, viene visualizzata la visualizzazione Microsoft Office Backstage, in cui è possibile ottenere informazioni su database corrente, creare un nuovo database, aprire un database esistente e visualizzazione in primo piano contenuti da Office.com.

visualizzazione backstage di access 2010

La visualizzazione Backstage contiene inoltre molti altri comandi che è possibile utilizzare per modificare, gestire o condividere i database. I comandi della visualizzazione Backstage si applicano in genere a interi database e non agli oggetti all'interno di un database.

Nota : È possibile passare alla visualizzazione Backstage in qualsiasi momento facendo clic sulla scheda File.

Inizio pagina

Trovare e applicare un modello

In Access è disponibile un'ampia gamma di modelli che consentono di velocizzare il processo di creazione dei database. Per modello si intende un database già pronto in cui sono contenuti tutti i report, tabelle, query e maschere necessari per l'esecuzione di un'attività specifica. Sono disponibili, ad esempio, modelli che possono essere utilizzati per tenere traccia dei problemi, per gestire contatti o per registrare le spese. In alcuni modelli sono presenti alcuni record di esempio che ne dimostrano l'utilizzo. È possibile utilizzare i modelli di database disponibili oppure personalizzarli in base alle proprie esigenze.

Per trovare e applicare un modello di database, eseguire le operazioni seguenti:

  1. Nella scheda File fare clic su Nuovo.

  2. In Modelli disponibili eseguire una delle seguenti operazioni:

    • Per riutilizzare un modello utilizzati di recente, fare clic su Modelli recenti e quindi selezionare il modello desiderato.

    • Per utilizzare un modello di cui è già installato, fare clic su Modelli personali e quindi selezionare il modello desiderato.

    • Per trovare un modello in Office.com, in Modelli di Office.com, fare clic su una categoria di modelli, selezionare il modello desiderato e quindi fare clic su Download per scaricare il modello da COM di Office nel computer in uso.

      Nota : È anche possibile cercare modelli su Office.com all'interno di Access. Nella casella Cerca in Office.com per i modelli digitare uno o più termini di ricerca e quindi fare clic sulla freccia per la ricerca.

  3. Facoltativamente, fare clic sull'icona a forma di cartella accanto alla casella Nome file per selezionare il percorso in cui si desidera creare il database. Se non si indica un percorso specifico, il database verrà creato nel percorso predefinito visualizzato sotto la casella Nome file.

  4. Fare clic su Crea.

Il database verrà creato e aperto per l'utilizzo.

Inizio pagina

Creare un database partendo da zero

Nota : Per un'introduzione più completa ai concetti correlati all'utilizzo di Access per la creazione di un database, vedere l'articolo Nozioni fondamentali sulla progettazione di database.

Se non è disponibile alcun modello adeguato alle proprie esigenze o se si desidera utilizzare in Access dati di un altro programma, è possibile creare un database partendo da zero. A questo scopo, per la maggior parte delle applicazioni è necessario eseguire una o entrambe le operazioni seguenti:

Nota : Per ulteriori informazioni sui database Web, vedere l'articolo Creare un database da condividere sul Web.

Per creare un nuovo database, eseguire le operazioni seguenti:

  1. Avviare Access.

  2. Nella scheda Nuovo della visualizzazione Backstage fare clic su Database vuoto o Database Web vuoto.

    Importante : L'opzione selezionata in questa scheda determinerà le caratteristiche disponibili nel database. I database desktop non possono essere pubblicati sul Web, mentre i database Web non supportano alcune caratteristiche desktop, ad esempio le query di totalizzazione.

  3. Sulla destra digitare un nome per il database nella casella Nome file.

    Per cambiare il percorso in cui creare il file, fare clic su Sfoglia Icona del pulsante accanto alla casella Nome file, individuare e selezionare il nuovo percorso e quindi fare clic su OK.

  4. Fare clic su Crea.

    Verrà creato il database e quindi verrà aperta una tabella vuota, denominata Tabella1, in visualizzazione Foglio dati.

  5. Il cursore è posizionato nella prima cella vuota della colonna Fare clic per aggiungere della nuova tabella.

    Per aggiungere dati, digitarli nella cella oppure incollarli da un'altra origine, come descritto nella sezione Incollare dati da un'altra origine in una tabella di Access più avanti in questo articolo. 

    Note : 

    • L'immissione di dati in visualizzazione Foglio dati è analoga all'immissione di dati in un foglio di lavoro di Excel. La limitazione principale è costituita dalla necessità di immettere i dati in righe e colonne contigue, a partire dall'angolo superiore sinistro del foglio dati. A differenza di quanto è possibile eseguire in un foglio di lavoro di Excel, in questo caso è consigliabile non inserire righe o colonne vuote per formattare i dati, poiché questa operazione provocherebbe uno spreco di spazio nella tabella, destinata unicamente a contenere i dati. Tutte le presentazioni grafiche dei dati saranno disponibili nelle maschere e nei report progettati successivamente.

    • Durante l'immissione di dati, viene creata la struttura della tabella. Ogni volta che si aggiunge una nuova colonna del foglio dati, viene definito un nuovo campo nella tabella. Access imposta tipo di dati del campo in base al tipo di dati immessi. Ad esempio, se si dispone di una colonna in cui è stato immesso solo i valori di data, Access verrà impostare il tipo di dati del campo Data/ora. Se successivamente si tenta di immettere un valore diverso da una data (ad esempio un nome o un numero di telefono) in questo campo, verrà visualizzato un messaggio che indica che il valore non corrisponde il tipo di dati della colonna. Se possibile, è necessario pianificare la tabella in modo che ogni colonna che contiene lo stesso tipo di dati, sia che si tratti di testo, date, numeri o un altro tipo. In questo modo molto più facile creare query, maschere e report per selezionare i dati che si desidera.

Se non si desidera ancora immettere dati, fare clic su Chiudi Icona del pulsante.

Nota : La tabella Tabella1 verrà eliminata se viene chiusa senza salvarla.

Inizio pagina

Aprire un database di Access esistente

Suggerimento : Per aprire rapidamente uno degli ultimi database aperti, nella scheda File fare clic su Recente e quindi sul nome file del database desiderato.

  1. Nella scheda File fare clic su Apri.

  2. Nella finestra di dialogo Apri fare clic su un collegamento oppure nella casella Cerca in fare clic sull'unità o sulla cartella in cui si trova il database desiderato. 

  3. Nell'elenco delle cartelle fare doppio clic sulle cartelle fino all'apertura della cartella in cui si trova il database.

  4. Dopo avere individuato il database, eseguire una delle operazioni seguenti:

    • Per aprire il database in modalità di apertura predefinita, fare doppio clic sul database stesso.

    • Per aprire il database in accesso condiviso in un ambiente multiutente, in modo che sia ad altri utenti possono sia leggere e scrivere al database contemporaneamente, fare clic su Apri.

    • Per aprire il database con accesso in sola lettura in modo che sia possibile visualizzarlo ma non modificarlo, fare clic sulla freccia accanto al pulsante Apri e quindi su Apri in sola lettura.

    • Per aprire il database in accesso esclusivo in modo che non possa essere aperto da altri utenti contemporaneamente, fare clic sulla freccia accanto al pulsante Apri e quindi su Apertura esclusiva.

    • Per aprire il database per l'accesso in sola lettura, fare clic sulla freccia accanto al pulsante Apri e quindi fare clic su Apri in sola lettura con accesso esclusivo. Gli altri utenti potranno comunque aprire il database, ma solo con accesso in sola lettura.

Operazioni da eseguire se non viene individuato il database da aprire   

  1. Nella finestra di dialogo Apri fare clic sul collegamento Risorse del computer oppure nella casella Cerca in fare clic su Risorse del computer

  2. Nell'elenco delle unità fare clic con il pulsante destro del mouse sull'unità in cui si ritiene sia contenuto il database e quindi scegliere Cerca in.

  3. Immettere i criteri di ricerca e quindi premere INVIO per eseguire la ricerca del database.

  4. Se il database viene individuato, per aprirlo fare doppio clic sul database nella finestra di dialogo Risultati ricerca.

    Nota : Poiché la ricerca è stata avviata nella finestra di dialogo Apri, è necessario fare clic su Annulla nella stessa finestra affinché il database venga aperto.

È possibile aprire un file di dati direttamente in un formato di file esterno, quale dBASE, Paradox, Microsoft Exchange o Microsoft Excel. È inoltre possibile aprire direttamente qualsiasi origine dati ODBC, ad esempio Microsoft SQL Server o Microsoft FoxPro. Verrà creato automaticamente un nuovo database di Access nella stessa cartella del file di dati e verranno aggiunti collegamenti a ogni tabella del database esterno.

Inizio pagina

Per iniziare a utilizzare il nuovo database

A seconda del modello utilizzato, potrebbe essere necessario eseguire una o più delle operazioni seguenti per iniziare a utilizzare il nuovo database:

  • Se in Access viene visualizzata una finestra di dialogo Accesso con un elenco vuoto di utenti, utilizzare la procedura seguente per iniziare:

    1. Fare clic su Nuovo utente.

    2. Compilare la maschera Dettagli utente.

    3. Fare clic su Salva e chiudi.

    4. Selezionare il nome dell'utente appena immesso e quindi fare clic su Accesso.

  • Se in Access viene visualizzato un foglio dati vuoto, è possibile iniziare a digitare i dati direttamente in tale foglio dati oppure fare clic su altri pulsanti e schede per esplorare il database.

  • Se in Access viene visualizzata la pagina Riquadro attività iniziale, è possibile fare clic sui collegamenti presenti nella pagina per visualizzare ulteriori informazioni sul database oppure fare clic su altri pulsanti e schede per esplorare il database.

  • Se sulla barra dei messaggi di Access viene visualizzato un messaggio Avviso di sicurezza e il modello proviene da una fonte attendibile, fare clic su Abilita contenuto. Se il database richiede l'accesso, sarà necessario effettuare di nuovo l'accesso.

Per i database desktop e web, si desidera anche iniziare da uno di questi passaggi:

Inizio pagina

Aggiungere una tabella

È possibile aggiungere una nuova tabella a un database esistente utilizzando gli strumenti disponibili nel gruppo Tabelle della scheda Crea.

Gruppo Tabelle nella scheda Crea

Nota : Nel gruppo Tabelle è disponibile solo il comando Tabella per un database Web.

Indipendentemente dalla visualizzazione selezionata inizialmente, è sempre possibile passare all'altra mediante i pulsanti delle visualizzazioni disponibili sulla barra di stato della finestra di Access.

Creare una tabella vuota nella visualizzazione Foglio dati    In visualizzazione Foglio dati è possibile immettere i dati immediatamente. La struttura della tabella viene creata automaticamente da Access. I nomi di campo vengono assegnati in ordine numerico (Campo1, Campo2 e così via) e i tipi di dati di un campo vengono impostati in base al tipo di dati immessi.

  1. Nel gruppo tabelle della scheda Crea fare clic su tabella Icona del pulsante.

  2. Dopo che la tabella è stata creata, il cursore viene posizionato nella prima cella vuota della colonna Fare clic per aggiungere.

  3. Per aggiungere dati, digitarli nella prima cella vuota oppure incollarli da un'altra origine, come descritto più avanti in questo articolo.

    • Per rinominare una colonna (campo), fare doppio clic sull'intestazione di colonna e quindi digitare il nuovo nome.

      Suggerimento : Assegnare un nome significativo a ogni campo, in modo che sia possibile riconoscerne il contenuto senza esaminare i dati.

    • Per spostare una colonna, fare clic sulla relativa intestazione per selezionarla e quindi trascinarla nella posizione desiderata. È inoltre possibile selezionare più colonne contigue e trascinarle tutte insieme nella nuova posizione.

      Per aggiungere altri campi alla tabella, è possibile iniziare a digitare nella colonna Fare clic per aggiungere della visualizzazione Foglio dati oppure aggiungere nuovi campi utilizzando i comandi disponibili nel gruppo Aggiungi ed elimina della scheda Campi.

Creare una tabella a partire dalla visualizzazione Struttura    In visualizzazione Struttura viene creata innanzitutto la struttura della nuova tabella. Per immettere i dati, è necessario passare alla visualizzazione Foglio dati, come nel caso di una maschera.

Nota : La visualizzazione Struttura non è disponibile per le tabelle di un database Web.

  1. Nel gruppo Tabelle della scheda Crea fare clic su Struttura tabella.Icona del pulsante

  2. Per ogni campo della tabella, digitare un nome nella colonna Nome campo e quindi selezionare un tipo di dati nell'elenco Tipo dati.

  3. È possibile immettere ulteriori informazioni per ogni campo nella colonna Descrizione. La descrizione immessa viene visualizzata sulla barra di stato quando il punto di inserimento si trova nel campo specifico e viene utilizzata come testo della barra di stato per tutti i controlli creati trascinando il campo dal riquadro Elenco campi in una maschera o un report e per tutti i controlli creati per il campo specifico mediante la Creazione guidata Maschera o la Creazione guidata Report.

  4. Dopo avere aggiunto tutti campi, salvare la tabella:

    • Nella scheda File fare clic su Salva.

  5. Per immettere dati nella tabella, passare alla visualizzazione Foglio dati, fare clic sulla prima cella vuota e digitare i dati. È inoltre possibile incollare i dati da un'altra origine, come descritto nella sezione successiva.

Creare una tabella basata su un elenco SharePoint    Un elenco SharePoint consente di utilizzare i dati anche a utenti che non dispongono di Access. I dati dell'elenco vengono inoltre memorizzati in un server e risultano pertanto maggiormente protetti da possibili perdite rispetto ai file memorizzati in un computer desktop. È possibile iniziare con un nuovo elenco oppure eseguire il collegamento a un elenco esistente. È comunque necessario disporre di autorizzazioni sufficienti sul sito di SharePoint in cui si desidera creare l'elenco. Poiché tali autorizzazioni possono variare in base al sito, è necessario contattare l'amministratore di SharePoint per ottenere informazioni dettagliate sulle opzioni disponibili.

Nota : Questa caratteristica non è disponibile in un database Web.

  1. Nel gruppo Tabelle della scheda Crea fare clic su Elenchi SharePoint.

  2. È possibile utilizzare uno dei modelli di elenco disponibili per creare un elenco SharePoint standard, ad esempio Contatti o Eventi.

    È inoltre possibile scegliere di creare un elenco personalizzato oppure di importare o eseguire un collegamento a un elenco esistente. Fare clic sull'opzione desiderata.

  3. Se si seleziona uno dei modelli di elenco oppure si sceglie di creare un elenco personalizzato, verrà visualizzata la finestra di dialogo Crea nuovo elenco per completare il processo. Se si sceglie di utilizzare un elenco esistente, verrà aperta la finestra di dialogo Carica dati esterni.

Per ulteriori informazioni sulle tabelle, vedere l'articolo Introduzione alle tabelle.

Inizio pagina

Incollare dati da un'altra origine in una tabella di Access

Se i dati sono attualmente memorizzati in un altro programma, ad esempio Excel, è possibile copiarli e incollarli in una tabella di Access. L'esito dell'operazione risulta in genere più accurato se i dati sono già separati in colonne, come nei fogli di lavoro di Excel. Se i dati si trovano in un programma di elaborazione testi, è preferibile separare le colonne di dati utilizzando caratteri di tabulazione oppure convertirli in una tabella nel programma di elaborazione testi prima di procedere alla copia. Se è necessario elaborare o modificare i dati, ad esempio per suddividere i nomi completi in nomi e cognomi, potrebbe essere necessario apportare le modifiche desiderate prima di copiare i dati, soprattutto se non si ha familiarità con Access.

Quando si incollano dati incollati in una tabella vuota, il tipo di dati di ogni campo viene impostato automaticamente sul tipo di dati del campo incollato. Se in un campo in cui vengono incollati dati sono contenute solo date, il tipo di dati applicato al campo è Data/ora. Se nel campo incollato sono contenute solo le parole "sì" e "no", il tipo di dati applicati al campo è Sì/No.

Ai campi viene attribuito un nome in base al contenuto della prima riga dei dati incollati. Se la prima riga dei dati incollati è simile alle righe successive, Access determinerà che la prima riga fa parte dei dati e assegnerà ai campi nomi generici (Campo1, Campo2 e così via). Se invece la prima riga dei dati incollati non è simile alle righe successive, Access utilizzerà la prima riga per definire i nomi di campo e la escluderà dai dati effettivi.

Se vengono assegnati nomi di campo generici, rinominare i campi il prima possibile per evitare confusione. A tale proposito eseguire le operazioni seguenti:

  1. Nella scheda File fare clic su Salva per salvare la tabella.

  2. In visualizzazione Foglio dati fare doppio clic su ogni intestazione di colonna e quindi digitare un nome per la colonna.

  3. Salvare nuovamente la tabella.

Inizio pagina

Importare o collegare dati di un'altra origine

È possibile che si desideri utilizzare in Access dati raccolti o memorizzati in un altro programma. È inoltre possibile che si utilizzino dati di origini diverse e che si desideri importarli tutti in una posizione centralizzata per poterli analizzare in dettaglio.

Access consente di importare o collegare facilmente dati da altre applicazioni. È ad esempio possibile importare dati da un foglio di lavoro di Excel, da una tabella in un altro database di Access, da un elenco SharePoint o da un'ampia gamma di origini diverse. Sebbene il processo di importazione sia leggermente diverso in base all'origine dati, le istruzioni indicate di seguito consentono di eseguirne le operazioni iniziali.

  1. Nel gruppo Importa e collega della scheda Dati esterni fare clic sul comando relativo al tipo di file da cui si stanno importando i dati.

    Se ad esempio si importano dati da un foglio di lavoro di Excel, fare clic su Excel. Se non è visualizzato il tipo di programma appropriato, fare clic su Altro.

    Nota : Se si riesce a trovare il tipo di formato corretto nel gruppo Importa e collega, potrebbe essere necessario avviare il programma in cui sono stati creati i dati e quindi utilizzare tale programma per salvare i dati in un formato di file supportato da Access (ad esempio un file con testo delimitato ) e quindi importare o collegare i dati.

  2. Nella finestra di dialogo Carica dati esterni fare clic su Sfoglia per selezionare il file di dati di origine oppure digitare il percorso completo del file di dati di origine nella casella Nome file.

  3. Fare clic sull'opzione desiderata in Specificare la modalità e il percorso di memorizzazione dei dati nel database corrente. Per creare una nuova tabella, è possibile utilizzare i dati importati o creare una tabella collegata che utilizza un collegamento all'origine dati.

  4. Fare clic su OK.

    A seconda dell'opzione selezionata, verrà visualizzata la finestra di dialogo Collega oggetti o Importa oggetti.

  5. Utilizzare la finestra di dialogo per completare il processo. Le operazioni da eseguire dipendono dalle opzioni di importazione o di collegamento scelte.

  6. Nell'ultima pagina della procedura guidata fare clic su Fine.

    Se si è scelto di eseguire l'importazione, verrà chiesto se si desidera salvare i dettagli relativi all'operazione di importazione completata.

  7. Se si pensa che si dovrà ripetere la stessa operazioni di importazione in futuro, fare clic su Salvare i passaggi dell'operazione di importazione e quindi specificare i dettagli.

    In questo modo sarà possibile in futuro ripetere agevolmente l'operazione di importazione facendo clic su Importazioni salvate nel gruppo Importa della scheda Dati esterni, facendo clic sulle specifiche di importazione e quindi su Esegui.

  8. Se non si desidera salvare i dettagli dell'operazione di importazione, fare clic su Chiudi.

I dati verranno importati automaticamente in una nuova tabella, che verrà successivamente visualizzata in Tabelle nel riquadro di spostamento.

Per ulteriori informazioni sull'importazione di dati in Access, fare clic sui collegamenti disponibili nella sezione Vedere anche di questo articolo.

Inizio pagina

Passaggi successivi

I restanti passaggi del processo di progettazione variano in base agli obiettivi dell'utente, tuttavia è probabile che si desideri creare query, maschere, report e macro. In questo articolo non sono incluse informazioni sulla creazione di altri oggetti di database.

Per ulteriori informazioni, vedere gli articoli seguenti:

Inizio pagina

Importare dati da un foglio di calcolo o da un altro programma

Se si ha familiarità con altri programmi di database o del foglio di calcolo, probabilmente si conoscono le nozioni di base del funzionano di queste applicazioni e i database vengono utilizzati per. Access è diverso da molte altre applicazioni di database, consentendo di creare database relazionali e ulteriormente differisce dalla maggior parte dei programmi di foglio di calcolo mediante l'utilizzo di strumenti per lo sviluppo di report, maschere e query complesse. Access offre molte opzioni per l'utilizzo di altri programmi di database, ad esempio SQL Server.

Importare un foglio di lavoro di Excel in Access

Molti utenti iniziano a utilizzare Access dopo avere creato un elenco in Excel. Poiché alla crescita delle dimensioni dell'elenco, tuttavia, in Excel corrisponde un aumento della complessità per organizzarlo e mantenerlo aggiornato, lo spostamento dell'elenco in Access rappresenta in genere il passaggio logico successivo.

Una tabella di database è simile per struttura a un foglio di lavoro nel quale i dati vengono memorizzati in righe e colonne. Per questo solitamente risulta facile importare un foglio di lavoro in una tabella di database. La differenza principale tra memorizzare dati in un foglio di lavoro e memorizzarli in un database è il modo in cui vengono organizzati. Importare semplicemente l'intero foglio di lavoro sotto forma di nuova tabella in un database non consente di risolvere i problemi legati all'organizzazione e all'aggiornamento dei dati, in particolare se il foglio di lavoro contiene dati ridondanti. Per risolvere questi problemi è necessario suddividere i dati del foglio di calcolo in tabelle separate, ognuna contenente dati correlati. Per ulteriori informazioni sull'organizzazione dei dati nelle tabelle, vedere l'articolo Nozioni fondamentali della progettazione di database.

Accedere a caratteristiche la creazione guidata Analizzatore tabelle, che può essere utile per completare il processo. Dopo avere importato i dati in una tabella, la procedura guidata consente di dividere la tabella in tabelle separate, ognuno dei quali contiene dati non duplicati in altre tabelle. La procedura guidata crea anche le relazioni tra le tabelle necessarie.

Inizio pagina

Importare un foglio di lavoro di Excel sotto forma di tabella in un nuovo database

  1. Nella scheda File fare clic su Nuovo e quindi su Database vuoto.

  2. Digitare un nome per il nuovo database nella casella Nome file e quindi fare clic su Crea.

    Il nuovo database verrà aperto e verrà creata una nuova tabella vuota, denominata Tabella1.

  3. Chiudere la Tabella1.

    Quando viene chiesto se si desidera salvare le modifiche alla struttura della Tabella1, fare clic su No.

  4. Nel gruppo Importa e collega della scheda Dati esterni fare clic su Excel. Icona del pulsante

  5. Nella finestra di dialogo Carica dati esterni fare clic su Sfoglia.

  6. Per individuare il file, utilizzare la finestra di dialogo Apri file.

  7. Selezionare il file e quindi fare clic su OK.

  8. Nella finestra di dialogo Carica dati esterni verificare che l'opzione Importa dati di origine in una nuova tabella nel database corrente sia selezionata.

  9. Fare clic su OK.

    Verrà avviata l'Importazione guidata Foglio di calcolo e verranno richieste alcune informazioni relative ai dati.

  10. Seguire le istruzioni visualizzate e fare clic su Avanti o Indietro per spostarsi tra le pagine. Nell'ultima pagina della procedura guidata fare clic su Fine.

    Nota : Verrà chiesto se si desidera salvare i dettagli dell'operazione di importazione appena completata. Se si pensa che si dovrà ripetere la stessa operazioni di importazione in futuro, fare clic su e quindi specificare i dettagli. In futuro sarà possibile riprodurre l'operazione facendo clic su Importazioni salvate nel gruppo Importa della scheda Dati esterni. Se non si vuole salvare i dettagli dell'operazione, fare clic su Chiudi.

I dati verranno importati in una nuova tabella, che verrà successivamente visualizzata in Tutte le tabelle nel riquadro di spostamento.

Inizio pagina

Utilizzare la Creazione guidata Analizzatore tabelle per organizzare i dati

Dopo che i dati sono stati importati in una tabella di Access è possibile utilizzare la Creazione guidata Analizzatore tabelle per identificare velocemente i dati ridondanti. La procedura guidata semplifica infatti l'operazione di organizzazione dei dati in tabelle diverse, in modo da poterli memorizzare nella maniera più efficiente possibile. La tabella originale viene conservata come backup e vengono create delle nuove tabelle che potranno essere utilizzate come base per la propria applicazione di database.

  1. Aprire il database di Access in cui è contenuta la tabella da analizzare.

  2. Nel gruppo Analizza della scheda Strumenti database fare clic su Analizza tabella.

    Verrà avviata la Creazione guidata Analizzatore tabelle.

    Le prime due pagine della procedura guidata includono una breve esercitazione che consente di visualizzare gli esempi mediante l'utilizzo di pulsanti appropriati. Se anziché le pagine introduttive viene visualizzata la casella di controllo Mostra pagine introduttive, selezionare la casella di controllo e quindi fare clic su Indietro due volte per visualizzare l'introduzione. Se non si desidera visualizzare le pagine introduttive dopo avere letto l'introduzione, deselezionare la casella di controllo. 

  3. Nella pagina Quale tabella contiene campi con valori ripetuti in molti record? selezionare la tabella da analizzare e quindi fare clic su Avanti.

  4. È possibile decidere quali campi inserire nelle tabelle specifiche in modo automatico o manuale. Nel primo caso è comunque possibile apportare modifiche al layout della tabella nella pagina successiva della procedura guidata.

    Nota : Se la scelta dei campi da inserire nelle tabelle viene eseguita automaticamente, le scelte potrebbero non essere quelle ottimali per i propri dati, soprattutto se il numero di dati non è elevato. È pertanto necessario verificare con attenzione i risultati della procedura guidata. La procedura guidata, tuttavia, potrebbe suggerire un'organizzazione più efficiente rispetto a quella dell'utente. È pertanto consigliabile seguire innanzitutto le istruzioni della procedura guidata. Se i risultati non sono adeguati alle proprie esigenze, è possibile fare clic su Indietro e disporre i campi manualmente.

  5. Fare clic su Avanti. In questa pagina vengono indicate le tabelle in cui inserire i campi specifici. Se la scelta è stata eseguita in modo automatico, vengono visualizzate più tabelle connesse da linee di relazione. In caso contrario, viene creata un'unica tabella in cui sono contenuti tutti i campi. È comunque possibile apportare modifiche in entrambi i casi.

    • È possibile trascinare campi da una tabella a un'area vuota della pagina per creare una nuova tabella che contiene tali campi. Verrà chiesto di immettere un nome per la tabella.

    • È possibile trascinare campi da una tabella a un'altra per memorizzarli in modo più efficiente.

    • Alla maggior parte delle tabelle viene assegnato un campo ID o ID univoco generato. Per ulteriori informazioni sui campi di questo tipo, fare clic su Suggerimenti nell'angolo superiore destro della procedura guidata.

    • Per annullare una modifica, fare clic sul pulsante Annulla.

    • Per rinominare una tabella, fare doppio clic sulla relativa barra del titolo, digitare il nuovo nome e quindi fare clic su OK.

  6. Dopo avere disposto i campi nel modo desiderato, fare clic su Avanti.

  7. Se vengono individuati record con valori molto simili, tali valori vengono identificati come possibili errori di battitura e verrà visualizzata una schermata in cui è possibile confermare le operazioni da eseguire. Scorrere l'elenco per individuare quelli con eventuali valori nella colonna Correzione e quindi fare clic sulla voce appropriata nell'elenco a discesa. Selezionare Lascia inalterato per non apportare alcuna modifica al valore. Al termine dell'operazione, fare clic su Avanti.

  8. Verrà chiesto se si desidera creare una query somigliante alla tabella originale. Se sono già stati creati report e maschere basati sulla tabella originale, è consigliabile creare una query di questo tipo. Se si seleziona Crea la query, la tabella originale verrà rinominata mediante l'accodamento del suffisso "_OLD" al nome della tabella e alla nuova query verrà assegnato il nome della tabella originale. Le maschere e i report che si basavano sulla tabella utilizzeranno la query per i propri dati e manterranno inalterato il funzionamento precedente.

  9. Fare clic su Fine.

    Verranno create le nuove tabelle in base alle specifiche indicate e successivamente verranno aperte. Dopo avere controllato i risultati, chiudere le tabelle.

Inizio pagina

Utilizzare dati di altri programmi

Access 2010 include caratteristiche che consentono di utilizzare dati memorizzati in altri programmi.

Creare un nuovo database di Access collegato a dati contenuti in file di formato diverso    È possibile utilizzare Access per aprire file in un formato diverso, ad esempio testo, dBASE o foglio di calcolo. Verrà creato automaticamente un database di Access e il file verrà collegato.

  1. Avviare Access.

  2. Nella scheda File fare clic su Apri.

  3. Nella finestra di dialogo Apri fare clic sul tipo di file che si desidera aprire nell'elenco. Se non si è certi del tipo di file, fare clic su Tutti i file (*.*).

  4. Se necessario, selezionare la cartella in cui è contenuto il file da aprire. Una volta individuato, fare doppio clic sul file per aprirlo.

  5. Seguire le istruzioni visualizzate. Nell'ultima pagina della procedura guidata fare clic su Fine.

Importare o collegare dati a un database di Access esistente    I dati possono essere importati da origini e programmi diversi in tabelle di Access in modo che siano contenuti in file di questo programma oppure è possibile collegarsi ai dati a partire da Access in modo che i dati stessi rimangano nel file originale.

  1. Nel gruppo Importa e collega della scheda Dati esterni fare clic sul formato in cui sono memorizzati i dati.

    È possibile importare o eseguire il collegamento a dati dalle origini seguenti:

    • Excel    È possibile importare i dati da un foglio di lavoro o da un intervallo denominato di una cartella di lavoro di Excel. Ogni foglio di lavoro o intervallo denominato deve essere importato o collegato separatamente.

    • Access    Questa opzione risulta molto utile per separare il processo dai dati, creando in tal modo un database diviso. È quindi possibile utilizzare un database per le maschere, i report e le macro e mantenere i dati in un altro database. In tal modo è possibile sviluppare miglioramenti senza interrompere il lavoro di altri utenti. È inoltre possibile combinare in un unico database dati di più database di Access diversi, semplificando la creazione di un riepilogo dei dati tra reparto o partner aziendale.

    • Database ODBC    Questo formato è supportato da molti programmi, inclusi numerosi prodotti per server di database. Consente di creare database centralizzati in cui combinare dati di sistemi diversi.

    • File di testo    È possibile eseguire la connessione a un file di testo semplice e persino utilizzare Access per modificare il contenuto del file. In tal modo i dati di Access risulteranno più facilmente utilizzabili in una vasta gamma di programmi.

    • File XML    Questo formato offre la compatibilità con numerosi programmi, tra cui alcuni server Web.

    • Elenco SharePoint    Questo formato rende i dati utilizzabili con un Web browser e costituisce il metodo standard per utilizzare un elenco SharePoint.

    • Servizi dati    Consente di connettersi ai servizi dati Web in ambito aziendale.

    • Documento HTML   

    • Cartella di Outlook    È possibile connettersi alle cartelle di Outlook per integrare più facilmente le informazioni sui contatti con gli altri dati disponibili.

    • File di dBASE    dBase è un noto sistema di database alternativo supportato da Access.

      Verrà visualizzata la finestra di dialogo Carica dati esterni.

  2. Seguire le istruzioni visualizzate.

    I dati verranno importati o collegati al database. Per la maggior parte dei formati, è necessario specificare il percorso dei dati e quindi scegliere le modalità di memorizzazione nel database.

Inizio pagina

Utilizzare un database di una versione precedente con versioni diverse di Access

Se il database o il progetto di Access è stato creato in Access 2000 o versione successiva, sarà possibile utilizzarlo nella versione del programma in cui è stato creato o in qualsiasi versione successiva, anche se si tratta di un file con sicurezza abilitata. I file di Access 2000 possono ad esempio essere utilizzati in tutte le versioni a partire da Access 2000, Access 2002, Access 2003, Access 2007 e Access 2010.

Si può verificare una situazione in cui si desidera conservare i dati in una versione precedente di Access, ma sono presenti hanno alcuni utenti che disponendo di una versione successiva di Access vogliono collegarsi a tali dati continuando a sfruttare alcune delle caratteristiche della versione successiva. La soluzione in questo caso consisterà nel creare un nuovo database "front-end" nella versione successiva, contenente ovvero maschere, report, query, macro, ma nessuna tabella, e collegandolo alle tabelle nel file della versione precedente. A tale proposito, utilizzare una delle procedure descritte di seguito a seconda che il database sia contenuto in un solo file oppure sia già stato suddiviso in un'applicazione front-end/back-end.

Utilizzare un file di database di Access in diverse versioni di Access

Se tutte le tabelle, le maschere e gli altri oggetti di database di Access di versioni precedenti sono contenuti in un unico file e si desidera utilizzare il database in diverse versioni di Access, sarà possibile creare un nuovo database front-end in una versione successiva e collegarlo al file originale. Gli utenti che dispongono della versione precedente di Access potranno continuare a utilizzare il database originale, mentre gli utenti della versione successiva potranno utilizzare il nuovo database front-end per collegarsi agli stessi dati. Se necessario, per gestire più versioni di Access, è possibile creare diverse versioni dei database front-end.

Inizio pagina

Passaggio 1: Creare una copia del database esistente e salvarlo in un nuovo formato

Utilizzare la procedura seguente per convertire il database in uno dei tre formati più recenti: Access 2000, Access 2002-2003 o Access 2007. Questo comando consente di mantenere il database originale nel formato originale e crea una copia nel formato specificato.

  1. Chiudere il file di Access. Se si tratta di un database multiutente di Access che si trova in un server o in una cartella condivisa, assicurarsi che non sia aperto da altri utenti.

  2. Avviare Access 2010.

  3. Nella scheda File fare clic su Apri.

  4. Selezionare il percorso del file che si desidera convertire e quindi fare doppio clic sul file per aprirlo.

    Nota : Se viene visualizzata la finestra di dialogo Miglioramento database in cui viene chiesto se si desidera migliorare il database, fare clic su No.

  5. Chiudere l'eventuale maschera visualizzata all'apertura del database.

  6. Nella scheda File fare clic su Salva database con nome.

  7. Nella finestra Salva con nome digitare un nome per il nuovo database.

    Nota : A meno che non si salverà il nuovo database in un percorso diverso, il relativo nome deve essere diverso da quello del database originale. In entrambi i casi, è consigliabile utilizzare un nome diverso, in modo da poter facilmente distinguere tra il database front-end e il database back-end. Tuttavia, se si desidera convertire in formato Access 2007, l'estensione del file le modifiche dal file con estensione mdb a accdb, in modo che è possibile utilizzare lo stesso nome file.

  8. Fare clic su Salva.

Inizio pagina

Passaggio 2: Dividere il database copiato e utilizzare il file originale come database back-end

Dividere il database convertito eseguendo le operazioni seguenti:

  • Nel gruppo Sposta dati della scheda Strumenti database fare clic su Database di Access. Icona del pulsante

  • Nella finestra di dialogo Divisione guidata database fare clic su Dividi database.

    Nota : Se si desidera, è possibile creare un backup. In alternativa, è possibile solo ricreare la copia utilizzando il database originale.

  • Digitare un nome per il database back-end e quindi fare clic su Dividi.

Inizio pagina

Passaggio 3: Collegare il nuovo database front-end al database originale

  1. Eliminare il database back-end creato dalla Divisione guidata database, prestando particolare attenzione a non eliminare il database originale. 

  2. Collegare il nuovo database front-end alle tabelle del database originale. Nel gruppo Importa e collega della scheda Dati esterni fare clic su Gestione tabelle collegate. Icona del pulsante

  3. Fare clic su Seleziona tutto e quindi selezionare la casella di controllo Richiedi sempre nuovo percorso.

  4. Fare clic su OK, selezionare il database nella versione precedente e quindi fare doppio clic sul database stesso.

    Se tutto procede regolarmente, verrà visualizzato un messaggio che informa che tutte le tabelle collegate selezionate sono state aggiornate correttamente.

A questo punto è possibile migliorare il nuovo database front-end affinché supporti nuove caratteristiche per gli utenti che dispongono di versioni più recenti di Access. Gli utenti che dispongono delle versioni precedenti potranno tuttavia continuare a utilizzare il database della versione precedente.

Inizio pagina

Utilizzare un'applicazione front-end/back-end in diverse versioni di Access

Se il database di Access è già un applicazione front-end/back-end, è possibile convertire il front-end fino al nuovo formato di file. Non sono necessarie modifiche per il database back-end.

La procedura seguente viene illustrato come utilizzare il comando Salva Database con nome per il database front-end convertito in uno dei tre formati più recenti: Access 2000, Access 2002-2003 o Access 2007. Questo comando consente di mantenere il database originale nel formato originale e crea una copia nel formato specificato.

  1. Chiudere il database front-end. Se si tratta di un database multiutente di Access disponibile in un server o in una cartella condivisa, assicurarsi che non sia aperto da altri utenti.

  2. Avviare Access 2010.

  3. Nella scheda File fare clic su Apri.

  4. Selezionare il percorso del database front-end e quindi fare doppio clic sul database stesso per aprirlo.

    Nota : Se viene visualizzata la finestra di dialogo Miglioramento database in cui viene chiesto se si desidera migliorare il database, fare clic su No.

  5. Chiudere l'eventuale maschera visualizzata all'apertura del database.

  6. Nella scheda File fare clic su Salva database con nome.

  7. Nella finestra Salva con nome digitare un nome per il nuovo database.

  8. Fare clic su Salva.

A questo punto è possibile migliorare il nuovo database front-end affinché supporti nuove caratteristiche.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.



Queste informazioni sono risultate utili?

Che cosa possiamo migliorare?

Che cosa possiamo migliorare?

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti