Archiviare o estrarre un file da una raccolta SharePoint

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Un utente che estrae un file da un raccolta in un sito di Microsoft Windows SharePoint Services si assicura che nessun altro utente possa modificarlo contemporaneamente. Quando il file è estratto, è possibile modificarlo, chiuderlo, riaprirlo e persino utilizzarlo nel disco rigido locale. Gli altri utenti non potranno tuttavia modificarlo o visualizzare le modifiche apportate finché il file non sarà stato archiviato.

Contenuto dell'articolo

Panoramica

Estrarre un file da una raccolta SharePoint

Archiviare un file in una raccolta SharePoint

Modificare la posizione in cui si sta lavorando estratti

Panoramica

L'estrazione dei file prima che vengano modificati consente di evitare conflitti o confusione quando più utenti lavorano sullo stesso gruppo di file. L'utente che estrae un file è infatti l'unico autorizzato ad apportarvi modifiche. È possibile estrarre qualsiasi file in un sito di SharePoint per il quale si dispone dell'autorizzazione nonché estrarre file direttamente dalle applicazioni di Microsoft Office System 2007 seguenti: Word, Excel, PowerPoint e Visio.

Quando si archivia un file, è possibile digitare commenti per informare gli altri utenti delle modifiche apportate da una versione all'altra del file. Tale funzionalità è particolarmente utile se un file viene utilizzato da più utenti o se è probabile che debba essere revisionato da più utenti. Se nella raccolta viene tenuta traccia delle versioni dei file, i commenti diverranno parte integrante della cronologia delle versioni del file e potranno risultare utili qualora altri utenti debbano visualizzare o ripristinare una versione precedente.

È possibile che nella propria organizzazione sia necessario estrarre un file prima di poterlo modificare. In tal caso, quando si crea o si carica un nuovo file in una raccolta, sarà necessario archiviarlo.

Quando un utente estrae un file, le modifiche apportate non saranno visibili ad altri utenti finché il file non viene archiviato. In alcuni casi è possibile che si desideri archiviare il file in modo che altri possano visualizzare le modifiche apportate, ma al contempo mantenerlo estratto per continuare a modificarlo. Quando si archivia un file, è possibile scegliere di continuare a modificarlo, a meno che nella raccolta non venga tenuta traccia delle versioni principali e secondarie e non si intenda archiviare una versione principale. Una versione principale è in genere stata modificata significativamente rispetto alla precedente versione principale, mentre una versione secondaria include solo modifiche di minor entità rispetto alla versione precedente. Una versione principale può ad esempio includere un'ampia sezione di contenuto nuovo, mentre una versione secondaria può includere solo le correzioni degli errori di ortografia.

Quando si utilizza un'applicazione di Office per estrarre un file in un sito di Windows SharePoint Services 3.0, per impostazione predefinita il file viene archiviato nel disco rigido locale in una cartella bozze contenuta nella cartella Documenti. È possibile modificare questo percorso specificandone uno diverso sul disco rigido o in rete. In alternativa, è possibile specificare che i file estratti vengano archiviati nel server Web quando vengono utilizzati. È possibile tuttavia che, a seconda delle esigenze dell'organizzazione, l'amministratore specifichi un percorso personalizzato o impedisca la modifica del percorso.

Quando si estrae un file da un sito di Microsoft Windows SharePoint Services 2.0, il file rimane archiviato nel server mentre viene modificato, ma deve essere archiviato per consentire ad altri utenti di visualizzare le modifiche apportate. Nella maggior parte dei casi quando si estrae un file da un sito di Windows SharePoint Services 3.0, viene visualizzato un messaggio in cui è indicato il percorso in cui verrà archiviato il file quando è estratto. Tale messaggio non verrà invece visualizzato quando si estrae un file da un sito di Windows SharePoint Services 2.0.

Quando un documento è estratto, nel riquadro attività Gestione documenti nell'applicazione di Office è presente un comando che consente di archiviare il file.

Se viene tenuta traccia delle versioni principali e secondarie dei file, è possibile che venga richiesto di scegliere se si intende archiviare una versione principale o secondaria.

Torna all'inizio

Estrarre un file da una raccolta SharePoint

Utilizzare questa procedura per estrarre un file già aperto in un'applicazione di Office. È inoltre possibile estrarre un file dalla raccolta nel sito di SharePoint.

Eseguire le operazioni seguenti nelle applicazioni di versione 2007 di Office:

Word, Excel o PowerPoint

  1. Scegliere il Pulsante Microsoft Office Icona del pulsante Office , fare clic su Server e quindi fare clic su Estrai.

    Per impostazione predefinita, i documenti di Word vengono spesso aperti nella visualizzazione Lettura a schermo intero. In tal caso, per poter completare questo passaggio, potrebbe essere necessario fare dapprima clic su Layout di stampa per passare alla visualizzazione Layout di stampa.

  2. Se viene visualizzato un messaggio in cui è indicato il percorso di archiviazione del file durante l'estrazione, fare clic su OK.

    Nella maggior parte dei casi questo messaggio viene visualizzato se si estrae un file da un sito Windows SharePoint Services 3.0.

    Suggerimento : Nel messaggio in cui è indicato il percorso di archiviazione del file durante l'estrazione è possibile modificare le opzioni per la gestione dei file estratti.

Visio

  1. Scegliere Estrai dal menu File.

  2. Se viene visualizzato un messaggio in cui è indicato il percorso di archiviazione del file durante l'estrazione, fare clic su OK.

    Nella maggior parte dei casi questo messaggio viene visualizzato se si estrae un file da un sito Windows SharePoint Services 3.0.

    Suggerimento : Nel messaggio in cui è indicato il percorso di archiviazione del file durante l'estrazione è possibile modificare le opzioni per la gestione dei file estratti.

Torna all'inizio

Archiviare un file in una raccolta SharePoint

Utilizzare questa procedura per archiviare un file aperto nell'applicazione di Office. È inoltre possibile archiviare un file dalla raccolta nel sito di SharePoint.

Eseguire le operazioni seguenti nelle applicazioni di versione 2007 di Office:

Word, Excel o PowerPoint

  1. Scegliere il Pulsante Microsoft Office Icona del pulsante Office , fare clic su Server e quindi fare clic su Archivia.

    Per impostazione predefinita, i documenti di Word vengono spesso aperti nella visualizzazione Lettura a schermo intero. In tal caso, per poter completare questo passaggio, potrebbe essere necessario fare dapprima clic su Layout di stampa per passare alla visualizzazione Layout di stampa.

  2. Se viene richiesto se archiviare una versione principale o secondaria, fare clic su Numero di versione secondario se la modifica apportata è di lieve entità oppure su Numero di versione principale se la modifica apportata è rilevante.

  3. Nella casella Commenti sulla versione digitare eventuali commenti che si desidera aggiungere in relazione alle modifiche.

    Tali commenti verranno inclusi nella cronologia delle versioni del file nella raccolta SharePoint e potranno risultare utili ad altri utenti che desiderano visualizzare informazioni sulle versioni precedenti.

  4. Se la casella di controllo Mantieni il documento estratto dopo aver archiviato questa versione è disponibile, è possibile selezionarla se si intende continuare a lavorare sul file.

    Questa opzione è disponibile se nella raccolta non viene tenuta traccia delle versioni, se viene tenuta traccia di tutte le versioni nello stesso modo oppure se si intende archiviare una versione secondaria. Non è invece disponibile se si intende archiviare una versione principale o pubblicare un file.

Visio

  1. Scegliere Archivia dal menu File.

  2. Se viene richiesto se archiviare una versione principale o secondaria, fare clic su Numero di versione secondario se la modifica apportata è di lieve entità oppure su Numero di versione principale se la modifica apportata è rilevante.

  3. Nella casella Commenti sulla versione digitare eventuali commenti che si desidera aggiungere in relazione alle modifiche.

    Tali commenti verranno inclusi nella cronologia delle versioni del file nella raccolta SharePoint e potranno risultare utili ad altri utenti che desiderano visualizzare informazioni sulle versioni precedenti.

  4. Se la casella di controllo Mantieni il documento estratto dopo aver archiviato questa versione è disponibile, è possibile selezionarla se si intende continuare a lavorare sul file.

    Questa opzione è disponibile se nella raccolta non viene tenuta traccia delle versioni, se viene tenuta traccia di tutte le versioni nello stesso modo oppure se si intende archiviare una versione secondaria. Non è invece disponibile se si intende archiviare una versione principale o pubblicare un file.

Torna all'inizio

Modificare il percorso in cui vengono utilizzati i file estratti

Questa impostazione consente di modificare il percorso in cui viene utilizzato il successivo file estratto. La procedura non ha effetto se si utilizza un file attualmente estratto.

Eseguire le operazioni seguenti nelle applicazioni di versione 2007 di Office:

Word, Excel o PowerPoint

  1. Scegliere il Pulsante Microsoft Office Icona del pulsante Office e quindi fare clic su Opzioni per il programma: Opzioni di Word, le Opzioni di Excel o PowerPoint opzioni.

  2. Nella finestra di dialogo visualizzata fare clic su Salvataggio.

  3. Nella sezione Opzioni modifica non in linea per i file del server Document Management eseguire una delle operazioni seguenti:

    • Utilizzare la procedura seguente per utilizzare i file estratti sul disco rigido o in un percorso di rete:

      1. In Salva file estratti in fare clic su Percorso bozze server locale nel computer.

      2. Nella casella Percorso bozze server digitare il percorso del disco rigido in cui utilizzare i file estratti oppure fare clic su Sfoglia per individuare il percorso.

    • Per utilizzare i file estratti in un server Web, in Salva file estratti in fare clic su Server Web.

      Questa opzione consente di utilizzare i file estratti nel sito o nel server Web in cui sono archiviati. Non è possibile personalizzare il percorso specifico.

  4. Fare clic su OK.

Visio

  1. Scegliere Opzioni dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni fare clic sulla scheda Generale e quindi su Opzioni servizio.

  3. Nella finestra di dialogo visualizzata fare clic su Opzioni modifica non in linea.

  4. Nella sezione Opzioni modifica non in linea per i file del server Document Management eseguire una delle operazioni seguenti:

    • Utilizzare la procedura seguente per utilizzare i file estratti sul disco rigido o in un percorso di rete:

      1. Per utilizzare i file estratti sul disco rigido, in Salva file estratti in fare clic su Percorso bozze server locale nel computer.

      2. In Percorso bozze server digitare il percorso del disco rigido in cui utilizzare i file estratti oppure fare clic su Sfoglia per individuare il percorso.

    • Per utilizzare i file estratti in un server, in Salva file estratti in fare clic su Server Web.

      Questa opzione consente di utilizzare i file estratti nel sito o nel server Web in cui sono archiviati. Non è possibile personalizzare il percorso specifico.

  5. Fare clic su OK.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×