Annidare una funzione all'interno di una funzione

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Quando si crea una formula usando una funzione, è possibile annidare le funzioni all'interno di altre funzioni. Quando si esegue, si sta utilizzando i risultati delle funzioni annidate come argomento,s-elementi di dati per poter eseguire correttamente la funzione di prima. È sempre possibile stabilire quando una funzione è nidificata in quanto si trova all'interno delle parentesi.

Ecco un esempio. La funzione IF utilizza le funzioni MEDIA e SOMMA annidate come argomenti.

=SE(MEDIA(F2:F5)>50,SOMMA(G2:G5),0)

È possibile leggere questa formula da sinistra a destra. SE il valore medio delle celle da F2 a F5 è maggiore di 50, si applica la funzione SOMMA ai valori nelle celle da G2 a G5. In caso contrario viene restituito 0.

È possibile annidare fino a 64 livelli di funzioni che vengono immesse come ogni altra funzione:

  1. Fare clic sulla cella che conterrà la formula.

  2. Immettere la formula nella barra della formula e premere Invio.

Ecco un altro esempio, in cui una funzione SE viene annidata in un'altra funzione SE per calcolare le deduzioni in base al livello del reddito.

=SE(A5<31500,A5*15%,SE(A5<72500,A5*25%,A5*28%))

È anche possibile leggere questo esempio da sinistra a destra. SE il valore nella cella A5 è minore di 31.500, il valore viene moltiplicato per il 15%. SE non lo è, si verifica se il valore è minore di 72.500. SE lo è, viene moltiplicato per il 25%, in caso contrario per il 28%.

Si noti che per i livelli di reddito non si utilizzano virgole. Altrimenti, la funzione SE tenterebbe di utilizzarli come argomenti e la formula verrebbe interrotta.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×