Aggiungere una tabella a una pagina Web

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Per aggiungere una tabella a una pagina Web in un sito di Microsoft Office SharePoint Server 2007 viene utilizzato l'editor HTML. È possibile utilizzare l'editor HTML Editor per aggiungere una tabella a un controllo campo Contenuto pagina o a una web part Editor contenuto.

Per saperne di più

Aprire l'Editor HTML

Aggiungere una tabella a una pagina Web

Aprire l'editor HTML

Il modo in cui aprire l'editor HTML è diverso a seconda che si utilizzi un controllo campo Contenuto pagina o una web part Editor contenuto.

Aprire l'editor in un controllo campo Contenuto pagina

  1. Nella pagina a cui si desidera aggiungere la tabella scegliere Mostra barra degli strumenti modifica pagina dal menu Azioni sito.

  2. Sulla barra degli strumenti modifica pagina fare clic su Modifica pagina.

  3. Nel controllo campo Contenuto pagina fare clic su Modifica contenuto. Verrà visualizzata la barra degli strumenti Editor HTML.

    Nota : Alcuni layout di pagina contengono un controllo campo Contenuto pagina che visualizza l'editor HTML in una finestra di dialogo pagina Web anziché in linea. Se è questo il caso del layout di pagina utilizzato per creare la pagina che si sta modificando, quando si fa clic su Modifica contenuti l'editor HTML verrà visualizzato in una nuova finestra.

Aggiungere una web part Editor contenuto a una pagina

Se la pagina a cui si desidera aggiungere la tabella supporta le web part, ma non contiene una web part Editor contenuto, è possibile aggiungerne una utilizzando la procedura seguente:

  1. Nella pagina alla quale si desidera aggiungere una web part Editor contenuto, scegliere la zona in cui aggiungere la web part e quindi fare clic su Aggiungi web part in quel punto. Verrà visualizzata la finestra di dialogo pagina Web Aggiungi Web part.

  2. Nella finestra di dialogo pagina Web Aggiungi Web part scorrere fino alla sezione Varie, selezionare la casella di controllo accanto a Web part Editor contenuto e quindi fare clic su Aggiungi. La pagina verrà aggiornata e verrà visualizzato il contenuto della web part Editor contenuto nella zona selezionata.

Aprire l'editor HTML nella web part Editor contenuto

  1. Sulla barra degli strumenti Web part Editor contenuto fare clic su Modifica e quindi su Modifica web part condivisa. Verrà visualizzato il riquadro Strumenti Editor contenuto.

  2. Nella tool part Editor contenuto fare clic su Editor testo RTF. Verrà visualizzata la finestra di dialogo pagina Web Editor HTML.

Torna all'inizio

Aggiungere una tabella a una pagina Web

Utilizzo dell'Editor HTML, è possibile inserire una tabella facendo clic sul pulsante della barra degli strumenti Icona del pulsante Inserisci tabella. Quando si fa clic su Inserisci tabella, verrà visualizzata una nuova finestra in cui è possibile scegliere le proprietà della tabella seguente:

  • Proprietà Dimensioni:

    • Righe      Utilizzare questa proprietà per scegliere il numero di righe.

    • Colonne      Utilizzare questa proprietà per scegliere il numero di colonne.

    • Specifica dimensioni      Selezionare questa casella di controllo al fine di modificare la larghezze e l'altezza della tabella nelle caselle Larghezza e Altezza. Deselezionare questa casella di controllo se si desidera che le dimensioni della tabella vengano gestite dal server.

    • Larghezza e Altezza     Se si seleziona la casella di controllo Specifica dimensioni, è possibile impostare le proprietà Larghezza e Altezza per controllare le dimensioni della tabella. Digitare un numero nella casella Larghezza o Altezza e quindi fare clic sulla freccia per selezionare pixel o percentuale. Ad esempio, per configurare una tabella con una larghezza pari a metà della larghezza della pagina, digitare 50 nella casella Larghezza e quindi fare clic su percentuale nell'elenco.

  • Proprietà Formato:

    • Utilizza formato tabella predefinito      Selezionare questa casella di controllo per selezionare un formato di tabella nell'elenco a discesa. In Office SharePoint Server 2007 sono disponibili diversi formati tabella predefiniti, che è possibile utilizzare in un controllo campo Contenuto pagina o in una web part Editor contenuto presente in una pagina contenente anche un controllo campo Contenuto pagina. Gli utenti del sito con autorizzazioni di progettazione possono creare formati tabella personalizzati e aggiungerli all'elenco dei formati tabella predefiniti. Formati tabella predefiniti possono essere disponibili sia nei controlli campo Contenuto pagina che nelle web part Editor contenuto.

      Quando si seleziona un formato tabella dall'elenco, viene visualizzata un'anteprima del formato nella casella Anteprima.

      Deselezionare la casella di controllo Utilizza formato tabella predefinito per disattivare le opzioni della sezione Formato e non applicare alcun formato alla tabella.

    • Applica formati speciali a      Ogni formato di tabella predefinito può contenere formattazione per la riga del titolo, l'ultima riga, la prima colonna e l'ultima colonna. Utilizzare queste quattro opzioni per le righe e le colonne per specificare se applicare una formattazione specifica a tale riga o colonna. Ad esempio, per specificare che la riga del titolo non deve essere formattata come indicato nel formato di tabella, deselezionare la casella di controllo Riga del titolo.

      Nota : Queste opzioni sono disponibili solo se la casella di controllo Utilizza formato tabella predefinito è selezionata.

È inoltre possibile modificare le dimensioni, la formattazione e altre proprietà di una tabella. Il metodo migliore per modificare una tabella è utilizzare il Menu cella. Per aprire il Menu cella, fare clic sulla freccia sul bordo destro della cella della tabella che si sta modificando.

Il Menu cella contiene i comandi seguenti:

  • Inserisci riga sopra      Questo comando inserisce una riga direttamente sopra la cella che si sta modificando.

  • Inserisci riga sotto      Questo comando inserisce una riga direttamente sotto la cella che si sta modificando.

  • Inserisci colonna a sinistra      Questo comando inserisce una colonna direttamente a sinistra della cella che si sta modificando.

  • Inserisci colonna a destra      Questo comando inserisce una colonna direttamente a destra della cella che si sta modificando.

  • Elimina riga      Questo comando elimina la riga contenente la cella che si sta modificando.

  • Elimina colonna      Questo comando elimina la colonna contenente la cella che si sta modificando.

  • Unisci celle      Questo comando unisce la cella che si sta modificando con quella alla sua destra (quella alla sua sinistra per le lingue da destra a sinistra).

  • Dividi cella      Questo comando divide la cella che si sta modificando e posiziona il cursore nella cella più a sinistra tra quelle create.

  • Altezza e larghezza      Questo comando apre una finestra di dialogo che consente di modificare l'altezza della riga e la larghezza della colonna che contengono la cella che si sta modificando.

  • Modifica tabella      Questo comando apre una finestra di dialogo che consente di modificare qualsiasi proprietà della tabella che contiene la cella che si sta modificando.

È inoltre possibile eseguire tutte le azioni disponibili nel Menu cella utilizzando i pulsanti della barra degli strumenti.

Per ulteriori informazioni sull'utilizzo dell'Editor HTML, vedere l'articolo utilizzare l'Editor HTML.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×