Aggiungere una connessione dati utilizzando le impostazioni in una raccolta di connessioni

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo

Panoramica

Prima di iniziare

Aggiunta di una connessione dati per query

Aggiunta di una connessione dati per invio

Panoramica

Se si progetta vari modelli di modulo che utilizzano le connessioni dati simili, è consigliabile usando un file di connessione dati invece di creare una connessione dati a un'origine dati esterna per ogni modello di modulo. In questo modo, è necessario aggiornare un solo file di connessione dati quando le informazioni di connessione dati per un set di modelli di modulo correlati. Ad esempio, quando si spostano i modelli di modulo da una rete di test in una rete di produzione, è necessario aggiornare i dati impostazioni di connessione una sola volta nella raccolta di connessione anziché aggiornare la connessione dati di ogni modello di modulo. Quando un modulo basato su un modello di modulo che utilizza un file di connessione dati utilizza la connessione dati, la connessione dati viene aggiornata automaticamente con le nuove impostazioni.

Un file di connessione dati è un file XML con un'estensione di file XML o udcx che contiene le informazioni di connessione per una singola origine dati esterna. Il file è archiviato in una raccolta di connessioni dati in un server che esegue Microsoft Office SharePoint Server 2007. Da uno sviluppatore o per la conversione di una connessione dati in un modello di modulo esistente in un file di connessione dati facendo clic sul pulsante Converti nella finestra di dialogo Connessioni dati (menuStrumenti ), viene creato un file di connessione dati.

Vantaggi dell'utilizzo di file di connessione dati:

  • Più moduli è possono utilizzare lo stesso file di connessione dati, in modo che non è necessario per creare la stessa connessione dati da zero per ogni modello di modulo.

  • Se la posizione o le impostazioni di connessione per un'origine dati esterna cambiano, è necessario aggiornare soltanto il file di connessione dati e non tutti i modelli di moduli.

  • File di connessione dati può contenere le informazioni di autenticazione alternativo che possono essere usate dal server durante la compilazione di un modulo tramite un Web browser.

  • Moduli basati su un modello di modulo compatibile con browser che sono compilati in un browser è possono connettersi al server in un altro dominio solo con le connessioni dati che utilizzano i file di connessione dati.

Nota : Microsoft Office InfoPath utilizza file di connessione dati che seguono il formato di file 2.0 versione universale connessione dati. Questa versione è un insieme di versione 1.0 formato di file utilizzato da Microsoft Office FrontPage e Microsoft Office Excel. InfoPath non è possibile usare i file di connessione dati nel formato di file 1.0 versione.

Durante l'aggiunta di una connessione a un modello di modulo utilizzando le impostazioni in una raccolta di connessioni dati, è necessario creare una connessione dati secondaria nel modello di modulo. Questa connessione dati è diversa dalla connessione dati principale che viene creata quando si progetta un modello di modulo basato su un database, un servizio Web o sulle impostazioni in una raccolta di connessioni dati. La connessione dati secondaria va aggiunta solo se non è possibile richiamare o inviare i dati mediante la connessione dati principale.

Inizio pagina

Prima di iniziare

Per poter aggiungere una connessione dati al modello di modulo utilizzando le impostazioni memorizzate in una raccolta di connessioni dati, è necessario richiedere le seguenti informazioni dall'amministratore del sito:

  • Il percorso del server che esegue Microsoft Office SharePoint Server 2007, contenente il sito che include la raccolta di connessioni dati

  • Il nome del file di connessione dati nella raccolta di connessioni dati che si desidera utilizzare

  • Se il file di connessioni dati contiene le impostazioni per una connessione dati per query o per una connessione dati per l'invio

  • Se è possibile configurare il modello di modulo per la memorizzazione dei risultati della query nel modulo per l'utilizzo non in linea se le impostazioni sono relative a una connessione dati per query

Inizio pagina

Aggiunta di una connessione dati per query

Per poter aggiungere una connessione dati al modello di modulo utilizzando le impostazioni in una raccolta connessioni, è necessario completare le seguenti procedure:

  1. Aggiungere la connessione dati secondaria al modello di modulo.

  2. Associare i controlli ai campi della query e ai campi dati nell'origine dati secondaria.

  3. Configurare il modello di modulo per utilizzare la connessione dati mediante una regola o un pulsante.

Passaggio 1: aggiunta di una connessione dati secondaria

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Nella Connessione guidata dati fare clic su Cerca connessioni in un server Microsoft Office SharePoint Server, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, nell'elenco Sito, selezionare il nome del sito in un server che esegue Office SharePoint Server 2007 con la raccolta di connessioni.

    Il mio sito non è presente nell'elenco

    Per aggiungere il sito all'elenco, effettuare le seguenti operazioni:

    1. Click Manage Sites.

    2. In the Manage Sites dialog box, click Add.

    3. In the URL box, type the location of the data connection library.

    4. In the Display name box, type a name for the data connection library. This name will appear in the Site list in the Data Connection Wizard.

    5. Click OK.

    6. Click Close.

  5. Fare clic sul nome della raccolta connessione dati per visualizzare un elenco dei file della connessione dati, selezionare il nome della connessione dati che si desidera utilizzare e fare clic su Avanti.

  6. A seconda delle impostazioni di connessione nel file di connessione dati, nella pagina successiva della procedura guidata potrebbe essere richiesto di specificare i valori di esempio per ogni parametro.

    Modalità di specifica dei valori di esempio

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Nota tecnica

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  7. Se si desidera che i risultati della query siano disponibili anche quando il modulo non è connesso a una rete, selezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo.

    Nota sulla sicurezza : Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, è disponibile nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete. Se si ottengono dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  8. Fare clic su Avanti.

    Nella pagina successiva della procedura guidata verrà visualizzato un riepilogo delle impostazioni per questa connessione dati.

  9. Digitare un nome descrittivo per la connessione dati. Questo nome verrà visualizzati nell'elenco Origine dati nel riquadro delle attività Origine dati.

  10. Per consentire ai moduli basati su questo modello di modulo di utilizzare questa connessione dati all'apertura, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

Inizio pagina

Passaggio 2: aggiunta di un controllo per la visualizzazione dei dati

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Trascinare un controllo sul modello di modulo.

  3. Nella finestra di dialogo Associazione controllo selezionare il campo a cui si desidera associare il controllo, quindi fare clic su OK.

Passaggio 3: configurazione del modello di modulo per utilizzare la connessione dati

Se si desidera che gli utenti recuperino i dati da questa connessione dati all'apertura del modulo, è possibile aggiungere una regola al modello di modulo per utilizzare la connessione dati in determinate condizioni oppure è possibile aggiungere un pulsante che può essere selezionato per utilizzare la connessione dati.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo che esegue la connessione dati per la query se viene soddisfatta la condizione per la regola. Nella procedura seguente si assume che sia stata creata una connessione dati per query per il modello di modulo e che sul modulo sia stato configurato un controllo per visualizzare i dati da tale connessione.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo a cui si desidera aggiungere la regola.

  3. Fare clic sulla scheda Dati.

  4. In Convalida e regole fare clic su Regole.

  5. Nella finestra di dialogo Regole fare clic su Aggiungi.

  6. Nella casella Nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nell'elenco Azione, fare clic su Esegui query tramite una connessione dati.

  10. Nell'elenco delle connessioni dati, selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere finestre di dialogo.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante per utilizzare la connessione dati per query

È possibile aggiungere un pulsante al modello di modulo che può essere selezionato quando si compila un modulo basato sul modello di modulo. Se selezionato, questo pulsante consente di recuperare i dati dalla connessione dati per la query.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare un pulsante sul modello di modulo.

  4. Fare doppio clic sul pulsante appena aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nell'elenco Azione fare clic su Aggiorna.

  7. Nella casella Etichetta immettere il nome che si desidera visualizzare sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna fare clic su Una origine dati secondaria.

  10. Nell'elenco Selezionare l'origine dati secondaria fare clic sull'origine dati secondaria associata alla connessione dati per la query.

  11. Fare clic su OK per chiudere le finestre di dialogo aperte.

  12. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Aggiungere una connessione dati per invio

Se il file di connessione dati contiene impostazioni per una connessione di dati per l'invio, è possibile configurare il modello di modulo in modo da consentire l'invio dei dati del modulo mediante questa connessione dati. Quando si configura il modello di modulo, in InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File. È inoltre possibile configurare le opzioni di invio per il modello di modulo nella finestra di dialogo Opzioni invio (nel menu Strumenti). Le opzioni di invio sono configurate nello stesso modo in cui vengono configurate se viene aggiunta una connessione dati secondaria che è una connessione dati per l'invio. Per ulteriori informazioni sull'aggiunta di una connessione dati di invio al modello di modulo, fare riferimento ai collegamenti presenti nella sezione Vedere anche.

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Nella Connessione guidata dati fare clic su Cerca connessioni in un server Microsoft Office SharePoint Server, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, nell'elenco Sito, selezionare il nome del sito con la raccolta di connessioni.

    Il mio sito non è presente nell'elenco

    Per aggiungere il sito all'elenco, effettuare le seguenti operazioni:

    1. Click Manage Sites.

    2. In the Manage Sites dialog box, click Add.

    3. In the URL box, type the location of the data connection library.

    4. In the Display name box, type a name for the data connection library. This name will appear in the Site list in the Data Connection Wizard.

    5. Click OK.

    6. Click Close.

  5. Fare clic sul nome della raccolta connessione dati per visualizzare un elenco dei file della connessione dati, selezionare il nome della connessione dati che si desidera utilizzare per questa connessione dati di invio e fare clic su Avanti.

  6. Se le impostazioni sono relative a una connessione dati di invio a un servizio Web, in InfoPath vengono rilevati i parametri nel servizio Web che possono ricevere i dati. È possibile configurare la connessione dati di invio per inviare tutti i dati o una parte di essi nel modello di modulo.

    Procedura

    1. Nell'elenco Parametro selezionare un parametro a cui verranno inviati i dati dal modulo.

    2. Per inviare tutti i dati nel modulo per il parametro, tra cui l'elemento principale e le istruzioni di elaborazione, effettuare le seguenti operazioni:

      1. Fare clic su Intero modulo (documento XML, incluse istruzioni di elaborazione).

      2. Per inviare i dati come stringa, selezionare la casella di controllo Invia dati come stringa. In genere è consigliabile selezionare questa casella di controllo per inviare dati con firma digitale. Nella maggior parte dei casi deselezionare questa casella di controllo.

    3. Per specificare un campo o un gruppo per questo parametro, effettuare le seguenti operazioni:

      1. In Opzioni parametro, fare clic su Campo o gruppo.

      2. Fare clic su Modifica icona del pulsante .

      3. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

      4. Nell'elenco Includi fare clic su Solo testo ed elementi figlio per inviare solo il contenuto del campo o del gruppo oppure fare clic su Sottostruttura XML, incluso l'elemento selezionato per inviare sia il contenuto che il campo o il gruppo selezionato.

    4. Ripetere questi passaggi per tutti i parametri.

  7. Fare clic su Avanti.

  8. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×