Aggiungere una connessione dati a una raccolta documenti o a un elenco SharePoint

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile aggiungere una o più connessioni dati secondaria al modello di modulo che può ricevere i dati da una raccolta documenti o un elenco o inviare dati a una raccolta documenti in un server che esegue Microsoft Windows SharePoint Services.

In questo articolo

Panoramica

Prima di iniziare

Aggiungere una connessione dati di query

Aggiungere una connessione dati

Panoramica

Una connessione dati secondaria è qualsiasi connessione dati a un'origine dati esterna da aggiungere a un modello di modulo. La connessione dati è la differenza tra la connessione dati principale che viene creata quando si progetta modello di modulo in base a un database, servizio Web o impostazioni in una raccolta di connessioni. Aggiungere una connessione dati secondaria solo se non è possibile eseguire una query o inviare i dati mediante la connessione dati principale.

Quando si aggiunge una connessione dati secondaria al modello di modulo che corrisponde a quello che vengono memorizzati in un elenco o la raccolta documenti dati di query, Microsoft Office InfoPath crea un secondario origine dati con gruppi e i campi di dati. Icona concettuale per la sezione sull'avvio

Perché la struttura di dati nell'origine dati secondaria deve corrispondere al modo che i dati vengono archiviati in un elenco o la raccolta documenti, non è possibile modificare campi esistenti o i gruppi nell'origine dati secondaria.

Una connessione dati che riceve i dati da una condivisione nella raccolta documenti o elenco automaticamente restituisce tutti gli elementi in tale elenco o raccolta documenti. Se si utilizza una connessione dati di query per popolare un elenco casella, casella di riepilogo a discesa o casella combinata e il controllo contiene troppi elementi o che si desidera visualizzare solo gli elementi che soddisfano un criterio specificato, è possibile usare un filtro nel controllo per limitare il numero di elementi. Sono disponibili collegamenti a ulteriori informazioni sul filtraggio dei dati visualizzati in un controllo nella sezione Vedere anche.

È inoltre possibile configurare ogni connessione dati per query in modo da salvarne i risultati per poter accedere ai dati nel caso in cui il modulo non sia collegato a una rete. A seconda della natura dei dati, è possibile decidere di visualizzare i risultati della query solo se si è collegati a una rete.

Nota sulla sicurezza : Se si utilizza una connessione dati secondaria per recuperare dati riservati da un'origine dati esterna, è consigliabile disabilitare questa caratteristica per proteggere i dati da un utilizzo non autorizzato nel caso in cui è interrotta o furto del computer. Se si disattiva questa caratteristica, i dati sarà disponibili solo se l'utente è connesso alla rete.

Quando si aggiunge una connessione dati di query a un modello di modulo, per impostazione predefinita i moduli basati sul modello di modulo userà la connessione dati quando vengono aperti da un utente. È anche possibile configurare il modello di modulo per l'utilizzo della connessione dati di query in uno dei modi seguenti:

  • Aggiungere una regola    È possibile configurare una regola per l'utilizzo della connessione dati query ogni volta che si verifica la condizione della regola.

  • Pulsante Aggiungi    È possibile aggiungere un pulsante al modello di modulo che consente agli utenti di importare dati utilizzando la connessione dati di query.

  • Utilizzare codice personalizzato    Se non è possibile aggiungere una regola o un pulsante, è possibile utilizzare codice personalizzato per recuperare dati tramite la connessione dati di query. Con codice personalizzato, è necessario uno sviluppatore creare il codice personalizzato.

Durante l'aggiunta di una connessione dati per l'invio al modello di modulo, è possibile configurare il modello in modo da consentire l'invio dei dati e configurare le opzioni di invio per i moduli che si basano sul modello stesso.

Torna all'inizio

Prima di iniziare

Prima di aggiungere una connessione dati secondaria al modello di modulo, è necessario richiedere le seguenti informazioni all'amministratore del sito:

  • Il percorso del sito SharePoint e le autorizzazioni necessarie per accedervi

  • Verifica che il sito è configurato in modo che sia possibile richiamare i dati dalla raccolta documenti o dall'elenco

  • Verifica che sia possibile memorizzare i dati dalla raccolta documenti o dall'elenco sui computer per l'utilizzo non in linea

Torna all'inizio

Aggiunta di una connessione dati per query

Per consentire agli utenti di richiamare i dati da una raccolta documenti o da un elenco su un sito che si trova in un server che esegue Microsoft Windows SharePoint Services, è necessario effettuare le seguenti operazioni nel modello di modulo:

  1. Aggiungere una connessione dati secondaria.

  2. Configurare il modello di modulo per utilizzare la connessione dati secondaria.

Passaggio 1: aggiunta di una connessione dati secondaria

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Raccolta o elenco SharePoint, quindi fare clic su Avanti.

    Pagina nella connessione guidata dati per specificare un sito di SharePoint come origine dati.

  5. Nella pagina successiva della procedura guidata, digitare l'URL del sito di SharePoint con la raccolta documenti o l'elenco e quindi fare clic su Avanti. Per utilizzare un elenco di documenti in un sito di SharePoint con l' URL http://www.adventureworks.com/EmployeeList, ad esempio, digitare http://www.adventureworks.com/EmployeeList.

  6. Nella pagina successiva della procedura guidata, nell'elenco Selezionare un elenco o una raccolta, selezionare l'elenco o la raccolta che si desidera utilizzare, quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata selezionare le caselle di controllo accanto ai valori che si desidera ricevere. Se il modello di modulo verrà pubblicato sulla raccolta di documenti e si desidera che i moduli siano basati su questo modello per ottenere i metadati relativi al modulo, selezionare la casella di controllo Includi dati solo per il modulo attivo.

  8. Fare clic su Avanti.

  9. Se si desidera memorizzare i risultati della query con il modello di modulo, selezionare la casella di controllo archiviare una copia dei dati nel modello di modulo. Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, i dati sono disponibili nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete.

    Nota sulla sicurezza : Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, è disponibile nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete. Se si ottengono dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  10. Fare clic su Avanti.

  11. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per la connessione dati secondaria. Questo è il nome visualizzato nell'elenco di origine dati nel riquadro attività origine dati. Se si desidera la query venga eseguita automaticamente ogni volta che viene aperto il modulo da un utente, selezionare la casella di controllo Recupera automaticamente i dati all'apertura di modulo.

Passaggio 2: configurazione del modello di modulo per utilizzare la connessione dati secondaria

Se si vuole moduli basati sul modello di modulo per utilizzare questa connessione dati dopo l'apertura del modulo, è possibile aggiungere una regola al modello di modulo che utilizza la connessione dati in una determinata condizione oppure è possibile aggiungere un pulsante al modello di modulo che consente agli utenti di utilizzare questa connessione dati.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo per ottenere i dati dalla connessione dati per la query se viene soddisfatta la condizione per la regola. Nella procedura seguente si assume che sia stata creata una connessione dati per query per il modello di modulo e che sul modulo sia stato configurato un controllo per visualizzare i dati da tale connessione.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo per visualizzare i risultati della query.

  3. Fare clic sulla scheda Dati.

  4. In Convalida e regole fare clic su Regole.

  5. Nella finestra di dialogo Regole fare clic su Aggiungi.

  6. Nella casella Nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nell'elenco Azione, fare clic su Esegui query tramite una connessione dati.

  10. Nell'elenco Connessione dati selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere le finestre di dialogo aperte.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante

È possibile aggiungere al modello di modulo un pulsante che può essere selezionato per utilizzare la connessione dati per la query. nella seguente procedura si assume che sia già stata creata una connessione dati per la query per il modello di modulo.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare un pulsante sul modello di modulo.

  4. Fare doppio clic sul pulsante appena aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nell'elenco Azione fare clic su Aggiorna.

  7. Nella casella Etichetta immettere il nome che si desidera visualizzare sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna fare clic su Una origine dati secondaria.

  10. Nell'elenco Selezionare l'origine dati secondaria selezionare l'origine dati secondaria associata alla connessione dati per query, quindi fare clic su OK per chiudere tutte le finestre di dialogo aperte.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Aggiungere una connessione dati per invio

Per inviare i moduli basati sul modello di modulo a una raccolta documenti, effettuare le seguenti operazioni:

  1. Aggiungere una connessione dati secondaria che invia i dati al modello di modulo.

  2. Configurare il modello di modulo in modo da poter inviare i dati del modulo alla raccolta documenti.

Passaggio 1: aggiunta di una connessione dati secondaria

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Invio dati, quindi fare clic su Avanti.

  4. In Modalità di invio dei dati selezionare A una raccolta documenti in un sito di SharePoint, quindi fare clic su Avanti.

  5. In Connessione guidata dati nella casella Raccolta documenti digitare l'URL della raccolta documenti di SharePoint.

  6. Nella casella Nome file digitare un nome da utilizzare per identificare il modulo nella raccolta documenti.

    Suggerimento : È anche possibile utilizzare una formula per verificare che ogni nome di modulo sia univoco.

    Procedura

    1. Fare clic su Inserisci formula icona del pulsante .

    2. Nella finestra di dialogo Inserisci formula eseguire una delle operazioni seguenti:

      • Per includere un campo nella formula, fare clic su Inserisci campo o gruppo, nella finestra di dialogo Seleziona campo o gruppo selezionare il campo che si desidera utilizzare e quindi fare clic su OK.

      • Per includere una funzione nella formula, fare clic su Inserisci funzione, nella finestra di dialogo Inserisci funzione selezionare la funzione che si desidera utilizzare e quindi fare clic su OK.

        Suggerimento : Se la funzione richiede parametri, selezionare la funzione nella finestra di dialogo Inserisci funzione, fare clic su OK e quindi nella casella Formula nella finestra di dialogo Inserisci Formula, fare doppio clic sulla funzione che è stato aggiunto e fare clic su un campo o gruppo. Nella sezione Vedere anche sono disponibili collegamenti a ulteriori informazioni sulle funzioni.

      • Per inserire un valore o un operatore matematico nella formula, digitare il valore o il simbolo dell'operazione matematica nella casella Formula.

    Operazione

    Simbolo

    Addizione

    +

    Sottrazione

    -

    Moltiplicazione

    *

    Divisione

    /

    • Nota : Se la formula utilizza l'operatore di divisione (/), assicurarsi che sia presente uno spazio prima e dopo l'operatore di divisione. Se l'operatore di divisione non dispone di uno spazio prima e dopo tale voce, InfoPath possono interpretare "/" come separatore per i passaggi percorso XPath anziché come un operatore di divisione.

    • Per verificare la correttezza della sintassi della formula, nella finestra di dialogo Inserisci formula fare clic su Verifica formula.

      Per ulteriori informazioni sulle formule, vedere i collegamenti nella sezione Vedere anche.

  7. Per sovrascrivere moduli esistenti con lo stesso nome nella raccolta documenti, selezionare la casella di controllo Sovrascrivi se il file esiste.

  8. Fare clic su Avanti.

  9. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

Una volta aggiunta la connessione dati per l'invio secondaria, è necessario configurare il modello di modulo per consentire agli utenti di inviare i relativi dati del modulo mediante questa connessione dati.

Passaggio 2: attivazione dell'invio sul modello di modulo

Quando si configura il modello di modulo per consentire agli utenti di inviare i dati dei loro moduli, in InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia nel menu File del modulo. È inoltre possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo visualizzato nel pulsante Invia.

  • Modificare il tasto di scelta rapida del pulsante Invia.

  • Creare messaggi personalizzati da visualizzare agli utenti durante l'invio dei moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

  • Scegliere Opzioni invio dal menu Strumenti.

  • Nella finestra di dialogo Opzioni invio, selezionare la casella di controllo Consenti agli utenti di inviare il modulo, fare clic su Invia dati del modulo a una singola destinazione e quindi nell'elenco fare clic su raccolta documenti di SharePoint.

  • Nell'elenco Connessione dati per l'invio selezionare il nome della connessione dati per l'invio alla raccolta SharePoint.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  • Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×