Aggiungere una connessione dati a un servizio Web

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile aggiungere una o più connessioni dati secondarie al modello di modulo che possono recuperare o inviare dati a un servizio Web.

Contenuto dell'articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Aggiunta di una connessione dati per query

Aggiunta di una connessione dati per invio

Panoramica

Una connessione dati secondaria è qualsiasi connessione dati a un'origine dati esterna da aggiungere a un modello di modulo. La connessione dati è la differenza tra la connessione dati principale che viene creata quando si progetta modello di modulo in base a un database, servizio Web o impostazioni in una raccolta di connessioni. Aggiungere una connessione dati secondaria solo se non è possibile eseguire una query o inviare i dati mediante la connessione dati principale.

Quando si aggiunge una connessione dati secondaria al modello di modulo che riceve i dati, Microsoft Office InfoPath consente di creare un secondario origine dati con gruppi e i campi di dati che corrisponde al XML Schema del servizio Web. Poiché la struttura di dati nell'origine dati secondaria deve corrispondere lo Schema XML, non è possibile modificare i campi o i gruppi nell'origine dati secondaria esistenti. Quando si aggiunge una connessione dati al modello di modulo, si configura il modello di modulo per consentire agli utenti di inviare i dati del modulo e configurare le opzioni di invio per i moduli basati sul modello di modulo.

Inizio pagina

Considerazioni sulla compatibilità

Non è possibile configurare la connessione dati per invio in un modello di modulo compatibile con browser per consentire agli utenti di inviare le informazioni sulle modifiche insieme ai dati del modulo a un servizio Web che accetta un DataSet Microsoft ADO.NET. Le informazioni sulle modifiche sono costituite dalle modifiche che un utente apporta ai dati memorizzati in un database. Il database utilizza un servizio Web per connettere gli utenti. ADO.NET può utilizzare le informazioni sulle modifiche per determinare la modalità di aggiornamento dei dati nel database. Chiedere all'amministratore del servizio Web se il servizio Web richiede informazioni sulle modifiche per aggiornare un database. In questo caso, è necessario progettare un modello di modulo i cui moduli possano essere completati soltanto mediante InfoPath.

Inizio pagina

Prima di iniziare

Prima di aggiungere una connessione dati secondaria al modello di modulo, è necessario richiedere le seguenti informazioni dall'amministratore del servizio Web:

  • Il percorso del servizio Web.

  • Verifica che il servizio Web utilizza una codifica stile documento/letterale. InfoPath può utilizzare soltanto documenti Web con questo stile.

  • Il nome dell'operazione del servizio Web che invierà o riceverà i dati dai moduli basati sul modello di modulo.

Inizio pagina

Aggiunta di una connessione dati per query

Per consentire di recuperare i dati da un servizio Web utilizzando il modello di modulo, è necessario effettuare le seguenti operazioni nel modello di modulo:

  1. Aggiungere una connessione dati secondaria.

  2. Configurare il modello di modulo per utilizzare la connessione dati secondaria.

Passaggio 1: aggiunta di una connessione dati secondaria

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. In Provenienza dei dati, selezionare Servizio Web e fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata digitare il percorso del servizio Web e quindi fare clic su Avanti.

    Nota : Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio che viene specificato, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  6. Nell'elenco Selezionare un'operazione nella pagina successiva della procedura guidata selezionare l'operazione del servizio Web che restituisce i dati al modulo, quindi fare clic su Avanti.

  7. Se la Connessione guidata dati rileva un elemento sconosciuto nello schema del servizio Web, nella pagina successiva della procedura potrebbe essere richiesto di specificare valori di esempio per i parametri in modo da determinare i campi o i gruppi da aggiungere all'origine dati principale.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  8. Se si desidera che i risultati della query siano disponibili anche quando il modulo non è connesso a una rete, selezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo.

    Nota sulla sicurezza : Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, è disponibile nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete. Se si ottengono dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  9. Fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata immettere un nome descrittivo per la connessione dati per query.

  11. Per attivare i moduli basati su questo modello di modulo in modo da recuperare automaticamente i dati all'apertura, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

  12. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

  13. Fare clic su Chiudi.

Passaggio 2: configurazione del modello di modulo per utilizzare la connessione dati secondaria

Quando si aggiunge una connessione dati di query a un modello di modulo, per impostazione predefinita i moduli basati sul modello di modulo userà la connessione dati quando vengono aperti da un utente. È anche possibile configurare il modello di modulo per l'utilizzo della connessione dati di query in uno dei modi seguenti:

  • Aggiungere una regola    È possibile configurare una regola per l'utilizzo della connessione dati query ogni volta che si verifica la condizione della regola.

  • Pulsante Aggiungi    È possibile aggiungere un pulsante al modello di modulo che consente agli utenti di importare dati utilizzando la connessione dati di query.

  • Utilizzare codice personalizzato    Se non è possibile aggiungere una regola o un pulsante, è possibile utilizzare codice personalizzato per recuperare dati tramite la connessione dati di query. Con codice personalizzato, è necessario uno sviluppatore creare il codice personalizzato.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo per ottenere i dati dalla connessione dati per la query se viene soddisfatta la condizione per la regola. Nella procedura seguente si assume che sia stata creata una connessione dati per query per il modello di modulo e che sul modulo sia stato configurato un controllo per visualizzare i dati da tale connessione.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo a cui si desidera aggiungere la regola.

  3. Fare clic sulla scheda Dati.

  4. In Convalida e regole fare clic su Regole.

  5. Nella finestra di dialogo Regole fare clic su Aggiungi.

  6. Nella casella Nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nell'elenco Azione, fare clic su Esegui query tramite una connessione dati.

  10. Nell'elenco Connessione dati selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere le finestre di dialogo aperte.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante

È possibile aggiungere un pulsante al modello di modulo che può essere selezionato dagli utenti per richiamare i dati dalla connessione dati per query. Nella seguente procedura si assume che sia stata creata una connessione dati per query per il modello di modulo.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare un pulsante sul modello di modulo.

  4. Fare doppio clic sul pulsante appena aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nell'elenco Azione fare clic su Aggiorna.

  7. Nella casella Etichetta immettere il nome che si desidera visualizzare sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna fare clic su Una origine dati secondaria.

  10. Nell'elenco Selezionare l'origine dati secondaria selezionare l'origine dati secondaria associata alla connessione dati per query, quindi fare clic su OK per chiudere tutte le finestre di dialogo aperte.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Aggiungere una connessione dati per invio

Per consentire l'invio di moduli basati sul modello di modulo a un servizio Web, è necessario per prima cosa aggiungere una connessione dati secondaria al modello di modulo che invia i dati e configurare quindi il modello in modo da consentire agli utenti di inviare i dati del modulo.

Passaggio 1: aggiunta di una connessione dati secondaria

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Invio dati, quindi fare clic su Avanti.

  4. In Modalità di invio dei dati, selezionare A un servizio Web e fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web a cui gli utenti invieranno i dati, quindi fare clic su Avanti.

    Nota : Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio che viene specificato, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  6. Nell'elenco Selezionare un'operazione fare clic sull'operazione del servizio Web che riceverà i dati del modulo e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata per selezionare i dati del modulo da inviare per ogni parametro del servizio Web, eseguire una delle operazioni seguenti:

    Inviare i dati di un campo o gruppo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni parametro, fare clic su Campo o gruppo.

    3. Fare clic su Modifica Icona del pulsante .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su Solo testo ed elementi figlio per inviare solo i dati del campo selezionato e gli elementi figlio del campo o gruppo, oppure fare clic su Sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati contenuti nel campo e gli elementi figlio del gruppo o campo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come stringa

    1. Nell'elenco Parametri fare clic sul parametro del servizio Web in base a cui verranno inviati i dati dal modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come stringa.

      Nota : In genere è consigliabile selezionare questa casella di controllo per inviare dati con firma digitale. Nella maggior parte dei casi deselezionare questa casella di controllo.

    Nota tecnica sugli oggetti DataSet di ADO.NET

    Se il servizio Web richiede un oggetto DataSet ADO.NET, quando si configura questa connessione dati selezionare un nodo di set di dati. Se si utilizza un qualsiasi altro tipo di nodo per una connessione dati a un servizio Web che richiede un DataSet ADO.NET, l'azione di invio riporterà un errore.

  8. Fare clic su Avanti.

  9. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati.

  10. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

  11. Fare clic su Chiudi.

Una volta aggiunta la connessione dati per l'invio secondaria, è necessario configurare il modello di modulo per consentire agli utenti di inviare i relativi dati del modulo mediante questa connessione dati.

Passaggio 2: attivazione dell'invio sul modello di modulo

Quando si configura il modello di modulo per consentire agli utenti di inviare i dati dei loro moduli, in InfoPath vengono aggiunti un pulsante Invia sulla barra degli strumenti Standard e un comando Invia nel menu File del modulo. È inoltre possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo visualizzato per il pulsante Invia e il comando Invia.

  • Modificare il tasto di scelta rapida del pulsante Invia e del comando Invia.

  • Creare messaggi personalizzati da visualizzare agli utenti durante l'invio dei moduli.

  • Specificare se dopo l'invio del modulo, quest'ultimo deve essere tenuto aperto o chiuso oppure se deve essere aperto un modulo vuoto.

  • Scegliere Opzioni invio dal menu Strumenti.

  • Nella finestra di dialogo Opzioni invio selezionare la casella di controllo Consenti agli utenti di inviare il modulo, fare clic su Invia dati modulo a una destinazione sola e quindi selezionare Servizio Web nell'elenco.

  • Nell'elenco Connessione dati per l'invio selezionare il nome della connessione dati per l'invio al servizio Web creato nei passaggi precedenti.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella didascalia nella finestra di dialogo Opzioni invio.

      Suggerimento : Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  • Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento : Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori istruzioni contattare una persona.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×