Aggiungere una connessione dati a un database di Microsoft Access

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Se gli utenti hanno l'esigenza di accedere ai dati da un database di Microsoft Office Access 2007 (in formato accdb) o da un database di Access salvato in una versione precedente (in formato mdb) per compilare un modulo basato su un modello di modulo di Microsoft Office InfoPath, è possibile aggiungere una connessione dati secondaria al modello di modulo da cui vengono inviate query a un database di Access.

È possibile aggiungere una connessione dati secondaria, ma tramite questa connessione dati sarà possibile inviare query solo a un database di Access. Non è possibile aggiungere una connessione dati secondaria per l'invio di dati di un modulo a un database di Access.

Per consentire agli utenti di inviare dati dei moduli a un database di Access, è possibile progettare un modello di modulo basato su un database di Access, quindi abilitare la connessione dati per invio nella connessione dati principale. In alternativa è possibile aggiungere una connessione dati secondaria a un servizio Web che interagisca con il database di Access.

Per ulteriori informazioni sulla progettazione di modelli di modulo basati su un database di Access e sull'aggiunta di una connessione dati secondaria a un servizio Web, fare clic sui collegamenti disponibili nella sezione Vedere anche.

In questo articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Passaggio 1: Aggiungere una connessione dati secondaria

Passaggio 2: Configurare il modello di modulo per utilizzare la connessione dati

Panoramica

Una connessione dati secondaria è una connessione dati aggiunta a un modello di modulo. Questa connessione dati è diversa dalla connessione dati principale creata durante la progettazione di un nuovo modello di modulo basato su un database o un servizio Web. Una connessione dati principale di un modello di modulo può essere utilizzata per ricevere dati da un'origine dati esterna e, inoltre, inviare dati del modulo a un'origine dati esterna. Per un modello di modulo è tuttavia possibile configurare una sola connessione dati principale.

È possibile aggiungere un numero illimitato di connessioni dati secondarie a un modello di modulo. Si supponga, ad esempio, che in un database di Access siano incluse una tabella in cui sono archiviati i dati dei dipendenti e un'altra tabella in cui sono archiviati i dati dei clienti. È possibile aggiungere una connessione dati secondaria che recuperi i dati dalla tabella dei dipendenti e una connessione dati secondaria che recuperi i dati dalla tabella dei clienti nello stesso database di Access.

Anche se è possibile aggiungere una connessione dati secondaria al modello di modulo per inviare i dati del modulo a un'origine dati esterna, ad esempio un servizio Web o una raccolta di Windows SharePoint Services, le connessioni dati secondarie possono essere utilizzate solo per recuperare dati da un database di Access. Non è infatti possibile aggiungere una connessione dati secondaria per l'invio di dati del modulo a un database di Access.

Quando si aggiunge una connessione dati di query a un database, viene creata una secondaria origine dati che contiene i campi dati e i gruppi che corrispondono in modo che i dati sono stati memorizzati nel database. Perché la struttura di dati nell'origine dati secondaria deve corrispondere al modo che i dati vengono archiviati in tabelle di database, non è possibile modificare i campi o i gruppi nell'origine dati secondaria.

È possibile configurare ogni connessione dati per query in modo che i relativi dati vengano salvati per consentire agli utenti di accedere ai dati stessi quando il modulo non è connesso a una rete. A seconda della natura dei dati, i risultati della query possono essere visualizzati solo quando gli utenti sono connessi a una rete.

Nota sulla sicurezza : Se si utilizza una connessione dati secondaria per recuperare dati riservati da un'origine dati esterna, è consigliabile disabilitare questa caratteristica per proteggere i dati da un utilizzo non autorizzato nel caso in cui è interrotta o furto del computer. Se si disattiva questa caratteristica, i dati sarà disponibili solo se l'utente è connesso alla rete.

Quando si aggiunge una connessione dati di query a un modello di modulo, per impostazione predefinita i moduli basati sul modello di modulo userà la connessione dati quando vengono aperti da un utente. È anche possibile configurare il modello di modulo per l'utilizzo della connessione dati di query in uno dei modi seguenti:

  • Aggiungere una regola    È possibile configurare una regola per l'utilizzo della connessione dati query ogni volta che si verifica la condizione della regola.

  • Pulsante Aggiungi    È possibile aggiungere un pulsante al modello di modulo che consente agli utenti di importare dati utilizzando la connessione dati di query.

  • Utilizzare codice personalizzato    Se non è possibile aggiungere una regola o un pulsante, è possibile utilizzare codice personalizzato per recuperare dati tramite la connessione dati di query. Utilizzo di codice personalizzato richiede agli sviluppatori di creare il codice personalizzato.

Torna all'inizio

Considerazioni sulla compatibilità

Non è possibile aggiungere una connessione dati a un database di Access a un modello di modulo compatibile con browser.

Torna all'inizio

Prima di iniziare

Prima di aggiungere una connessione dati a un database di Access al modello di modulo in uso, è necessario disporre delle seguenti informazioni:

  • Il nome e il percorso del database.

    Nota : Se il database di Access è archiviato in un percorso di rete, assicurasi che il database sia accessibile agli utenti.

  • Il nome della tabella o della query che invierà i dati ai moduli basati su questo modello di modulo. Questa tabella o query verrà utilizzata come tabella o query primaria quando si configura la connessione dati per query.

  • I nomi di tabelle o query che forniscono dati aggiuntivi per la tabella primaria o la query. Nella maggior parte dei casi, tabella sono già state definite relazioni nel database. Se è necessario effettuare manualmente le relazioni tra la tabella primaria o query e un'altra tabella o la query, sarà necessario i nomi dei campi correlati di entrambe le tabelle o query.

Torna all'inizio

Passaggio 1: aggiunta di una connessione dati secondaria

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Database (solo Microsoft SQL Server o Microsoft Office Access), quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Seleziona database.

  6. Nella finestra di dialogo Seleziona origine dati individuare il percorso del database.

    Nota : Se il database è archiviato in un percorso di rete, selezionare il percorso universal naming convention (UNC) della posizione. Non visualizzare il percorso di rete tramite un'unità di rete. Se si usa un'unità di rete, gli utenti che creano moduli basati sul modello di modulo cercherà il database da un'unità di rete. Se l'utente non dispone di un'unità di rete, la maschera non troverà il database.

  7. Fare clic sul nome del database, quindi scegliere Apri.

  8. Nella finestra di dialogo Seleziona tabella fare clic sulla tabella o sulla query primaria che si desidera utilizzare, quindi scegliere OK.

  9. Nella pagina successiva della procedura guidata selezionare la casella di controllo Mostra colonne tabella.

    Per impostazione predefinita, tutti i campi nella tabella o nella query vengono aggiunti all'origine dati principale del modello di modulo.

  10. Deselezionare le caselle di controllo dei campi che non si desidera includere nell'origine dati secondaria.

    Aggiungere eventuali ulteriori tabelle o query alla connessione dati.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Ripetere queste operazioni per aggiungere altre tabelle figlio.

  11. Fare clic su Avanti.

  12. Per rendere disponibili i risultati della connessione dati per query quando il modulo non è connesso a una rete, selezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo.

    Nota sulla sicurezza : Selezionando questa casella di controllo, i dati verranno archiviati sul computer dell'utente quando la connessione dati viene utilizzata dal modulo. Se da questa connessione dati vengono recuperati dati riservati, si consiglia di disattivare questa funzionalità al fine di proteggere i dati qualora il computer venga perso o rubato.

  13. Fare clic su Avanti.

  14. Nella pagina successiva della procedura guidata digitare un nome descrittivo per la connessione dati secondaria, quindi verificare che le informazioni nella sezioneRiepilogo siano corrette.

  15. Per configurare il modulo in modo che all'apertura riceva automaticamente i dati, selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

Torna all'inizio

Passaggio 2: Configurare il modello di modulo per l'utilizzo della connessione dati

Se si desidera che dopo l'apertura da parte degli utenti i moduli basati su questo modello di modulo personalizzato utilizzino questa connessione dati, è possibile aggiungere una regola al modello di modulo che attivi l'utilizzo della connessione dati in una determinata condizione oppure un pulsante su cui gli utenti possono fare clic per utilizzare la connessione dati.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo per recuperare i dati dalla connessione dati per query ogni volta che viene soddisfatta la condizione specificata. Ad esempio, è possibile aggiungere una casella di testo al modello di modulo che potrà essere compilata dagli utenti per ottenere dati specifici da un'origine dati esterna, quindi aggiungere una regola affinché venga utilizzata la connessione dati ogni volta che un utente immette dati nella casella di testo.

Nella procedura riportata di seguito si presuppone che sia stata creata una connessione dati per query per il modello di modulo e che nello stesso modello di modulo si sia configurato un controllo, diverso da un pulsante, per la visualizzazione dei dati tramite quella connessione dati.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo a cui si desidera aggiungere la regola.

  3. Fare clic sulla scheda Dati.

  4. In Convalida e regole fare clic su Regole.

  5. Nella finestra di dialogo Regole fare clic su Aggiungi.

  6. Nella casella Nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nell'elenco Azione, fare clic su Esegui query tramite una connessione dati.

  10. Nell'elenco Connessione dati selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere le finestre di dialogo aperte.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante

È possibile aggiungere un pulsante al modello di modulo che può essere selezionato dagli utenti per recuperare i dati dalla connessione dati per query.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare un pulsante nel modello di modulo.

  4. Fare doppio clic sul pulsante aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nell'elenco Azione fare clic su Aggiorna.

  7. Nella casella Etichetta immettere il nome che si desidera visualizzare sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna effettuare una delle seguenti operazioni:

    • Per ricevere i dati più recenti da tutte le origini dati esterne con connessioni dati secondarie con questo modello di modulo, fare clic su Tutte le origini dati secondarie.

    • Per configurare il pulsante in modo da ricevere i dati più recenti da un'origine dati esterna con una connessione dati secondaria al modello di modulo, fare clic su Una origine dati secondaria, quindi fare clic su un'origine dati secondaria nell'elenco Selezionare l'origine dati secondaria.

  10. Scegliere OK per chiudere ogni finestra di dialogo aperta.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×