Aggiungere una connessione dati a un database Microsoft SQL Server

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile aggiungere una connessione dati secondaria al modello di modulo che esegue query in un database Microsoft SQL Server. Non è possibile aggiungere una connessione dati secondaria al modello di modulo che invia dati a un database. Se si desidera utilizzare una connessione dati secondaria per inviare i dati del modulo a un database, utilizzare una connessione dati secondaria a un servizio Web associato a tale database. Per ulteriori informazioni sull'aggiunta di una connessione dati secondaria a un servizio Web, fare clic sui collegamenti nella sezione Vedere anche.

Per aggiungere una connessione dati secondaria a un database, effettuare le seguenti operazioni:

Passaggio 1: aggiunta di una connessione dati secondaria al modello di modulo    In questo passaggio viene creata l'origine dati secondaria con i campi e i gruppi appropriati in base alla modalità di memorizzazione dei dati nel database. È inoltre possibile configurare il modello di modulo in modo da utilizzare questa connessione dati all'apertura del modulo.

Passaggio 2: configurazione del modello di modulo per utilizzare la connessione dati    Se si desidera utilizzare questa connessione dati una volta aperto il modulo, è possibile aggiungere una regola o un pulsante al modello di modulo in modo da consentire agli utenti di richiamare i dati da questa connessione dati.

Contenuto dell'articolo

Panoramica

Prima di iniziare

Passaggio 1: Aggiungere una connessione dati secondaria

Passaggio 2: Configurare il modello di modulo per utilizzare la connessione dati

Informazioni generali

Durante la creazione di un modello di dati che si basa su un'origine dati esterna, in Microsoft Office InfoPath viene creata una connessione dati principale all'origine dati esterna. L'origine dati principale viene quindi creata in base al modo in cui sono stati memorizzati nell'origine dati esterna. Tuttavia, l'origine dati esterna utilizzata nella connessione dati principale potrebbe non contenere i valori che si desidera inserire nei controlli nel modello di modulo, che potrebbero invece essere presenti in un'altra origine dati esterna, come ad esempio un altro database SQL Server. Per recuperare i valori da un'altra origine dati esterna, è possibile aggiungere una connessione dati secondaria al modello di modulo.

Una connessione dati secondaria è una connessione dati che viene aggiunta a un modello di modulo. Tale connessione può essere una connessione dati per query o una connessione dati per l'invio. È possibile aggiungere una connessione dati per query al modello di modulo solo come connessione dati secondaria a un server SQL Server e solo se sono necessari dati da un'origine esterna diversa da quella nella connessione dati principale. Non è possibile aggiungere una connessione dati per l'invio a un database SQL Server come connessione dati secondaria.

Quando si aggiunge una connessione dati di query a un database, viene creata una secondario origine dati con campi dati e gruppi corrispondenti in modo che i dati sono stati memorizzati nel database. Perché la struttura di dati nell'origine dati secondaria deve corrispondere al modo che i dati vengono archiviati in tabelle di database, non è possibile modificare i campi o i gruppi nell'origine dati secondaria. È possibile configurare ogni connessione a dati query per salvare i risultati in modo che gli utenti abbiano accesso ai dati quando il modulo non è connesso a una rete. A seconda della natura dei dati, si desidera visualizzare i risultati della query solo quando gli utenti sono connessi a una rete.

Nota sulla sicurezza : Se si utilizza una connessione dati secondaria per recuperare dati riservati da un'origine dati esterna, è consigliabile disabilitare questa caratteristica per proteggere i dati da un utilizzo non autorizzato nel caso in cui è interrotta o furto del computer. Se si disattiva questa caratteristica, i dati sarà disponibili solo se l'utente è connesso alla rete.

Quando si aggiunge una connessione dati di query a un modello di modulo, per impostazione predefinita i moduli basati sul modello di modulo userà la connessione dati quando vengono aperti da un utente. È anche possibile configurare il modello di modulo per l'utilizzo della connessione dati di query in uno dei modi seguenti:

  • Aggiungere una regola    È possibile configurare una regola per l'utilizzo della connessione dati query ogni volta che si verifica la condizione della regola.

  • Pulsante Aggiungi    È possibile aggiungere un pulsante al modello di modulo che consente agli utenti di importare dati utilizzando la connessione dati di query.

  • Utilizzare codice personalizzato    Se non è possibile aggiungere una regola o un pulsante, è possibile utilizzare codice personalizzato per recuperare dati tramite la connessione dati di query. Utilizzo di codice personalizzato richiede agli sviluppatori di creare il codice personalizzato.

Torna all'inizio

Prima di iniziare

Prima di aggiungere una connessione dati secondaria a un database SQL Server al modello di modulo, è necessario richiedere le seguenti informazioni all'amministratore del database:

  • Il nome del server con il database che verrà utilizzato con questo modello di modulo.

  • Il nome del database che verrà utilizzato con questo modello di modulo.

  • L'autenticazione richiesta dal database. Il database può utilizzare sia l'autenticazione Microsoft Windows che l'autenticazione SQL Server per determinare il modo in cui gli utenti possono accedere al database.

  • Il nome della tabella contenente i dati che si desidera inviare al modulo. Questa è la tabella primaria. Se si intende utilizzare più di una tabella nel database, è necessario conoscere i nomi di queste altre tabelle figlio. Sono inoltre necessari i nomi dei campi della tabella figlio che hanno relazioni con i campi nella tabella primaria.

  • Se è possibile memorizzare i risultati della query nel modulo per l'utilizzo non in linea.

Torna all'inizio

Passaggio 1: aggiunta di una connessione dati secondaria

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Da Connessione guidata dati, fare clic su Crea nuova connessione per, selezionare Ricezione dati, quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Database (solo Microsoft SQL Server o Microsoft Office Access), quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Seleziona database.

  6. Nella finestra di dialogo Selezione origine dati fare clic su Nuova origine.

  7. Nell'elenco Indicare l'origine dati alla quale connettersi selezionare Microsoft SQL Server e fare clic su Avanti.

  8. Nella casella Nome server immettere il nome del server che contiene il database.

  9. In Credenziali di accesso, effettuare una delle seguenti operazioni:

    • Se il database determina l'utente che ha accesso in base alle credenziali utilizzate in una rete Microsoft Windows, fare clic su Usa autenticazione di Windows.

    • Se il database determina l'utente che ha accesso in base al nome utente e alla password specificati ottenuti dall'amministratore del database, fare clic su Usa nome utente e password seguenti, quindi immettere il nome utente e la password nelle caselle Nome utente e Password.

  10. Fare clic su Avanti.

  11. Nella pagina successiva della procedura guidata fare clic sul database che si desidera utilizzare nell'elenco Selezionare il database contenente i dati desiderati, selezionare la casella di controllo Connetti a una tabella specifica, fare clic sul nome della tabella primaria, quindi fare clic su Avanti.

  12. Nella pagina successiva della procedura guidata digitare nella casella Nome file il nome da assegnare al file in cui sono archiviate le informazioni sulla connessione dati.

  13. Per salvare le impostazioni, fare clic su Fine.

  14. Aggiungere le eventuali altre tabelle che si desidera utilizzare nella connessione dati per query.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Ripetere queste operazioni per aggiungere altre tabelle figlio.

  15. Fare clic su Avanti.

  16. Per rendere i risultati della query disponibili anche quando il modulo non è connesso a una rete, selezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo.

    Nota sulla sicurezza : Selezionando questa casella di controllo, i dati verranno memorizzati nel computer dell'utente quando il modulo utilizzerà questa connessione dati. Se il modulo richiama i dati riservati da questa connessione dati, è possibile disattivare tale caratteristica per proteggere i dati in caso di perdita o furto del computer.

  17. Fare clic su Avanti.

  18. Nella pagina successiva della procedura guidata, immettere un nome descrittivo per questa connessioni dati secondaria. Se si desidera recuperare automaticamente i dati all'apertura del modulo, selezionare la casella di controllo Recupera automaticamente dati all'apertura del modulo.

Torna all'inizio

Passaggio 2: configurazione del modelli di modulo per utilizzare la connessione dati

Se si desidera che i moduli basati su questo modello di modulo utilizzino questa connessione dati in seguito all'apertura del modulo, è possibile aggiungere una regola al modello di modulo che utilizza questa connessione dati in base a una determinata connessione oppure è possibile aggiungere un pulsante che possa essere selezionato dagli utenti.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo per ottenere i dati dalla connessione dati per la query se viene soddisfatta la condizione per la regola. Nella procedura seguente si assume che sia stata creata una connessione dati per query per il modello di modulo e che sul modulo sia stato configurato un controllo per visualizzare i dati da tale connessione.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo a cui si desidera aggiungere la regola.

  3. Fare clic sulla scheda Dati.

  4. In Convalida e regole fare clic su Regole.

  5. Nella finestra di dialogo Regole fare clic su Aggiungi.

  6. Nella casella Nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nell'elenco Azione, fare clic su Esegui query tramite una connessione dati.

  10. Nell'elenco Connessione dati selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere le finestre di dialogo aperte.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante

È possibile aggiungere un pulsante al modello di modulo che può essere selezionato dagli utenti per recuperare i dati dalla connessione dati per query.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare un pulsante nel modello di modulo.

  4. Fare doppio clic sul pulsante aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nell'elenco Azione fare clic su Aggiorna.

  7. Nella casella Etichetta immettere il nome che si desidera visualizzare sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna fare clic su Una origine dati secondaria.

  10. Nell'elenco Selezionare l'origine dati secondaria fare clic sull'origine dati secondaria associata alla connessione dati per la query.

  11. Fare clic su OK per chiudere le finestre di dialogo aperte.

  12. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×