Aggiungere un pulsante per passare da una visualizzazione all'altra

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In Microsoft Office InfoPath, è possibile creare visualizzazioni diverse dello stesso modello di modulo. Una visualizzazione è un'alternativa per presentare i dati in un modello di modulo. Durante la compilazione moduli basati sul modello di modulo di utenti possono passare tra le visualizzazioni per scegliere la quantità di dati rappresentati nel modulo. In un modello di modulo rapporto di stato, ad esempio, si potrebbe progettare una visualizzazione Riepilogo oltre a una visualizzazione dettagliata. Gli utenti possono quindi scegliere la visualizzazione preferiscono esaminare, a seconda di quali tipi di informazioni hanno bisogno.

Le visualizzazioni vengono spesso progettate in modo che possano essere integrate con le regole. Le regole consentono di rendere automatiche alcune operazioni specifiche in un modulo in risposta ad azioni o eventi avviati dall'utente che compila il modulo. In questo articolo, ad esempio, viene descritto come inserire un pulsante nel modello di modulo e come creare una regola per passare da una visualizzazione all'altra quando si fa clic sul pulsante.

Contenuto dell'articolo

Passaggio 1: Inserire un pulsante in ogni visualizzazione

Passaggio 2: Creare una regola per passa da una visualizzazione

Passaggio 3: Verifica dell'esperienza utente

Passaggio 1: Inserire un pulsante in ciascuna visualizzazione

Nota : Per completare la procedura seguente, è necessario disporre di un modello di modulo con due visualizzazioni esistenti. I collegamenti a ulteriori informazioni sulla creazione di visualizzazioni sono disponibili nella sezione Vedere anche.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione fare clic sulla visualizzazione a cui si desidera aggiungere un pulsante.

  3. Nel modello di modulo posizionare il cursore nel punto in cui si desidera inserire il pulsante.

  4. Scegliere Altri controlli dal menu Inserisci, oppure premere ALT+I, A.

  5. Nel gruppo Inserisci controlli del riquadro attività Controlli fare clic su Pulsante.

  6. Nel modello di modulo fare doppio clic sul pulsante inserito.

  7. Scegliere la scheda Generale.

  8. Nella casella Etichetta digitare il testo da visualizzare nel pulsante, quindi scegliere OK.

  9. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  10. In Selezionare una visualizzazione fare clic sul nome della seconda visualizzazione.

  11. Seguire i passaggi da 3 a 8 per aggiungere un pulsante alla seconda visualizzazione.

Torna all'inizio

Passaggio 2: Creare una regola per il passaggio da una visualizzazione all'altra

Dopo avere aggiunto i pulsanti a ciascuna visualizzazione nel modello di modulo, è necessario creare le regole per passare da una visualizzazione all'altra quando gli utenti fanno clic sui pulsanti.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione fare clic sulla visualizzazione che si desidera utilizzare.

  3. Nel modello di modulo fare doppio clic sul pulsante inserito nella procedura precedente.

  4. Scegliere la scheda Generale.

  5. Nell'elenco Azione scegliere Regole e codice personalizzato.

  6. Fare clic su Regole.

  7. Nella finestra di dialogo Regole fare clic su Aggiungi.

  8. Nella casella Nome digitare un nome per la regola, ad esempio Passa a visualizzazione 2. Questo nome verrà visualizzato quando si utilizzerà la visualizzazione in modalità progettazione. Il nome non verrà tuttavia visualizzato dagli utenti che compilano il modulo.

  9. Fare clic su Aggiungi azione.

  10. Nell'elenco Azione scegliere Cambia visualizzazione.

  11. Nell'elenco Visualizzazione fare clic sulla visualizzazione a cui si desidera passare, quindi scegliere OK.

  12. Scegliere OK per chiudere tutte le finestre di dialogo aperte.

  13. Nell'elenco Selezionare una visualizzazione del riquadro attività Visualizzazioni fare clic sulla seconda visualizzazione.

  14. Seguire i passaggi da 3 a 12 per creare una regola per il pulsante nella seconda visualizzazione.

Torna all'inizio

Passaggio 3: Verificare il modello di modulo

Dopo avere aggiunto i pulsanti alle visualizzazioni e creato le regole necessarie, è consigliabile verificare il modello di modulo per assicurarsi che funzioni come previsto.

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

    Nota : L'ultima visualizzazione utilizzata verrà visualizzata nella finestra di anteprima.

  2. Per verificare che i pulsanti per passare da una visualizzazione all'altra funzionino correttamente, fare clic sui pulsanti creati nella procedura precedente.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×