Aggiungere un campo a una maschera o a un report

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile aggiungere rapidamente campi a una maschera o a un report utilizzando il riquadro Elenco campi. Quando si fa doppio clic su un campo del riquadro Elenco campi o si trascina un campo dall'elenco alla maschera o al report, in Microsoft Office Access 2007 viene automaticamente creato il controllo appropriato per visualizzare il campo, ad esempio una casella di testo o una casella di controllo, e quindi tale controllo viene associato al campo.

Se non è una maschera o report esistente per aggiungere un campo, vedere creare una maschera utilizzando lo strumento maschera o creare un report semplice per iniziare.

Suggerimento : Report di Access 2010 include layout controllo, che consentono di mantenere elementi allineati e dall'aspetto ottimale!

Per saperne di più

Aggiungere un campo a una maschera o report utilizzando il riquadro elenco campi

Aggiungere un campo a una maschera o un report in visualizzazione struttura

Ulteriori informazioni sul riquadro elenco campi

Aggiungere un campo a una maschera o report utilizzando il riquadro elenco campi

  1. Aprire il report in visualizzazione Layout o Struttura.

    Se il riquadro Elenco campi non viene visualizzato, eseguire una delle operazioni seguenti:

    • Nel gruppo Controlli della scheda Formato fare clic su Aggiungi campi esistenti Icona del pulsante . Icona del pulsante

    • Premere ALT+F8.

  2. Nel riquadro Elenco campi individuare la tabella contenente il campo che si desidera aggiungere. Per visualizzare o nascondere l'elenco di campi per ogni tabella, fare clic sul segno più (+) o meno (-) accanto al nome della tabella.

    Nota : Se il database non contiene alcuna tabella, il riquadro Elenco campi risulterà vuoto.

  3. Dopo avere individuato il campo che si desidera aggiungere, eseguire una delle operazioni seguenti per aggiungerlo alla maschera o al report:

    • Fare doppio clic sul campo.

    • Trascinare il campo dal riquadro Elenco campi alla maschera o al report.

    • Fare clic su più campi tenendo premuto CTRL e quindi trascinarli insieme nella maschera o nel report.

      Nota : Questa tecnica può essere utilizzata solo con i campi inclusi nella sezione Campi disponibili per la visualizzazione del riquadro Elenco campi.

    • Aggiungere un intervallo di campi inclusi nel riquadro Elenco campi alla maschera o al report eseguendo una delle operazioni seguenti:

    • Fare clic sul primo campo nell'intervallo.

    • Tenendo premuto MAIUSC, fare clic sull'ultimo campo nell'intervallo.

      Verranno selezionati i due campi su cui si è fatto clic, insieme a tutti quelli inclusi nell'intervallo.

    • Trascinare tutti i campi selezionati nella maschera o nel report.

      Nota : Questa tecnica può essere utilizzata solo con i campi inclusi nella sezione Campi disponibili per la visualizzazione del riquadro Elenco campi.

  4. In Office Access 2007 viene creato il controllo appropriato per visualizzare ogni campo e tale controllo viene associato al campo. Per il controllo viene inoltre creata un'etichetta allegata. È possibile modificare l'etichetta. A tale scopo, fare clic sull'etichetta per selezionarla e quindi fare clic di nuovo per posizionare il punto di inserimento nell'etichetta. Sarà quindi possibile modificare l'etichetta allo stesso modo in cui si modifica il testo in un documento.

  5. Se si desidera che un campo venga visualizzato in un tipo di controllo diverso da quello creato automaticamente in Access, è possibile modificare il controllo in un altro tipo. Il controllo, tuttavia, può essere modificato solo in un tipo appropriato per il campo. Ad esempio, è possibile modificare una casella combinata in una casella di testo o una casella di riepilogo, ma non in un pulsante di comando.

    Modificare un controllo da un tipo a un altro

    1. Aprire la maschera o il report in visualizzazione Struttura. A tale scopo, fare clic con il pulsante destro del mouse sulla maschera o il report nel riquadro di spostamento e quindi scegliere Visualizzazione Struttura Icona del pulsante .

    2. Fare clic con il pulsante destro del mouse sul controllo che si desidera modificare e quindi scegliere Cambia in.

      Se la voce di menu Cambia in non è disponibile, significa che non sono presenti altri tipi di controllo appropriati per il campo. In caso contrario, in Access verrà visualizzato un elenco di tipi di controllo.

    3. Fare clic su uno dei tipi di controllo disponibili per modificare il controllo di conseguenza.

      Il controllo sarà sempre associato al campo, ma potrebbe essere necessario impostare alcune proprietà affinché il nuovo tipo di controllo funzioni nel modo desiderato. Per visualizzare la finestra delle proprietà per un controllo, fare clic sul controllo per selezionarlo e quindi premere F4.

Torna all'inizio

Aggiungere un campo a una maschera o a un report in visualizzazione Struttura

L'utilizzo del riquadro Elenco campi rappresenta in genere il modo più semplice per aggiungere un campo a una maschera o a un report. È tuttavia possibile aggiungere un campo anche creando un controllo e quindi associando tale controllo a un campo. Di seguito viene indicata la procedura per eseguire questa operazione.

  1. Aprire la maschera o il report in visualizzazione Struttura. A tale scopo, fare clic con il pulsante destro del mouse sulla maschera o il report nel riquadro di spostamento e quindi scegliere Visualizzazione struttura.

    Creazioni guidate Controllo    È possibile utilizzare lo strumento Creazioni guidate Controllo per creare pulsanti di comando, caselle di riepilogo, sottomaschere, caselle combinate e gruppi di opzioni. In una Creazione guidata Controllo viene visualizzata una serie di domande sulle preferenze relative all'aspetto e al funzionamento del controllo e il controllo viene quindi creato e le relative proprietà vengono impostate in base alle risposte immesse. Se nel gruppo Controlli della scheda Struttura il pulsante Usa creazioni guidate Controllo non è evidenziato, fare clic su di esso per evidenziarlo.

    Icona del pulsante

    Per creare controlli senza usare le procedure guidate, fare clic sul pulsante Usa creazioni guidate Controllo per deselezionarlo.

    Icona del pulsante

  2. Nel gruppo Controlli della scheda Struttura fare clic sullo strumento corrispondente al tipo di controllo che si desidera aggiungere.

    immagine della barra multifunzione di access

    Per determinare il nome di uno strumento, posizionare il puntatore sull'icona corrispondente per visualizzarne il nome in Access.

  3. Fare clic sulla griglia di struttura della maschera o del report nel punto in cui si desidera posizionare l'angolo superiore sinistro del controllo. Fare clic una volta per creare un controllo con dimensioni predefinite oppure fare clic sullo strumento e quindi trascinarlo nella griglia di struttura per creare un controllo delle dimensioni desiderate.

  4. Se si è selezionato Usa creazioni guidate Controllo e il controllo che si desidera inserire è associato a una procedura guidata, questa verrà avviata per eseguire le diverse impostazioni del controllo.

  5. Se al primo tentativo il controllo non è stato posizionato in modo corretto, è possibile spostarlo eseguendo una delle operazioni seguenti:

    1. Fare clic sul controllo per selezionarlo

    2. Posizionare il puntatore sul controllo fino a quando non si trasforma in un puntatore Sposta puntatore sposta .

    3. Fare clic sul controllo e trascinarlo nella posizione desiderata.

Se si utilizza una procedura guidata, potrebbero essere visualizzati i passaggi necessari per associare il controllo a un campo. Se la procedura guidata non esegue l'associazione del controllo a un campo e il tipo di controllo, ad esempio una casella di testo o una casella combinata, consente di visualizzare dati, è necessario immettere un nome di campo o un'espressione nella proprietà Origine controllo per il controllo prima che sia possibile visualizzare i dati. Utilizzare la procedura seguente per associare il controllo a un campo.

  1. Visualizzare la finestra delle proprietà per il controllo facendo clic sul controllo, quindi premendo F4.

  2. Nella scheda Dati della finestra delle proprietà fare clic sulla freccia accanto alla proprietà Origine controllo e selezionare il campo che si desidera visualizzare nel controllo. Nella casella Origine campo è inoltre possibile digitare un'espressione.

    Per ulteriori informazioni sulle espressioni, vedere l'articolo creare un'espressione.

Torna all'inizio

Ulteriori informazioni sul riquadro elenco campi

Nell'elenco seguente sono inclusi alcuni suggerimenti utili sull'utilizzo del riquadro Elenco campi per aggiungere campi alla maschera o al report. Per visualizzare il riquadro Elenco campi, aprire una maschera o un report in visualizzazione Layout o Struttura e quindi premere ALT+F8.

  • Se la proprietà Origine record della maschera o del report è vuota e si trascina un campo dal riquadro Elenco campi alla maschera o al report, la proprietà Origine record della maschera o del report verrà impostata automaticamente in Access.

  • Se la proprietà Origine record della maschera o del report è un'istruzione SELECT o un nome di tabella, è possibile alternare la visualizzazione del riquadro Elenco campi tra i due stati seguenti:

    • Mostra tutte le tabelle    Visualizza le sezioni Campi disponibili per la visualizzazione, Campi disponibili nelle tabelle correlate (se tali tabelle sono presenti) e Campi disponibili in altre tabelle (se tali tabelle sono presenti).

    • Mostra solo i campi dell'origine record corrente    Visualizza solo la sezione Campi disponibili per la visualizzazione.

      Per passare tra le due modalità, fare clic su Mostra solo i campi dell'origine record corrente o su Mostra tutte le tabelle nella parte inferiore del riquadro Elenco campi.

      Nota : Se la proprietà Origine record della maschera o del report è stata impostata su una query salvata, nel riquadro Elenco campi verrà visualizzata solo la sezione Campi disponibili per la visualizzazione e nella parte inferiore del riquadro Elenco campi non sarà disponibile l'opzione Mostra tutte le tabelle. Per modificare l'origine record, fare clic con il pulsante destro del mouse su uno dei campi e quindi scegliere Modifica origine record.

  • Se la proprietà Origine record della maschera o del report è stata impostata su una tabella e quindi si trascina un campo dalla sezione Campi disponibili nelle tabelle correlate del riquadro Elenco campi alla maschera o al report, in Access la proprietà Origine record della maschera o del report verrà modificata in un'istruzione SELECT contenente il campo aggiunto. Se Access non è in grado di determinare come correlare le tabelle, viene visualizzata la finestra di dialogo Scegli relazioni, in cui è possibile scegliere la relazione appropriata.

  • Se si trascina un campo dalla sezione Campi disponibili in altre tabelle del riquadro Elenco campi alla maschera o al report, in Access viene visualizzata la finestra di dialogo Specifica relazione. È necessario utilizzare questa finestra di dialogo per specificare una relazione tra l'altra tabella e l'origine record della maschera o del report. In caso di dubbi sui campi da immettere in questa finestra di dialogo, è possibile fare clic su Annulla e quindi esaminare le relazioni tra tabelle.

    Per ulteriori informazioni sulle relazioni, vedere Guida alle relazioni tra tabelle o creare, modificare o eliminare una relazione.

    È possibile che un campo incluso nella sezione Campi disponibili in altre tabelle del riquadro Elenco campi sia indirettamente correlato all'origine record della maschera o del report tramite una delle tabelle incluse nella sezione Campi disponibili nelle tabelle correlate. In tal caso, se si trascina un campo da una delle tabelle correlate alla maschera o al report, una o più tabelle potrebbero venire spostate dalla sezione Campi disponibili in altre tabelle alla sezione Campi disponibili nelle tabelle correlate.

  • Se l'origine record della maschera o del report è un'istruzione SELECT o una query salvata, può essere visualizzata o modificata nel Generatore di query facendo clic con il pulsante destro del mouse su un campo nel riquadro Elenco campi e quindi scegliendo Modifica origine record. Se l'origine record è una tabella, questo comando richiama il Generatore di query nella tabella. In Access viene richiesto se si desidera creare una query basata sulla tabella. Fare clic su per modificare l'origine record in una query oppure su No per mantenere inalterata l'origine record.

  • È possibile aprire una tabella in visualizzazione Foglio dati facendo clic su Modifica tabella accanto al nome della tabella oppure facendo clic con il pulsante destro del mouse sul nome della tabella nel riquadro Elenco campi e quindi scegliendo Apri tabella in visualizzazione Foglio dati.

  • È possibile utilizzare il riquadro Elenco campi per aggiungere un campo di ricerca a una tabella eseguendo le operazioni seguenti:

    1. Fare clic su Modifica tabella accanto alla tabella in cui si desidera aggiungere il campo di ricerca.

      La tabella verrà aperta in visualizzazione Foglio dati.

    2. Trascinare un campo dal riquadro Elenco campi al foglio dati.

    3. Verrà avviata la Ricerca guidata. Seguire le istruzioni visualizzate nella procedura guidata. Nell'ultima pagina fare clic su Fine.

  • È possibile disancorare il riquadro Elenco campi dal lato destro dell'area di lavoro di Access posizionando il puntatore del mouse sulla barra del titolo del riquadro Elenco campi finché non si trasforma in un puntatore Sposta puntatore sposta e quindi trascinare il riquadro Elenco campi a sinistra. È possibile posizionare l'elenco in un punto qualsiasi dell'area di lavoro oppure è possibile ancorare al lato sinistro dell'area di lavoro trascinandola a sinistra.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×