Aggiungere testo di Guida personalizzato a un modello di modulo

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Per consentire agli utenti di comprendere lo scopo del modulo e agevolarne la compilazione, è possibile aggiungere al modello di modulo un testo di Guida informativo.

In questo articolo viene spiegato come determinare il tipo di testo di Guida più appropriato per il modello di modulo prendendo in considerazione fattori quali il tipo di modello creato, i destinatari, la distribuzione del modello e se i moduli basati sul modello di modulo verranno compilati tramite un browser.

Contenuto dell'articolo

Considerazioni sulla compatibilità

Tipi di Guida

Creare una visualizzazione per la Guida

Creare un riquadro attività personalizzato per visualizzare la Guida

Utilizzare la formattazione condizionale per visualizzare la Guida contestuale

Creare un collegamento ipertestuale a un file di Guida esterno o a un sito Web

Aggiungere le istruzioni utente per la visualizzazione del sistema di Guida di InfoPath

Considerazioni sulla compatibilità

Quando si progetta un modello di modulo in Microsoft Office InfoPath 2007, è possibile progettare un modello di modulo compatibile con browser. Quando si progetta un modello di modulo compatibile con browser, alcune caratteristiche non sono disponibili. Ad esempio riquadri attività personalizzati, che vengono spesso utilizzati per visualizzare il testo della Guida personalizzato, non sono supportati nei modelli di modulo compatibile con browser. Per aggiungere contenuto della Guida a un modello di modulo compatibile con browser, è consigliabile un modo alternativo per aggiungere contenuto della Guida, ad esempio utilizzando formattazione condizionale per visualizzare la Guida contestuale.

Inizio pagina

Tipi di Guida

A seconda della complessità del modello di modulo e delle esigenze degli utenti, è possibile aggiungere tipi di testo di Guida diversi, utilizzando procedure diverse. In base al modello di modulo è ad esempio possibile utilizzare più tipi di testo di Guida. Di seguito è riportato un elenco delle soluzioni più comuni per visualizzare testo di Guida nel modello di modulo:

  • Vista Guida    Creare una visualizzazione distinta in cui visualizzare testo di Guida quando si desidera fornire istruzioni dettagliate agli utenti. È possibile utilizzare una visualizzazione contenente solo testo di Guida oppure duplicare i controlli aggiunti nella visualizzazione predefinita del modello di modulo e includere il testo di Guida corrispondente. L'aggiunta di controlli al testo di Guida consente di creare una visualizzazione alternativa per la compilazione del modulo , ovvero una visualizzazione contenente Guida contestuale per ogni sezione o controllo. Tale approccio risulta utile quando il modulo è destinato sia a nuovi utenti che necessitano di ulteriore assistenza per la compilazione, sia a utenti esperti che sanno già come compilarlo.

    Suggerimento : Poiché i modelli di modulo compatibili con browser non supportano i riquadri attività personalizzati, l'utilizzo di visualizzazioni specifiche per il testo di Guida costituisce una valida alternativa ai riquadri attività personalizzati.

  • Riquadro attività personalizzato    Un riquadro attività personalizzato è un file HTML il cui contenuto viene visualizzato in un riquadro attività di InfoPath durante la compilazione di un modulo. È possibile specificare un unico file HTML da aprire nel riquadro attività personalizzato predefinito per il modello di modulo, nonché aggiungere al modello altri file HTML come file di risorsa e quindi creare collegamenti ipertestuali tra gli stessi. Nei riquadri attività personalizzati è possibile visualizzare solo file HTML. Tali riquadri consentono di visualizzare comandi e informazioni di Guida specifici per il modulo. È possibile aggiungere un file HTML direttamente al modello di modulo, in modo da consentire agli utenti di visualizzare il riquadro attività personalizzato anche quando compilano il modulo in modalità non in linea, oppure collegarlo a un file HTML archiviato in un'altra posizione. Se ad esempio si intende aggiornare frequentemente il contenuto della Guida ma non si desidera pubblicare il modello di modulo a ogni aggiornamento del file della Guida in formato HTML, è consigliabile archiviare il file HTML in un'altra posizione ed aggiungere un collegamento allo stesso nel riquadro attività personalizzato. Si noti che i modelli di modulo compatibili con browser non supportano i riquadri attività personalizzati, pertanto si deve creare un riquadro attività personalizzato solo per i moduli che verranno compilati in InfoPath.

  • La formattazione condizionale     È possibile utilizzare la formattazione condizionale per specificare diverse opzioni di formattazione per un controllo che sono in base a condizioni che si verificano nel modulo. Se le condizioni specificate sono vere durante la compilazione di un modulo, viene applicata la formattazione condizionale. Quando si aggiunge il testo della Guida a una sezione nel modello di modulo e aggiungere condizionale formattazione di sezione, consentire all'utente di visualizzare o nascondere contestuale testo della Guida per una sezione o controllo in base alle esigenze, senza cambiare visualizzazione. Questo è utile per fornire all'interno del testo della Guida per sezioni o controlli per la Guida gli utenti specifici.

  • Guida esterna     È possibile aggiungere un collegamento a un file esterno, ad esempio a un file HTML disponibile in un sito Web. Se ad esempio il sito Web del servizio di supporto tecnico dell'organizzazione include una pagina per l'avvio di una sessione di chat in tempo reale con un addetto del servizio, è possibile aggiungere al modello di modulo un collegamento ipertestuale che consenta agli utenti di aprire tale pagina nei rispettivi browser. Tale approccio risulta utile quando si progetta un modello di modulo per un altro reparto dell'organizzazione maggiormente qualificato a fornire assistenza o supporto tecnico.

  • Sistema di Guida di InfoPath per utenti che compilano i moduli     InfoPath include un sistema di Guida dedicato per gli utenti che compilano i moduli. Premendo F1 durante la compilazione di un modulo gli utenti potranno accedere agli argomenti della Guida sulle funzionalità standard di InfoPath. Utilizzare questo approccio per moduli che vengono compilati esclusivamente con InfoPath.

Inizio pagina

Creare una visualizzazione per la Guida

Per poter creare nel modello di modulo una visualizzazione distinta e consentire agli utenti di visualizzare la Guida relativa alla compilazione, è dapprima necessario creare una visualizzazione per la Guida per il modello e quindi aggiungere alla visualizzazione del modulo predefinita un pulsante che consenta l'accesso alla visualizzazione per la Guida.

Creare una visualizzazione per la Guida

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Azioni nel riquadro attività Visualizzazioni fare clic su Aggiungi nuova visualizzazione.

  3. Nella casella Nome nuova visualizzazione digitare un nome per la visualizzazione per la Guida e quindi fare clic su OK.

    È ad esempio possibile digitare Guida.

  4. Nel modello di modulo fare clic nella visualizzazione appena aggiunta e quindi digitare o incollare il testo desiderato per la Guida.

  5. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  6. Nel riquadro attività Controlli fare clic su Pulsante.

  7. Fare clic con il pulsante destro del mouse sul pulsante aggiunto e quindi scegliere Proprietà pulsante dal menu di scelta rapida.

  8. Fare clic sulla scheda Generale.

  9. Nella casella etichetta digitare un'etichetta per il pulsante. Digitare ad esempio, tornare al modulo.

  10. Fare clic su Regole.

  11. Nella finestra di dialogo Regole fare clic su Aggiungi.

  12. Fare clic su Aggiungi azione.

  13. Nella finestra di dialogo Azione fare clic su Cambia visualizzazione.

  14. Nella casella Visualizzazione fare clic sul nome della visualizzazione predefinita.

  15. Fare clic quattro volte su OK per tornare al modello di modulo.

Dopo aver creato la visualizzazione per la Guida per il modello di modulo, è necessario aggiungere alla visualizzazione predefinita un pulsante che consenta di accedere facilmente alla visualizzazione per la Guida durante la compilazione del modulo.

Aggiungere un pulsante alla visualizzazione predefinita

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. Nel riquadro attività Visualizzazioni fare clic sul nome della visualizzazione predefinita.

  3. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  4. Nel riquadro attività Controlli fare clic su Pulsante.

  5. Fare clic con il pulsante destro del mouse sul pulsante aggiunto e quindi scegliere Proprietà pulsante dal menu di scelta rapida.

  6. Fare clic sulla scheda Generale.

  7. Nella casella Etichetta digitare un'etichetta nome per il pulsante, ad esempio Guida.

  8. Fare clic su Regole.

  9. Nella finestra di dialogo Regole fare clic su Aggiungi.

  10. Fare clic su Aggiungi azione.

  11. Nella finestra di dialogo Azione fare clic su Cambia visualizzazione.

  12. Nella casella Visualizzazione fare clic sul nome della visualizzazione per la Guida aggiunta nella procedura precedente.

  13. Fare clic quattro volte su OK per tornare al modello di modulo.

Suggerimento : Se lo si desidera, è possibile aggiungere alla visualizzazione per la Guida gli stessi controlli inclusi nella visualizzazione predefinita. In tal modo gli utenti potranno scegliere se compilare il modulo nella visualizzazione predefinita qualora non necessitino di assistenza oppure se utilizzare la visualizzazione per la Guida qualora necessitino di visualizzare le istruzioni riportate nella Guida.

Inizio pagina

Creare un riquadro attività personalizzato per visualizzare la Guida

Note : Prima di creare un riquadro attività personalizzato per visualizzare la Guida nel modello di modulo, tenere presente quanto segue:

  • I modelli di modulo compatibili con browser non supportano i riquadri attività personalizzati.

  • Prima di attivare un riquadro attività personalizzato, è necessario creare un file HTML per il riquadro utilizzando un editor HTML quale Microsoft Office SharePoint Designer 2007.

Per creare e attivare un riquadro attività personalizzato, eseguire le operazioni seguenti:

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. In Categoria fare clic su Programmazione.

  3. Selezionare la casella di controllo Utilizza riquadro attività personalizzato.

  4. Nella casella Nome riquadro attività digitare il nome che si desidera visualizzare nella parte superiore del riquadro attività personalizzato, ad esempio Guida.

  5. Per aggiungere un file al modello di modulo, fare clic su File di risorse.

    Nota : Per collegare un file al modello di modulo, nella casella posizione del riquadro attività digitare il percorso assoluto relativa al percorso del file HTML e quindi fare clic su OK.

    Nota sulla sicurezza : È consigliabile collegare un file HTML disponibile nello stesso dominio del modello di modulo. In caso contrario, verrà visualizzato un avviso all'apertura di un modulo basato su tale modello.

  6. Nella finestra di dialogo File di risorse fare clic su Aggiungi.

  7. Nella finestra di dialogo Aggiungi file trovare e selezionare il file HTML desiderato e quindi fare clic su OK.

  8. Se il file HTML aggiunto fa riferimento ad altri file, ad esempio fogli di stile CSS aggiunta anche tali file.

    Suggerimento : È possibile specificare un solo file HTML da aprire nel riquadro attività predefinito del modello di modulo, ma è possibile aggiungere al modello altri file HTML come file di risorse e quindi creare collegamenti ipertestuali tra loro.

  9. Nella finestra di dialogo Opzioni modulo fare clic sul nome del file HTML appena aggiunto nella casella Posizione riquadro attività.

  10. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL + MAIUSC + B. Il riquadro attività personalizzato appena creata deve essere visualizzato per impostazione predefinita, quando si visualizza in anteprima il modello di modulo.

Inizio pagina

Utilizzare la formattazione condizionale per visualizzare la Guida contestuale

Nella procedura seguente viene descritto come utilizzare la formattazione condizionale per visualizzare o nascondere la Guida contestuale.

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Nel riquadro attività Controlli fare clic su Casella di controllo e quindi su Sezione.

  3. Fare clic nella sezione appena aggiunta al modello di modulo e digitare il testo della Guida.

  4. Eliminare il testo dell'etichetta predefinita per la casella di controllo e quindi digitare fare clic per visualizzare o nascondere la Guida.

  5. Fare clic sulla scheda relativa alla sezione nel modello di modulo e quindi scegliere Formattazione condizionale dal menu Formato.

  6. Fare clic su Aggiungi.

  7. Nella prima casella di Condizioni fare clic su Selezionare un campo o un gruppo.

  8. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo corrispondente al controllo casella di riepilogo aggiunto al passaggio 2 e quindi fare clic su OK.

  9. Nella seconda casella della finestra di dialogo Formattazione condizionale selezionare è uguale a.

  10. Nella terza casella fare clic su FALSE.

  11. In Formattazione da applicare selezionare la casella di controllo Nascondi controllo.

    Nota : La condizione indica ora che la sezione verrà visualizzata se si seleziona la casella di controllo.

  12. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Creare un collegamento ipertestuale a un file di Guida esterno o a un sito Web

La procedura seguente viene descritto come aggiungere un collegamento ipertestuale dal modello di modulo a un file della Guida esterno, ad esempio un file HTML o un file della Guida (chm) compilato, o a un sito Web, ad esempio un sito Web supporto tecnico.

Note : 

  • Assicurarsi che il file della Guida esterno o il sito Web che si crea un collegamento a sia accessibile agli utenti. Se si desidera aggiungere un collegamento a un file HTML in un modello di modulo compatibile con InfoPath solo (in altre parole, gli utenti devono utilizzare InfoPath per compilare i moduli basati su tale modello), è possibile aggiungere file HTML al modello di modulo aggiungendoli come file di risorse da aprono in un riquadro attività personalizzato. Per il modello di modulo compatibile con browser, si deve pubblicare i file HTML in un sito accessibile agli utenti preferenza lo stesso sito Web in cui si trova il modello di modulo e creare un collegamento ipertestuale statico nel modello di modulo che punti ai file HTML esterno.

  • Se si decide di usare un altro formato di file della Guida, ad esempio chm, non dimenticare di verificare se il formato di file che si è scelto è supportato nei sistemi operativi nei computer degli utenti.

Creare un collegamento ipertestuale statico a un file esterno

  1. Nel modello di modulo fare clic nel punto in cui si desidera inserire un collegamento ipertestuale oppure selezionare il testo o l'immagine da convertire in collegamento ipertestuale.

  2. Nella barra degli strumenti Standard fare clic su Inserisci collegamento ipertestuale   Icona del pulsante .

  3. Fare clic sulla scheda Generale.

  4. Nella casella Indirizzo digitare l'URL per il quale si intende inserire il collegamento.

  5. Per modificare il testo del collegamento ipertestuale visualizzato nel modello di modulo, digitare il testo desiderato nella casella Testo.

    Nota : Se al passaggio 1 è stata selezionata un'immagine, questa opzione non risulterà disponibile.

  6. Per assegnare una descrizione comando che verrà visualizzata quando gli utenti posizionano il puntatore del mouse sul collegamento ipertestuale, digitare il testo da visualizzare nella casella Descrizione comando della scheda Avanzate.

  7. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Aggiungere le istruzioni utente per la visualizzazione del sistema di Guida di InfoPath

InfoPath include un sistema di Guida dedicato utilizzabile durante la compilazione dei moduli. In tale sistema di Guida sono riportate informazioni su attività comuni, quali l'attivazione o la disattivazione della caratteristica Completamento automatico e il controllo dell'ortografia del testo di un modulo. Il progettista dei moduli può visualizzare la Guida di InfoPath per gli utenti dei moduli premendo F1 durante la visualizzazione di un modulo nella finestra di anteprima.

La Guida per gli utenti dei moduli è limitata alle attività applicabili a tutti i moduli, pertanto è consigliabile fornire una Guida personalizzata per i modelli progettati. Per consentire agli utenti di visualizzare il sistema di Guida di InfoPath durante la compilazione di un modulo, è possibile aggiungere al modello le istruzioni per l'accesso al sistema di Guida, ad esempio includendo uno degli esempi seguenti:

  • Per aprire la Guida di InfoPath, premere F1.

  • Per aprire la Guida di InfoPath, scegliere Guida Microsoft Office InfoPath dal menu ?.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×