Aggiungere, rimuovere o aggiornare file di risorse in un modello di modulo

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Un file di risorse è un file utilizzato per visualizzare informazioni aggiuntive in un modello di modulo. Quando si salva o si pubblica un modello di modulo, gli eventuali file di risorse sono inclusi in esso.

È possibile aggiungere i tipi seguenti di file di risorse al modello di modulo:

File HTML    È possibile utilizzare file HTML per visualizzare informazioni in un riquadro attività personalizzato.

Nota : Quando si aggiunge un file HTML come file di risorse a un modello di modulo, è consigliabile aggiungere anche eventuali file necessari al file HTML, ad esempio altri file HTML, fogli di stile o file di grafica.

File XML     È possibile utilizzare file XML per popolare controlli casella di riepilogo, controlli casella combinata o controlli casella di riepilogo a discesa. Se i dati in un controllo casella di riepilogo, un controllo casella combinata o un controllo casella di riepilogo a discesa sono costanti, inserirli in un XML file e aggiungere il file al modello di modulo come un file di risorse, anziché utilizzare una connessione dati per popolare i controlli. Quando si utilizza un file di risorse, l'apertura dei moduli basati sul modello di modulo sarà più rapida rispetto a quella dei moduli che utilizzano una connessione dati per popolare i controlli. Questo perché i dati in un file di risorse sono considerati parte del modello di modulo e non si basano su una connessione dati per ottenere i dati. Se il modello di modulo non è configurato in modo che il modulo memorizzi i dati da un'origine dati esterna, è necessario che il modulo sia connesso alla rete per ottenere i dati necessari. Per un file di risorse non è necessaria una connessione dati, in quanto i dati sono già parte del modulo.

Per saperne di più

Aggiungere un file di risorse a un modello di modulo

Rimuovere un file di risorse da un modello di modulo

Aggiornare un file di risorse in un modello di modulo

Aggiungere un file di risorse a un modello di modulo

  1. Dal menu Strumenti fare clic su File di risorse.

  2. Nella finestra di dialogo File di risorse fare clic su Aggiungi.

  3. Nella finestra di dialogo Aggiungi file selezionare il file da aggiungere.

Inizio pagina

Rimuovere un file di risorse da un modello di modulo

  1. Dal menu Strumenti fare clic su File di risorse.

  2. Nell'elenco File di risorse nel modello di modulo della finestra di dialogo File di risorse selezionare il file di risorse che si desidera rimuovere dal modello di modulo.

  3. Fare clic su Rimuovi.

Inizio pagina

Aggiornare un file di risorse in un modello di modulo

È possibile aggiornare il file di risorse in un modello di modulo dopo la pubblicazione del modello di modulo. Ad esempio, è possibile che si desideri aggiungere nuovi elementi o eliminare elementi esistenti in un file di risorse utilizzato per popolare un controllo casella di riepilogo nel modello di modulo. Per aggiornare il file di risorse, è necessario modificare una copia del file di risorse e quindi aggiungere il file di risorse aggiornato al modello di modulo. Quando si aggiunge il file di risorse aggiornato al modello di modulo, in realtà si sta sostituendo il file di risorse esistente. Dopo aver aggiunto il file di risorse aggiornato, pubblicare di nuovo il modello di modulo. Gli utenti accederanno quindi al file di risorse aggiornato all'apertura di un nuovo modulo vuoto basato sul modello di modulo.

  1. Apportare le modifiche eventualmente necessarie a una copia locale del file di risorse.

    Suggerimento : Se non è disponibile una copia locale del file di risorse, è possibile estrarre una copia dal modello di modulo. Per ulteriori informazioni sull'estrazione di file in un modello di modulo, fare clic sui collegamenti nella sezione Vedere anche.

  2. In modalità progettazione di InfoPath, aprire il modello di modulo cui il file di risorse è associato.

  3. Dal menu Strumenti fare clic su File di risorse.

  4. Nella finestra di dialogo File di risorse fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiungi file selezionare il file aggiornato e quindi fare clic su OK.

  6. Nella finestra di dialogo Microsoft Office InfoPath fare clic su Sostituire il file esistente e quindi fare clic su OK.

  7. Nella finestra di dialogo File di risorse fare clic su OK.

  8. Per pubblicare il modello di modulo scegliere Pubblica dal menu File e quindi completare i passaggi della Pubblicazione guidata.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×