Aggiungere, eliminare e cambiare visualizzazioni (pagine) in un modulo

Progettando varie visualizzazioni nel modulo, è possibile offrire agli utenti modi diversi di osservare i dati, a seconda del tipo di modulo o del tipo di utente a cui si presenta il modulo. Ad esempio, creando più visualizzazioni è possibile:

  • Rendere più semplice un modulo lungo e complesso, ad esempio un sondaggio, suddividendolo in più pagine tra cui gli utenti possono spostarsi mediante i pulsanti Avanti e Indietro.

  • Mostrare versioni diverse di un modulo a persone diverse in base al loro ruolo nell'organizzazione, ad esempio creando visualizzazioni per i titolari di polizze, per gli agenti e per i periti assicurativi per l'elaborazione delle richieste di risarcimento.

  • Creare una versione del modulo destinata alla stampa.

Tutte le visualizzazioni dello stesso modulo di InfoPath condividono gli stessi dati. Pertanto, se un modulo ha due visualizzazioni e una di esse contiene una casella di testo per l'indirizzo di posta elettronica, è possibile copiare la casella di testo nella seconda visualizzazione. L'indirizzo di posta elettronica digitato dall'utente in una visualizzazione comparirà automaticamente nell'altra visualizzazione.

In questo articolo

Introduzione alle visualizzazioni

Esperienza utente

Considerazioni di progettazione

Gruppo Visualizzazioni nella scheda Struttura pagina

Aggiungere una visualizzazione

Eliminare una visualizzazione

Cambiare la visualizzazione predefinita

Rinominare una visualizzazione

Aggiungere un pulsante per passare da una visualizzazione all'altra

Aprire una visualizzazione usando una regola al caricamento del modulo

Introduzione alle visualizzazioni

Esperienza utente

Per impostazione predefinita, gli utenti del modulo possono passare da una visualizzazione all'altra selezionando quella desiderata nel gruppo Visualizzazioni/Visualizzazioni pagina sulla barra multifunzione. Tutte le visualizzazioni sono elencate per nome e quella attiva è evidenziata. Sono elencate tutte le visualizzazioni tranne quelle per cui è stata deselezionata la casella di controllo Includi nel menu Visualizza durante la compilazione del modulo nella finestra di dialogo Visualizza proprietà.

Se per nessuna delle visualizzazioni è selezionata la casella di controllo Includi nel menu Visualizza durante la compilazione del modulo, nella scheda Home non sarà presente il gruppo Visualizzazioni pagina. Questo è utile nei casi in cui si vuole che gli utenti possano accedere solo alla visualizzazione che devono compilare e non ad altre. Ad esempio, a un modulo per la raccolta di informazioni sui candidati per un posto di lavoro potrebbero essere associati tre ruoli utente: uno per gli addetti alla selezione, uno per gli esaminatori e uno per i responsabili delle assunzioni. Per ogni ruolo utente è possibile progettare una visualizzazione leggermente diversa del modulo.

Nota :  La possibilità di nascondere le visualizzazioni agli utenti non garantisce la sicurezza, infatti gli utenti che sono in grado di accedere ai dati XML possono vedere i dati.

Per evitare che gli esaminatori possano passare alle visualizzazioni per gli addetti alla selezione e per i responsabili delle assunzioni, quando si progettano queste ultime visualizzazioni è possibile aprire la finestra di dialogo Proprietà visualizzazione e deselezionare la casella di controllo Includi nel menu Visualizza durante la compilazione del modulo.

Nota :  In Opzioni modulo è possibile disattivare il cambio di visualizzazione per gli utenti che compilano il modulo in Web browser. Fare clic sulla scheda File, su Informazioni, su Opzioni modulo e quindi nella sezione Web Browser deselezionare la casella di controllo Visualizzazioni.

Per personalizzare i cambi di visualizzazione, aggiungere pulsanti specifici al modulo come descritto più avanti in questo capitolo.

Considerazioni di progettazione

Quando si progetta una nuova visualizzazione, in genere occorre eseguire le attività seguenti:

  1. Pianificare la visualizzazione

Pianificare ogni visualizzazione e le rispettive interazioni ponendo particolare attenzione alle domande seguenti:

  • Quale visualizzazione deve comparire la prima volta che il modulo viene aperto?

  • Gli utenti hanno la necessità di usare più visualizzazioni? Come si sposteranno tra le visualizzazioni?

  • È necessario che una o più visualizzazioni siano di sola lettura?

  • È probabile che gli utenti stampino le visualizzazioni dal modulo di InfoPath?

  • Popolare la visualizzazione.

Quando si aggiunge una nuova visualizzazione a un modulo, viene visualizzato un modello di layout di pagina. Da qui è possibile aggiungere tabelle di layout mediante la scheda Inserisci della barra multifunzione per strutturare il modulo e aggiungere controlli dalla scheda Home nel gruppo Controlli.

È anche possibile aggiungere alla nuova visualizzazione controlli che condividono lo stesso campo dei controlli usati in altre visualizzazioni, trascinando il campo in questione dal riquadro attività Campi.

  1. Personalizzare gli spostamenti nel modulo.

È importante considerare in che modo gli utenti si sposteranno nel modulo, valutare se conoscono il significato dei comandi predefiniti per il cambio di visualizzazione, se i comandi predefiniti sono adeguati o se si preferisce che possano passare da una visualizzazione all'altra facendo clic su un pulsante presente nel modulo. In quest'ultimo caso è necessario scegliere se mettere a disposizione degli utenti i pulsanti Avanti e Indietro oppure un'interfaccia con schede. Per quanto riguarda le visualizzazioni per la stampa, occorre scegliere se consentire agli utenti di stampare tutte le visualizzazioni contemporaneamente o solo la visualizzazione attiva.

Gruppo Visualizzazioni nella scheda Struttura pagina

Nella scheda Struttura pagina della barra multifunzione usare il gruppo Visualizzazioni per aggiungere o eliminare visualizzazioni o per passare da una visualizzazione all'altra. Per personalizzare le impostazioni e il comportamento di una visualizzazione selezionata, fare clic sul pulsante Proprietà per aprire la finestra di dialogo Proprietà visualizzazione.

È anche possibile creare e associare una visualizzazione di stampa a una visualizzazione esistente creando prima di tutto la visualizzazione di stampa che si vuole mettere a disposizione degli utenti, quindi assegnandola a una visualizzazione esistente mediante la finestra di dialogo Proprietà visualizzazione. È anche possibile specificare opzioni di stampa personalizzate per la visualizzazione di stampa nelle schede Impostazioni di stampa e Imposta pagina della finestra di dialogo Proprietà visualizzazione, come intestazioni, piè di pagina e margini della pagina.

Inizio pagina

Aggiungere una visualizzazione

Usare la procedura seguente per aggiungere altre visualizzazioni a un modulo.

  1. Fare clic sulla scheda Struttura pagina, quindi nel gruppo Visualizzazioni fare clic su Nuova visualizzazione.

  2. Digitare un nome per la visualizzazione e fare clic su OK.

aggiungere, eliminare e cambiare visualizzazioni in un modulo

  1. Per aprire la finestra di dialogo Proprietà visualizzazione fare clic sulla scheda Struttura pagina, quindi nel gruppo Visualizzazioni fare clic su Proprietà.

  2. Nella finestra di dialogo Proprietà visualizzazione modificare o specificare le impostazioni o le opzioni desiderate per la visualizzazione e quindi fare clic su OK.

aggiungere, eliminare e cambiare visualizzazioni in un modulo

  1. Progettare la visualizzazione nell'area di lavoro aggiungendo tabelle layout e controlli.

Se si vuole basare la progettazione della nuova visualizzazione su una visualizzazione esistente, aprire la visualizzazione, premere CTRL+A per selezionare tutti gli elementi nella visualizzazione e premere CTRL+C per copiare la selezione negli Appunti. Selezionare la nuova visualizzazione nell'elenco Visualizza del gruppo Visualizzazioni della scheda Struttura pagina, eliminare il contenuto prepopolato della visualizzazione e quindi premere CTRL+V per incollare la selezione nella nuova visualizzazione.

Inizio pagina

Eliminare una visualizzazione

Una visualizzazione eliminata non può essere recuperata né ripristinata. Se si elimina la visualizzazione predefinita in un modulo che ha soltanto una visualizzazione, InfoPath crea automaticamente una nuova visualizzazione predefinita. Se si elimina la visualizzazione predefinita in un modulo che ha più visualizzazioni, viene assegnato automaticamente lo stato di visualizzazione predefinita alla successiva visualizzazione dell'elenco di visualizzazioni contenuto nell'elenco Visualizza del gruppo Visualizzazioni della scheda Struttura pagina.

  1. Selezionare la visualizzazione che si vuole eliminare nell'elenco Visualizza del gruppo Visualizzazioni della scheda Struttura pagina.

  2. Nel gruppo Visualizzazioni della scheda Struttura pagina fare clic su Elimina.

  3. Quando viene chiesto se eliminare la visualizzazione, fare clic su .

Inizio pagina

Modificare la visualizzazione predefinita

Ogni modulo ha una visualizzazione predefinita, che viene visualizzata quando un utente apre un modulo basato su quel modulo. Se si creano visualizzazioni personalizzate per un modulo, è possibile scegliere quale delle visualizzazioni disponibili sarà quella predefinita per gli utenti.

  1. Selezionare la visualizzazione che si vuole impostare come predefinita nell'elenco Visualizza del gruppo Visualizzazioni della scheda Struttura pagina.

  2. Nel gruppo Visualizzazioni della scheda Struttura pagina fare clic su Proprietà.

  3. Selezionare la casella di controllo Imposta come visualizzazione predefinita e quindi fare clic su OK.

Se un modello ha una sola visualizzazione, questa viene automaticamente impostata come visualizzazione predefinita.

Inizio pagina

Rinominare una visualizzazione

  1. Selezionare la visualizzazione che si vuole rinominare nell'elenco Visualizza del gruppo Visualizzazioni della scheda Struttura pagina.

  2. Nel gruppo Visualizzazioni della scheda Struttura pagina fare clic su Proprietà.

  3. Nella finestra di dialogo Proprietà visualizzazione digitare il nuovo nome della scheda nella casella di testo Nome visualizzazione e quindi fare clic su OK.

Nota : Se si rinomina una visualizzazione associata a codice personalizzato, il codice potrebbe non funzionare come previsto. Per risolvere il problema, è necessario trovare tutti i riferimenti al vecchio nome della visualizzazione nel codice e aggiornarli con il nuovo nome.

Inizio pagina

Aggiungere un pulsante per passare da una visualizzazione all'altra

Le visualizzazioni vengono spesso progettate in modo che possano essere integrate con le regole. Le regole consentono di rendere automatiche alcune operazioni in risposta ad azioni o eventi avviati dall'utente che compila il modulo. Ad esempio, è possibile inserire un pulsante nel modulo e creare una regola che consenta di passare a un'altra visualizzazione quando viene fatto clic sul pulsante, quindi dopo aver inserito il pulsante nel modulo è possibile associare la regola al pulsante in modo che gli utenti possano fare clic sul pulsante per cambiare visualizzazione.

Più nello specifico, in un modello di modulo per la denuncia di un sinistro si potrebbe creare un pulsante Mostra riepilogo che apra una visualizzazione generale dei dati della denuncia. Nella visualizzazione di riepilogo gli utenti potrebbero quindi fare clic sul pulsante Mostra dettagli per tornare alla visualizzazione dettagliata. Allo stesso modo, in presenza di un modulo molto lungo, si potrebbe suddividerlo in più visualizzazioni e quindi aggiungere i pulsanti Avanti e Indietro o la caratteristica di spostamento tramite schede per consentire agli utenti di spostarsi nel modulo.

  1. Inserire un pulsante in ogni visualizzazione.

Per completare la procedura seguente, è necessario un modulo con due visualizzazioni esistenti.

  1. Selezionare la visualizzazione a cui si vuole aggiungere un pulsante nell'elenco Visualizza del gruppo Visualizzazioni della scheda Struttura pagina.

  2. Posizionare il cursore nel punto del modulo in cui si vuole inserire il pulsante.

  3. Nel gruppo Controlli della scheda Home selezionare Pulsante.

  4. In Strumenti controllo fare clic sulla scheda Proprietà sulla barra multifunzione.

  5. Nella casella Etichetta digitare il nome da assegnare all'etichetta e quindi fare clic su OK.

  • Creare una regola che consenta di cambiare visualizzazione.

    1. Selezionare il pulsante.

    2. In Strumenti controllo passare alla scheda Proprietà e nel gruppo Regole fare clic su Aggiungi regola.

      aggiungere, eliminare e cambiare visualizzazioni in un modulo

    3. Selezionare Quando l'utente fa clic sul pulsante e quindi selezionare Cambia visualizzazione nell'elenco Azioni.

    4. Nella casella di testo Visualizzazione selezionare la visualizzazione da mostrare quando viene fatto clic sul pulsante e quindi fare clic su OK.

      aggiungere, eliminare e cambiare visualizzazioni in un modulo

  • Ripetere i passaggi 1 e 2 per creare altri pulsanti e le regole corrispondenti per ogni visualizzazione.

  • Dopo avere aggiunto i pulsanti alle visualizzazioni e aver creato le regole necessarie, è consigliabile verificare il modulo per assicurarsi che funzioni come previsto.

  • Nel gruppo Modulo della scheda Home fare clic su Anteprima.

  • Fare clic sui pulsanti per controllare che sia possibile cambiare visualizzazione come desiderato.

    Nella finestra di anteprima compare l'ultima visualizzazione usata, a meno che non sia stata creata una regola che al caricamento del modulo mostri una visualizzazione specifica a seconda del ruolo dell'utente.

Nota :  Nelle visualizzazioni di sola lettura i pulsanti non sono disponibili. Per gli spostamenti nelle visualizzazioni di sola lettura, come la visualizzazione per lo schermo nel modulo elenco di SharePoint, usare un pulsante immagine e deselezionare la casella di controllo Nascondi pulsante immagine nelle visualizzazioni di sola lettura nella finestra di dialogo delle proprietà del controllo nella scheda Proprietà sulla barra multifunzione.

Inizio pagina

Aprire una visualizzazione usando una regola al caricamento del modulo

È possibile fare in modo che all'apertura di un modulo venga mostrata una visualizzazione specifica in base al ruolo dell'utente che ha aperto il modulo o in base ad altri criteri. Se, ad esempio, si sta progettando un modulo che include ruoli utenti e contiene più visualizzazioni, può essere utile mostrare una visualizzazione in base al ruolo utente assegnato a un utente. Nello specifico, è possibile usare una regola per mostrare una visualizzazione quando un utente assegnato a un dato ruolo utente apre un modulo basato sul modulo che si sta progettando.

I ruoli utente possono essere usati solo nei moduli progettati per InfoPath Filler. Per consentire di cambiare visualizzazione in base all'appartenenza a un gruppo nei moduli Web, valutare la possibilità di creare una regola Caricamento modulo che usi il metodo getUserMemberships del servizio Web profili utente per determinare il ruolo dell'utente.

In questa procedura si presuppone che nel modulo sia stato definito un ruolo utente. Se nel modulo non è incluso alcun ruolo utente, aggiungere un ruolo utente mediante la scheda Dati prima di iniziare la procedura.

  1. Nel gruppo Regole della scheda Dati fare clic su Caricamento modulo.

  2. Fare clic su Nuovo, quindi su Azione e infine nella casella di testo Dettagli per immettere un nome per la regola.

  3. Per fare in modo che nel modulo venga caricata una regola in base al ruolo utente, fare clic sul collegamento nella sezione Condizione. Nel primo elenco fare clic su Il ruolo corrente dell'utente e quindi selezionare il ruolo dell'utente.

È possibile selezionare altre opzioni a seconda delle condizioni che si vuole impostare per il caricamento del modulo.

aggiungere, eliminare e cambiare visualizzazioni in un modulo

  1. Fare clic su OK.

  2. Fare clic sul pulsante Aggiungi e quindi selezionare Cambia visualizzazione.

aggiungere, eliminare e cambiare visualizzazioni in un modulo

  1. Nell'elenco Visualizzazioni fare clic sulla visualizzazione desiderata e quindi fare clic su OK.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×