Aggiungere connettori tra le forme in Visio

Aggiungere connettori tra le forme in Visio

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Con Visio diventa facile connettere le forme del disegno. È possibile usare Connessione automatica per connettere le forme aggiunte e quelle già presenti tramite lo strumento Connettore.

Tipi di connessione

Esistono due tipi di connessione che è possibile impostare tra un connettore e una forma: connessione a un punto o connessione dinamica. Una connessione a un punto mantiene il connettore associato a uno specifico punto della forma, anche se quest'ultima viene spostata o ruotata. Una connessione dinamica consente di cambiare la posizione di un connettore su una forma, in modo che se la forma viene spostata o ruotata, il connettore si sposta sul punto di connessione più vicino al proprio punto di origine.

Nel diagramma seguente, la forma A ha un punto di connessione con la forma C e ogni volta che si sposta C il connettore di A rimane connesso allo stesso punto su C. Al contrario, la forma B ha una connessione dinamica con C e il connettore di B si sposta sul punto di connessione di C più vicino.

A ha una connessione punto a C, ma B ha una connessione dinamica a C.

È possibile impostare entrambi i tipi di connessione alle estremità di un connettore. Se si usa la connessione automatica per connettere le forme, entrambe le estremità avrà una connessione dinamica. Se si seleziona manualmente nel punto in cui è associato un connettore a una forma, è possibile specificare il tipo di connessione.

Connettere automaticamente una forma quando la si aggiunge

Uno dei modi disponibili per connettere le forme consiste nel consentire a Visio di eseguire automaticamente questa operazione quando si aggiungono forme a un disegno. Questa opzione risulta particolarmente utile quando si creano diagrammi di flusso.

Per aggiungere una forma nel disegno e consentire a Visio di connetterla automaticamente a una forma già presente, eseguire la procedura seguente.

Nota : Prima di eseguire la procedura, assicurarsi che l'opzione Connessione automatica sia attiva. Nel gruppo Strumenti visivi della scheda Visualizza verificare che l'opzione Connessione automatica sia selezionata.

Per aggiungere una forma e connettere automaticamente a una forma esistente

  1. Trascinare una forma dalla finestra Forme alla pagina, se quest'ultima non contiene ancora forme.

  2. Posizionare il puntatore del mouse sulla forma iniziale finché attorno a essa non vengono visualizzate frecce di connessione automatica.

    Quando l'opzione Connessione automatica è attiva, passare il puntatore del mouse sopra una forma per visualizzare le frecce di connessione.

    Se le frecce di Connessione automatica non sono visibili, controllare la scheda Visualizza per verificare che l'opzione Connessione automatica sia selezionata.

  3. Posizionare il puntatore del mouse sulla freccia nella direzione in cui si desidera aggiungere una forma.

    Passando il puntatore del mouse su una freccia di Connessione automatica viene visualizzata una barra degli strumenti con le forme da aggiungere.

    Viene visualizzata una barra di formattazione rapida contenente le prime quattro forme rapide presenti nello stencil Forme rapide. Quando si posiziona il puntatore su una forma nella barra degli strumenti, Visio visualizza l'anteprima corrispondente nella pagina.

  4. Fare clic sulla forma che si desidera aggiungere.

  5. Se si vuole continuare, posizionare il puntatore su una freccia di Connessione automatica su una forma appena aggiunta per aggiungerne un'altra che verrà connessa automaticamente.

    Passando il puntatore del mouse sulla forma appena aggiunta, viene visualizzata l'opzione Connessione automatica che consente di aggiungere un'altra forma.

Nota : Se si desidera una forma diversa da quelle descritte nella barra di formattazione rapida, trascinare la forma desiderata dalla finestra forme nella posizione desiderata nella pagina. Per connettere la forma, utilizzare il metodo descritto nella sezione successiva.

Connettere forme già presenti nella pagina

Ovviamente, è possibile connettere forme già presenti nel disegno, tramite Connessione automatica oppure con lo strumento Connettore.

Quando si effettua la connessione di forme, è possibile farlo con due tipi di connessioni: un punto di connessione o una connessione dinamica. Per ulteriori informazioni sui tipi di connessioni, vedere tipi di connessioni, in precedenza.

Per creare una connessione a un punto in modo da mantenere il connettore associato a un punto specifico di una forma, trascinare da un punto di connessione della prima forma a un punto di connessione della seconda forma. I punti finali del connettore diventano verdi quando le forme sono connesse.

Associare un connettore a un punto specifico di una forma per fissarlo a tale punto.
Associare un connettore a un punto specifico di una forma per fissarlo a tale punto.

Per creare una connessione dinamica e consentire al connettore di spostarsi automaticamente nel punto più vicino su una forma, posizionare lo strumento Connettore sul centro della prima forma finché non viene circondata da un riquadro verde. Tenere premuto il pulsante del mouse e trascinare al centro della seconda forma. Quando viene visualizzato un riquadro verde attorno alla seconda forma, rilasciare il pulsante del mouse.

Associare un connettore a una forma per consentire il movimento dinamico del connettore ai punti della forma.
Associare un connettore a una forma per consentire il movimento dinamico del connettore ai punti della forma.

Connettere forme esistenti mediante la connessione automatica

  1. Posizionare il puntatore del mouse su una forma finché attorno a essa non vengono visualizzate frecce di connessione automatica.

    Quando l'opzione Connessione automatica è attiva, passare il puntatore del mouse sopra una forma per visualizzare le frecce di connessione.
  2. Fare clic e trascinare dalla freccia di Connessione automatica su un'altra forma e rilasciare il punto finale del connettore nella parte centrale della forma per creare una connessione dinamica oppure su un punto di connessione specifico per creare una connessione a un punto.

    Quando si posiziona il puntatore del mouse sulla freccia di Connessione automatica, viene visualizzata un'anteprima della forma, che può tuttavia essere ignorata. Scomparirà non appena si trascina il connettore sulla destinazione.

Connettere forme mediante lo strumento connettore

  1. Nel gruppo Strumenti della scheda Home fare clic su Connettore.

    Lo strumento Connettore connette due forme con una connessione punto a punto a ogni estremità.
  2. Fare clic su una forma e trascinare un connettore su un'altra forma.

  3. Al termine, nel gruppo Strumenti della scheda Home fare clic su Strumento Selezione.

Attività rapide

Attività

Azione

Cambiare il tipo di connettore scegliendo quello ad angolo retto, diritto o curvo.

Fare clic con il pulsante destro del mouse sul connettore e quindi scegliere un tipo dal menu di scelta rapida: ad angolo retto, diritto o curvo.

Allineare e spaziare le forme in modo che i connettori siano ben visibili.

Selezionare tutte le forme da allineare e quindi nel gruppo Disponi della scheda Home fare clic su Allinea > Allineamento automatico o su Posizione > Spaziatura automatica. Per selezionare più forme, premere CTRL mentre si fa clic su di esse oppure usare le opzioni di Seleziona nel gruppo Modifica della scheda Home.

Convertire una connessione dinamica in connessione a un punto e viceversa.

Selezionare il connettore e quindi trascinarne il punto finale allontanandolo dalla forma. Rilasciare quindi il connettore in un punto specifico per creare una connessione a un punto oppure al centro della forma per creare una connessione dinamica.

Attivare o disattivare la connessione automatica

È possibile attivare o disattivare la caratteristica Connessione automatica in tutti i disegni di Visio o solo in quello attivo.

Attivare la connessione automatica o disattivare nel diagramma attivo

  • Nel gruppo Strumenti visivi della scheda Visualizza selezionare o deselezionare Connessione automatica.

    Selezionare o deselezionare Connessione automatica nella scheda Visualizza per attivare o disattivare questa opzione.

Nota : Se la casella di controllo Connessione automatica non è disponibile, verificare se tale caratteristica è stata disattivata per tutti i diagrammi eseguendo la procedura seguente.

Attivare la connessione automatica o disattivare in tutti i diagrammi

  1. Fare clic sulla scheda File e quindi su Opzioni.

  2. Nella casella Opzioni di Visio fare clic su Avanzate.

  3. In Opzioni di modifica selezionare o deselezionare la casella di controllo Attiva connessione automatica rispettivamente per attivare o disattivare la caratteristica.

    Selezionare o deselezionare Attiva connessione automatica per attivare o disattivare questa opzione per tutti i diagrammi e i disegni.
  4. Fare clic su OK.

Vedere anche

Aggiungere frecce, punti o altre terminazioni di linea a un connettore

Usare lo strumento punto di connessione per aggiungere, spostare o eliminare punti di connessione

Connettere automaticamente una forma quando la si aggiunge

Uno dei modi disponibili per connettere le forme consiste nel consentire a Visio di eseguire automaticamente questa operazione quando si aggiungono forme a un disegno. Questa opzione risulta particolarmente utile quando si creano diagrammi di flusso.

Per aggiungere una forma nel disegno e consentire a Visio di connetterla automaticamente a una forma già presente, eseguire la procedura seguente.

  1. Trascinare una forma iniziale dalla finestra Forme alla pagina, se quest'ultima non contiene ancora forme.

  2. Posizionare il puntatore sulla forma iniziale finché non vengono visualizzate frecce di connessione automatica blue intorno alla forma.

  3. Posizionare il puntatore del mouse sulla freccia nella direzione in cui si desidera aggiungere una forma.

    Verrà visualizzata una barra di formattazione rapida contenente le prime quattro forme rapide attualmente presenti nello stencil Forme rapide. Nella pagina verrà visualizzata un'anteprima dinamica della forma selezionata nello stencil.

  4. Spostare il puntatore del mouse sulle quattro forme nella barra di formattazione rapida per visualizzare un'anteprima dinamica di ciascuna forma nella pagina.

  5. Fare clic sulla forma che si desidera aggiungere.

Se si desidera una forma diversa, allontanare il puntatore dalla freccia di connessione automatica e le anteprime scompariranno. È quindi possibile trascinare la forma desiderata dalla finestra Forme.

Attività rapide

Attività

Azione

Cambiare le forme rapide per uno stencil.

Aprire lo stencil e trascinare le forme rapide nell'ordine desiderato. È possibile trascinare le forme all'interno e all'esterno dell'area forme rapide.

Cambiare le forme visualizzate nella barra di formattazione rapida.

Nello stencil Forme rapide selezionare una forma del gruppo di forme rapide che si desidera visualizzare nella barra di formattazione rapida. Nella barra verrà così visualizzato il gruppo con le forme selezionate.

In alternativa, è possibile trascinare lo stencil contenente le forme che si desidera visualizzare per prime e rilasciarlo subito sotto la barra del titolo Forme rapide. È possibile modificare l'ordine degli altri stencil trascinandoli più in alto o più in basso nella finestra Forme. Verranno visualizzati nello stencil Forme rapide nello stesso ordine.

Connettere forme già presenti nella pagina

È possibile connettere forme già presenti nel disegno, mediante la connessione automatica o lo strumento connettore.

Connettere forme mediante la connessione automatica

  1. Posizionare il puntatore sopra una forma fino a quando non vengono visualizzate frecce di connessione automatica blue intorno alla forma.

  2. Fare clic e trascinare dalla freccia di connessione automatica a un'altra forma e rilasciare il punto finale del connettore nella parte centrale della forma per creare una connessione dinamica oppure su un punto di connessione specifico per creare una connessione a un punto.

    Quando si posiziona il puntatore del mouse sulla freccia blu, viene visualizzata un'anteprima dinamica di una forma, che può tuttavia essere ignorata. Scomparirà non appena si allontana il puntatore.

Connettere forme mediante lo strumento Connettore

  1. Nel gruppo Strumenti della scheda Home fare clic su Connettore.

  2. Fare clic su una forma e trascinare un connettore su un'altra forma.

Per mantenere il connettore associato a un punto specifico di una forma, trascinare da un punto di connessione della prima forma a un punto di connessione della seconda forma. I punti finali del connettore diventano rossi quando le forme sono connesse. Questa è una connessione a un punto.

Per consentire al connettore di spostarsi nella forma quando quest'ultima viene spostata, mantenere posizionato lo strumento Connettore sul centro della prima forma finché attorno a essa non viene visualizzato un riquadro rosso. Tenere premuto il pulsante del mouse e trascinare al centro della seconda forma. Quando viene visualizzato un riquadro rosso attorno alla seconda forma, rilasciare il pulsante del mouse. Questa è una connessione dinamica.

Attività rapide

Attività

Azione

Cambiare il tipo di connettore scegliendo quello ad angolo retto, diritto o curvo.

Fare clic con il pulsante destro del mouse sul connettore e quindi scegliere il tipo di connettore dal menu di scelta rapida.

Allineare e spaziare le forme in modo che i connettori siano ben visibili.

Selezionare tutte le forme che si desidera allineare e quindi nella scheda Home fare clic su allineamento e spaziatura automatici. È possibile selezionare più forme premendo il tasto CTRL mentre si fa clic su tutti o mediante una delle opzioni Selezionare.

Convertire una connessione dinamica in connessione a un punto e viceversa.

Selezionare il connettore e quindi trascinarne il punto finale allontanandolo dalla forma. Rilasciare quindi il connettore in un punto specifico per creare una connessione a un punto oppure al centro della forma per creare una connessione dinamica.

Attivare o disattivare la connessione automatica

È possibile attivare o disattivare la funzionalità di connessione automatica in tutti i disegni di Visio o solo nel disegno attivo.

Attivare o disattivare la connessione automatica nel diagramma attivo

  • Nel gruppo Strumenti visivi della scheda Visualizza selezionare o deselezionare la casella di controllo Connessione automatica.

Se la casella di controllo Connessione automatica non è disponibile, verificare se tale funzionalità è stata disattivata per tutti i diagrammi eseguendo la procedura seguente.

Attivare o disattivare la connessione automatica in tutti i diagrammi

  1. Fare clic su File > Opzioni.

  2. Fare clic sulla categoria Impostazioni avanzate.

  3. In Opzioni di modifica selezionare o deselezionare la casella di controllo Attiva connessione automatica rispettivamente per attivare o disattivare la funzionalità.

Vedere anche

Aggiungere frecce, punti o altre terminazioni di linea a un connettore

Aggiungere, spostare o eliminare punti di connessione

Connettere forme mediante la connessione automatica

Uno dei modi disponibili per connettere le forme consiste nel consentire a Visio di eseguire automaticamente questa operazione quando si aggiungono forme a un disegno. Questa opzione risulta particolarmente utile quando si creano diagrammi di flusso.

Per aggiungere una forma nel disegno e consentire a Visio di connetterla automaticamente a una forma già presente, eseguire la procedura seguente.

Usare la connessione automatica mentre si trascina forme nella pagina

  1. Trascinare una forma da uno stencil nella pagina di disegno e posizionarla accanto a un'altra forma.

    Forma posizionata accanto a un'altra forma

  2. Tenendo premuto il pulsante del mouse, posizionare il puntatore del mouse su uno dei triangoli blu. Il triangolo diventerà blu scuro.

    puntatore sul triangolo blu

  3. Rilasciare il pulsante del mouse. La forma verrà inserita nella pagina di disegno, un connettore viene aggiunto e associato a entrambe le forme.

    When the blue triangle is clicked, a connector is added and glued to both shapes.

Suggerimento : Se non si è soddisfatti trascinando le forme, è possibile ottenere lo stesso risultato selezionando una forma nello stencil, posizionando il puntatore sopra una forma nel disegno e quindi facendo clic su uno dei triangoli blu accanto alla forma.

Usare la connessione automatica con forme già nella pagina

  1. Posizionare il puntatore del mouse sulla forma che si desidera far partirela connessione.

    Puntatore posizionato sulla forma dalla quale far partire la connessione

  2. Posizionare il puntatore sul triangolo blu più vicino alla forma che si desidera connettersi.

    puntatore posizionato sul triangolo blu più vicino alla forma alla quale si desidera effettuare la connessione

    Il triangolo blu e viene visualizzata una casella rossa attorno alla forma che si desidera connettersi.

    Nota : Se non viene visualizzato un riquadro rosso intorno alla forma che si desidera connettersi, la forma potrebbe essere troppo distante. Spostare la forma più vicino e riprovare o utilizzare lo strumento connettore.

  3. Fare clic sul triangolo blu. Un connettore, questo viene aggiunto e associato a entrambe le forme.

    When the blue triangle is clicked, a connector is added and glued to both shapes.

Attivare o disattivare la connessione automatica

È possibile attivare o disattivare la funzionalità di connessione automatica in tutti i disegni di Visio o solo del disegno corrente. Per tutti i disegni:

  1. Scegliere Opzioni dal menu Strumenti.

  2. Fare clic sulla scheda Generale.

  3. In Opzioni della finestra di disegno, selezionare la casella di controllo Attiva connessione automatica.

Per l'oggetto corrente disegno solo:

  • Nella barra degli strumenti Standard fare clic sullo strumento di connessione automatica.

    Nota : Se facendo clic sullo strumento connessione automatica non si attiva la connessione automatica, verificare che sia selezionata la casella di controllo Attiva connessione automatica nella finestra di dialogo Opzioni.

Connettere forme mediante lo strumento connettore

Uno dei modi più flessibili per aggiungere e associare un connettore consiste nel disegno usando la strumento connettore Icona del pulsante sulla barra degli strumenti Standard.

  1. Fare clic sullo strumento Connettore Icona del pulsante nella barra degli strumenti Standard.

  2. Eseguire una delle operazioni seguenti:

    • Per mantenere il connettore associato a un punto specifico di una forma, trascinare un punto di connessione Immagine del punto di connessione - X blu sulla prima forma a un punto di connessione della seconda forma. Il connettore diventeranno rossi quando le forme sono connesse. Si tratta di una connessione punto a punto. Con una connessione punto a punto, il connettore rimane associato agli stessi punti di connessione quando si sposta una forma.

    • Per consentire il connettore spostare il punto di connessione disponibili più vicino, posizionare lo strumento connettore al centro della prima forma finché non viene visualizzato un riquadro rosso intorno alla forma. Tenere premuto il pulsante del mouse e trascinare verso il centro della seconda forma. Quando viene visualizzato un riquadro rosso intorno alla seconda forma, rilasciare il pulsante del mouse. Si tratta di una connessione forma a altra. Con una connessione forma a forma, il connettore rimane associato a ogni forma spostando i punti di connessione disponibili più vicini quando si sposta una delle forme. Se non sono presenti punti di connessione, il connettore si sposta sui lati più vicini.

      Nota : È anche possibile creare connessioni tra le forme nel punto in cui un'estremità del connettore sia connesso a un punto di connessione e l'altra estremità del connettore è connesso alla forma (e viceversa).

  3. Fare clic sullo strumento Puntatore Icona del puntatore sulla barra degli strumenti Standard per tornare alle normali attività di modifica.

    Note : 

    • Per aggiungere una connessione da una forma a più forme, è necessario aggiungere più connettori. non esiste nessuna forma connettore "salto condizionato".

    • Se si sta tentando di creare una connessione punto a punto e caso di difficoltà associando un connettore esattamente nel punto in cui si desidera, provare a snap diversi e associare impostazioni:

    • Dal menu Strumenti scegliere Aggancia e associa e quindi nella scheda Generale selezionare le opzioni desiderate.

      Se si associa a geometria della forma, un punto di manipolazione o vertice di una forma, un punto di connessione aggiunto automaticamente se non si è già presente.

Vedere anche

Aggiungere frecce, punti o altre terminazioni di linea a un connettore

Aggiungere, spostare o eliminare punti di connessione

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×