Aggiornare i dati della tabella pivot

È possibile fare clic su Aggiorna in qualsiasi momento per aggiornare i dati delle tabelle pivot nella cartella di lavoro. Si possono aggiornare i dati per le tabelle pivot connesse a dati esterni, ad esempio un database (SQL Server, Oracle, Access o altro), a un cubo di Analysis Services, un feed di dati e molte altre origini. I dati possono essere aggiornati da una tabella di origine nella stessa cartella di lavoro o in una diversa. Si può anche impostare la cartella di lavoro in modo che i dati della tabella pivot siano aggiornati automaticamente all'apertura.

Per impostazione predefinita, le tabelle pivot non vengono aggiornate automaticamente, ma è possibile specificare che la tabella pivot venga aggiornata automaticamente quando si apre la cartella di lavoro che contiene la tabella pivot.

Aggiornare manualmente

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

    Strumenti tabella pivot

  2. Fare clic su Analizza > Aggiorna o premere ALT+F5.

    Pulsante Aggiorna nella scheda Analizza

    Suggerimento: Per aggiornare tutte le tabelle pivot della cartella di lavoro in una sola volta, fare clic su analizza > Aggiorna tutto.

Se l'aggiornamento dura più del previsto, fare clic su Analizza > Aggiorna > Stato aggiornamento per controllare lo stato dell'aggiornamento.

Per interrompere l'aggiornamento, fare clic su Annulla aggiornamento.

Impedire la modifica della larghezza delle colonne e della formattazione delle celle

Se la larghezza delle colonne e la formattazione delle celle cambia con l'aggiornamento dei dati della tabella pivot e non si vuole che questo accada, accertarsi che siano selezionate le opzioni seguenti:

  1. Fare clic su Analizza > Opzioni.

    Pulsante Opzioni nella scheda Analizza

  2. Nella scheda Layout e formato selezionare le caselle Adatta larghezza colonne all'aggiornamento e Mantieni formattazione celle all'aggiornamento.

Aggiornare automaticamente i dati all'apertura della cartella di lavoro

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

    Strumenti tabella pivot

  2. Fare clic su Analizza > Opzioni.

    Pulsante Opzioni nella scheda Analizza

  3. Nella scheda dati selezionare la casella di controllo Aggiorna dati all'apertura della finestra di dialogo file.

Aggiornare manualmente

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Verranno visualizzati gli Strumenti tabella pivot, l'aggiunta di Opzioni e una scheda progettazione .

  2. Nel gruppo dati della scheda Opzioni eseguire una delle operazioni seguenti:

  3. Per aggiornare le informazioni in base all'origine dati, fare clic sul pulsante Aggiorna oppure premere ALT + F5.

    È anche possibile fare clic con il pulsante destro del mouse sulla tabella pivot e quindi scegliere Aggiorna.

  4. Per aggiornare tutte le tabelle pivot della cartella di lavoro, fare clic sulla freccia del pulsante Aggiorna e quindi su Aggiorna tutto.

    Immagine della barra multifunzione di Excel

    Se l'aggiornamento richiede più tempo del previsto, fare clic su opzioni > Aggiorna > stato di aggiornamento per verificare lo stato di aggiornamento.

    Per interrompere l'aggiornamento, fare clic su Annulla aggiornamento.

Impedire la modifica della larghezza delle colonne e della formattazione delle celle

Se la larghezza delle colonne e la formattazione delle celle cambia con l'aggiornamento dei dati della tabella pivot e non si vuole che questo accada, accertarsi che siano selezionate le opzioni seguenti:

  1. Fare clic su opzioni > opzioni.

    Gruppo Tabella pivot nella scheda Opzioni in Strumenti tabella pivot
  2. Nella scheda Layout e formato selezionare le caselle Adatta larghezza colonne all'aggiornamento e Mantieni formattazione celle all'aggiornamento.

Aggiornare automaticamente i dati della tabella pivot all'apertura della cartella di lavoro

  1. Fare clic in un punto qualsiasi della tabella pivot.

  2. Nel gruppo Tabella pivot della scheda Opzioni fare clic su Opzioni.

    Gruppo Tabella pivot nella scheda Opzioni in Strumenti tabella pivot

  3. Nella scheda dati della finestra di dialogo Opzioni tabella pivot selezionare la casella di controllo Aggiorna dati all'apertura del file .

Se si aggiungono nuovi dati all'origine dati della tabella pivot, sarà necessario aggiornare tutte le tabelle pivot basate su tale origine dati. Per aggiornare la tabella pivot, è possibile fare clic con il pulsante destro del mouse all'interno dell'intervallo della tabella pivot e scegliere Aggiorna.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×