CERCA.X (funzione CERCA.X)

Usare la funzione CERCA.X per trovare elementi in una tabella o in un intervallo per riga. Ad esempio è possibile cercare il prezzo di un componente di un’auto in base al numero del pezzo o trovare il nome di un dipendente in base al suo ID dipendente. Con CERCA.X è possibile cercare un termine di ricerca in una colonna e ottenere un risultato nella stessa riga ma in un'altra colonna, indipendentemente dal lato in cui si trova la colonna del risultato.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

La funzione CERCA.X esegue la ricerca in un intervallo o in una matrice e restituisce un elemento corrispondente alla prima corrispondenza che trova. Se non esiste una corrispondenza, CERCA.X può restituire la corrispondenza più vicina (approssimativa). 

=CERCA.X(valore;matrice_ricerca;matrice_restituita;[se_non_trovato];[modalità_confronto];[modalità_ricerca]) 

Argomento

Descrizione

valore

Obbligatorio

Il valore da ricercare

matrice_ricerca

Obbligatorio

La matrice o l’intervallo in cui effettuare la ricerca

matrice_restituita

Obbligatorio

La matrice o l’intervallo da restituire

[se_non_trovato]

Facoltativo

Se non è stata trovata una corrispondenza valida, restituire il testo [se_non_trovato] che si specifica.

Se non viene trovata una corrispondenza valida e [se_non_trovato] manca, verrà restituito #N/D.

[modalità_confronto]

Facoltativo

Specificare il tipo di corrispondenza:

0 - Corrispondenza esatta. Se non trovata, restituisce #N/D. Questa è l’impostazione predefinita.

-1 - Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più piccolo.

1 - Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più grande.

2 - Una corrispondenza jolly in cui *, ? e ~ hanno un significato speciale.

[modalità_ricerca]

Facoltativo

Specificare la modalità di ricerca da usare:

1 - Effettuare una ricerca a partire dal primo elemento. Questa è l’impostazione predefinita.

-1 - Effettuare una ricerca inversa a partire dall’ultimo elemento.

2 - Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine crescente. Se non è classificata, vengono restituiti risultati non validi.

- 2 - Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine decrescente. Se non è classificata, vengono restituiti risultati non validi.

Esempi

Esempio 1

Questo esempio è illustrato nel video e usa una semplice funzione CERCA.X per cercare il nome di un paese e restituire il suo prefisso telefonico. Include solo gli argomenti valore (cella F2), matrice_ricerca (intervallo B2:B11) e matrice_restituita (intervallo D2:D11). L'argomento modalità_confronto non viene incluso, perché per impostazione predefinita CERCA.X equivale a una corrispondenza esatta.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:C14).

Nota: CERCA.X è diverso da CERCA.VERT, poiché usa una matrice di ricerca e una matrice restituita distinte, mentre CERCA.VERT usa una singola matrice della tabella, seguita dal numero di indice della colonna. In questo caso la formula CERCA.VERT equivalente sarà: =CERCA.VERT(F2;B2:D11;3;FALSO)

Esempio 2

In questo esempio vengono cercate informazioni sui dipendenti in base al loro numero ID dipendente. A differenza di CERCA.VERT, CERCA.X può restituire una matrice con più elementi, il che consente di restituire sia il nome del dipendente sia il suo reparto dalle celle C5:D14.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1)

Esempio 3

In questo esempio viene aggiunto l’argomento se_non_trovato all'esempio precedente.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente con l’argomento se_non_trovato. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1, “dipendente non trovato”)

Esempio 4

Nell'esempio seguente viene cercato nella colonna C il reddito personale immesso nella cella E2 per trovare un'aliquota di imposta corrispondente nella colonna B. L'argomento se_non_trovato viene impostato in modo da restituire 0 se non viene trovato alcun valore. L'argomento modalità_confronto è impostato su 1, quindi la funzione cercherà una corrispondenza esatta e, se non riesce a trovarne una, restituirà l’elemento seguente più grande. Infine, l'argomento modalità_ricerca è impostato su 1, quindi la funzione eseguirà la ricerca dal primo all’ultimo elemento.

Immagine della funzione CERCA.X usata per restituire un'aliquota di imposta in base al reddito massimo. Si tratta di una corrispondenza approssimativa. La formula è: =CERCA.X(E2,C2:C7,B2:B7,1,1)

Nota: A differenza di CERCA.VERT, la colonna matrice_ricerca si trova a destra della colonna matrice_restituita, e CERCA.VERT può invece cercare solo da sinistra a destra.

Esempio 5

Ora useremo una funzione CERCA.X annidata per eseguire una corrispondenza verticale e orizzontale allo stesso tempo. In questo caso, viene innanzitutto cercato il Profitto lordo nella colonna B, quindi Trim1 nella prima riga della tabella (intervallo C5:F5) e viene restituito il valore all'intersezione di esse. Si tratta di un modo analogo all'uso combinato delle funzioni INDICE e CONFRONTA. È anche possibile usare CERCA.X al posto della funzione CERCA.ORIZZ.

Immagine della funzione CERCA.X usata per restituire dati orizzontali da una tabella annidando due CERCA.X. La formula è: =CERCA.X(D2,$B6:$B17,CERCA.X($C3,$C5:$G5,$C6:$G17))

La formula nelle celle D3:F3 è: =CERCA.X(D2;$B6:$B17;CERCA.X($C3;$C5:$G5;$C6:$G17)).

Esempio 6

In questo esempio viene usata la funzione SOMMA e due funzioni CERCA.X annidate insieme per sommare tutti i valori compresi tra due intervalli. In questo caso, si vogliono sommare i valori di uva e banane e includere quelli delle pere, che si trovano tra di essi.

Utilizzo di CERCA.X con SOMMA per sommare un intervallo di valori compresi tra due selezioni

La formula nella cella E3 è: =SOMMA(CERCA.X(B3;B6:B10;E6:E10):CERCA.X(C3;B6:B10;E6:E10))

Come funziona? CERCA.X restituisce un intervallo, quindi, quando esegue il calcolo, la formula finisce per avere l'aspetto seguente: =SOMMA($E$7:$E$9). È possibile vedere il funzionamento del processo selezionando una cella con una formula CERCA.X simile a questa, quindi passare a Formule > Verifica formule > Valuta formula, e premere il pulsante Valuta per eseguire il calcolo.

Nota: Grazie all’MVP di Microsoft Excel, Bill Jelen, per aver suggerito questo esempio.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

CONFRONTA.X (funzione CONFRONTA.X)

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×