Menyisipkan lembar data ke dalam formulir

Catatan: Kami ingin secepatnya menyediakan konten bantuan terbaru dalam bahasa Anda. Halaman ini diterjemahkan menggunakan mesin dan mungkin terdapat kesalahan tata bahasa atau masalah keakuratan. Kami bertujuan menyediakan konten yang bermanfaat untuk Anda. Dapatkah Anda memberi tahu kami apakah informasi ini bermanfaat untuk Anda di bagian bawah halaman ini? Berikut artikel dalam bahasa Inggris untuk referensi.

Lembar data adalah tampilan sederhana data yang disusun dalam baris dan kolom. Jika Anda mengklik ganda tabel di panel navigasi, Microsoft Office Access 2007 menampilkan tabel sebagai lembar data. Karena mereka presentasi ringkas data, lembar data berfungsi baik ketika mereka digunakan sebagai subformulir untuk menampilkan data dari sisi "banyak" hubungan satu ke banyak. Artikel ini menguraikan cara Anda bisa menambahkan lembar data untuk formulir Office Access 2007.

Apa yang ingin Anda lakukan?

Menampilkan contoh lembar data pada formulir

Menetapkan hubungan antara tabel

Membuat formulir yang berisi lembar data dengan menggunakan alat formulir

Membuat formulir yang berisi lembar data dengan menggunakan tampilan tata letak

Menyisipkan lembar data ke dalam formulir yang sudah ada dengan menggunakan tampilan tata letak

Menyisipkan lembar data ke dalam formulir yang sudah ada dengan menggunakan tampilan desain

Memahami perbedaan antara formulir terpisah dan formulir yang berisi lembar data

Menampilkan contoh lembar data pada formulir

Anggap Anda ingin membuat formulir yang memperlihatkan data tentang kategori produk dan juga semua produk dalam kategori tersebut. Data dalam tabel kategori menunjukkan sisi "satu" dari hubungan itu, dan data dalam tabel produk menunjukkan sisi "banyak" dari hubungan itu. Setiap kategori bisa memiliki banyak produk.

Formulir dengan subformulir

1. Formulir utama memperlihatkan data dari sisi "satu" hubungan tersebut.

2. lembar data memperlihatkan data dari sisi "banyak" dari hubungan itu.

Atas Halaman

Menetapkan hubungan antara tabel

Sebelum Anda mendesain formulir yang berisi lembar data, Anda harus meninjau hubungan antara tabel Anda dan tambahkan hubungan yang hilang. Melakukan ini memungkinkan akses ke secara otomatis membuat hubungan antara lembar data dan formulir utama. Untuk menampilkan, menambahkan atau mengubah hubungan antar tabel dalam database Anda, pada tab Alat tingkat lanjut , di grup analisis , klik hubungan. Untuk informasi selengkapnya tentang membuat hubungan, lihat link di bagian Lihat juga .

Atas Halaman

Membuat formulir yang berisi lembar data dengan menggunakan alat formulir

Saat Anda menggunakan alat formulir untuk membuat formulir yang didasarkan pada tabel yang berada di sisi "satu" dari hubungan satu ke banyak tunggal, Access secara otomatis menyisipkan lembar data yang menampilkan data di sisi "banyak" dari hubungan itu.

Misalnya, jika kondisi berikut ini true, Access menyisipkan lembar data yang memperlihatkan semua perintah untuk masing-masing pelanggan:

  • Anda membuat formulir yang didasarkan pada tabel Customers.

  • Hubungan satu ke banyak dengan tabel pesanan yang menentukan bahwa satu rekaman dalam tabel pelanggan bisa terkait dengan banyak rekaman dalam tabel pesanan yang sudah Anda tetapkan.

  • Tabel pelanggan tidak berada di sisi "satu" dari hubungan satu ke banyak lainnya.

  • Di panel navigasi, klik tabel yang berada di sisi "satu" dari hubungan satu ke banyak.

  • Pada tab buat , di grup formulir , klik formulir. Gambar tombol

Access membuat formulir dengan lembar data di bagian bawah formulir. Jika Access tidak membuat lembar data, artinya bahwa tabel yang Anda gunakan untuk formulir bukan merupakan bagian dari hubungan satu ke banyak atau tabel adalah bagian dari lebih dari satu hubungan satu ke banyak.

Catatan: 

  • Selain membuat formulir utama, proses ini tidak membuat objek formulir lain. Lembar data adalah tampilan langsung tabel.

  • Untuk menyembunyikan kolom di lembar data    Klik kanan kolom dan klik Sembunyikan kolom. Pengaturan ini disimpan; Jika Anda menyimpan dan tutup formulir dan lalu membukanya kembali, kolom masih dapat disembunyikan.

  • Untuk memulihkan kolom tersembunyi dalam lembar data    Klik kanan judul kolom mana pun di lembar data dan lalu klik Munculkan kolom. Pilih kotak centang di samping setiap kolom yang ingin Anda Pulihkan ke tampilan, dan lalu klik tutup.

Atas Halaman

Membuat formulir yang berisi lembar data dengan menggunakan tampilan tata letak

Jika Anda sudah ditentukan hubungan antar tabel dalam database Anda, Anda bisa dengan cepat membuat formulir yang berisi lembar data dengan menggunakan tampilan tata letak. Saat Anda menambahkan bidang dari sisi "banyak" dari hubungan ke formulir yang didasarkan pada sisi "satu" dari hubungan itu, Access otomatis membuat lembar data untuk menampilkan rekaman terkait.

  1. Pada tab buat , di grup formulir , klik Formulir kosong. Gambar tombol

    Access membuka formulir kosong dalam tampilan tata letak dan menampilkan panel Daftar bidang .

    Catatan: Jika Anda tidak sengaja menutup panel Daftar bidang , Anda bisa membukanya dengan melakukan salah satu hal berikut ini:

    • Tekan ALT+F8.

      —atau—

      Pada tab Format , di grup kontrol , klik Tambahkan bidang yang ada. Gambar tombol

  2. Klik tanda plus di samping tabel yang berada di sisi "satu" dari hubungan satu ke banyak, dan lalu seret bidang pertama yang Anda inginkan ke formulir.

    Panel Daftar bidang membagi tabel menjadi bagian-bagian catatan: bidang yang tersedia untuk tampilan ini dan, di bawah ini, bidang yang tersedia di tabel terkait. Di bagian bawah panel Daftar bidang , tabel lain yang tidak langsung terkait dengan tabel utama dicantumkan di bawah bidang tersedia di tabel lain.

  3. Dari bagian bidang yang tersedia untuk tampilan ini , seret bidang lain yang Anda inginkan ke formulir utama.

  4. Dari bagian bidang yang tersedia di tabel terkait , seret bidang pertama yang Anda inginkan dalam lembar data Anda ke formulir. Access membuat lembar data dan menambahkan bidang ke dalamnya.

  5. Untuk menambahkan bidang tambahan ke lembar data baru, Anda harus terlebih dahulu mengklik lembar data untuk memilihnya. Perhatikan bahwa akses menyusun panel Daftar bidang sehingga bidang yang tersedia untuk lembar data di bagian atas. Dari bagian bidang yang tersedia untuk tampilan ini , seret bidang lain yang Anda inginkan ke lembar data. Saat Anda menyeret setiap bidang dalam lembar data, Access menggambar penyisipan bilah untuk memperlihatkan tempat disisipkan bidang saat Anda melepaskan tombol mouse.

  6. Terus tambahkan bidang ke formulir utama atau lembar data dengan terlebih dahulu mengklik formulir utama atau lembar data untuk memilihnya, lalu menyeret bidang dari panel Daftar bidang .

Bagian bidang tersedia di tabel lain dari panel Daftar bidang berisi tabel yang tidak langsung terkait dengan tabel atau kueri yang dipilih formulir atau lembar data. Jika Anda telah menetapkan semua hubungan valid tabel dalam jendela hubungan, lalu bidang di bagian bidang tersedia di tabel lain tidak valid pilihan untuk formulir yang Anda membangun mungkin. Jika Anda menyeret bidang dari bagian ini ke formulir, Access menampilkan kotak dialog Tentukan hubungan . Anda harus memasukkan bidang atau beberapa bidang yang berkaitan dengan dua tabel satu sama lain sebelum Anda melanjutkan. Jika Anda melakukan ini, panel Daftar bidang tidak akan lagi bagian diurutkan menurut hubungan yang sudah ditentukan sebelumnya. Mungkin yang terbaik untuk klik Batalkan di kotak dialog ini dan menilai hubungan tabel Anda sebagai gantinya. Untuk informasi selengkapnya tentang hubungan, lihat artikel membuat, mengedit atau menghapus hubungan.

Atas Halaman

Menyisipkan lembar data ke dalam formulir yang sudah ada dengan menggunakan tampilan tata letak

Jika Anda belum menentukan hubungan antar tabel dalam database Anda, Anda bisa dengan cepat menambahkan lembar data untuk formulir yang sudah ada dengan menggunakan tampilan tata letak. Saat Anda menambahkan bidang dari sisi "banyak" dari hubungan ke formulir yang didasarkan pada sisi "satu" dari hubungan itu, Access otomatis membuat lembar data untuk menampilkan rekaman terkait.

  1. Buka formulir yang ada dalam tampilan tata letak dengan mengklik kanan di panel navigasi, lalu klik Tampilan tata letak pada menu pintasan.

    Jika panel Daftar bidang tidak ditampilkan:

    • Tekan ALT+F8.

      —atau—

      Pada tab Format , di grup kontrol , klik Tambahkan bidang yang ada. Gambar tombol

      Panel Daftar bidang membagi tabel menjadi bagian-bagian catatan: bidang yang tersedia untuk tampilan ini dan, di bawah ini, bidang yang tersedia di tabel terkait. Di bagian bawah panel Daftar bidang , tabel lain yang tidak langsung terkait dengan tabel utama dicantumkan di bawah bidang tersedia di tabel lain.

  2. Di bagian bidang yang tersedia di tabel terkait , Perluas tabel yang berisi bidang pertama yang Anda inginkan pada lembar data Anda, dan seret bidang ke formulir. Access membuat lembar data dan menambahkan bidang ke dalamnya.

  3. Untuk menambahkan bidang tambahan ke lembar data baru, Anda harus terlebih dahulu mengklik lembar data untuk memilihnya. Perhatikan bahwa akses menyusun panel Daftar bidang sehingga bidang yang tersedia untuk lembar data di bagian atas. Dari bagian bidang yang tersedia untuk tampilan ini , seret bidang lain yang Anda inginkan ke lembar data. Saat Anda menyeret setiap bidang dalam lembar data, Access menggambar penyisipan bilah untuk memperlihatkan tempat disisipkan bidang saat Anda melepaskan tombol mouse.

  4. Terus tambahkan bidang ke formulir utama atau lembar data dengan terlebih dahulu mengklik formulir utama atau lembar data untuk memilihnya, lalu menyeret bidang dari panel Daftar bidang .

Bagian bidang tersedia di tabel lain dari panel Daftar bidang berisi tabel yang tidak langsung terkait dengan tabel atau kueri yang dipilih formulir didasarkan pada. Jika Anda telah menetapkan semua hubungan valid tabel dalam jendela hubungan, lalu bidang di bagian bidang tersedia di tabel lain tidak valid pilihan untuk formulir yang Anda membangun mungkin. Jika Anda menyeret bidang dari bagian ini ke formulir, Access menampilkan kotak dialog Tentukan hubungan . Anda harus memasukkan bidang atau beberapa bidang yang berkaitan dengan dua tabel satu sama lain sebelum Anda melanjutkan. Jika Anda melakukan ini, panel Daftar bidang tidak lagi akan diurutkan menjadi bagian-bagian menurut hubungan yang sudah ditentukan sebelumnya. Mungkin yang terbaik untuk klik Batalkan di kotak dialog ini dan menilai hubungan tabel Anda sebagai gantinya. Untuk informasi selengkapnya tentang hubungan, lihat artikel membuat, mengedit atau menghapus hubungan.

Atas Halaman

Menyisipkan lembar data ke dalam formulir yang sudah ada dengan menggunakan tampilan desain

Gunakan prosedur ini untuk menambahkan lembar data yang berdasarkan secara langsung pada tabel atau kueri ke formulir yang sudah ada dalam tampilan desain.

  1. Buka formulir dalam tampilan desain dengan mengklik kanan formulir dalam panel navigasi, lalu klik Tampilan desain.

  2. Pada tab desain , di grup kontrol , jika alat Gunakan panduan kontrol yang dipilih, klik sehingga tidak dipilih.

    Gambar tombol

    Mengapa?

    Jika digunakan, panduan kontrol subformulir menyusun objek formulir terpisah dan basis kontrol subformulir pada objek formulir tersebut. Sebaliknya, prosedur ini membuat lembar data yang berdasarkan pada tabel atau kueri dan bukan formulir.

  3. Pada tab desain , di grup kontrol , klik tombol Gambar tombol Subformulir/sublaporan. Gambar tombol

  4. Dalam kisi desain formulir, klik di mana Anda ingin lembar data untuk disisipkan.

  5. Memosisikan ulang dan mengubah ukuran kontrol subformulir dengan menyeret gagang di tepi dan sudut kontrol.

  6. Mengedit label lampiran untuk kontrol subformulir dengan terlebih dahulu mengklik label, klik ganda untuk memilih teks, lalu ketikkan label baru. Jika Anda memilih untuk menghapus label, klik label sekali dan tekan DELETE.

  7. Jika lembar properti belum ditampilkan, tekan F4 untuk menampilkannya.

  8. Jika kontrol subformulir tidak saat ini dipilih, klik sekali untuk memilihnya.

  9. Pada tab Data lembar properti, klik Daftar turun bawah Sumber objek , dan lalu klik tabel atau kueri yang Anda inginkan untuk ditampilkan di lembar data. Misalnya, jika Anda ingin menampilkan data dari tabel pesanan, klik Table.Orders.

  10. Jika Anda membuat hubungan dengan benar sebelum Anda memulai prosedur ini, Access secara otomatis mengatur Tautkan bidang anak dan properti Tautkan bidang Master dengan nilai yang benar yang akan menautkan formulir utama ke lembar data.

    Properti tautkan bidang anak dan tautkan bidang Master saya kosong

    Jika Access tidak bisa menentukan cara menautkan kontrol subformulir ke formulir utama, meninggalkan properti Tautkan bidang anak dan Tautkan bidang Master kontrol subformulir kosong. Anda harus mengatur properti ini secara manual dengan melakukan hal berikut:

    1. Buka formulir utama dalam tampilan desain.

    2. Klik kontrol subformulir sekali untuk memilihnya.

    3. Jika lembar properti belum ditampilkan saat ini, tekan F4.

    4. Pada tab Data lembar properti, klik () di samping kotak properti Tautkan bidang anak .

      Kotak dialog Penaut Bidang Subformulir akan muncul.

    5. Di daftar turun bawah Bidang Master dan Bidang turunan , pilih bidang yang ingin Anda tautkan formulir dengan. Jika Anda tidak yakin mana bidang untuk digunakan, klik sarankan memiliki akses yang menentukan bidang penautan. Saat Anda selesai, klik OK.

      Jika Anda tidak melihat bidang yang ingin Anda gunakan untuk menautkan ke formulir, Anda mungkin perlu mengedit sumber rekaman formulir master atau anak untuk memastikan bidang yang ada di dalamnya. Misalnya, jika formulir didasarkan pada kueri, pastikan bidang penautan ada dalam hasil kueri.

    6. Simpan formulir utama dan beralih ke tampilan formulir untuk memverifikasi bahwa formulir berfungsi seperti yang Anda harapkan.

  11. Simpan formulir dengan mengklik Simpan Gambar tombol pada Toolbar akses cepat atau dengan menekan CTRL + S.

  12. Beralih ke Tampilan formulir dan pastikan bahwa lembar data berfungsi seperti yang Anda harapkan.

Atas Halaman

Memahami perbedaan antara formulir terpisah dan formulir yang berisi lembar data

Formulir yang berisi lembar data menampilkan data dari sumber data berbeda (tapi biasanya terkait). Misalnya, formulir dapat memperlihatkan karyawan, dan mungkin memiliki lembar data yang memperlihatkan semua tugas yang ditetapkan untuk setiap karyawan. Lembar data memiliki sumber data yang berbeda dari formulir yang berisi tersebut. Sebaliknya, formulir terpisah memiliki dua bagian (formulir dan lembar data), tapi data yang sama ditampilkan di bagian kedua. Dua bagian Lacak dengan satu sama lain dan memberikan dua tampilan berbeda dari data Anda sekaligus.

Untuk informasi selengkapnya tentang membuat dan bekerja dengan formulir terpisah, lihat artikel membuat formulir terpisah.

Atas Halaman

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×