Menyambungkan ke Analysis Services

Catatan: Kami ingin secepatnya menyediakan konten bantuan terbaru dalam bahasa Anda. Halaman ini diterjemahkan menggunakan mesin dan mungkin terdapat kesalahan tata bahasa atau masalah keakuratan. Kami bertujuan menyediakan konten yang bermanfaat untuk Anda. Dapatkah Anda memberi tahu kami apakah informasi ini bermanfaat untuk Anda di bagian bawah halaman ini? Berikut artikel dalam bahasa Inggris untuk referensi.

Anda bisa membuat koneksi yang dinamis dari buku kerja Excel ke sumber data Analysis Services , lalu refresh koneksi tersebut saat data yang diperbarui.

Gunakan pengalaman Dapatkan & transformasi (Power Query) Excel untuk menyambungkan ke Analysis Services.

  1. Masuk ke Data > Dapatkan Data eksternal > dari Database > dari Analysis Services. Jika Anda tidak melihat tombol Dapatkan Data , klik Dapatkan Data eksternal > Dari sumber lain > Dari Analysis Services.

    Panduan koneksi Data ditampilkan. Panduan ini memiliki tiga panel.

    • Menyambungkan ke Server Database

    • Pilih Database dan tabel

    • Menyimpan File koneksi Data dan selesai

  2. Di panel menyambungkan ke Database Server , dalam kotak Server nama , ketikkan nama OLAP database server.

    Tips: Jika Anda mengetahui nama file kubus offline yang Anda inginkan untuk menyambungkan ke, Anda dapat mengetikkan jalur lengkap file, nama file dan ekstensi.

  3. Di bawah masuk kredensial, lakukan salah satu hal berikut ini, lalu klik berikutnya:

    • Untuk menggunakan nama pengguna Windows dan kata sandi Anda saat ini, klik Gunakan autentikasi Windows.

    • Untuk memasukkan nama pengguna database dan kata sandi, klik Gunakan nama pengguna dan kata sandi berikut ini, dan lalu ketikkan nama pengguna dan kata sandi dalam kotak Nama pengguna dan kata sandi yang terkait.

  4. Di panel pilih database yang berisi data yang Anda inginkan , pilih database, lalu klik berikutnya.

    Untuk menyambungkan ke tertentu kubus dalam database, pastikan bahwa menyambungkan ke kubus tertentu atau tabel dipilih, dan lalu pilih kubus dari daftar.

  5. Di panel Simpan File koneksi Data dan selesai , dalam kotak Nama File , revisi nama file default diperlukan (opsional).

  6. Klik Telusuri untuk mengubah lokasi file default sayasumber Data, atau periksa nama file yang sudah ada.

  7. Dalam kotak Deskripsi, Nama yang mudah dikenal, dan Kata kunci pencarian , ketikkan Deskripsi file, nama yang mudah dikenal, dan umum kata-kata pencarian (semua opsional).

  8. Untuk memastikan bahwa file koneksi yang digunakan saat PivotTable akan di-refresh, klik selalu berusaha menggunakan file ini untuk melakukan refresh data ini.

    Memilih kotak centang ini memastikan bahwa pembaruan ke file koneksi akan selalu digunakan oleh semua buku kerja yang menggunakan file koneksi tersebut.

  9. Klik selesai untuk menutup panduan koneksi Data.

  10. Dalam kotak dialog Impor Data , di bawah pilih cara yang diinginkan untuk menampilkan data ini dalam buku kerja Anda, lakukan salah satu hal berikut ini:

    • Untuk membuat hanya laporan PivotTable, klik Laporan PivotTable.

    • Untuk membuat laporan PivotTable dan laporan PivotChart, klik laporan PivotTable dan PivotChart.

    • Untuk menyimpan koneksi dipilih di buku kerja untuk digunakan nanti, klik Hanya Buat koneksi. Kotak centang ini memastikan bahwa koneksi digunakan oleh rumus yang berisi fungsi kubus yang Anda buat dan bahwa Anda tidak ingin membuat laporan PivotTable.

  11. Di bawah tempat Anda ingin meletakkan data, lakukan salah satu hal berikut ini:

    • Untuk meletakkan laporan PivotTable dalam lembar kerja yang sudah ada, pilih lembar kerja yang ada, dan lalu ketikkan referensi sel dari sel pertama di rentang sel tempat Anda ingin menemukan laporan PivotTable.

      Anda juga bisa mengklik Ciutkan Dialog Gambar tombol untuk sementara waktu menyembunyikan kotak dialog, pilih awal sel pada lembar kerja yang ingin Anda gunakan, lalu tekan Perluas Dialog Gambar tombol .

    • Untuk meletakkan laporan PivotTable di lembar kerja baru yang dimulai pada sel A1, klik lembar kerja baru.

    • Untuk memverifikasi atau mengubah properti koneksi, klik properti, buat perubahan yang diperlukan dalam kotak dialog Properti koneksi , dan lalu klik OK.

Panduan Koneksi Data

  1. Pada tab Data , dalam grup Dapatkan Data eksternal , klik Dari sumber lain, dan lalu klik Dari layanan analisis.

    Gambar Pita Excel

    Panduan koneksi Data ditampilkan. Panduan ini memiliki tiga panel.

    • Menyambungkan ke Server Database

    • Pilih Database dan tabel

    • Menyimpan File koneksi Data dan selesai

  2. Di panel menyambungkan ke Database Server , dalam kotak Server nama , ketikkan nama OLAP database server.

    Tips: Jika Anda mengetahui nama file kubus offline yang Anda inginkan untuk menyambungkan ke, Anda dapat mengetikkan jalur lengkap file, nama file dan ekstensi.

  3. Di bawah masuk kredensial, lakukan salah satu hal berikut ini, lalu klik berikutnya:

    • Untuk menggunakan nama pengguna Windows dan kata sandi Anda saat ini, klik Gunakan autentikasi Windows.

    • Untuk memasukkan nama pengguna database dan kata sandi, klik Gunakan nama pengguna dan kata sandi berikut ini, dan lalu ketikkan nama pengguna dan kata sandi dalam kotak Nama pengguna dan kata sandi yang terkait.

  4. Di panel pilih database yang berisi data yang Anda inginkan , pilih database, lalu klik berikutnya.

    Untuk menyambungkan ke tertentu kubus dalam database, pastikan bahwa menyambungkan ke kubus tertentu atau tabel dipilih, dan lalu pilih kubus dari daftar.

  5. Di panel Simpan File koneksi Data dan selesai , dalam kotak Nama File , revisi nama file default diperlukan (opsional).

    Klik Telusuri untuk mengubah lokasi file default sayasumber Data, atau periksa nama file yang sudah ada.

  6. Dalam kotak Deskripsi, Nama yang mudah dikenal, dan Kata kunci pencarian , ketikkan Deskripsi file, nama yang mudah dikenal, dan umum kata-kata pencarian (semua opsional).

  7. Untuk memastikan bahwa file koneksi yang digunakan saat PivotTable akan di-refresh, klik selalu berusaha menggunakan file ini untuk melakukan refresh data ini.

    Memilih kotak centang ini memastikan bahwa pembaruan ke file koneksi akan selalu digunakan oleh semua buku kerja yang menggunakan file koneksi tersebut.

  8. Klik selesai untuk menutup panduan koneksi Data.

  9. Dalam kotak dialog Impor Data , di bawah pilih cara yang diinginkan untuk menampilkan data ini dalam buku kerja Anda, lakukan salah satu hal berikut ini:

    • Untuk membuat hanya laporan PivotTable, klik Laporan PivotTable.

    • Untuk membuat laporan PivotTable dan laporan PivotChart, klik laporan PivotTable dan PivotChart.

    • Untuk menyimpan koneksi dipilih di buku kerja untuk digunakan nanti, klik Hanya Buat koneksi. Kotak centang ini memastikan bahwa koneksi digunakan oleh rumus yang berisi fungsi kubus yang Anda buat dan bahwa Anda tidak ingin membuat laporan PivotTable.

  10. Di bawah tempat Anda ingin meletakkan data, lakukan salah satu hal berikut ini:

    • Untuk meletakkan laporan PivotTable dalam lembar kerja yang sudah ada, pilih lembar kerja yang ada, dan lalu ketikkan referensi sel dari sel pertama di rentang sel tempat Anda ingin menemukan laporan PivotTable.

      Anda juga bisa mengklik Ciutkan Dialog Gambar tombol untuk sementara waktu menyembunyikan kotak dialog, pilih awal sel pada lembar kerja yang ingin Anda gunakan, lalu tekan Perluas Dialog Gambar tombol .

  11. Untuk meletakkan laporan PivotTable di lembar kerja baru yang dimulai pada sel A1, klik lembar kerja baru.

  12. Untuk memverifikasi atau mengubah properti koneksi, klik properti, buat perubahan yang diperlukan dalam kotak dialog Properti koneksi , dan lalu klik OK.

Perlu bantuan lainnya?

Anda selalu dapat bertanya kepada pakar di Komunitas Teknologi Excel, mendapatkan dukungan di Komunitas Jawaban, atau menyarankan fitur maupun fitur baru di Suara Pengguna Excel.

Lihat Juga

Power Query dikenal sebagai Dapatkan & Transformasi di Excel 2016

Mengimpor data dari sumber data eksternal

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×