Menerbitkan buku kerja ke situs SharePoint di Excel untuk Windows

Anda bisa menerbitkan buku kerja ke pustaka Microsoft SharePoint sehingga orang-orang bisa menampilkan dan mengeditnya dalam browser web tanpa harus menginstal Excel di komputer mereka. Menerbitkan pada dasarnya sama dengan menyimpan, tapi dengan beberapa opsi bawaan yang memungkinkan Anda mengontrol apa yang bisa dilihat orang-orang ketika mereka membuka buku kerja dalam browser.

Mengadopsi praktik yang banyak digunakan organisasi untuk menyimpan atau menerbitkan buku kerja ke situs pusat SharePoint bisa membantu Anda memastikan bahwa versi yang sedikit berbeda dari buku kerja yang sama tidak mulai bermunculan di dalam organisasi Anda ketika data dikirim melalui email.

Dengan mengatur beberapa opsi penerbitan, Anda bisa memberi penekanan di bagian tertentu dari buku kerja Anda, seperti bagan, atau mengeluarkan bagian lain agar tidak ditampilkan dalam browser. Sebagai contoh, Anda bisa memperlihatkan bagan tapi tidak memperlihatkan data yang mendasarinya. Atau, Anda hanya bisa memperlihatkan lembar kerja tertentu ke orang-orang yang perlu untuk melihatnya, dan menyembunyikan lembar kerja lain.

Artikel ini memperlihatkan kepada Anda cara menerbitkan buku kerja dari Excel untuk Windows dan tidak mencakup menyambungkan buku kerja atau data buku kerja ke komponen Web Excel Web Access di halaman SharePoint.

Ketika Anda menerbitkan buku kerja ke situs SharePoint, seluruh buku kerja disimpan ke SharePoint. Pengguna yang membutuhkan izin SharePoint bisa menampilkan dan bekerja dengan seluruh buku kerja, baik dalam browser atau dalam program desktop Excel.

Jika Office Online digunakan di SharePoint, menampilkan dan mengerjakan data Anda dalam browser bisa sangat mirip dengan mengerjakan data dalam program desktop Excel. Ternyata, tidak seperti program desktop Excel, beberapa pengguna bisa mengedit buku kerja bersama-sama dalam kisi browser. Ketika Anda menampilkan buku kerja dalam browser, jika tombol Edit di Excel Online terlihat, Anda akan mengetahui bahwa Office Online telah siap untuk digunakan.

Edit di Excel Online di menu Edit Buku Kerja

Mempersiapkan buku kerja

Sebelum Anda menerbitkan buku kerja, Anda bisa memutuskan untuk memilih hanya lembar kerja atau item yang Anda inginkan untuk terlihat dalam browser. Ingatlah walaupun Anda bisa membatasi apa yang ditampilkan dalam mode ini, namun seluruh konten buku kerja masih disimpan dalam server SharePoint.

Jika Anda ingin menyertakan seluruh lembar kerja sebagai item tambahan ke item lain, seperti bagan atau PivotTabel, tetapkan seluruh lembar kerja sebagai rentang bernama. Pilih seluruh lembar kerja, lalu tetapkan rentang bernama. Rentang bernama ini akan muncul sebagai item yang tersedia di kotak dialog Opsi Penerbitan ketika Anda telah siap untuk menerbitkannya.

Guna memungkinkan pengguna memasukkan nilai dalam sel untuk bekerja dengan rumus dalam sel lain, atur sel tersebut sebagai nama yang ditentukan dalam Excel sebelum Anda menerbitkan buku kerja. Anda kemudian bisa menambahkan nama yang ditentukan sebagai parameter pada tab Parameter dalam kotak dialog Opsi Tampilan Browser.

Misalnya, berikut ini memperlihatkan sel D2, yang memiliki nama yang ditentukan "Rate." Di browser, pengguna memasukkan nilai 5,625 dalam kotak nilai di panel parameter , lalu klik Terapkan. Nilai tersebut kemudian muncul di sel D2, dan Rumusnya menggunakan nilai dalam D2. Hasil rumus dihitung ulang, dan diperlihatkan di A2: $1.151,31.

Memasukkan parameter dalam panel yang menggunakannya dalam sel D2

Catatan: Jika Anda membuat pemotong untuk tabel Excel dan menetapkan nama untuk rentang sel yang berisi tabel dan pemotong, Anda tidak akan bisa menggunakan pemotong untuk memfilter tabel dalam browser jika Anda menerbitkan rentang yang ditentukan. Jika Anda menerbitkan tabel atau seluruh lembar kerja atau buku kerjanya, pemotong akan bekerja seperti yang diharapkan dalam browser.

Menerbitkan buku kerja

  1. Klik tab File, klik Simpan Sebagai, lalu klik SharePoint.

  2. Jika Anda melihat folder SharePoint di bawah saat ini, terbaru, atau yang lebih lama, klik folder yang Anda inginkan.

    Kotak dialog Simpan Sebagai muncul.


    Jika tidak, klik Telusuri, masukkan alamat web untuk situs SharePoint, lalu telusuri ke folder di mana Anda ingin menerbitkan buku kerja.

    Klik folder SharePoint atau klik Telusuri
  3. Untuk memilih lembar kerja atau item individual untuk diterbitkan dari buku kerja, klik Opsi Tampilan Browser.

    Dalam kotak dialog Simpan Sebagai, klik Opsi Tampilan Browser

    Anda akan melihat tab Perlihatkan dan tab Parameter.

  4. Jika Anda hanya ingin menerbitkan seluruh buku kerja, klik Simpan. Jika tidak, lakukan salah satu hal berikut ini:

    • Untuk memperlihatkan seluruh buku kerja dalam browser, pada tab Perlihatkan, pilih Seluruh Buku Kerja dalam kotak daftar.

    • Untuk memperlihatkan hanya lembar kerja tertentu dalam browser, pada tab Perlihatkan, pilih Lembar dalam kotak daftar, lalu kosongkan kotak centang untuk lembar yang tidak ingin Anda sembunyikan dalam browser.

      Secara default, semua lembar dipilih. Untuk membuat semua lembar dapat terlihat dengan cepat setelah Anda mengosongkan beberapa kotak centang, pilih kotak centang Semua Lembar.

    • Untuk memperlihatkan hanya item tertentu dalam browser (seperti rentang bernama, bagan, tabel, atau PivotTable), pada tab Perlihatkan, pilih Item dalam Buku Kerja dalam kotak daftar, lalu pilih kotak centang untuk item yang ingin Anda perlihatkan.

    • Pada tab Parameter, tambahkan nama yang ditentukan yang ingin Anda gunakan untuk menetapkan sel yang bisa diedit ketika pengguna menampilkan buku kerja dalam browser, lalu klik OK.

  5. Simpan buku kerja.

Catatan: 

  • Jika Anda memilih item yang memiliki nama yang sama (seperti tabel dan tabel yang mendasari data), hanya satu dari item ini yang akan tersedia dalam browser. Untuk memperlihatkan semua item, pastikan setiap item dalam buku kerja memiliki nama yang unik.

  • Anda bisa mengganti nama tabel pada tab Desain dalam grup Properti, ganti nama PivotTables pada tab Opsi dalam grup PivotTable, dan ganti nama bagan atau PivotCharts pada tab Tata letak dalam grup Properti. Ganti nama item duplikat lainnya, seperti rentang bernama di tab Rumus dalam grup Nama yang Ditentukan.

Jika Office Online digunakan di SharePoint, menampilkan dan mengerjakan data Anda dalam browser bisa sangat mirip dengan mengerjakan data dalam program desktop Excel. Ternyata, tidak seperti program desktop Excel, beberapa pengguna bisa mengedit buku kerja bersama-sama dalam kisi browser. Ketika Anda menampilkan buku kerja dalam browser, jika tombol Edit di Excel Online terlihat, Anda akan mengetahui bahwa Office Online telah siap untuk digunakan.

Edit di Excel Online di menu Edit Buku Kerja

Untuk informasi selengkapnya, lihat artikel perbedaan antara menggunakan buku kerja di Excel dan Excel Services.

Mempersiapkan buku kerja

Sebelum Anda menerbitkan buku kerja, Anda bisa memutuskan untuk memilih hanya lembar kerja atau item yang Anda inginkan untuk terlihat dalam browser. Ingatlah walaupun Anda bisa membatasi apa yang ditampilkan dalam mode ini, namun seluruh konten buku kerja masih disimpan dalam server SharePoint.

Jika Anda ingin menyertakan seluruh lembar kerja sebagai item tambahan ke item lain, seperti bagan atau PivotTabel, tetapkan seluruh lembar kerja sebagai rentang bernama. Pilih seluruh lembar kerja, lalu tetapkan rentang bernama. Rentang bernama ini akan muncul sebagai item yang tersedia di kotak dialog Opsi Penerbitan ketika Anda telah siap untuk menerbitkannya.

Guna memungkinkan pengguna memasukkan nilai dalam sel untuk bekerja dengan rumus dalam sel lain, atur sel tersebut sebagai nama yang ditentukan dalam Excel sebelum Anda menerbitkan buku kerja. Anda kemudian bisa menambahkan nama yang ditentukan sebagai parameter pada tab Parameter dalam kotak dialog Opsi Tampilan Browser.

Misalnya, berikut ini memperlihatkan sel D2, yang memiliki nama yang ditentukan "Rate." Di browser, pengguna memasukkan nilai, 5,625, dalam kotak di panel parameter dan klik Terapkan. Nilai tersebut kemudian muncul di sel D2, dan Rumusnya menggunakan nilai dalam D2. Hasil rumus dihitung ulang, dan diperlihatkan di A2: $1.151,31.

Lihat bantuan Excel untuk informasi tentang cara menentukan rentang.

Memasukkan parameter dalam panel yang menggunakannya dalam sel D2

Catatan: Jika Anda membuat pemotong untuk tabel Excel dan menetapkan nama untuk rentang sel yang berisi tabel dan pemotong, Anda tidak akan bisa menggunakan pemotong untuk memfilter tabel dalam browser jika Anda menerbitkan rentang yang ditentukan. Jika Anda menerbitkan tabel atau seluruh lembar kerja atau buku kerjanya, pemotong akan bekerja seperti yang diharapkan dalam browser.

Menerbitkan buku kerja

  1. Klik File > Simpan sebagai >SharePoint.

  2. Jika Anda melihat folder SharePoint di bawahfolder saat ini atau folder terbaru, klik folder yang Anda inginkan. Jika tidak, klik Telusuri dan masukkan alamat web untuk situs SharePoint. Lalu, telusuri ke folder tempat Anda ingin menerbitkan buku kerja. Kotak dialog Simpan Sebagai muncul.

  3. Untuk memilih lembar kerja atau item individual untuk diterbitkan dari buku kerja, klik Opsi Tampilan Browser. Anda akan melihat tab Perlihatkan dan tab parameter . Jika Anda hanya ingin menerbitkan seluruh buku kerja, klik Simpan. Jika tidak, lakukan salah satu hal berikut ini:

    • Untuk memperlihatkan seluruh buku kerja dalam browser, pada tab Perlihatkan, pilih Seluruh Buku Kerja dalam kotak daftar.

    • Untuk memperlihatkan hanya lembar kerja tertentu dalam browser, pada tab Perlihatkan , pilih lembar dalam kotak Daftar, lalu Kosongkan kotak untuk lembar yang tidak ingin Anda Sembunyikan di browser.

      Secara default, semua lembar dipilih. Untuk segera membuat semua lembar terlihat kembali setelah Anda menghapus centang beberapa kotak, pilih kotak centang semua lembar .

    • Untuk memperlihatkan hanya item tertentu di browser (seperti rentang bernama, bagan, tabel, atau PivotTable), pada tab Perlihatkan , pilih item dalam buku kerja dalam kotak Daftar, lalu centang kotak untuk item yang ingin Anda Perlihatkan.

    • Pada tab parameter , tambahkan nama yang ditentukan yang ingin Anda gunakan untuk menentukan sel yang dapat diedit saat pengguna melihat buku kerja di browser. Lalu klik OK untuk menutup kotak dialog.

  4. Simpan buku kerja.

Catatan: 

  • Jika Anda memilih item yang memiliki nama yang sama (seperti tabel dan tabel yang mendasari data), hanya satu dari item ini yang akan tersedia dalam browser. Untuk memperlihatkan semua item, pastikan setiap item dalam buku kerja memiliki nama yang unik.

  • Jika Anda memilih item yang memiliki nama yang sama (seperti tabel dan tabel yang mendasari data), hanya satu dari item ini yang akan tersedia dalam browser. Untuk memperlihatkan semua item, pastikan setiap item dalam buku kerja memiliki nama yang unik.

  • Anda bisa mengganti nama tabel pada tab Desain dalam grup Properti, ganti nama PivotTables pada tab Opsi dalam grup PivotTable, dan ganti nama bagan atau PivotCharts pada tab Tata letak dalam grup Properti. Ganti nama item duplikat lainnya, seperti rentang bernama di tab Rumus dalam grup Nama yang Ditentukan.

  • Anda bisa mengganti nama tabel pada tab Desain dalam grup Properti, ganti nama PivotTables pada tab Opsi dalam grup PivotTable, dan ganti nama bagan atau PivotCharts pada tab Tata letak dalam grup Properti. Ganti nama item duplikat lainnya, seperti rentang bernama di tab Rumus dalam grup Nama yang Ditentukan.

Untuk informasi selengkapnya tentang komponen Web Excel Web Access, lihat artikel menampilkan buku kerja dalam komponen Web Excel Web Access.

Saat menerbitkan buku kerja ke server SharePoint, seluruh konten buku kerja disimpan ke server dan bisa ditampilkan dan dikerjakan dengan jika Anda membuka buku kerja di program desktop Excel. Jika Office Web Apps disebarkan di SharePoint Server, menampilkan dan bekerja dengan data Anda di browser web bisa sangat mirip dengan bekerja dengan data Anda di program desktop Excel. Bahkan, pengeditan simultan buku kerja dimungkinkan di kisi browser ketika Office Web Apps disebarkan. Saat Anda menampilkan buku kerja di browser, jika tombol Edit di browser terlihat, ini berarti bahwa Office Web Apps tersedia.

Tombol Edit di Browser

Untuk informasi selengkapnya, lihat artikel perbedaan antara menggunakan buku kerja di Excel dan Excel Services.

Mempersiapkan buku kerja

Sebelum Anda menerbitkan buku kerja, Anda memiliki kesempatan (dalam kotak dialog opsi penerbitan ) untuk memilih lembar kerja atau item yang ingin Anda terlihat di browser saat pengeditan tidak diaktifkan dengan mengklik tombol Edit di browser . Ingatlah bahwa meskipun Anda bisa memilih apa yang dapat dilihat dalam mode ini, seluruh konten buku kerja masih disimpan ke server SharePoint.

Jika Anda ingin menyertakan seluruh lembar kerja sebagai item tambahan ke item lain, seperti bagan atau PivotTabel, tetapkan seluruh lembar kerja sebagai rentang bernama. Pilih seluruh lembar kerja, lalu tetapkan rentang bernama. Rentang bernama ini akan muncul sebagai item yang tersedia di kotak dialog Opsi Penerbitan ketika Anda telah siap untuk menerbitkannya.

Jika Anda ingin memperbolehkan pengguna untuk menyediakan parameter pada rumus saat menampilkan lembar kerja dalam browser, atur sel sebagai nama yang ditentukan. Anda kemudian dapat menambahkan nama yang ditentukan sebagai parameter pada tab parameter dalam kotak dialog opsi terbitkan .

Misalnya, dalam grafik berikut yang memperlihatkan lembar kerja di browser, sel D2 memiliki tingkat nama yang ditentukan. Di browser, pengguna telah memasukkan nilai, 5,625, dalam kotak di panel parameter lalu mengklik Terapkan. Nilai tersebut kemudian muncul di sel D2, dan Rumusnya menggunakan nilai dalam D2. Hasil rumus dihitung ulang, dan diperlihatkan di A2: $1.151,31.

Menggunakan parameter di browser

Lihat bantuan Excel untuk informasi tentang cara menentukan rentang.

Menerbitkan buku kerja

  1. Klik tab File, lalu klik Simpan & Kirim.

  2. Klik Simpan ke SharePoint.
    Catatan    jika perintah Simpan ke SharePoint tidak tersedia, Anda masih bisa menyimpan buku kerja ke situs SharePoint dengan menggunakan perintah Simpan sebagai . Kotak dialog opsi terbitkan tidak akan tersedia. Anda juga bisa langsung mengunggah buku kerja dari pustaka SharePoint. Pengguna bisa menampilkan dan mengedit konten buku kerja di browser dengan masuk langsung ke situs tempat buku kerja tersebut disimpan.

    Perintah Simpan Sebagai

  3. Jika Anda ingin memilih lembar kerja atau item individual untuk diterbitkan dalam buku kerja, klik tombol opsi terbitkan . Jika tidak, jika Anda ingin menerbitkan seluruh buku kerja, lewati langsung ke langkah 4.
    Pada tab Perlihatkan , lakukan hal berikut:

    • Untuk memperlihatkan seluruh buku kerja di browser, pilih seluruh buku kerja dalam kotak daftar.

    • Untuk memperlihatkan hanya lembar kerja tertentu di browser, pilih lembar dalam kotak Daftar, lalu Kosongkan kotak centang untuk lembar yang tidak ingin Anda buat terlihat.
      Catatan    secara default, Semua lembar dipilih. Untuk segera membuat semua lembar terlihat kembali setelah Anda mengosongkan kotak centang, Anda bisa memilih kotak centang semua lembar .

    • Untuk memperlihatkan hanya item tertentu di browser (seperti rentang bernama, bagan, tabel, atau PivotTable), pilih item dalam buku kerja dalam kotak Daftar, lalu pilih kotak centang item yang ingin Anda Perlihatkan.
      Catatan jika Anda memilih item yang memiliki nama yang sama (seperti bagan dan tabel data yang mendasari), hanya satu item ini yang akan tersedia di browser. Untuk memperlihatkan semua item, Anda harus memastikan bahwa setiap item dalam buku kerja memiliki nama yang unik. Anda bisa mengganti nama tabel pada tab Desain dalam grup Properti, ganti nama PivotTables pada tab Opsi dalam grup PivotTable, dan ganti nama bagan atau PivotCharts pada tab Tata letak dalam grup Properti. Item duplikat, seperti rentang bernama, bisa diubah namanya pada tab rumus dalam grup nama yang ditentukan .
      Memilih lembar kerja atau item

    • Pada tab parameter , tambahkan nama yang ditentukan yang ingin Anda gunakan untuk menentukan sel yang dapat diedit saat pengguna melihat buku kerja di browser. Lalu klik OK untuk menutup kotak dialog.
      Parameter pengaturan

  4. Pilih lokasi untuk menerbitkan buku kerja Anda.
    Mungkin sudah ada lokasi server yang disimpan di bawah Lokasi terkini, lokasi terbaru, atau lokasi yang dapat Anda pilih. Jika tidak ada lokasi seperti itu, atau Anda ingin menyimpan ke lokasi baru, di bawah lokasi , klik ganda Telusuri lokasi.

  5. Dalam kotak dialog Simpan sebagai , masukkan alamat web untuk situs SharePoint, lalu Telusuri ke situs atau pustaka tempat Anda ingin menyimpan buku kerja.

  6. Jika Anda belum memilih lembar kerja atau item individual atau mengatur parameter, klik tombol opsi terbitkan .

  7. Dalam kotak nama file , terima nama yang disarankan untuk buku kerja, atau ketikkan nama baru jika Anda ingin.

  8. Untuk menampilkan konten buku kerja di jendela browser segera setelah operasi penerbitan selesai, pastikan kotak centang buka dengan Excel di browser dipilih.

  9. Klik Simpan.

Catatan:  Halaman ini diterjemahkan menggunakan mesin dan mungkin terdapat kesalahan tata bahasa atau masalah keakuratan. Kami bertujuan menyediakan konten yang bermanfaat untuk Anda. Dapatkah Anda memberi tahu kami apakah informasi ini bermanfaat untuk Anda? Berikut adalah artikel dalam bahasa Inggris untuk referensi.

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×