Menambahkan koneksi data ke layanan Web

Catatan:  Kami ingin secepatnya menyediakan konten bantuan terbaru dalam bahasa Anda. Halaman ini diterjemahkan menggunakan mesin dan mungkin terdapat kesalahan tata bahasa atau masalah keakuratan. Kami bertujuan menyediakan konten yang bermanfaat untuk Anda. Dapatkah Anda memberi tahu kami apakah informasi ini bermanfaat untuk Anda di bagian bawah halaman ini? Berikut artikel dalam bahasa Inggris untuk referensi.

Anda bisa menambahkan satu atau beberapa koneksi data sekunder untuk Templat formulir yang dapat kueri atau mengirimkan data ke layanan Web.

Dalam artikel ini

Gambaran Umum

Pertimbangan kompatibilitas

Sebelum Anda mulai

Menambahkan koneksi data kueri

Menambahkan koneksi data kirim

Gambaran Umum

Koneksi data sekunder adalah koneksi data apa pun ke sumber data eksternal yang Anda tambahkan ke Templat formulir. Koneksi data ini berbeda dari koneksi data utama yang dibuat saat Anda mendesain Templat formulir yang didasarkan pada database, Layanan Web, atau pengaturan di pustaka koneksi. Anda menambahkan koneksi data sekunder hanya jika Anda tidak bisa kueri atau mengirim data melalui koneksi data utama.

Saat Anda menambahkan koneksi data sekunder untuk Templat formulir yang kueri data, Microsoft Office InfoPath membuat sekunder sumber data dengan bidang data dan grup yang terkait dengan Skema XML layanan Web. Karena struktur data di sumber data sekunder harus cocok dengan skema XML, Anda tidak bisa mengubah bidang yang sudah ada atau grup di sumber data sekunder. Saat Anda menambahkan koneksi data kirim ke Templat formulir Anda, Anda mengonfigurasi Templat formulir untuk memperbolehkan pengguna untuk mengirimkan formulir data, dan Anda mengonfigurasi opsi Kirim untuk formulir yang didasarkan pada Templat formulir Anda.

Atas halaman

Pertimbangan kompatibilitas

Anda tidak bisa mengonfigurasi koneksi kirim data di templat formulir yang kompatibel dengan browser untuk memperbolehkan pengguna untuk kirim mengubah informasi bersama dengan formulir data ke layanan Web yang menerima Microsoft ADO.NET DataSet. Ubah informasi terdiri dari modifikasi yang pengguna membuat data yang disimpan dalam database. Database menggunakan layanan Web untuk menyambungkan pengguna ke database. ADO.NET bisa menggunakan Ubah informasi untuk menentukan cara untuk memperbarui data dalam database. Mintalah administrator layanan Web Anda jika Layanan Web memerlukan Ubah informasi untuk memperbarui database. Jika tidak, Anda harus mendesain Templat formulir formulir yang bisa diisi hanya dengan menggunakan InfoPath.

Atas halaman

Sebelum Anda mulai

Sebelum Anda menambahkan koneksi data sekunder ke Templat formulir Anda, Anda memerlukan informasi berikut ini dari administrator layanan Web:

  • Lokasi layanan Web.

  • Verifikasi bahwa layanan Web menggunakan dokumen literal gaya pengodean. InfoPath bisa menggunakan hanya dokumen literal gaya layanan Web.

  • Nama operasi layanan Web yang akan mengirim data ke atau menerima data dari formulir yang didasarkan pada Templat formulir ini.

Atas halaman

Menambahkan koneksi data kueri

Untuk memperbolehkan pengguna untuk kueri data dari layanan Web dengan menggunakan templat formulir Anda, Anda perlu melakukan hal berikut ini di Templat formulir:

  1. Menambahkan koneksi data sekunder.

  2. Mengonfigurasi Templat formulir untuk menggunakan koneksi data sekunder.

Langkah 1: Menambahkan koneksi data sekunder

  1. Pada menu alat , klik Koneksi Data.

  2. Dalam kotak dialog Koneksi Data , klik Tambahkan.

  3. Di panduan koneksi Data, klik membuat koneksi baru ke, klik terima data, dan lalu klik berikutnya.

  4. Di bawah dari tempat Anda ingin menerima data Anda, klik layanan Web dan lalu klik berikutnya.

  5. Pada halaman berikutnya panduan, ketikkan lokasi layanan Web, dan lalu klik berikutnya.

    Catatan: Jika Anda ingin mencari layanan Web dengan menggunakan server Universal Deskripsi penemuan, dan integrasi (UDDI), klik UDDI pencarian, masukkan URL server UDDI yang ingin Anda Cari, tentukan Apakah Anda ingin mencari dengan penyedia atau layanan yang disediakan, masukkan kata kunci pencarian, dan lalu klik pencarian. Layanan web yang cocok dengan kata kunci pencarian Anda akan muncul dalam daftar hasil pencarian . Pilih Layanan Web yang ingin Anda gunakan, dan lalu klik OK.

  6. Di daftar pilih operasi di halaman berikutnya panduan, klik operasi layanan Web yang mengembalikan data ke formulir, dan lalu klik berikutnya.

  7. Jika panduan koneksi Data menemukan elemen tidak diketahui dalam skema layanan Web, halaman berikutnya panduan mungkin meminta Anda untuk menentukan nilai sampel untuk setiap parameter untuk menentukan apa bidang atau grup untuk menambahkan ke sumber data utama.

    Caranya?

    1. Pilih parameter dalam tabel parameter , dan lalu klik Tetapkan nilai sampel.

    2. Dalam kotak contoh nilai , ketikkan nilai pengguna Anda mungkin menggunakan untuk bidang ini, dan lalu klik OK.

    3. Ulangi langkah-langkah ini untuk setiap parameter dalam tabel parameter , dan lalu klik berikutnya.

    Detail teknis

    Saat Anda mengonfigurasi koneksi data ke layanan Web di panduan koneksi Data, Microsoft Office InfoPath tersambung ke layanan Web dan permintaan file bahasa Deskripsi Layanan Web (WSDL). WSDL file berisi skema yang digunakan oleh layanan Web. Layanan Web menanggapi permintaan dengan mengirimkan file ini ke InfoPath. InfoPath menggunakan informasi dalam file ini untuk menambahkan bidang yang sesuai dan grup ke sumber data sekunder di Templat formulir. Jika InfoPath menemukan tipe elemen yang tidak diketahui dalam WSDL file, InfoPath menggunakan contoh data untuk menentukan definisi tipe elemen yang tidak diketahui dan lalu menambahkan bidang yang sesuai dan grup ke sumber data sekunder.

  8. Jika Anda menginginkan hasil kueri akan tersedia saat formulir tidak tersambung ke jaringan, pilih kotak centang Simpan salinan data di Templat formulir .

    Catatan Keamanan: Memilih kotak centang ini menyimpan hasil kueri di Templat formulir. Karena data yang disimpan di Templat formulir, tersedia di formulir yang pengguna isi, bahkan jika komputer mereka tidak tersambung ke jaringan. Jika Anda mendapatkan data sensitif dari koneksi data ini, Anda mungkin ingin menonaktifkan fitur ini untuk membantu melindungi data seandainya komputer yang hilang atau dicuri.

  9. Klik Berikutnya.

  10. Pada halaman berikutnya panduan, ketikkan nama deskriptif untuk sambungan data kueri tersebut.

  11. Untuk mengaktifkan formulir yang didasarkan pada Templat formulir ini untuk menerima data secara otomatis saat dibuka, pilih kotak centang secara otomatis mengambil data saat formulir dibuka .

  12. Verifikasi bahwa informasi di bagian ringkasan sudah benar dan lalu klik selesai.

  13. Klik Tutup.

Langkah 2: Mengonfigurasi Templat formulir untuk menggunakan koneksi data sekunder

Saat Anda menambahkan koneksi data kueri ke Templat formulir, secara default formulir yang didasarkan pada Templat formulir ini menggunakan koneksi data saat dibuka oleh pengguna. Anda juga bisa mengonfigurasi Templat formulir Anda untuk menggunakan koneksi data kueri dalam salah satu cara berikut ini:

  • Tambahkan aturan    Anda dapat mengonfigurasi aturan untuk menggunakan koneksi data kueri saat terjadi kondisi di aturan.

  • Tombol Tambahkan    Anda bisa menambahkan tombol ke Templat formulir yang bisa diklik pengguna untuk mendapatkan data dengan menggunakan koneksi data kueri.

  • Gunakan kode kustom    Jika Anda tidak bisa menambahkan aturan atau tombol, Anda bisa menggunakan kode kustom untuk mendapatkan data dengan menggunakan koneksi data kueri. Menggunakan kode kustom memerlukan pengembang untuk membuat kode kustom.

Menambahkan aturan

Anda bisa menambahkan aturan untuk Templat formulir untuk mendapatkan data dari koneksi data kueri setiap kali kondisi untuk aturan terpenuhi. Prosedur berikut ini mengasumsikan bahwa Anda telah membuat koneksi data kueri untuk Templat formulir Anda, dan bahwa Anda telah mengonfigurasi kontrol pada Templat formulir Anda untuk menampilkan data dari koneksi data tersebut.

  1. Jika Templat formulir memiliki beberapa tampilan, klik nama tampilan pada menu tampilan untuk masuk ke tampilan dengan kontrol tempat Anda ingin menampilkan data dari sumber data sekunder.

  2. Klik ganda kontrol yang ingin Anda tambahkan aturan untuk.

  3. Klik tab Data.

  4. Di bawah aturan validasi dan, klik aturan.

  5. Dalam kotak dialog aturan , klik Tambahkan.

  6. Dalam kotak nama , ketikkan nama untuk aturan.

  7. Untuk menentukan kondisi saat aturan harus berjalan, klik Atur kondisi, dan lalu masukkan kondisi. Aturan yang akan berjalan saat terjadi kondisi. Jika Anda tidak menentukan kondisi, aturan akan berjalan setiap kali pengguna mengubah nilai dalam kontrol, dan lalu menggerakkan kursor miliknya menjauh dari kontrol tersebut.

  8. Klik Tambahkan tindakan.

  9. Di daftar tindakan , klik kueri menggunakan koneksi data.

  10. Di daftar koneksi Data , klik koneksi data kueri yang ingin Anda gunakan, dan lalu klik OK untuk menutup setiap kotak dialog buka.

  11. Untuk menguji perubahan, klik Pratinjau pada toolbar Standar, atau tekan CTRL+SHIFT+B.

Menambahkan tombol

Anda bisa menambahkan kontrol tombol ke Templat formulir yang bisa diklik pengguna Anda untuk mendapatkan data dari kueri koneksi data. Prosedur berikut ini mengasumsikan bahwa Anda telah membuat koneksi data kueri untuk Templat formulir Anda.

  1. Jika Templat formulir memiliki beberapa tampilan, klik nama tampilan pada menu tampilan untuk masuk ke tampilan dengan kontrol tempat Anda ingin menampilkan data dari sumber data sekunder.

  2. Jika panel tugas Kontrol tidak terlihat, klik Kontrol Lainnya pada menu Sisipkan, atau tekan ALT+I, C.

  3. Seret kontrol tombol ke Templat formulir Anda.

  4. Klik ganda tombol yang baru saja Anda tambahkan ke Templat formulir Anda.

  5. Klik tab umum .

  6. Di daftar tindakan , klik Refresh.

  7. Dalam kotak Label , ketikkan nama yang Anda inginkan muncul pada tombol di Templat formulir Anda.

  8. Klik Pengaturan.

  9. Dalam kotak dialog Refresh , klik salah satu sumber data sekunder.

  10. Di daftar pilih sumber data sekunder , klik sumber data sekunder yang terkait dengan koneksi data kueri, dan lalu klik OK untuk menutup setiap kotak dialog buka.

  11. Untuk menguji perubahan, klik Pratinjau pada toolbar Standar, atau tekan CTRL+SHIFT+B.

Atas halaman

Menambahkan koneksi data kirim

Untuk memperbolehkan pengguna untuk mengirimkan formulir yang didasarkan pada Templat formulir Anda ke layanan Web, pertama-tama Anda menambahkan koneksi data sekunder ke Templat formulir Anda mengajukan data, dan kemudian Anda mengonfigurasi Templat formulir untuk memperbolehkan pengguna Anda untuk mengirim data formulir mereka.

Langkah 1: Menambahkan koneksi data sekunder

  1. Pada menu alat , klik Koneksi Data.

  2. Dalam kotak dialog Koneksi Data , klik Tambahkan.

  3. Di panduan koneksi Data, klik membuat koneksi baru ke, klik kirim data, dan lalu klik berikutnya.

  4. Di bawah bagaimana Anda ingin mengirim data Anda, klik layanan untuk Web dan lalu klik berikutnya.

  5. Pada halaman berikutnya panduan, ketikkan lokasi layanan Web di mana pengguna Anda akan mengirim data mereka, dan lalu klik berikutnya.

    Catatan: Jika Anda ingin mencari layanan Web dengan menggunakan server Universal Deskripsi penemuan, dan integrasi (UDDI), klik UDDI pencarian, masukkan URL server UDDI yang ingin Anda Cari, tentukan Apakah Anda ingin mencari dengan penyedia atau layanan yang disediakan, masukkan kata kunci pencarian, dan lalu klik pencarian. Layanan web yang cocok dengan kata kunci pencarian Anda akan muncul dalam daftar hasil pencarian . Pilih Layanan Web yang ingin Anda gunakan, dan lalu klik OK.

  6. Di daftar pilih operasi , klik operasi layanan Web yang akan menerima formulir data, lalu klik berikutnya.

  7. Pada halaman berikutnya panduan tersebut, untuk memilih data dalam formulir untuk mengirimkan bagi setiap parameter dalam layanan Web, lakukan salah satu hal berikut ini:

    Mengirimkan data dalam bidang atau grup

    1. Di daftar parameter , klik parameter layanan Web yang akan menerima data dari formulir.

    2. Di bawah opsi Parameter, klik bidang atau grup.

    3. Klik Ubah Tombol Sumber Data .

    4. Dalam kotak dialog pilih bidang atau grup , klik bidang atau grup data yang ingin Anda kirim, dan lalu klik OK.

    5. Dalam kotak sertakan , klik teks dan turunan elemen hanya untuk mengirim data di bidang ini dan elemen turunan dari bidang atau grup, atau klik XML anak pohon, termasuk elemen dipilih untuk mengirimkan nama bidang, data dalam bidang, dan elemen turunan dalam grup yang dipilih atau bidang.

    Mengirim semua data dalam formulir

    1. Di daftar parameter , klik parameter layanan Web yang akan menerima data dari formulir.

    2. Di bawah opsi Parameter, klik seluruh formulir (dokumen XML, termasuk instruksi pemrosesan).

    Mengirimkan data sebagai string

    1. Di daftar parameter , klik parameter layanan Web yang akan menerima data dari formulir.

    2. Di bawah opsi Parameter, klik seluruh formulir (dokumen XML, termasuk instruksi pemrosesan).

    3. Pilih kotak centang kirim data sebagai string .

      Catatan: Biasanya, Anda memilih kotak centang ini untuk mengirim data ditandatangani secara digital. Dalam banyak kasus, kosongkan kotak centang ini.

    Catatan teknis tentang ADO.NET DataSet objek

    Jika layanan Web memerlukan ADO.NET DataSet objek, pilih node kumpulan data saat Anda mengonfigurasi koneksi data. Jika Anda menggunakan jenis node untuk koneksi data ke layanan Web yang memerlukan objek ADO.NET DataSet, tindakan kirim akan gagal.

  8. Klik Berikutnya.

  9. Pada halaman berikutnya panduan, ketikkan nama untuk koneksi data kirim.

  10. Verifikasi bahwa informasi di bagian ringkasan sudah benar dan lalu klik selesai.

  11. Klik Tutup.

Setelah Anda menambahkan sekunder mengirimkan koneksi data, Anda harus mengonfigurasi Templat formulir Anda untuk memungkinkan pengguna untuk mengirim data formulir dengan menggunakan ini mengirimkan koneksi data.

Langkah 2: Aktifkan mengirimkan pada Templat formulir

Saat Anda mengonfigurasi Templat formulir untuk memperbolehkan pengguna untuk mengirimkan formulir data, InfoPath menambahkan tombol kirim ke bar alat standar dan kirim perintah pada menu File pada formulir. Anda juga bisa mengkustomisasi opsi Kirim untuk Templat formulir Anda dalam cara-cara berikut ini:

  • Mengubah teks yang muncul pada tombol kirim dan perintah kirim .

  • Mengubah pintasan keyboard untuk tombol kirim dan perintah kirim .

  • Membuat pesan kustom untuk menampilkan untuk pengguna Anda saat mereka mengirim formulir mereka.

  • Menentukan apakah ingin biarkan formulir terbuka, tutup formulir, atau buka formulir kosong lain setelah formulir dikirimkan.

  • Pada menu alat , klik Opsi mengirimkan.

  • Dalam kotak dialog Opsi mengirimkan , pilih kotak centang Perbolehkan pengguna untuk mengirim formulir ini , klik kirim data formulir ke tujuan tunggal, dan lalu di daftar, klik Layanan Web.

  • Di daftar pilih koneksi data untuk kirim , klik nama koneksi kirim data ke layanan Web yang Anda buat di langkah sebelumnya.

    1. Untuk mengubah nama tombol kirim yang muncul pada Bar alat standar dan perintah kirim yang muncul pada File menu saat pengguna mengisi formulir, ketikkan nama baru di kotak keterangan di kirim Opsi kotak dialog.

      Tips: Jika Anda ingin menetapkan pintasan keyboard untuk tombol dan perintah, ketik simbol ampersand (&) sebelum karakter yang ingin Anda gunakan sebagai pintasan keyboard. Sebagai contoh, untuk menetapkan ALT + B sebagai pintasan keyboard untuk tombol kirim dan perintah, ketik Su & bmit.

  • Jika Anda tidak ingin orang-orang untuk menggunakan perintah kirim atau tombol kirim pada toolbar standar saat mereka mengisi formulir Anda, kosongkan kotak centang Perlihatkan kirim item menu dan toolbar tombol Kirim .

    1. Secara default, setelah pengguna mengirimkan formulir, InfoPath membuat formulir terbuka dan menampilkan pesan untuk menunjukkan jika formulir berhasil dikirim. Untuk mengubah perilaku default, klik tingkat lanjut, dan lalu lakukan salah satu hal berikut ini:

      • Tutup formulir atau membuat formulir kosong baru setelah pengguna mengirimkan formulir selesai, klik opsi yang Anda inginkan di daftar setelah mengirim .

      • Untuk membuat pesan kustom untuk menunjukkan jika formulir berhasil dikirim, pilih kotak centang gunakan kustom pesan , dan lalu ketik pesan Anda dalam kotak di keberhasilan dan kegagalan .

        Tips: Gunakan pesan di kotak di kegagalan untuk memberi tahu pengguna apa yang harus dilakukan jika mereka tidak bisa mengirim formulir mereka. Misalnya, Anda dapat menyarankan bahwa pengguna menyimpan bentuk dan menghubungi seseorang untuk instruksi lebih lanjut.

      • Jika Anda tidak ingin menampilkan pesan setelah pengguna mengirimkan formulir, kosongkan kotak centang Perlihatkan pesan keberhasilan dan kegagalan .

Atas halaman

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×