Menambahkan bidang ke formulir atau laporan

Anda dapat menambahkan bidang ke formulir atau laporan dengan cepat menggunakan panel Daftar Bidang. Saat Anda mengklik ganda bidang dalam panel Daftar Bidang (atau menyeret bidang dari daftar ke formulir atau laporan), Microsoft Access akan otomatis membuat kontrol yang sesuai untuk menampilkan bidang tersebut, misalnya kotak teks atau kotak centang, lalu mengikatkannya ke bidang tersebut.

Jika belum memiliki formulir atau laporan yang akan ditambahkan bidang, lihat Pengenalan pada formulir atau Pengenalan pada laporan untuk membantu Anda memulai.

Apa yang ingin Anda lakukan?

Menambahkan bidang ke formulir atau laporan menggunakan panel Daftar Bidang

Menambahkan bidang ke formulir atau laporan tanpa menggunakan Daftar Bidang

Mempelajari selengkapnya tentang panel Daftar Bidang

Menambahkan bidang ke formulir atau laporan menggunakan panel Daftar Bidang

  1. Buka laporan dalam Tampilan Tata Letak atau Tampilan Desain.

    Jika panel Daftar Bidang tidak ditampilkan, lakukan salah satu hal berikut:

    • Pada tab Desain, dalam grup Alat, klik Tambahkan Bidang yang Ada. Jika menggunakan Access 2007, pada tab Format, dalam grup Kontrol, klik Tambahkan Bidang yang Ada.
      -ATAU-

    • Tekan ALT+F8.

  2. Di panel Daftar Bidang, temukan tabel berisi bidang yang ingin ditambahkan. Untuk memperlihatkan atau menyembunyikan daftar bidang dalam setiap tabel, klik tanda plus (+) atau tanda minus (-) di samping nama tabel.

    Catatan: Jika database tidak berisi tabel apa pun, panel Daftar Bidang akan kosong.

  3. Saat menemukan bidang yang ingin ditambahkan, lakukan salah satu hal berikut untuk menambahkannya ke formulir atau laporan:

    • Klik ganda bidang.

    • Seret bidang dari panel Daftar Bidang ke formulir atau laporan.

    • Tahan tombol CTRL dan klik beberapa bidang, lalu seret semuanya ke formulir atau laporan secara bersamaan.

      Catatan: Teknik ini hanya dapat digunakan pada bidang di bagian Bidang yang tersedia untuk tampilan ini dari panel Daftar Bidang.

    • Tambahkan rentang bidang dari panel Daftar Bidang ke formulir atau laporan dengan melakukan hal berikut:

    • Klik bidang pertama dalam rentang.

    • Tekan dan tahan tombol SHIFT, lalu klik bidang terakhir dalam rentang.

      Access memilih bidang yang Anda klik, serta semua bidang di antaranya.

    • Seret semua bidang yang dipilih ke formulir atau laporan.

      Catatan: Teknik ini hanya dapat digunakan pada bidang di bagian Bidang yang tersedia untuk tampilan ini dari panel Daftar Bidang.

  4. Access membuat kontrol yang sesuai untuk menampilkan setiap bidang, juga mengikat kontrol tersebut ke bidang. Selain itu, Access akan membuat label yang menempel bagi kontrol tersebut. Anda dapat mengedit label dengan mengkliknya satu kali untuk memilihnya, kemudian mengkliknya lagi untuk meletakkan titik penyisipan dalam label. Kemudian, Anda dapat mengedit label dengan cara yang sama seperti mengedit teks dalam dokumen.

  5. Jika ingin bidang ditampilkan dalam tipe kontrol yang berbeda dari yang dibuat otomatis oleh Access, Anda dapat mengubah kontrol ke tipe lain. Namun, Anda hanya dapat mengubahnya ke tipe kontrol yang sesuai untuk bidang tersebut. Misalnya, Anda dapat mengubah kotak kombo menjadi kotak teks atau kotak daftar, tetapi tidak dapat mengubah kotak kombo menjadi tombol perintah.

    Mengubah kontrol dari satu tipe ke yang lain

    1. Buka formulir atau laporan dalam Tampilan Desain dengan mengklik kanan file di Panel Navigasi lalu mengklik Tampilan Desain.

    2. Klik kanan kontrol yang ingin diubah, kemudian klik Ubah Ke.

      Jika item menu Ubah Ke tidak tersedia, artinya tidak ada tipe kontrol lain yang sesuai untuk bidang ini. Jika tersedia, Access akan menampilkan daftar tipe kontrol.

    3. Klik salah satu tipe kontrol yang tersedia untuk mengubah kontrol ke tipe tersebut.

      Kontrol akan tetap terikat ke bidang, tetapi Anda mungkin perlu mengatur beberapa properti agar kontrol yang baru dapat berfungsi sesuai keinginan. Untuk menampilkan lembar properti bagi suatu kontrol, klik kontrol untuk memilihnya, kemudian tekan F4.

Atas Halaman

Menambahkan bidang ke formulir atau laporan tanpa menggunakan Daftar Bidang

Secara umum, menggunakan panel Daftar Bidang adalah cara termudah untuk menambahkan bidang ke formulir atau laporan. Namun, Anda juga dapat menambahkan bidang dengan membuat kontrol dan mengikatkannya ke bidang. Prosedur berikut ini menunjukkan caranya.

  1. Di Panel Navigasi, klik kanan formulir atau laporan, lalu klik Tampilan Tata Letak atau Tampilan Desain.

    Panduan Kontrol    Anda dapat menggunakan Panduan Kontrol untuk membantu membuat tombol perintah, kotak daftar, subformulir, kotak kombo, dan grup opsi. Panduan Kontrol memberikan beberapa pertanyaan tentang bagaimana tampilan dan cara operasi kontrol yang Anda inginkan, kemudian membuat kontrol dan mengatur propertinya berdasarkan jawaban Anda. Pada tab Desain, dalam grup Kontrol, klik panah daftar menurun di samping Galeri Kontrol. Jika Gunakan Panduan Kontrol tidak disorot, klik untuk menyorotnya.

    Gambar tombol

    Jika memilih untuk membuat kontrol tanpa bantuan panduan, klik Gunakan Panduan Kontrol agar tidak dipilih.

    Gambar tombol

  2. Pada tab Desain, dalam grup Kontrol, klik alat untuk tipe kontrol yang ingin Anda tambahkan.

    Untuk menentukan nama alat, letakkan penunjuk pada alat. Access akan menampilkan nama alat.

  3. Klik dalam kisi desain laporan atau formulir tempat Anda ingin meletakkan sudut kiri atas kontrol. Klik sekali untuk membuat kontrol dengan ukuran default, atau klik alat lalu seret dalam kisi desain formulir untuk membuat kontrol sesuai ukuran yang diinginkan.

  4. Jika Anda telah memilih Gunakan Panduan Kontrol dan kontrol yang sedang diletakkan memiliki panduan yang terkait dengannya, panduan tersebut akan dimulai dan memandu Anda untuk mengatur kontrol.

  5. Jika Anda tidak meletakkan kontrol dengan tepat pada percobaan pertama, pindahkan dengan melakukan hal berikut:

    1. Klik kontrol untuk memilihnya. Jika terdapat label yang terkait dengan kontrol tersebut, tahan tombol CTRL dan klik label untuk memilihnya juga.

    2. Letakkan penunjuk pada kontrol hingga berubah menjadi penunjuk pemindah Gerakkan penunjuk .

    3. Klik dan seret kontrol ke lokasi yang diinginkan.

Jika menggunakan panduan kontrol, panduan mungkin berisi langkah-langkah yang akan membantu Anda mengikat kontrol ke bidang. Jika panduan tidak mengikatkan kontrol ke bidang, dan kontrol merupakan tipe yang dapat menampilkan data (kotak teks atau kotak kombo, misalnya), Anda harus memasukkan nama bidang atau ekspresi dalam properti Sumber Kontrol untuk kontrol sebelum data akan ditampilkan. Gunakan prosedur berikut ini untuk mengikat kontrol ke bidang.

  1. Tampilkan lembar properti untuk kontrol dengan mengklik kontrol lalu menekan F4.

  2. Pada tab Data dari lembar properti, klik panah daftar menurun di samping properti Sumber Kontrol dan pilih bidang yang ingin ditampilkan dalam kontrol. Anda juga dapat mengetikkan ekspresi dalam kotak Sumber Kontrol.

    Untuk informasi selengkapnya tentang ekspresi, lihat artikel Menyusun ekspresi.

Atas Halaman

Mempelajari selengkapnya tentang panel Daftar Bidang

Daftar berikut ini berisi tips tentang bekerja dengan panel Daftar Bidang yang mungkin berguna saat Anda menambahkan bidang ke formulir atau laporan. Untuk menampilkan panel Daftar Bidang, buka formulir atau laporan dalam Tampilan Tata Letak atau Tampilan Desain, kemudian tekan ALT+F8.

  • Jika properti Sumber Catatan formulir atau laporan kosong, dan Anda menyeret bidang dari panel Daftar Bidang ke formulir atau laporan, Access akan mengisi properti Sumber Catatan formulir atau laporan secara otomatis.

  • Jika properti Sumber Catatan formulir atau laporan adalah pernyataan SELECT atau nama tabel, Anda dapat mengalihkan tampilan panel Daftar Bidang ke salah satu dari dua keadaan berikut:

    • Semua bidang database    Menampilkan bagian Bidang yang tersedia untuk tampilan ini, bagian Bidang yang tersedia dalam tabel terkait (jika tabel tersebut ada), dan bagian Bidang yang tersedia dalam tabel lain (jika tabel tersebut ada).

    • Bidang sumber catatan saja    Hanya menampilkan bagian Bidang yang tersedia untuk tampilan ini.

      Untuk beralih antara dua mode, klik Perlihatkan bidang dalam sumber catatan saat ini saja atau Perlihatkan semua tabel di bagian bawah panel Daftar Bidang.

      Catatan: Jika Anda telah menetapkan properti Sumber Catatan formulir atau laporan ke kueri yang tersimpan, panel Daftar Bidang hanya akan menampilkan bagian Bidang yang tersedia untuk tampilan ini (tidak ada opsi Perlihatkan semua tabel di bagian bawah panel Daftar Bidang). Untuk mengedit sumber catatan, klik kanan salah satu bidang, kemudian klik Edit Sumber Catatan.

  • Jika Anda telah menetapkan properti Sumber Catatan formulir atau laporan ke tabel, lalu menyeret bidang dari bagian Bidang yang tersedia dalam tabel terkait dari panel Daftar Bidang ke formulir atau laporan, Access akan mengubah Sumber Catatan formulir atau laporan ke pernyataan SELECT yang menyertakan bidang yang ditambahkan. Jika tidak dapat menentukan cara mengaitkan tabel, Access akan menampilkan kotak dialog Pilih Hubungan sehingga Anda dapat memilih hubungan yang tepat.

  • Jika Anda menyeret bidang dari bagian Bidang yang tersedia dalam tabel lain dari panel Daftar Bidang ke formulir atau laporan, Access akan menampilkan kotak dialog Tentukan Hubungan. Gunakan kotak dialog ini untuk menentukan hubungan antara tabel lainnya dan sumber catatan formulir atau laporan. Jika tidak yakin bidang mana yang perlu dimasukkan dalam kotak dialog ini, silakan klik Batal, kemudian teliti hubungan tabel.

    Untuk informasi selengkapnya tentang hubungan, lihat Panduan hubungan tabel atau Membuat, mengedit, atau menghapus hubungan.

    Ada kemungkinan bahwa bidang di bagian Bidang yang tersedia dalam tabel lain dari panel Daftar Bidang terkait secara tidak langsung dengan sumber catatan dari formulir atau laporan melalui salah satu tabel di bagian Bidang yang tersedia dalam tabel terkait. Jika demikian, menyeret bidang dari salah satu tabel yang terkait ke formulir atau laporan dapat menyebabkan satu atau beberapa tabel berpindah dari bagian Bidang yang tersedia dalam tabel lain ke bagian Bidang yang tersedia dalam tabel terkait.

  • Jika sumber catatan formulir atau laporan adalah pernyataan SELECT atau kueri yang tersimpan, Anda dapat menampilkan dan mengedit sumber catatan dalam Penyusun Kueri dengan mengklik kanan bidang apa pun dalam panel Daftar Bidang lalu mengklik Edit data Sumber. Jika sumber catatan adalah tabel, perintah ini akan membuka Penyusun Kueri pada tabel. Access menanyakan apakah Anda ingin membuat kueri berdasarkan tabel; klik Ya untuk mengubah sumber catatan menjadi kueri, atau Tidak untuk membiarkan sumber catatan tidak berubah.

  • Anda dapat membuka tabel dalam Tampilan Lembar Data dengan mengklik Edit Tabel di samping nama tabel, atau dengan mengklik kanan nama tabel pada panel Daftar Bidang kemudian mengklik Buka Tabel dalam Tampilan Lembar Data.

  • Anda dapat menggunakan panel Daftar Bidang untuk menambahkan Bidang pencarian ke tabel dengan melakukan hal berikut:

    1. Klik Edit Tabel di samping tabel yang ingin Anda tambahkan bidang Pencarian.

      Tabel ditampilkan dalam Tampilan Lembar Data.

    2. Seret bidang dari panel Daftar Bidang ke lembar data.

    3. Panduan Pencarian dimulai. Ikuti instruksi dalam panduan. Pada halaman terakhir, klik Selesai.

  • Anda dapat melepaskan panel Daftar Bidang dari sisi kanan area kerja Access dengan meletakkan penunjuk di bilah judul panel Daftar Bidang hingga berubah menjadi penunjuk pemindah Gerakkan penunjuk lalu menyeret panel Daftar Bidang ke sebelah kiri. Anda dapat meletakkan daftar di mana saja dalam area kerja, atau menambatkannya di sebelah kiri area kerja dengan menyeretnya ke ujung sebelah kiri.

Atas Halaman

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×