Membuat, menjalankan, mengedit, atau menghapus makro di Office for Mac

Catatan: Kami ingin secepatnya menyediakan konten bantuan terbaru dalam bahasa Anda. Halaman ini diterjemahkan menggunakan mesin dan mungkin terdapat kesalahan tata bahasa atau masalah keakuratan. Kami bertujuan menyediakan konten yang bermanfaat untuk Anda. Dapatkah Anda memberi tahu kami apakah informasi ini bermanfaat untuk Anda di bagian bawah halaman ini? Berikut artikel dalam bahasa Inggris untuk referensi.

Untuk menghemat waktu pada tugas yang sering dilakukan, Anda dapat merekam langkah-langkah tugas tersebut sebagai makro. Lalu, saat Anda ingin melakukan salah satu tugas tersebut direkam, Anda dapat mengaktifkan makro untuk melakukan langkah-langkah untuk Anda.

Word

Di Word 2016 untuk Mac, Anda dapat membuat makro yang memiliki pintasan keyboard, menjalankan makro, dan menghapus makro yang tidak lagi Anda perlukan.

  1. Klik Tampilan > Makro > Rekam Makro.

    Pada tab Tampilkan, klik Makro, dan klik Rekam Makro untuk mulai membuat makro.
  2. Ketikkan nama untuk makro, atau terima default tersebut Word menyediakan.

    Masukkan nama untuk makro Anda dalam Nama makro, atau terima nama generik yang disediakan oleh Word.
  3. Untuk menggunakan makro ini di dokumen baru apa pun yang Anda buat, pastikan bahwa Semua dokumen (Normal) dipilih dalam daftar Simpan makro di .

  4. Klik Keyboard untuk menetapkan kombinasi tombol untuk makro Anda.

    Word menampilkan kotak dialog Kustomisasi Keyboard .

  5. Ketik kombinasi tombol dalam kotak Tekan pintasan keyboard baru .

    Word menampilkan perintah atau makro yang sudah ditetapkan pada kombinasi tombol, jika ada, setelah Anda menekan kombinasi.

    Saat Anda menekan kombinasi tombol, Word menampilkan perintah atau tindakan saat ini ditetapkan untuk kombinasi tombol tersebut, jika ada.

  6. Jika kombinasi tombol yang Anda pilih sudah ditetapkan, Hapus dari kotak Tekan pintasan keyboard baru , dan lalu pilih kombinasi tombol baru.

    Masuk di ke langkah berikutnya setelah Anda menemukan kombinasi tombol tidak ditetapkan.

    Word mengidentifikasi saat Anda telah menekan kombinasi tombol yang belum ditetapkan ke perintah atau makro.
  7. Untuk menggunakan pintasan keyboard ini di dokumen baru apa pun, akan yakin Normal.dotm, Templat global, dipilih dalam Simpan perubahan dalam daftar.

    Pilih Normal.dotm untuk membuat makro tersedia untuk digunakan dalam dokumen baru yang Anda buat.
  8. Klik Tetapkan.

  9. Bila Anda sudah siap untuk merekam makro, klik OK.

  10. Klik perintah atau tekan tombol untuk setiap langkah dalam tugas.

    Word catatan klik dan tekanan tombol, tetapi tidak merekam teks yang Anda pilih dengan mouse. Untuk memilih teks saat merekam makro, menggunakan keyboard.

  11. Untuk menghentikan perekaman, klik Tampilkan > Makro > Hentikan Perekaman.

    Klik Hentikan Rekaman pada Menu makro untuk menghentikan merekam makro.

Untuk menjalankan makro, Tekan pintasan keyboard yang ditetapkan ke dalamnya, atau menjalankan makro dari daftar makro .

  1. Klik Tampilan > Makro > Tampilkan Makro.

    Klik Tampilkan Makro untuk menampilkan dan mengedit makro yang terkait dengan dokumen saat ini.
  2. Dalam daftar di bawah nama makro, pilih makro yang ingin Anda jalankan.

  3. Klik Jalankan.

    Setelah memilih makro di bawah nama Makro, klik Jalankan untuk menjalankannya.

  1. Klik Tampilan > Makro > Tampilkan Makro.

    Klik Tampilkan Makro untuk menampilkan dan mengedit makro yang terkait dengan dokumen saat ini.
  2. Verifikasi bahwa lokasi yang ditentukan oleh makro dalam menyertakan Lokasi makro yang ingin Anda hapus.

    Pilih lokasi makro yang ingin Anda tampilkan dari Makro di dalam daftar.

    Daftar akan menyertakan dokumen yang terbuka di jendela saat ini, serta perintah Templat dan Word global.

  3. Di bawah nama makro, pilih makro yang ingin Anda hapus, dan lalu klik tanda minus di bawah daftar.

    Pilih makro yang ingin Anda hapus, dan klik tanda minus di bawah daftar.
  4. Saat Word meminta untuk mengonfirmasi bahwa Anda ingin menghapus makro, klik ya.

Excel

Di Excel 2016 untuk Mac, Anda dapat membuat makro yang memiliki pintasan keyboard, menjalankan makro, dan menghapus makro yang tidak lagi Anda perlukan.

Ketika Anda merekam makro, perekam makro merekam semua langkah yang diperlukan untuk menyelesaikan tindakan yang Anda inginkan untuk dijalankan makro Anda. Langkah ini bisa mencakup mengetik teks atau angka, mengklik sel atau perintah pada peta atau menu, memformat, memilih sel, baris, atau kolom, dan menyeret mouse Anda untuk memilih sel pada lembar bentang Anda.

Catatan: Perintah untuk merekam, membuat, dan menghapus makro, serta fitur tingkat lanjut lainnya, juga tersedia pada tab pengembang pada pita. Untuk informasi selengkapnya tentang menggunakan tab pengembang, lihat menggunakan tab pengembang untuk membuat atau menghapus makro di Excel 2016 untuk Mac.

  1. Pilih alat > makro > catatan baru.

    Pilih alat, lalu makro, lalu merekam makro baru

  2. Dalam kotak Nama makro, masukkan nama untuk makro.

    Memasukkan kunci nama, lokasi, dan pintasan makro

  3. Untuk membuat pintasan keyboard untuk makro, ketikkan huruf dalam kotak Option + Cmd .

  4. Pilih lokasi untuk makro dari daftar turun bawah.

    Untuk menyimpan makro

    Klik

    Dalam dokumen yang Anda membuat makro di

    Buku Kerja Ini

    Di semua dokumen yang terbuka

    Buku Kerja Baru

    Tersedia setiap kali Anda menggunakan Excel

    Buku Kerja Makro Pribadi

  5. (Opsional) Menambahkan deskripsi makro Anda.

  6. Bila Anda sudah siap untuk merekam, klik OK.

  7. Klik perintah atau tekan tombol untuk setiap langkah dalam tugas.

  8. Untuk menghentikan perekaman, pilih alat > makro > Hentikan perekaman. (Langkah ini akan tidak direkam dalam makro Anda.)

    Pilih Hentikan perekaman

Untuk menjalankan makro, Tekan pintasan keyboard yang ditetapkan ke dalamnya, atau menjalankan makro dari dialog makro .

  1. Pada tab Tampilan, klik Tampilkan Makro.

  2. Klik makro di menu pop up dan pilih Buku kerja ini.

  3. Pilih makro Anda dari daftar dan klik Jalankan.

    Dialog Makro Excel untuk Mac

  1. Pilih alat > makro > makro.

    Pilih makro, lalu pilih makro

  2. Pilih makro untuk menghapus, dan tekan tanda minus.

    Pilih nama makro, lalu pilih tanda minus

  3. Pesan konfirmasi akan muncul. Klik Ya untuk mengonfirmasi penghapusan.

    Konfirmasi penghapusan

Anda juga bisa menghapus makro dari tab pengembang .

  1. Pada tab Pengembang, klik Makro.

  2. Di daftar, klik makro yang ingin Anda hapus, dan klik tombol hapus.

    Pilih makro dan klik tanda minus untuk menghapusnya

Word

Untuk mengotomatisasi tugas berulang, Anda bisa dengan cepat membuat makro di Word. Anda juga bisa menggunakan Visual Basic Editor dalam Microsoft Visual Basic for Applications untuk menulis skrip makro Anda sendiri, atau untuk menyalin semua atau sebagian makro ke makro yang baru.

Ketika Anda merekam makro, semua langkah-langkah yang diperlukan untuk menyelesaikan tindakan yang Anda inginkan makro Anda untuk melakukan direkam. Namun, navigasi kembali ke tab untuk menghentikan perekaman tidak disertakan dalam langkah-langkah yang direkam.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Rekam.

    Tab Pengembang Word, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam kotak Nama makro, masukkan nama untuk makro.

  3. Pada menu pop-up Simpan makro di, lakukan salah satu hal berikut ini:

    Untuk menyimpan makro

    Klik

    Dalam dokumen tempat Anda membuat makro

    [nama dokumen] (dokumen)

    Di semua dokumen yang terbuka

    Semua Dokumen (Normal)

  4. Klik OK, lalu lakukan tindakan yang Anda inginkan untuk merekam.

  5. Pada tab pengembang, di bawah Visual Basic, klik Hentikan.

Anda bisa menggunakan Visual Basic Editor bawaan untuk membuat makro.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Editor.

    Tab Pengembang Word, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Jika diperlukan untuk menyisipkan modul, dalam Visual Basic Editor, pada menu Sisipkan, klik Modul.

  3. Di jendela kode modul, ketik atau tempelkan kode makro yang ingin Anda gunakan.

  4. Bila sudah selesai, pada menu Word, klik Tutup dan Kembali ke Microsoft Word.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Word, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda jalankan, lalu klik Jalankan.

Untuk mengedit makro, Anda menggunakan Visual Basic Editor.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Word, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda edit, lalu klik Edit.

    Visual Basic Editor akan terbuka.

  3. Buat perubahan yang Anda inginkan.

  4. Bila sudah selesai, pada menu Word, klik Tutup dan Kembali ke Microsoft Word.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Word, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda salin, lalu klik Edit.

    Visual Basic Editor akan terbuka.

  3. Di jendela kode dari Visual Basic Editor, pilih garis makro yang ingin Anda salin.

    Tips: Untuk menyalin keseluruhan makro, sertakan baris Sub dan End Sub dalam pilihan.

  4. Pada menu Edit, klik Salin.

  5. Dalam kotak Projek dari jendela kode, klik modul tempat Anda ingin meletakkan kode.

  6. Pada menu Edit, klik Tempel.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Word, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Di daftar, klik makro yang ingin Anda hapus, lalu klik Hapus.

PowerPoint

Untuk mengotomatisasi tugas berulang, Anda bisa menggunakan Visual Basic for Applications untuk membuat makro di PowerPoint.

Anda bisa menggunakan Visual Basic Editor bawaan untuk membuat makro.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Editor.

    Tab Pengembang PowerPoint, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Jika diperlukan untuk menyisipkan modul, dalam Visual Basic Editor, pada menu Sisipkan, klik Modul.

  3. Di jendela kode modul, ketik atau tempelkan kode makro yang ingin Anda gunakan.

  4. Bila sudah selesai, pada menu PowerPoint, klik Tutup dan Kembali ke Microsoft PowerPoint.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang PowerPoint, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda jalankan, lalu klik Jalankan.

Untuk mengedit makro, Anda menggunakan Visual Basic Editor.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang PowerPoint, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda edit, lalu klik Edit.

    Visual Basic Editor akan terbuka.

  3. Buat perubahan yang Anda inginkan.

  4. Bila sudah selesai, pada menu PowerPoint, klik Tutup dan Kembali ke Microsoft PowerPoint.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang PowerPoint, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda salin, lalu klik Edit.

    Visual Basic Editor akan terbuka.

  3. Di jendela kode dari Visual Basic Editor, pilih garis makro yang ingin Anda salin.

    Tips: Untuk menyalin keseluruhan makro, sertakan baris Sub dan End Sub dalam pilihan.

  4. Pada menu Edit, klik Salin.

  5. Dalam kotak Projek dari jendela kode, klik modul tempat Anda ingin meletakkan kode.

  6. Pada menu Edit, klik Tempel.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang PowerPoint, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Di daftar, klik makro yang ingin Anda hapus, lalu klik Hapus.

Excel

Untuk mengotomatisasi tugas berulang, Anda bisa dengan cepat membuat makro di Excel. Anda juga bisa menggunakan Visual Basic Editor dalam Microsoft Visual Basic for Applications untuk menulis skrip makro Anda sendiri, atau untuk menyalin semua atau sebagian makro ke makro yang baru.

Semua langkah-langkah yang diperlukan untuk menyelesaikan tindakan yang Anda inginkan untuk dijalankan makro akan direkam. Namun, navigasi kembali ke tab untuk menghentikan perekaman tidak disertakan dalam langkah-langkah yang direkam.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Rekam.

    Tab Pengembang Excel, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam kotak Nama makro, masukkan nama untuk makro.

    Tips: Untuk membuat pintasan papan ketik untuk makro, ketikkan huruf dalam kotak Option+Cmd+.

  3. Pada menu pop-up Simpan makro di, lakukan salah satu hal berikut ini:

    Untuk menyimpan makro

    Klik

    Dalam dokumen tempat Anda membuat makro

    Buku Kerja Ini

    Di semua dokumen yang terbuka

    Buku Kerja Baru

    Tersedia setiap kali Anda menggunakan Excel

    Buku Kerja Makro Pribadi

    Buku kerja makro pribadi berada di pengguna / username/Library/aplikasi mendukung / Microsoft/Office/Excel.

  4. Klik OK, lalu lakukan tindakan yang Anda inginkan untuk merekam.

  5. Pada tab Pengembang, di bawah Visual Basic, klik lagi Rekaman.

Anda bisa menggunakan Visual Basic Editor bawaan untuk membuat makro.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Editor.

    Tab Pengembang Excel, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Jika diperlukan untuk menyisipkan modul, dalam Visual Basic Editor, pada menu Sisipkan, klik Modul.

  3. Di jendela kode modul, ketik atau tempelkan kode makro yang ingin Anda gunakan.

  4. Bila sudah selesai, pada menu Excel klik Tutup dan Kembali ke Microsoft Excel.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Excel, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda jalankan, lalu klik Jalankan.

    Tips: Untuk menjalankan makro dengan menggunakan pintasan papan ketik, tekan OPTION + PERINTAH +huruf yang Anda ketik saat membuat pintasan papan ketik.

Untuk mengedit makro, Anda menggunakan Visual Basic Editor.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Excel, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda edit, lalu klik Edit.

    Visual Basic Editor akan terbuka.

  3. Buat perubahan yang Anda inginkan.

  4. Bila sudah selesai, pada menu Excel klik Tutup dan Kembali ke Microsoft Excel.

Setelah menyelesaikan prosedur ini, makro akan berjalan setiap kali Anda membuka buku kerja yang berisi makro.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Rekam.

    Tab Pengembang Excel, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam kotak Nama makro, ketik Auto_Open.

  3. Pada menu pop-up Simpan makro di, lakukan salah satu hal berikut ini:

    Untuk menyimpan makro

    Klik

    Dalam dokumen tempat Anda membuat makro

    Buku Kerja Ini

    Di semua dokumen yang terbuka

    Buku Kerja Baru

    Tersedia setiap kali Anda menggunakan Excel

    Buku Kerja Makro Pribadi

  4. Klik OK, lalu lakukan tindakan yang Anda inginkan untuk merekam.

  5. Pada tab Pengembang, di bawah Visual Basic, klik lagi Rekaman.

  6. Pada menu File, klik Simpan Sebagai.

  7. Pada menu pop-up Format, klik Buku Kerja Excel Makro AKtif (.xlsm), lalu klik Simpan.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Excel, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Dalam daftar, klik makro yang ingin Anda salin, lalu klik Edit.

    Visual Basic Editor akan terbuka.

  3. Di jendela kode dari Visual Basic Editor, pilih garis makro yang ingin Anda salin.

    Tips: Untuk menyalin keseluruhan makro, sertakan baris Sub dan End Sub dalam pilihan.

  4. Pada menu Edit, klik Salin.

  5. Dalam kotak Projek dari jendela kode, klik modul tempat Anda ingin meletakkan kode.

  6. Pada menu Edit, klik Tempel.

  1. Pada tab Pengembang, di bawah Visual Basic, klik Makro.

    Tab Pengembang Excel, grup Visual Basic

    Jika tab Pengembang tidak tersedia

    1. Di sisi kanan pita, klik Menu pop-up Tindakan , lalu klik Preferensi Pita.

    2. Di bawah Kustomisasi, pilih kotak centang Pengembang.

  2. Di daftar, klik makro yang ingin Anda hapus, lalu klik Hapus.

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×