Membuat dan menggunakan sublaporan

Jika bekerja dengan data relasional (data yang terkait disimpan dalam tabel terpisah), sering kali Anda harus menampilkan informasi dari lebih dari satu tabel atau kueri pada laporan yang sama. Misalnya, Anda ingin melihat data pelanggan tetapi juga sekaligus ingin mengetahui informasi tentang pesanan pelanggan. Sublaporan adalah alat yang berguna di Access untuk melakukan hal tersebut, karena alat ini memungkinkan Anda untuk menampilkan informasi pesanan serta informasi pelanggan pada laporan, secara jelas dan logis. Access menyediakan banyak cara untuk membantu Anda membuat sublaporan dengan cepat.

Apa yang ingin Anda lakukan?

Memahami sublaporan

Membuat sublaporan

Membuat perubahan desain pada sublaporan

Memahami sublaporan

Sublaporan adalah laporan yang disisipkan dalam laporan lain. Ketika menggabungkan laporan, salah satunya harus bertindak sebagai laporan utama yang memuat laporan lainnya. Laporan utama dapat terikat maupun tak terikat. Laporan terikat adalah laporan yang dapat menampilkan data dan berisi tabel, kueri, atau pernyataan SQL yang ditentukan dalam properti Sumber Data. Laporan tak terikat adalah laporan yang tidak didasarkan pada tabel, kueri, atau pernyataan SQL (properti Sumber Data dari laporan kosong).

Contoh laporan utama tak terikat dengan dua sublaporan tidak terkait    

Laporan utama tak terikat tidak dapat menampilkan datanya sendiri, tetapi tetap dapat berfungsi sebagai laporan utama untuk sublaporan tidak terkait yang ingin Anda gabungkan.

Laporan utama tak terikat dengan dua sublaporan yang menampilkan data yang tidak terkait

1. Laporan utama tak terikat berisi dua sublaporan.

2. Satu sublaporan merangkum penjualan berdasarkan karyawan.

3. Sublaporan yang lain merangkum penjualan berdasarkan kategori.

Contoh laporan utama dan sublaporan yang terikat ke sumber data yang sama    

Anda dapat menggunakan laporan utama untuk memperlihatkan data detail, seperti setiap penjualan dalam setahun, lalu menggunakan sublaporan untuk memperlihatkan informasi ringkasan, seperti total penjualan setiap kuartal.

Laporan utama dan sublaporan terikat ke sumber data yang sama

1. Sublaporan akan merangkum penjualan dalam setahun berdasarkan kuartal.

2. Laporan utama akan mencantumkan penjualan sehari-hari.

Contoh laporan utama dan sublaporan yang terikat ke sumber data terkait    

Laporan utama dapat berisi data yang ada dalam satu atau beberapa sublaporan. Dalam hal ini, sublaporan berisi data yang terkait dengan data dalam laporan utama.

Laporan utama dengan dua sublaporan menampilkan data yang terkait

1. Laporan utama akan mencantumkan nama dan kota setiap festival makanan.

2. Sublaporan mencantumkan perwakilan yang akan menghadiri setiap festival makanan.

Subformulir pada laporan

Laporan utama dapat menyertakan subformulir dan sublaporan dengan jumlah sesuai keinginan Anda. Selain itu, laporan utama dapat memuat hingga tujuh tingkat subformulir dan sublaporan. Misalnya, laporan dapat berisi sebuah sublaporan, dan sublaporan tersebut dapat memuat sebuah subformulir atau sublaporan, dan seterusnya hingga tujuh tingkat.

Jika menambahkan subformulir ke laporan kemudian membuka laporan dalam tampilan Laporan, Anda dapat menggunakan subformulir untuk memfilter dan menelusuri data. Kode Visual Basic for Applications (VBA) dan makro tersemat yang dilampirkan ke formulir dan kontrolnya akan tetap berjalan meskipun beberapa kejadian dinonaktifkan dalam konteks ini. Anda tidak dapat menambahkan, mengedit, atau menghapus data menggunakan subformulir pada laporan.

Menautkan laporan ke subformulir atau sublaporan

Ketika menyisipkan subformulir atau sublaporan berisi informasi yang terkait dengan data dalam laporan utama, kontrol sublaporan harus ditautkan ke laporan utama. Tautan akan memastikan bahwa data yang ditampilkan dalam subformulir atau sublaporan benar-benar sesuai dengan data yang ditampilkan dalam laporan utama.

Jika membuat subformulir atau sublaporan menggunakan panduan atau dengan menyeret objek dari Panel Navigasi ke laporan, Access secara otomatis akan menautkan subformulir atau sublaporan ke laporan utama jika salah satu kondisi berikut terpenuhi.

  • Anda menetapkan hubungan untuk tabel yang dipilih atau Anda menetapkan hubungan untuk tabel yang mendasari kueri yang dipilih.

  • Laporan utama didasarkan pada tabel dengan kunci utama, dan subformulir atau sublaporan didasarkan pada tabel yang berisi bidang dengan nama yang sama dengan kunci primer serta memiliki tipe data yang sama atau kompatibel. Misalnya, jika kunci primer dari tabel yang mendasari laporan utama adalah bidang AutoNumber dan properti UkuranBidang diatur ke Bilangan Bulat Panjang, bidang yang terkait dalam tabel yang mendasari subformulir atau sublaporan harus berupa bidang Angka dengan properti UkuranBidang diatur ke Bilangan Bulat Panjang. Jika memilih satu atau beberapa kueri sebagai sumber data dari subformulir atau sublaporan, tabel yang mendasari dalam kueri tersebut harus memenuhi kondisi yang sama.

Atas Halaman

Membuat sublaporan

Jika sublaporan akan ditautkan ke laporan utama, pastikan sumber data yang mendasarinya terkait sebelum menggunakan prosedur berikut.

Menggunakan Panduan Sublaporan untuk membuat sublaporan

Prosedur ini menganggap bahwa Anda sudah memiliki laporan yang ingin ditambahkan sublaporan. Untuk informasi selengkapnya tentang membuat laporan, lihat artikel Membuat laporan sederhana atau Membuat laporan yang dikelompokkan atau ringkasan.

  1. Di Panel Navigasi, klik kanan laporan yang ingin ditambahkan sublaporan, lalu klik Tampilan Desain.

  2. Pada tab Desain, dalam grup Kontrol, buka Galeri Kontrol dengan mengklik panah menurun di sudut kanan bawah:

    Gambar pita

  3. Dalam menu yang muncul, pastikan Gunakan Panduan Kontrol telah dipilih.

  4. Buka kembali Galeri Kontrol, lalu klik Subformulir/Sublaporan.

  5. Di laporan, klik lokasi tempat Anda ingin meletakkan sublaporan tersebut.

  6. Jika kotak dialog pemberitahuan keamanan muncul, klik Buka untuk memulai panduan.

  7. Di halaman pertama Panduan Sublaporan, jika ingin membuat subformulir atau sublaporan baru dan mendasarkannya pada tabel atau kueri, klik Gunakan Tabel dan Kueri yang sudah ada. Jika ingin menggunakan laporan atau formulir yang sudah ada sebagai sublaporan, klik Gunakan laporan atau formulir yang sudah ada, pilih laporan atau formulir dalam daftar, lalu klik Berikutnya.

    Memilih sumber data di Panduan Sublaporan

    Catatan:  Jika tidak ada laporan atau formulir lain dalam database, daftar tersebut akan kosong dan opsi Gunakan laporan atau formulir yang sudah ada tidak akan tersedia.

  8. Jika memilih Gunakan laporan atau formulir yang sudah ada di halaman sebelumnya dari panduan, lewati langkah ini, lalu langsung lanjutkan ke langkah 9. Jika tidak, dari daftar Tabel/Kueri, pilih tabel atau kueri yang berisi bidang yang ingin disertakan pada sublaporan, lalu klik dua kali bidang yang diinginkan dalam daftar Bidang yang Tersedia untuk menambahkannya ke sublaporan.

    Memilih bidang dalam Panduan Sublaporan

    Jika ingin menautkan sublaporan ke laporan utama, pastikan untuk menyertakan satu atau beberapa bidang yang akan digunakan untuk membuat tautan meskipun tidak ingin ditampilkan. Bidang yang ditautkan biasanya bidang ID. Dalam ilustrasi sebelumnya, tabel Pesanan adalah sumber data untuk sublaporan dan tabel Pelanggan adalah sumber data untuk laporan utama. Karena tabel Pesanan terkait dengan tabel Pelanggan oleh bidang ID Pelanggan, bidang tersebut ditambahkan ke daftar Bidang Dipilih.

    Catatan: Anda dapat menyertakan bidang dari beberapa tabel dan kueri dalam sublaporan. Setelah selesai menambahkan bidang dari satu tabel, pilih tabel atau kueri berikutnya dari daftar Tabel/Kueri, lalu tambahkan bidang yang Anda inginkan.

    Klik Berikutnya untuk melanjutkan.

  9. Di halaman panduan ini, tentukan cara menautkan sublaporan ke laporan utama. Jika Access menemukan bidang yang sesuai untuk menautkan sublaporan ke laporan utama, panduan akan menampilkan daftar saran penautan yang memungkinkan.

    Access menyarankan bidang yang akan ditautkan dalam Panduan Sublaporan

    Pilih saran penautan yang paling tepat sesuai kebutuhan Anda, atau jika tidak ingin menautkan sublaporan ke laporan utama, pilih Tidak ada. Jika ingin menautkan sublaporan ke laporan utama tetapi tidak ada saran yang sesuai, klik Tentukan sendiri.

    Catatan: Jika tidak dapat menemukan bidang yang sesuai untuk penautan, panduan tidak akan menyediakan daftar saran penautan dan opsi Tentukan sendiri akan terpilih secara otomatis.

    Menetapkan tautan Anda sendiri dalam Panduan Sublaporan

    Ketika opsi Tentukan sendiri dipilih, panduan akan menampilkan dua kumpulan daftar.

    • Di bawah Bidang formulir/laporan, pilih satu atau beberapa bidang dari laporan utama yang ingin digunakan untuk menautkan laporan utama ke subformulir atau sublaporan. Anda dapat memilih hingga tiga bidang, dan setiap bidang yang dipilih harus sesuai dengan bidang yang terkait dalam sumber data subformulir atau sublaporan.

    • Di bawah Bidang subformulir/sublaporan, pilih satu atau beberapa bidang yang terkait dari subformulir atau sublaporan yang ditautkan ke bidang laporan utama pilihan Anda.

    • Agar subformulir atau sublaporan tidak ditautkan ke laporan utama, pastikan semua daftar kosong.

      Klik Berikutnya untuk melanjutkan.

  10. Di halaman terakhir panduan, ketikkan nama subformulir atau sublaporan, atau cukup klik Selesai untuk menerima nama default.

    Memasukkan nama di Panduan Sublaporan

Access akan menambahkan kontrol sublaporan ke laporan Anda dan mengikat kontrol tersebut (atau menetapkan properti Objek Sumber dari kontrol tersebut) sebagai berikut:

  • Jika Gunakan laporan atau formulir yang sudah ada dipilih di halaman pertama panduan, Access akan mengikat kontrol sublaporan ke laporan atau formulir yang Anda tentukan.

  • Jika Gunakan Tabel dan Kueri yang sudah ada dipilih di halaman pertama panduan, Access akan membuat objek laporan baru di Panel Navigasi, lalu mengikat kontrol sublaporan ke objek tersebut. Nama objek laporan baru sama seperti nama yang Anda ketikkan di halaman terakhir panduan.

Menambahkan tabel, kueri, formulir, atau laporan ke laporan sebagai sublaporan

Cara cepat untuk menambahkan sublaporan ke laporan adalah dengan membuka laporan utama dalam Tampilan Tata Letak atau Tampilan Desain, lalu menyeret objek ke laporan utama dari Panel Navigasi. Jika ingin sublaporan ditautkan ke laporan utama, pastikan sumber data yang mendasarinya terkait dan sumber data telah menyertakan bidang yang akan digunakan untuk menautkan subformulir atau sublaporan ke laporan utama.

  1. Di Panel Navigasi, klik kanan laporan yang ingin digunakan sebagai laporan utama, lalu klik Tampilan Tata Letak atau Tampilan Desain pada menu pintasan.

  2. Seret tabel, kueri, formulir, atau laporan lain dari Panel Navigasi ke bagian dalam laporan utama tempat Anda ingin menampilkan sublaporan.

Access akan melakukan salah satu hal berikut:

  • Jika dapat menentukan cara menautkan kedua objek tersebut, Access akan menambahkan kontrol sublaporan ke laporan. Jika Anda menambahkan formulir atau laporan, Access akan mengikat kontrol sublaporan ke objek tersebut. Jika Anda menambahkan tabel atau kueri, Access akan membuat objek laporan terlebih dahulu, lalu mengikat kontrol sublaporan ke objek baru tersebut.

  • Jika Access tidak dapat menentukan cara menautkan kedua objek tersebut, Panduan Sublaporan akan muncul. Untuk melanjutkan, ikuti prosedur di bagian Gunakan Panduan Sublaporan untuk membuat sublaporan, dimulai dari langkah 9.

    Setelah Anda menyelesaikan panduan, Access akan menambahkan sublaporan ke laporan.

Gunakan prosedur berikut untuk memastikan bahwa subformulir atau sublaporan telah ditautkan ke laporan utama dengan benar.

  1. Klik kontrol sublaporan untuk memilihnya.

  2. Jika lembar properti belum ditampilkan, tekan F4 untuk menampilkannya.

  3. Pada tab Data dari lembar properti, periksa properti Bidang Master Tautan dan Bidang Turunan Tautan.

    • Untuk subformulir atau sublaporan yang tidak tertaut, kedua properti tersebut akan kosong.

    • Untuk subformulir atau sublaporan yang tertaut, properti Bidang Master Tautan dan Bidang Turunan Tautan akan menampilkan satu atau beberapa bidang yang mengaitkan kedua objek. Misalnya, jika laporan utama menampilkan informasi dari tabel Karyawan dan subformulir atau sublaporan menampilkan informasi dari tabel Pesanan, properti Bidang Master Tautan akan menampilkan bidang ID dari tabel Karyawan dan properti Bidang Turunan Tautan akan menampilkan bidang ID Karyawan dari tabel Pesanan.

Properti ini mungkin perlu diedit agar subformulir atau sublaporan dapat berfungsi dengan benar. Gunakan prosedur berikut ini.

  1. Pada tab Data dari lembar properti, klik kotak properti Bidang Master Tautan, lalu klik tombol Susun Gambar tombol .

    Kotak dialog Penaut Bidang Sublaporan akan muncul.

    Kotak dialog Penaut Bidang Sublaporan

  2. Dalam daftar Bidang Master dan Bidang Turunan, pilih bidang yang ingin ditautkan dengan laporan. Jika tidak yakin bidang yang akan digunakan, klik Sarankan agar Access mencoba menentukan bidang yang ditautkan. Jika sudah selesai, klik OK.

    Jika tidak melihat bidang yang ingin digunakan untuk menautkan laporan, Anda perlu mengedit sumber data dari laporan utama atau dari subformulir maupun sublaporan untuk memastikan bahwa sumber data telah berisi bidang yang ditautkan. Misalnya, jika laporan didasarkan pada kueri, Anda harus memastikan bahwa bidang yang ditautkan ada dalam hasil kueri.

  3. Simpan laporan utama dan beralihlah ke tampilan Laporan, lalu verifikasi bahwa laporan berfungsi seperti yang diharapkan.

Menambahkan tabel atau kueri ke laporan sebagai lembar data

Lembar data adalah representasi visual sederhana dari data, hampir sama dengan lembar bentang. Setiap kolom dalam lembar data mewakili bidang dalam tabel atau kueri sumber dan setiap baris mewakili data. Anda dapat menggunakan kontrol Subformulir/Sublaporan untuk menampilkan lembar data pada laporan. Teknik ini cocok digunakan dalam situasi ketika Anda ingin menampilkan data secara ringkas tetapi tidak membutuhkan kemampuan pemformatan objek formulir atau laporan. Untuk menambahkan lembar data ke laporan:

  1. Di Panel Navigasi, klik kanan laporan yang ingin digunakan sebagai laporan utama, lalu klik Tampilan Tata Letak pada menu pintasan.

  2. Pada tab Desain, dalam grup Kontrol, buka galeri Kontrol dengan mengklik panah menurun di sudut kanan bawah:

    Gambar pita

  3. Dalam menu yang muncul, pastikan Gunakan Panduan Kontroltidak dipilih.

  4. Buka kembali Galeri Kontrol, lalu klik Subformulir/Sublaporan.

  5. Di laporan, klik lokasi tempat Anda ingin meletakkan sublaporan tersebut.

  6. Ketika Panduan Sublaporan dimulai, klik Batal untuk menutupnya.

  7. Jika lembar properti belum ditampilkan, tekan F4 untuk menampilkannya.

  8. Pada laporan, klik kontrol sublaporan baru untuk memilihnya.

  9. Pada tab Data dari lembar properti, klik panah dalam kotak properti Objek Sumber, lalu klik tabel atau kueri yang ingin ditampilkan dalam kontrol sublaporan. Misalnya, untuk menampilkan tabel Pesanan, klik Table.Pesanan.

    Access akan mencoba menautkan lembar data ke laporan utama, berdasarkan pada hubungan yang telah ditetapkan dalam database.

  10. Pada tab Data dari lembar properti, periksa properti Bidang Master Tautan dan Bidang Turunan Tautan.

    • Untuk lembar data yang tidak tertaut, pastikan kedua properti ini kosong.

    • Untuk lembar data yang tertaut, pastikan bahwa properti Bidang Master Tautan dan Bidang Turunan Tautan menampilkan satu atau beberapa bidang yang mengaitkan laporan utama ke lembar data. Misalnya, jika laporan utama menampilkan informasi dari tabel Karyawan dan lembar data menampilkan informasi dari tabel Pesanan, properti Bidang Master Tautan akan menampilkan bidang ID dari tabel Karyawan dan properti Bidang Turunan Tautan akan menampilkan bidang ID Karyawan dari tabel Pesanan.

Dalam beberapa kasus, Anda mungkin perlu mengatur sendiri properti bidang tautan. Anda dapat melakukannya dengan mengikuti prosedur berikut ini.

  1. Pada tab Data dari lembar properti, klik kotak properti Bidang Master Tautan, lalu klik tombol Susun Gambar tombol .

  2. Jika kotak dialog pemberitahuan keamanan muncul, klik Buka.

    Kotak dialog Penaut Bidang Sublaporan akan muncul.

    Kotak dialog Penaut Bidang Sublaporan

  3. Dalam daftar Bidang Master dan Bidang Turunan, pilih bidang yang ingin digunakan untuk menautkan laporan utama ke lembar data. Jika tidak yakin bidang yang akan digunakan, klik Sarankan agar Access mencoba menentukan bidang yang ditautkan. Jika sudah selesai, klik OK.

    Jika tidak melihat bidang yang ingin digunakan untuk penautan, Anda perlu mengedit sumber data laporan master atau lembar data untuk memastikan bahwa sumber data telah berisi bidang yang ditautkan. Misalnya, jika lembar data didasarkan pada kueri, Anda harus memastikan bahwa bidang yang ditautkan ada dalam hasil kueri.

  4. Simpan laporan utama dan beralihlah ke tampilan Laporan, lalu verifikasi bahwa laporan berfungsi seperti yang diharapkan.

Atas Halaman

Membuat perubahan desain pada sublaporan

Setelah menambahkan sublaporan ke laporan, Anda mungkin ingin membuat perubahan desain pada sublaporan atau ingin merujuk ke data sublaporan di laporan utama. Bagian berikut menyediakan tips tentang cara menyelesaikan tugas tersebut.

Membuka subformulir atau sublaporan di jendela baru dalam tampilan Desain

Untuk membuat perubahan desain pada subformulir saat sedang bekerja pada laporan utama dalam tampilan Desain, Anda dapat membuka subformulir atau sublaporan di jendelanya sendiri.

  1. Klik subformulir atau sublaporan untuk memilihnya.

  2. Pada tab Desain, dalam grup Alat, klik Sublaporan di Jendela Baru.

Catatan: Perintah ini tidak tersedia jika kontrol subformulir/sublaporan terikat ke tabel atau kueri.

Menampilkan total dari sublaporan pada laporan utama

Anggap saja Anda menggunakan sublaporan bernama Sublaporan pesanan yang berisi kotak teks bernama Total Biaya Pengiriman, dan kotak teks tersebut akan menghitung jumlah dari kolom Biaya Pengiriman. Untuk menampilkan jumlah dari sublaporan pada laporan utama, Anda harus menambahkan kotak teks ke laporan utama, lalu menggunakan ekspresi untuk merujuk ke kotak teks Total Biaya Pengiriman dalam sublaporan. Anda dapat melakukannya dengan mengikuti prosedur berikut ini.

  1. Klik kanan laporan utama dalam Panel Navigasi, lalu klik Tampilan Desain pada menu pintasan.

  2. Pada tab Desain, dalam grup Kontrol, klik Kotak Teks.

  3. Pada laporan utama, klik area tempat Anda ingin meletakkan kotak teks baru.

  4. Jika lembar properti belum ditampilkan, tekan F4 untuk menampilkannya.

  5. Pada tab Data dari lembar properti, dalam kotak properti Sumber Kontrol, ketikkan ekspresi berikut.

    =IIf(IsError([Sublaporan pesanan].[Laporan]![Total Biaya Pengiriman]),0,[Sublaporan pesanan].[[Laporan]![Total Biaya Pengiriman])

    Catatan: 

    • Dalam contoh ini, Anda dapat menggunakan ekspresi yang lebih sederhana, yaitu =[Sublaporan pesanan].[[Laporan]![Total Biaya Pengiriman]. Namun, jika sublaporan tidak berisi data apa pun, kontrol pada laporan utama akan menampilkan #Error. Menggunakan fungsi IsError di dalam fungsi IIf, seperti yang ditampilkan pada ekspresi pertama, akan memastikan bahwa kotak teks pada laporan utama menampilkan angka nol (0) jika sublaporan tidak mengembalikan data apa pun.

    • Anda dapat menggunakan Penyusun Ekspresi untuk membuat ekspresi dengan mengklik tombol Susun Gambar tombol dalam kotak properti Sumber Kontrol.

  6. Pada tab Format dari lembar properti, atur properti Format ke nilai yang sesuai (dalam hal ini, Mata Uang).

  7. Simpan laporan, lalu beralihlah ke tampilan Laporan untuk memverifikasi bahwa penghitungan sesuai dengan yang diharapkan.

Atas Halaman

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×