Pengenalan ke laporan di Access

Pengenalan ke laporan di Access

Penting: Artikel ini adalah terjemahan mesin, lihat penafian. Temukan versi bahasa Inggris artikel di sini sebagai rujukan Anda.

Laporan menawarkan cara menampilkan, memformat, dan merangkum informasi di database Microsoft Access Anda. Misalnya, Anda bisa membuat laporan sederhana dari nomor telepon semua kontak Anda, atau laporan rangkuman tentang penjualan total di seluruh wilayah dan periode waktu yang berbeda.

Dari artikel ini, Anda akan mendapatkan gambaran umum laporan di Access. Anda juga akan mempelajari dasar-dasar membuat laporan, dan menggunakan opsi seperti pengurutan, pengelompokan, dan peringkasan data, dan cara mempratinjau dan mencetak laporan.

Catatan: Informasi dalam artikel ini dimaksudkan untuk digunakan hanya dengan database desktop Access. Aplikasi web Access tidak mendukung laporan.

Di artikel ini

Gambaran umum laporan di Access

Membuat laporan di Access

Menambahkan pengelompokan, pengurutan, atau total

Menyoroti data dengan pemformatan bersyarat

Mengkustomisasi warna dan font

Menambahkan logo atau gambar latar belakang

Mempratinjau dan mencetak laporan

Gambaran umum laporan di Access

Apa yang bisa Anda lakukan dengan laporan?

Laporan adalah objek database yang praktis saat Anda ingin menyajikan informasi dalam database Anda untuk salah satu penggunaan berikut ini:

  • Menampilkan atau mendistribusikan rangkuman data.

  • Mengarsipkan snapshot data.

  • Menyediakan detail tentang rekaman individual.

  • Membuat label.

Bagian-bagian laporan

Meskipun dimungkinkan membuat laporan "tak terikat" yang tidak menampilkan data, demi tujuan artikel ini, kami akan menganggap bahwa sebuah laporan terikat dengan sumber data seperti tabel atau kueri. Desain laporan dibagi menjadi bagian-bagian yang bisa Anda tampilkan dalam tampilan Desain. Memahami cara tiap bagian berfungsi bisa membantu Anda membuat laporan yang lebih baik. Misalnya, bagian di mana Anda memilih meletakkan kontrol terhitung menentukan cara Access menghitung hasilnya. Daftar berikut ini adalah rangkuman tipe bagian dan penggunaannya:

Bagian

Bagaimana bagian ditampilkan saat dicetak

Di mana bagian bisa digunakan

Header Laporan

Di permulaan laporan.

Gunakan header laporan untuk informasi yang mungkin biasanya muncul di halaman sampul, seperti logo, judul, atau tanggal. Saat Anda menempatkan kontrol terhitung yang menggunakan fungsi agregat Sum di header laporan, jumlah yang dihitung adalah untuk seluruh laporan. Header laporan dicetak sebelum header halaman.

Header Halaman

Di bagian atas setiap halaman.

Gunakan header halaman untuk mengulangi judul laporan di setiap halaman.

Header Grup

Di permulaan tiap grup rekaman baru.

Gunakan header grup untuk mencetak nama grup. Misalnya, dalam laporan yang dikelompokkan menurut produk, gunakan header grup untuk mencetak nama produk. Saat Anda menempatkan kontrol terhitung yang menggunakan fungsi agregat Sum di header grup, jumlah adalah untuk grup sekarang. Anda bisa memiliki beberapa bagian header grup di laporan, bergantung pada berapa banyak tingkat pengelompokan yang sudah Anda tambahkan. Untuk informasi selengkapnya tentang membuat header dan footer grup, baca bagian Menambahkan pengelompokan, pengurutan, atau total.

Detail

Muncul sekali untuk setiap baris di sumber rekaman.

Ini tempat Anda menempatkan kontrol yang menyusun badan utama laporan.

Footer Grup

Di akhir tiap grup rekaman.

Gunakan footer grup untuk mencetak informasi ringkasan untuk grup. Anda bisa memiliki beberapa bagian footer grup di laporan, bergantung pada berapa banyak tingkat pengelompokan yang sudah Anda tambahkan.

Footer Halaman

Di bagian akhir setiap halaman.

Gunakan footer halaman untuk mencetak nomor halaman atau informasi per halaman.

Footer Laporan

Di akhir laporan.

Catatan: Dalam tampilan Desain, footer laporan muncul di bawah footer halaman. Tetapi, di semua tampilan lainnya (tampilan Tata Letak, misalnya, atau saat laporan dicetak atau dipratinjau), footer laporan terlihat di atas footer halaman, tepat setelah footer grup terakhir atau baris detail di halaman terakhir.

Gunakan footer laporan untuk mencetak total laporan atau informasi rangkuman lainnya untuk seluruh laporan.

Anda akan mendapati bahwa jauh lebih mudah membuat laporan bermakna saat database Anda memiliki struktur dan hubungan tabel yang didesain dengan baik. Untuk pengenalan tentang perencanaan dan perancangan database, lihat Dasar-dasar desain database.

Atas Halaman

Membuat laporan di Access

Anda bisa membuat laporan untuk database desktop Access Anda dengan mengikuti langkah-langkah di bawah ini:

Langkah 1: Pilih sumber rekaman

Sumber rekaman sebuah laporan bisa berupa tabel, kueri bernama, atau kueri yang disematkan. Sumber rekaman harus berisi semua baris dan kolom data yang ingin Anda tampilkan di laporan.

  • Jika data berasal dari tabel atau kueri yang sudah ada, pilih tabel atau kueri tersebut di Panel Navigasi, lalu lanjutkan ke Langkah 2.

  • Jika sumber rekaman belum ada, lakukan salah satu hal berikut ini:

    • Lanjutkan ke Langkah 2 dan gunakan alat Laporan Kosong,

      Atau

    • Buat tabel atau kueri yang berisi data yang diperlukan. Pilih kueri atau tabel dalam Panel Navigasi, lalu lanjutkan ke Langkah 2.

Langkah 2: Pilih alat laporan

Alat laporan berada di tab Buat dari pita, di grup Laporan. Tabel berikut ini menjelaskan opsinya:

Alat

Deskripsi

Laporan

Membuat laporan tabular sederhana berisi semua bidang dalam sumber rekaman yang Anda pilih di Panel Navigasi.

Desain Laporan

Membuat laporan kosong di tampilan Desain, yang bisa Anda tambahkan bidang dan kontrol yang diperlukan.

Laporan Kosong

Membuka laporan kosong dalam tampilan Tata Letak, dan menampilkan Daftar Bidang tempat bisa Anda menambahkan bidang ke laporan

Panduan Laporan

Menampilkan panduan beberapa langkah yang memungkinkan Anda menentukan opsi bidang, tingkat pengelompokan/pengurutan, dan tata letak.

Label

Menampilkan panduan yang memungkinkan Anda memilih ukuran label standar atau kustom, serta bidang yang ingin Anda tampilkan, dan cara pengurutan yang Anda inginkan.

Langkah 3: Buat laporan

  1. Klik tombol untuk alat yang ingin Anda gunakan. Jika panduan muncul, ikuti langkah dalam panduan tersebut dan klik Selesai di halaman terakhir.
    Access menampilkan laporan tersebut di tampilan Tata Letak.

  2. Format laporan untuk mendapatkan tampilan yang Anda inginkan:

    • Ubah ukuran bidang dan label dengan memilihnya lalu menyeret tepinya hingga menjadi ukuran yang Anda inginkan.

    • Pindahkan bidang dengan memilihnya (dan labelnya, jika ada), lalu menyeretnya ke lokasi baru.

    • Klik kanan sebuah bidang dan gunakan perintah di menu pintasan untuk menggabungkan atau memisahkan sel, menghapus atau memilih bidang, dan menjalankan tugas pemformatan lainnya.

      Selain itu, Anda bisa menggunakan fitur yang dijelaskan di bagian berikut untuk membuat laporan Anda lebih menarik dan lebih mudah dibaca.

Atas Halaman

Menambahkan pengelompokan, pengurutan, atau total

Cara tercepat untuk menambahkan pengelompokan, pengurutan, atau total ke laporan database desktop adalah mengklik kanan bidang yang ingin Anda terapkan pengelompokan, pengurutan, atau total, lalu klik perintah yang diinginkan di menu pintasan.

Anda juga bisa menambahkan pengelompokan, pengurutan, atau total dengan menggunakan panel Kelompokkan, Urutkan, dan Total saat laporan dibuka di tampilan Tata Letak atau tampilan Desain:

  1. Jika panel Pengelompokan, Pengurutan, dan Total tidak ditampilkan, pada tab Desain, di grup Pengelompokan & Total, klik Kelompokkan & Urutkan.

  2. Klik Tambahkan grup atau Tambahkan urutan, lalu pilih bidang di mana Anda ingin kelompokkan atau urutkan.

  3. Klik Lainnya di baris pengelompokan atau pengurutan untuk mengatur opsi lainnya dan menambahkan total.

Untuk informasi lebih detail tentang pengelompokan, pengurutan, dan total, lihat artikel Membuat laporan yang dikelompokkan atau ringkasan.

Atas Halaman

Menyoroti data dengan pemformatan bersyarat

Akses menyertakan alat untuk menyoroti data di laporan. Anda bisa menambahkan aturan pemformatan bersyarat untuk setiap kontrol atau grup kontrol, dan dalam laporan klien, Anda bisa juga menambahkan bilah data untuk membandingkan data.

Untuk menambahkan pemformatan bersyarat untuk kontrol:

  1. Klik kanan laporan dalam Panel Navigasi lalu klik Tampilan Tata Letak.

  2. Pilih kontrol yang diperlukan dan tab Format , dalam grup Pemformatan kontrol , klik Pemformatan bersyarat.

    Tips: Untuk memilih beberapa kontrol, tahan tombol CTRL dan klik kontrol.

  3. Dalam kotak dialog Pengelola Aturan Pemformatan Bersyarat, klik Aturan Baru.

  4. Dalam kotak dialog Aturan Pemformatan Baru, pilih nilai di bawah Pilih tipe aturan:

    • Untuk membuat aturan yang dievaluasi untuk tiap rekaman secara individual, pilih Periksa nilai dalam rekaman saat ini atau gunakan ekspresi.

    • Untuk membuat aturan yang membandingkan rekaman satu dengan lainnya dengan menggunakan bilah data, klik Bandingkan dengan rekaman lain.

  1. Di bawah Edit deskripsi aturan, tentukan aturan untuk saat pemformatan akan diterapkan serta pemformatan apa yang harus diterapkan, lalu klik OK.

  2. Untuk membuat aturan tambahan untuk kontrol atau sekumpulan kontrol yang sama, ulangi prosedur ini dari langkah 4.

Atas Halaman

Mengkustomisasi warna dan font

Coba opsi Tema Aplikasi untuk mengkustomisasi warna dan font.

  1. Buka laporan dalam tampilan tata letak dengan mengklik kanan di panel navigasi, lalu klik tata letak View.

  2. Dari opsi Alat Tata Letak Laporan, pada tab Desain, klik Tema dan arahkan kursor ke berbagai tema di galeri untuk mempratinjau efeknya. Klik pada tema untuk memilihnya, lalu simpan laporan Anda.

  3. Gunakan galeri Warna atau Font untuk mengatur warna atau font secara mandiri.


Atas halaman

Menambahkan logo atau gambar latar belakang

Anda bisa menambahkan logo atau gambar latar belakang ke laporan dan jika Anda memperbarui gambar, pembaruan tersebut otomatis dibuat di mana gambar tersebut digunakan di database.

Untuk menambahkan atau menghapus gambar:

  1. Dalam Panel Navigasi, klik kanan laporan dan klik Tampilan Tata Letak.

  2. Dalam laporan, klik posisi di mana Anda ingin menambahkan gambar dan pada tab Desain, di grup Header/Footer, klik Logo.

  3. Navigasi ke gambar tersebut, dan klik Buka. Access menambahkan gambar tersebut ke laporan.

  4. Untuk menghapus gambar, klik kanan gambar tersebut dan klik Hapus dari menu pintasan.

Untuk menambahkan gambar latar belakang:

  1. Dalam Panel Navigasi, klik kanan laporan dan klik Tampilan Tata Letak.

  2. Pada tab Format, di grup Latar Belakang, klik Gambar Latar Belakang.

  3. Pilih gambar dari daftar Galeri Gambar atau klik Telusuri, pilih gambar, lalu klik OK.

Atas Halaman

Mempratinjau dan mencetak laporan

Mempratinjau laporan

  1. Klik kanan laporan dalam Panel Navigasi lalu klik Pratinjau Cetak. Anda bisa menggunakan perintah di tab Pratinjau Cetak untuk melakukan salah satu hal berikut ini:

    • Mencetak laporan

    • Menyesuaikan ukuran atau tata letak halaman

    • Memperbesar atau memperkecil, atau menampilkan beberapa halaman dalam satu waktu

    • Me-refresh data di laporan

    • Mengekspor laporan ke format file lainnya.

  2. Klik Tutup Pratinjau Cetak.

Mencetak laporan

Untuk mencetak laporan tanpa mempratinjaunya:

  • Klik kanan laporan dalam Panel Navigasi dan klik Cetak. Laporan dikirim ke printer default Anda.

    Catatan:  Jika Anda memilih laporan dalam Panel Navigasi dan memilih Cetak dari tab File, Anda bisa memilih opsi pencetakan tambahan seperti jumlah halaman dan salinan dan menentukan printer.

    • Untuk membuka kotak dialog tempat Anda bisa memilih printer, tentukan jumlah salinan, dan seterusnya, klik Cetak.

Atas Halaman

Catatan: Penafian Terjemahan Mesin: Artikel ini telah diterjemahan oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan terjemahan mesin ini untuk membantu pengguna yang bukan penutur bahasa Inggris agar dapat menikmati konten tentang produk, layanan, dan teknologi Microsoft. Karena artikel ini diterjemahkan oleh mesin, mungkin akan terdapat kesalahan kosa kata, sintaksis, atau tata bahasa.

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×