Pengenalan ke laporan

Penting: Artikel ini adalah terjemahan mesin, lihat penafian. Temukan versi bahasa Inggris artikel di sini sebagai rujukan Anda.

Saat Anda menggunakan database, Anda biasanya menggunakan laporan untuk menampilkan, format, dan meringkas data. Misalnya, Anda dapat membuat laporan tipe daftar untuk menampilkan nomor telepon untuk semua kontak Anda, atau laporan ringkasan untuk total penjualan untuk perusahaan Anda di kawasan yang berbeda dan periode waktu.

Artikel ini menyediakan gambaran umum tentang laporan di Microsoft Access 2010, dan memperkenalkan fitur laporan baru atau diubah. Artikel ini juga menjelaskan cara membuat laporan, bagaimana cara mengurutkan, mengelompokkan, dan meringkas data, dan cara untuk mempratinjau dan mencetak laporan.

Anda akan menemukan lebih mudah untuk membuat laporan berguna jika database Anda memiliki struktur tabel yang didesain dengan baik dan hubungan. Untuk pengenalan perencanaan dan mendesain sebuah database, lihat artikel dasar-dasar desain Database.

Dalam artikel ini

Gambaran Umum

Apa yang baru

Membuat laporan baru

Menambahkan pengelompokan, pengurutan, atau Total

Menyoroti nilai dengan menggunakan pemformatan bersyarat

Mendapatkan tampilan yang profesional dengan tema

Menambahkan gambar

Mempratinjau dan mencetak laporan

Gambaran umum

Laporan adalah objek database yang Anda gunakan untuk menampilkan dan meringkas data. Laporan menyediakan cara untuk mendistribusikan atau mengarsipkan snapshot data Anda, baik dengan yang dicetak, dikonversi ke file PDF atau XPS, atau diekspor ke format file lainnya.

Laporan karyawan di Pratinjau Cetak

Laporan bisa menyediakan detail tentang rekaman individual, ringkasan seluruh banyak catatan, atau keduanya. Anda juga bisa menggunakan laporan Access untuk membuat label untuk surat-menyurat atau tujuan lain.

Dimungkinkan untuk membuat laporan "tidak terikat" yang tidak menampilkan data, tapi untuk tujuan artikel ini, kita akan berasumsi bahwa laporan terikat ke sumber data seperti tabel atau kueri.

Laporan klien vs laporan Web

Access 2010 menyediakan fitur baru yang memungkinkan Anda untuk membuat "Web database" dengan menerbitkan Access database ke SharePoint server yang menjalankan Access Services. Saat Anda membuat Web database, laporan Access disajikan di browser menggunakan layanan pelaporan SQL Server. Konversi ini tempat beberapa keterbatasan fitur yang bisa Anda gunakan dalam laporan yang ingin Anda menyajikan di browser. Namun, jika Anda tidak khawatir tentang Penyajian Laporan di browser, Anda bisa menggunakan fitur yang menyediakan akses desainer laporan lengkap.

Bagian-bagian laporan

Di Access, desain laporan dibagi menjadi beberapa bagian. Di database klien, Anda bisa menampilkan laporan dalam tampilan desain untuk melihat bagian tersebut. Di tata letak tampilan, Bagian tidak jelas, tetapi mereka masih ada di sana, dan bisa dipilih dengan menggunakan daftar drop-down dalam grup pilihan pada Format tab. Untuk membuat laporan yang berguna, Anda perlu memahami cara kerja setiap bagian. Sebagai contoh, Bagian di mana Anda memilih untuk menempatkan kontrol terhitung menentukan bagaimana Access menghitung hasil. Daftar berikut ini adalah ringkasan tipe bagian dan menggunakan mereka:

  • Header laporan    Bagian ini hanya sekali, dicetak di permulaan laporan. Menggunakan header laporan untuk informasi yang biasanya mungkin muncul di halaman sampul, seperti logo, judul atau tanggal. Saat Anda menempatkan kontrol terhitung yang menggunakan fungsi agregat Sum dalam header laporan, adalah jumlah terhitung untuk seluruh laporan. Header laporan dicetak sebelum header halaman.

  • Header halaman    Bagian ini dicetak di bagian atas setiap halaman. Sebagai contoh, gunakan header halaman untuk mengulangi judul laporan pada setiap halaman.

  • Header grup    Bagian ini akan dicetak pada permulaan tiap grup rekaman baru. Gunakan header grup untuk mencetak nama grup. Misalnya, dalam laporan yang dikelompokkan menurut produk, gunakan header grup untuk mencetak nama produk. Saat Anda menempatkan kontrol terhitung yang menggunakan fungsi agregat Sum di header grup, jumlah adalah untuk grup saat ini. Anda bisa memiliki beberapa bagian header grup di laporan, bergantung pada berapa banyak tingkat pengelompokan yang telah Anda tambahkan. Untuk informasi selengkapnya tentang cara membuat grup header dan footer, lihat bagian menambahkan pengelompokan, pengurutan, atau Total.

  • Detail    Bagian ini dicetak satu kali untuk setiap baris dalam sumber rekaman. Ini adalah tempat Anda menempatkan kontrol yang membentuk isi utama laporan.

  • Footer grup    Bagian ini dicetak di akhir tiap grup rekaman. Gunakan footer grup untuk mencetak informasi ringkasan untuk grup. Anda bisa memiliki beberapa bagian footer grup laporan, bergantung pada berapa banyak tingkat pengelompokan yang telah Anda tambahkan.

  • Footer halaman    Bagian ini dicetak di akhir setiap halaman. Gunakan footer halaman untuk mencetak nomor halaman atau informasi per halaman.

  • Footer laporan    Bagian ini dicetak sekali saja, di akhir laporan. Gunakan footer laporan untuk mencetak total laporan atau informasi Rangkuman lainnya untuk seluruh laporan.

Catatan: Dalam tampilan desain, footer laporan muncul di bawah footer halaman. Namun, dalam tampilan semua lainnya (tampilan tata letak, misalnya, atau saat laporan dicetak atau dipratinjau), footer laporan muncul di atas footer halaman, hanya setelah grup footer atau rincian baris terakhir pada halaman terakhir.

Atas dokumen

Yang baru

Membuat laporan di Access 2010 adalah proses sangat mirip dengan pembuatan laporan di Access 2007. Namun, di Access 2010 ada beberapa fitur baru yang berkaitan dengan laporan:

  • Gambar Galeri dibagikan    Dalam Access 2010, Anda bisa sekarang lampirkan gambar ke database, dan lalu menggunakan gambar di beberapa objek. Memperbarui satu gambar pembaruan mana yang digunakan di seluruh database.

  • Tema Office    Dalam Access 2010, Anda sekarang bisa menggunakan standar Microsoft Office tema untuk menerapkan didesain secara profesional kumpulan font dan warna ke semua akses formulir dan laporan Anda sekaligus.

  • Pemformatan bersyarat yang lebih efektif    Access 2010 menyertakan lebih efektif alat untuk menyoroti data di laporan. Anda bisa menambahkan hingga 50 aturan pemformatan bersyarat untuk setiap kontrol atau grup kontrol, dan dalam laporan klien, Anda bisa menambahkan bilah data untuk membandingkan data di catatan.

  • Tata letak yang lebih fleksibel    Dalam Access 2010, metode desain default untuk laporan adalah untuk menempatkan kontrol dalam tata letak. Kisi ini membantu Anda meratakan dan ukuran kontrol dengan mudah, dan diperlukan untuk laporan yang ingin Anda menyajikan di browser. Meskipun tata letak itu sendiri tidak baru dalam Access 2010, ada beberapa perubahan untuk cara di mana Anda menggunakannya untuk memindahkan, meratakan, dan mengubah ukuran kontrol. Untuk informasi selengkapnya, lihat video pengenalan ke tata letak formulir dan laporan.

Atas dokumen

Membuat laporan baru

Langkah 1: Pilih sumber rekaman

Sumber rekaman sebuah laporan bisa berupa tabel, kueri bernama, atau kueri yang disematkan. Sumber rekaman harus berisi semua baris dan kolom data yang ingin Anda tampilkan di laporan.

  • Jika data yang ingin Anda terdapat di tabel yang sudah ada atau kueri, pilih tabel atau kueri dalam panel navigasi, dan lalu lanjutkan ke langkah 2: Pilih alat laporan.

  • Jika sumber rekaman belum ada, lakukan salah satu hal berikut ini:

Untuk informasi selengkapnya tentang membuat tabel atau kueri, lihat artikel pengenalan tabel atau pengenalan ke kueri.

Untuk informasi selengkapnya tentang membuat dan memilih sumber rekaman, lihat artikel mengatur sumber rekaman untuk laporan.

Langkah 2: Pilih alat laporan

Alat laporan berada pada tab buat pada pita, dalam grup laporan . Tabel berikut ini menjelaskan secara singkat apa arti setiap alat:

Laporan web yang kompatibel

Laporan yang dibuat dengan menggunakan alat ini kompatibel dengan terbitkan ke Access Services fitur, dan akan membuat di browser. Perhatikan bahwa objek kompatibel Web ditunjukkan dengan bola dunia pada ikon objek.

Gambar tombol

Alat

Deskripsi

Gambar tombol

Laporan

Membuat laporan tabular sederhana berisi semua bidang dalam sumber rekaman yang Anda pilih di Panel Navigasi.

Gambar tombol

Laporan Kosong

Membuka laporan kosong dalam tampilan tata letak, dan menampilkan panel tugas daftar bidang. Access membuat kueri sumber rekaman saat Anda menyeret bidang dari daftar bidang ke laporan.

Untuk informasi selengkapnya tentang terbitkan ke Access Services fitur, lihat artikel membangun database Access untuk dibagikan di Web.

Laporan klien

Laporan yang dibuat dengan menggunakan alat ini tidak kompatibel dengan terbitkan ke Access Services fitur. Menambahkan laporan klien ke Web database akan tidak mencegah database penerbitan, namun laporan klien tidak akan tersedia di browser. Namun, Anda bisa menggunakan laporan klien saat database dibuka di Access.

Gambar tombol

Alat

Deskripsi

Gambar tombol

Laporan

Membuat laporan tabular sederhana berisi semua bidang dalam sumber rekaman yang Anda pilih di Panel Navigasi.

Gambar tombol

Desain Laporan

Membuka laporan kosong dalam tampilan Desain, yang dapat ditambahi bidang dan kontrol yang Anda inginkan.

Gambar tombol

Laporan Kosong

Membuka laporan kosong dalam tampilan Tata Letak, dan menampilkan panel tugas Daftar Bidang. Saat Anda menyeret bidang dari Daftar Bidang ke laporan, Access membuat kueri yang disematkan dan menyimpannya dalam properti Sumber Rekaman laporan.

Gambar tombol

Panduan Laporan

Menampilkan panduan beberapa langkah yang memungkinkan Anda menentukan opsi bidang, tingkat pengelompokan/pengurutan, dan tata letak. Panduan membuat laporan berdasarkan pilihan yang Anda buat.

Gambar tombol

Label

Menampilkan panduan yang memungkinkan Anda memilih ukuran label standar atau kustom, serta bidang yang ingin Anda tampilkan, dan cara pengurutan yang Anda inginkan. Panduan membuat laporan label berdasarkan pilihan yang Anda buat.


Langkah 3: Membuat laporan

  1. Klik tombol untuk alat yang ingin Anda gunakan. Jika panduan muncul, ikuti langkah-langkah dalam panduan dan klik selesai pada halaman terakhir.

    Access menampilkan laporan dalam tampilan tata letak.

  2. Memformat laporan sampai terlihat seperti yang Anda inginkan:

    • Ubah ukuran bidang dan label dengan memilihnya lalu menyeret tepinya hingga menjadi ukuran yang Anda inginkan.

    • Pindahkan bidang dengan memilihnya (dan labelnya, jika ada), lalu menyeretnya ke lokasi baru.

    • Klik kanan sebuah bidang dan gunakan perintah di menu pintasan untuk menggabungkan atau memisahkan sel, menghapus atau memilih bidang, dan menjalankan tugas pemformatan lainnya.

      Selain itu, Anda bisa menggunakan fitur yang dijelaskan di bagian berikut untuk membuat laporan Anda lebih menarik dan lebih mudah dibaca.

Atas dokumen

Menambahkan pengelompokan, pengurutan, atau total

Cara tercepat untuk menambahkan pengelompokan, pengurutan, atau total ke laporan adalah dengan klik kanan bidang yang Anda inginkan untuk menerapkan grup, Urutkan, atau total, lalu klik perintah yang diinginkan pada menu pintasan.

Anda juga bisa menambahkan pengelompokan, pengurutan, atau total dengan menggunakan panel Kelompokkan, Urutkan, dan Total saat laporan dibuka di tampilan Tata Letak atau tampilan Desain:

  1. Jika panel Pengelompokan, Pengurutan, dan Total tidak ditampilkan, pada tab Desain, di grup Pengelompokan & Total, klik Kelompokkan & Urutkan.

  2. Klik Tambahkan grup atau Tambahkan urutan, lalu pilih bidang di mana Anda ingin kelompokkan atau urutkan.

  3. Klik Lainnya di baris pengelompokan atau pengurutan untuk mengatur opsi lainnya dan menambahkan total.

Untuk informasi selengkapnya tentang pengelompokan, pengurutan, dan Total, lihat artikel membuat laporan yang dikelompokkan dan ringkasan.

Atas dokumen

Menyoroti nilai dengan menggunakan pemformatan bersyarat

Access 2010 menyertakan lebih efektif alat untuk menyoroti data di laporan. Anda bisa menambahkan hingga 50 aturan pemformatan bersyarat untuk setiap kontrol atau grup kontrol, dan dalam laporan klien, Anda bisa menambahkan bilah data untuk membandingkan data di catatan.

Untuk menambahkan pemformatan bersyarat :

  1. Buka laporan dalam tampilan tata letak dengan mengklik kanan laporan dalam panel navigasi lalu klik Tampilan tata letak.

  2. Pilih semua kontrol yang Anda inginkan untuk menerapkan pemformatan bersyarat. Untuk memilih beberapa kontrol, tahan tombol SHIFT atau CTRL dan klik kontrol yang Anda inginkan.

  3. Pada tab Format, di grup Pemformatan Kontrol, klik Pemformatan Bersyarat.

    Access membuka kotak dialog Manajer Aturan Pemformatan Bersyarat.

  4. Dalam kotak dialog Pengelola Aturan Pemformatan Bersyarat, klik Aturan Baru.

  5. Dalam kotak dialog Aturan Pemformatan Baru, pilih nilai di bawah Pilih tipe aturan:

    • Untuk membuat aturan yang dievaluasi untuk tiap rekaman secara individual, pilih Periksa nilai dalam rekaman saat ini atau gunakan ekspresi.

    • Untuk membuat aturan yang membandingkan rekaman satu dengan lainnya dengan menggunakan bilah data, klik Bandingkan dengan rekaman lain.

Catatan:  Opsi Bandingkan dengan rekaman lain tidak tersedia dalam database Web.


  1. Di bawah Edit deskripsi aturan, tentukan aturan yang akan menentukan kapan pemformatan harus diterapkan, serta pemformatan yang Anda inginkan saat kriteria aturan terpenuhi.

  2. Klik OK untuk kembali ke kotak dialog Manajer Aturan Pemformatan Bersyarat.

  3. Untuk membuat aturan tambahan untuk kontrol atau kumpulan kontrol ini, ulangi prosedur ini dari langkah 4. Jika tidak, klik OK untuk menutup kotak dialog.

Untuk informasi selengkapnya tentang menambahkan pemformatan bersyarat ke laporan, lihat video menggunakan pemformatan pada laporan bersyarat.

Atas dokumen

Mendapatkan tampilan yang profesional dengan tema

Anda sekarang bisa menerapkan tema Office 2010 ke Access database, membantu Anda untuk membuat gaya yang konsisten di semua dokumen Office Anda.

Penting: Jika Anda memilih sebuah tema Office, font, atau warna, diterapkan ke semua formulir dan laporan di database Anda (tidak hanya yang sedang Anda kerjakan).

  1. Buka laporan dalam tampilan tata letak dengan mengklik kanan di panel navigasi, lalu klik tata letak View.

  2. Pada tab desain , di grup tema , Pilih tema, warna atau font yang Anda inginkan:

    Gambar pita

    • Gunakan Galeri tema untuk bersamaan mengatur warna dan font skema siap pakai.

    • Gunakan galeri Warna atau Font untuk mengatur warna atau font secara mandiri.


Untuk informasi selengkapnya tentang menggunakan tema Office, lihat video membuat formulir Access dan laporan Anda lebih konsisten dan agar terlihat bagus dengan tema Office.

Atas dokumen

Menambahkan gambar

Tradisional di Access, gambar telah terikat ke tiap-tiap gambar kontrol pada formulir atau laporan. Untuk mengubah gambar yang sering digunakan yang digunakan di beberapa formulir dan laporan, masing-masing kontrol gambar harus bisa diedit secara manual. Dalam Access 2010, namun, Anda bisa sekarang lampirkan gambar ke database sekali, dan lalu menggunakan gambar di beberapa objek. Memperbarui satu gambar pembaruan mana yang digunakan di seluruh database. Ini sangat berguna untuk hal-hal seperti logo perusahaan atau gambar latar belakang yang digunakan di seluruh database.

Menambahkan gambar

  1. Di panel navigasi, klik kanan laporan yang ingin Anda tambahkan gambar, dan lalu klik Tampilan tata letak.

  2. Klik di mana Anda ingin menambahkan gambar laporan.

  3. Pada tab desain , di grup kontrol , klik Sisipkan gambar.

  4. Lakukan salah satu hal berikut ini:

    • Menggunakan gambar yang sudah ada    Jika gambar yang Anda inginkan sudah ada di Galeri, klik untuk menambahkannya ke laporan.

    • Mengunggah gambar baru    Di bagian bawah Galeri, klik Telusuri. Dalam kotak dialog Sisipkan gambar , navigasi ke gambar yang ingin Anda gunakan, dan lalu klik buka.

      Access menambahkan gambar yang dipilih ke laporan.

Menambahkan gambar latar belakang

Catatan: Gambar latar belakang tidak bisa ditambahkan ke laporan Web kompatibel.

  1. Di panel navigasi, klik kanan laporan yang ingin Anda tambahkan gambar latar belakang, dan lalu klik Tampilan tata letak.

  2. Pada tab Format, di grup Latar Belakang, klik Gambar Latar Belakang.

  3. Lakukan salah satu hal berikut ini:

    • Menggunakan gambar yang sudah ada    Jika gambar yang Anda inginkan sudah ada di Galeri, klik untuk menambahkannya ke laporan.

    • Mengunggah gambar baru    Di bagian bawah Galeri, klik Telusuri. Dalam kotak dialog Sisipkan gambar , navigasi ke gambar yang ingin Anda gunakan, dan lalu klik buka.

      Access menambahkan gambar yang dipilih ke laporan.

Atas dokumen

Mempratinjau dan mencetak laporan

Mempratinjau laporan

  1. Buka laporan yang ingin Anda pratinjau, atau cukup pilih di panel navigasi.

  2. Pada File tab, klik cetak, dan lalu klik Pratinjau cetak.

    Access membuka laporan dalam pratinjau cetak. Anda bisa menggunakan perintah di tab Pratinjau cetak untuk melakukan salah satu hal berikut:

    • Mencetak laporan;

    • Menyesuaikan ukuran halaman atau tata letak;

    • Memperbesar atau memperkecil, atau menampilkan beberapa halaman sekaligus;

    • Me-refresh data dalam laporan;

    • Mengekspor laporan ke format file lainnya.

  3. Untuk kembali ke database ruang kerja, pada tab Pratinjau cetak , di grup Tutup pratinjau , klik Tutup pratinjau cetak.

Mencetak laporan

Selain untuk mencetak dari pratinjau cetak, Anda juga bisa mencetak laporan tanpa mempratinjau:

  1. Buka laporan yang ingin Anda pratinjau, atau cukup pilih di panel navigasi.

  2. Pada tab File, klik Cetak.

    • Untuk mengirim laporan secara langsung ke default printer tanpa mengatur opsi printer, klik Cetak cepat.

    • Untuk membuka kotak dialog tempat Anda bisa memilih printer, tentukan jumlah salinan, dan seterusnya, klik Cetak.

Atas dokumen

Catatan: Penafian Terjemahan Mesin: Artikel ini telah diterjemahan oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan terjemahan mesin ini untuk membantu pengguna yang bukan penutur bahasa Inggris agar dapat menikmati konten tentang produk, layanan, dan teknologi Microsoft. Karena artikel ini diterjemahkan oleh mesin, mungkin akan terdapat kesalahan kosa kata, sintaksis, atau tata bahasa.

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×