Menyambungkan ke file XML (Power Query)

Penting: Artikel ini adalah terjemahan mesin, lihat penafian. Temukan versi bahasa Inggris artikel di sini sebagai rujukan Anda.

Menggunakan Excel Dapatkan & transformasi (Power Query) pengalaman untuk menyambungkan ke XML file.

  1. Klik pada tab Data , lalu Dapatkan Data > Dari File > Dari XML. Jika Anda tidak melihat tombol Dapatkan Data , klik Kueri baru > Dari File > Dari XML.

  2. Dalam kotak dialog Dari Penelusuran XML, telusuri atau ketikkan URL file untuk mengimpor atau menautkan ke file.

  3. Klik Buka.

    Setelah koneksi berhasil, Anda akan dapat menggunakan panel Navigator untuk menelusuri dan mempratinjau kumpulan item dalam file XML dalam bentuk tabular.

  1. Di tab pita Power Query , klik Dari File > Dari XML.

    Dialog Power Query dari File
  2. Dalam kotak dialog Dari Penelusuran XML, telusuri atau ketikkan URL file untuk mengimpor atau menautkan ke file.

  3. Klik Buka.

    Setelah koneksi berhasil, Anda akan dapat menggunakan panel Navigator untuk menelusuri dan mempratinjau kumpulan item dalam file XML dalam bentuk tabular.

Penting: Pastikan Anda mengunduh dan menginstal Power Query Add-In.

Catatan: Power Query tidak didukung di Excel 2007, tapi Anda bisa menggunakan metode Dapatkan Data eksternal untuk mengimpor XML data.

  1. Klik pada tab Data , lalu Dapatkan Data eksternal > Dari sumber lain > Dari XML.

  2. Dalam kotak dialog Pilih sumber Data , telusuri atau ketikkan URL file untuk mengimpor, atau pilih opsi Sumber baru untuk menautkan ke file.

Contoh Rumus

Anda juga bisa menggunakan Editor kueri untuk menulis rumus untuk Power Query. Misalnya:

= Xml.Tables(File.Contents("C:\Downloads\XML Example.xml"))

Catatan: Editor Kueri hanya muncul saat Anda memuat, mengedit, atau membuat kueri baru menggunakan Power Query. Video berikut ini memperlihatkan jendela Editor Kueri muncul setelah pengeditan kueri dari sebuah buku kerja Excel. Untuk menampilkan Editor Kueri tanpa memuat atau mengedit kueri buku kerja yang sudah ada, dari bagian Dapatkan Data Eksternal di tab pita Power Query, pilih Dari Sumber Lain > Kueri Kosong. Video berikut ini memperlihatkan salah satu cara untuk menampilkan Editor Kueri.

Cara untuk melihat Editor Kueri di Excel

Perlu bantuan lainnya?

Anda selalu dapat bertanya kepada pakar di Komunitas Teknologi Excel, mendapatkan dukungan di Komunitas Jawaban, atau menyarankan fitur maupun fitur baru di Suara Pengguna Excel.

Catatan: Penafian Terjemahan Mesin: Artikel ini telah diterjemahan oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan terjemahan mesin ini untuk membantu pengguna yang bukan penutur bahasa Inggris agar dapat menikmati konten tentang produk, layanan, dan teknologi Microsoft. Karena artikel ini diterjemahkan oleh mesin, mungkin akan terdapat kesalahan kosa kata, sintaksis, atau tata bahasa.

Lihat Juga

Power Query dikenal sebagai Dapatkan & transformasi di Excel 2016

Mengimpor data dari sumber data eksternal

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×