Mengimpor database Access 2.0 dan Access 95 ke dalam versi terbaru

Mengimpor database Access 2.0 dan Access 95 ke dalam versi terbaru

Jika menggunakan database dalam format Access 2.0 (.mdb) atau format Access 95 (.mdb) yang sudah ada, dalam beberapa kasus Anda dapat mengimpor tabel, kueri, dan makro dari database tersebut ke versi baru Access yang menggunakan format file .accdb.

Untuk mengimpor formulir dan laporan yang berisi kode VBA (dan juga modul), konversikan database Access 2.0 atau Access 95 ke format file Access 2002 - 2003 atau Access 2000 terlebih dahulu menggunakan Microsoft Office Access 2003, Access 2002, atau Access 2000. Kemudian, Anda dapat menggunakan versi yang lebih baru, seperti Access 2007 untuk mengonversi file tersebut ke format file .accdb yang dapat dibuka dengan Access 2010, Access 2013, atau Access 2016

Bagian berikut dalam artikel ini menjelaskan cara melakukan tugas-tugas tersebut.

Apakah Anda menggunakan Access 2010, Access 2013, atau Access 2016?

Access 2007 adalah versi terakhir dengan dukungan untuk membuka, mengimpor, menautkan atau mengekspor ke Access 2.0 dan Access 95. Anda memerlukan Access 2007 untuk mengekspor, mengimpor atau menautkan data dari file Access 1.0 dan 2.0 (Red 2, atau Jet 2) serta database Access 95. Dalam hal ini, Anda perlu menggunakan Access 2007 sebagai langkah perantara untuk mengonversi database Access 2.0 sepenuhnya ke salah satu versi tersebut.

Apa yang ingin Anda lakukan?

Membuka database Access 2.0 di Access 2007

Mengimpor data dari database Access 2.0 ke Access 2007

Mengimpor data dari database Access 95 ke Access 2007

Mengonversi database Access 2.0 atau Access 95 menggunakan Access 2003, Access 2002, atau Access 2000

Membuka database Access 2.0 di Access 2007

Saat Anda membuka database Access 2.0 di Access 2007, Access akan menampilkan beberapa perintah, yang jika diikuti, diakhiri dengan pesan Database ini disimpan dalam format file Microsoft Access 2.0.

Database ini disimpan dalam format file Microsoft Access 2.0.

Anda dapat mengimpor tabel, kueri, dan makro dari database Access 2.0 ke dalam database Access 2007 (.accdb). Untuk mengimpor formulir, laporan, atau modul ke dalam database Access 2007, konversikan database terlebih dahulu menggunakan versi Access yang lebih lama, lalu buka database tersebut menggunakan Access 2007, kemudian konversikan database ke dalam format file .accdb database Access 2007. Lihat bagian Mengonversi database Access 2.0 atau Access 95 menggunakan Access 2003, Access 2002, atau Access 2000 untuk informasi selengkapnya.

Mengimpor data dari database Access 2.0 ke Access 2007

Ketika Anda mengimpor objek dari database lain, salinan objek yang diimpor akan dibuat dalam database tujuan. Sumber tidak akan diubah. Untuk mengimpor data dari database Access 2.0 ke Access 2007, buka database yang akan menjadi tujuan pengimporan data terlebih dahulu. Kemudian gunakan perintah di tab Data Eksternal untuk melanjutkan proses impor, yang mencakup proses pembukaan Panduan Impor.

  1. Buka Access 2007, klik Tombol Microsoft Office, kemudian klik Buka.

  2. Dalam kotak dialog Buka, pilih dan buka database yang akan menjadi tujuan pengimporan tabel, kueri, atau makro.

  3. Di tab Data Eksternal, dalam grup Impor, klik Access.

  4. Dalam kotak teks Nama file dari Panduan Dapatkan Data Eksternal, ketikkan nama database sumber, atau klik Telusuri untuk menampilkan kotak dialog Buka File dan pilih atau ketikkan nama database sumber.

  5. Klik Impor tabel, kueri, formulir, laporan, makro, dan modul ke dalam database saat ini, lalu klik OK.

  6. Dalam kotak dialog Impor Objek, klik setiap tab dan pilih objek yang diinginkan. Ingat, Anda hanya dapat mengimpor tabel, kueri, dan makro dari database Access 2.0 ke Access 2007.

    Kotak dialog Impor Objek

    Untuk membatalkan objek yang dipilih, klik lagi objek tersebut.

  7. Klik Opsi untuk menentukan pengaturan tambahan.

    Tabel berikut ini menjelaskan bagaimana setiap opsi berdampak pada hasil operasi.

    Elemen

    Deskripsi

    Kotak centang Hubungan

    Mengimpor hubungan antara tabel yang dipilih.

    Kotak centang Menu dan Toolbar

    Mengimpor semua menu dan toolbar kustom yang ada dalam database sumber. Menu dan toolbar ditampilkan di tab yang bernama Add-In.

    Kotak centang Spesifikasi Impor/Ekspor

    Mengimpor semua spesifikasi impor atau ekspor tersimpan yang ada dalam database sumber.

    Kotak centang Grup Panel Navigasi

    Mengimpor semua grup Panel Navigasi kustom yang ada dalam database sumber.

    Tombol Definisi dan Data

    Mengimpor struktur dan data dari semua tabel yang dipilih.

    Tombol Definisi Saja

    Mengimpor bidang dalam tabel yang dipilih saja. Rekaman sumber tidak diimpor.

    Tombol Sebagai Kueri

    Mengimpor kueri yang dipilih sebagai kueri. Dalam hal ini, ingat untuk mengimpor semua tabel yang mendasari beserta kuerinya.

    Tombol Sebagai Tabel

    Mengimpor kueri sebagai tabel. Dalam hal ini, Anda tidak perlu mengimpor tabel yang mendasari.

  8. Klik OK untuk menyelesaikan operasi.

    Access akan menyalin data dan menampilkan pesan kesalahan jika terdapat masalah. Jika operasi pengimporan data berhasil, halaman terakhir panduan akan memungkinkan Anda menyimpan detail operasi sebagai spesifikasi impor untuk penggunaan selanjutnya.

Mengimpor data dari database Access 95 ke Access 2007

Untuk mengimpor data dari database Access 95 ke Access 2007, buka database Access 2007 yang akan menjadi tujuan pengimporan data. Kemudian, gunakan perintah di tab Data Eksternal yang akan membuka Panduan Impor.

Anda dapat mengimpor tabel, kueri, dan makro dari database berformat Access 95 (.mdb) ke database Access 2007 (.accdb). Anda juga dapat mengimpor formulir dan laporan yang tidak menggunakan kode VBA. Untuk mengimpor formulir dan laporan yang berisi kode VBA (dan juga modul), konversikan database Access 95 ke format file Access 2002 - 2003 atau Access 2000 terlebih dahulu menggunakan Microsoft Office Access 2003, Access 2002, atau 2000, lalu gunakan Access 2007 untuk mengonversi file tersebut ke format file .accdb Access 2007.

  1. Buka Access 2007, klik Tombol Microsoft Office, kemudian klik Buka.

  2. Dalam kotak dialog Buka, pilih dan buka database yang akan menjadi tujuan pengimporan tabel, kueri, atau makro.

  3. Di tab Data Eksternal, dalam grup Impor, klik Access.

  4. Dalam kotak Nama file dari Panduan Dapatkan Data Eksternal, ketikkan nama database sumber, atau klik Telusuri untuk menampilkan kotak dialog Buka File dan pilih atau ketikkan nama database sumber.

  5. Klik Impor tabel, kueri, formulir, laporan, makro, dan modul ke dalam database saat ini, kemudian klik OK.

  6. Dalam kotak dialog Impor Objek, klik setiap tab dan pilih objek yang ingin diimpor.

    Untuk membatalkan pemilihan objek, klik lagi objek tersebut.

  7. Klik Opsi untuk menentukan pengaturan tambahan. Pengaturan tambahan ini akan muncul dalam grup di bawah daftar objek.

  8. Klik OK untuk menyelesaikan operasi.

    Access akan menyalin data dan menampilkan pesan kesalahan jika terdapat masalah. Jika operasi pengimporan data berhasil, halaman terakhir panduan akan memungkinkan Anda menyimpan detail operasi sebagai spesifikasi impor untuk penggunaan selanjutnya.

Mengonversi database Access 2.0 atau Access 95 menggunakan Access 2003, Access 2002, atau Access 2000

Anda dapat mengonversi database Access 2.0 ke dalam format file Access 2000 atau Access 2002 - 2003 menggunakan salah satu versi Access yang tercantum dalam tabel berikut ini, dengan asumsi Anda telah membeli versi Access tersebut dan menginstalnya di komputer. Tergantung pada versi Access Anda, konverter Access 2.0 harus sudah diinstal.

Versi

Konverter Akses 2.0

Microsoft Office Access 2003

Versi ini memerlukan pengunduhan dan penginstalan Konverter Access 2.0 untuk Access 2003. Namun, alat ini tidak lagi tersedia di Pusat Unduhan Microsoft karena dukungan yang diperpanjang untuk Access 2003 telah dihentikan.

Microsoft Access 2002

Disertakan dalam produk.

Microsoft Access 2000

Disertakan dalam produk.

Anda harus mengonversi file Access 2.0 atau Access 95 ke dalam format file Access 2000 atau .mdb Access 2002-2003. Lalu, gunakan Access 2007 untuk mengonversi file hasil ke dalam format file .accdb Access 2007. Anda kemudian dapat menggunakan database tersebut di Access 2007 atau membukanya di Access 2010, Access 2013, atau Access 2016. Tergantung pada versi lama Access Anda, ikuti langkah-langkah berikut ini:

  1. Mulai Access 2003, Access 2002, atau Access 2000.

  2. Pada menu File, klik Buka, lalu klik nama file untuk database Access 95 yang ingin dikonversi.

  3. Pada menu Alat, klik Keperluan Database, klik Konversikan Database, lalu klik Ke Format File Access 2000.

  4. Dalam kotak dialog Konversikan Database Ke, masukkan nama file untuk file yang baru, kemudian klik Simpan.

    Anda mungkin melihat peringatan pesan informasi bahwa database yang dikonversi tersebut tidak dapat digunakan dalam versi Access yang lebih lama. Jika pesan ini muncul, klik OK.

    File kemudian disimpan dalam format file Access 2000.

  5. Mulai Access 2007.

  6. Klik Tombol Microsoft Office, lalu klik Buka.

  7. Dalam kotak dialog Buka, pilih dan buka database yang telah dikonversi.

  8. Klik Tombol Microsoft Office , lalu klik Konversikan.

  9. Dalam kotak dialog Simpan Sebagai, masukkan nama file untuk file Access 2007 tersebut, atau terima nama file yang diberikan, lalu klik Simpan.

    File kemudian disimpan dalam format file .accdb Access 2007.

Atas Halaman

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×