Mengimpor atau menautkan ke data dalam database SQL Server

Mengimpor atau menautkan ke data dalam database SQL Server

Anda dapat menautkan ke atau mengimpor data dari Database SQL, yaitu database terkelola berkinerja tinggi yang digunakan untuk aplikasi penting. Untuk informasi selengkapnya, lihat SQL Server 2016.

  • Ketika menautkan ke data, Access membuat koneksi dua arah yang menyinkronkan perubahan ke data di Access dan Database SQL.

  • Ketika mengimpor data, Access membuat salinan data sekali pakai, sehingga perubahan pada data di Access atau Database SQL tidak disinkronkan.

Gambaran umum menyambungkan Access ke SQL Server

Sebelum Anda memulai

Ingin proses yang lebih mulus? Lakukan persiapan berikut sebelum Anda menautkan atau mengimpor:

  • Temukan nama server database SQL Server, identifikasi informasi koneksi yang diperlukan, lalu pilih metode autentikasi (Windows atau SQL Server). Untuk informasi selengkapnya tentang metode autentikasi, lihat Menyambungkan ke Server (Mesin Database) dan Mengamankan database Anda.

  • Identifikasi tabel atau tampilan untuk tujuan penautan atau yang akan diimpor, serta bidang bernilai unik untuk tabel tertaut. Anda dapat menautkan ke atau mengimpor lebih dari satu tabel atau tampilan sekaligus.

  • Pertimbangkan jumlah kolom dalam setiap tabel atau tampilan. Access tidak mendukung lebih dari 255 bidang dalam tabel, sehingga hanya akan menautkan atau mengimpor 255 kolom pertama. Solusinya, Anda dapat membuat tampilan dalam Database SQL Server untuk mengakses kolom lebih dari batas tersebut.

  • Tentukan jumlah total data yang diimpor. Ukuran maksimal database Access adalah dua gigabyte, minus ruang yang diperlukan untuk objek sistem. Jika database SQL Server berisi tabel yang berukuran besar, Anda mungkin tidak akan dapat mengimpor semuanya ke satu database Access. Dalam hal ini, pertimbangkan untuk menautkan ke data, bukan mengimpornya.

  • Amankan database Access Anda beserta informasi koneksi di dalamnya menggunakan lokasi tepercaya dan kata sandi database Access. Hal ini penting, terutama jika Anda memilih untuk menyimpan kata sandi SQL Server di Access.

  • Rencanakan untuk membuat hubungan tambahan. Access tidak secara otomatis membuat hubungan antar tabel terkait di akhir operasi impor. Anda dapat membuat hubungan antar tabel baru dan yang sudah ada menggunakan jendela Hubungan secara manual. Untuk informasi selengkapnya, lihat Apa itu jendela Hubungan? dan Membuat, mengedit atau menghapus hubungan.

Tahap 1: Mulai

  1. Pilih Data Eksternal > Sumber Data Baru > Dari Database > Dari SQL Server.

  2. Dalam kotak dialog Dapatkan Data Eksternal – Database ODBC, lakukan salah satu hal berikut:

    • Untuk mengimpor data, pilih Impor data sumber ke tabel baru dalam database saat ini.

    • Untuk menautkan ke data, pilih Tautkan sumber data dengan membuat tabel tertaut.

  3. Pilih OK.

Tahap 2: Membuat atau menggunakan kembali file DSN

Anda dapat membuat file DSN atau menggunakan kembali file yang sudah ada. Gunakan file DSN ketika ingin mengandalkan informasi koneksi yang sama untuk tautan berbeda, serta mengimpor operasi atau untuk berbagi dengan aplikasi lain yang juga menggunakan file DSN. Anda dapat membuat file DSN secara langsung menggunakan Manajer Koneksi Data. Untuk informasi selengkapnya, lihat Mengelola sumber data ODBC.

Meskipun masih dapat menggunakan driver SQL ODBC versi sebelumnya, sebaiknya gunakan versi 13.1, yang memuat berbagai penyempurnaan dan mendukung fitur baru SQL Server 2016. Untuk informasi selengkapnya, lihat Driver ODBC Microsoft untuk SQL Server di Windows.

  1. Lakukan salah satu hal berikut ini:

    • Jika file DSN yang ingin Anda gunakan sudah ada, pilih dari daftar.

      Kotak dialog Pilih Sumber Data

      Tergantung pada metode autentikasi yang dimasukkan dalam informasi koneksi, Anda mungkin perlu memasukkan kata sandi lagi.

    • Untuk membuat file DSN baru:

      1. Pilih Baru.

        Kotak dialog Buat Sumber Data Baru
      2. Pilih Driver ODBC 13 untuk SQL Server, lalu pilih Berikutnya.

      3. Masukkan nama file DSN, atau klik Telusuri untuk membuat file di lokasi yang berbeda.

  2. Klik Berikutnya untuk meninjau informasi ringkasan, lalu klik Selesai.

Tahap 3: Menggunakan panduan Membuat Sumber Data Baru di SQL Server

Dalam panduan Membuat Sumber Data Baru di SQL Server, lakukan hal berikut:

  1. Di halaman satu, masukkan informasi identifikasi:

    • Dalam kotak Deskripsi , secara opsional masukkan informasi dokumenter tentang file DSN tersebut.

    • Dalam kotak Server, masukkan nama SQL Server. Jangan klik panah bawah.

  2. Di halaman dua, pilih salah satu metode autentikasi berikut:

    • Dengan autentikasi Windows Terintegrasi    Sambungkan melalui akun pengguna Windows. Secara opsional, masukkan nama Prinsipal Layanan (SPN). Untuk informasi selengkapnya, lihat Nama Prinsipal Layanan (SPN) dalam Koneksi Klien (ODBC).

    • Dengan autentikasi SQL Server...    Sambungkan dengan kredensial yang telah disiapkan dalam database dengan memasukkan ID masuk dan kata sandi.

  3. Di halaman tiga dan empat, pilih berbagai opsi untuk mengustomisasi koneksi Anda. Untuk informasi selengkapnya tentang opsi ini, lihat Driver ODBC Microsoft untuk SQL Server.

  4. Layar akan muncul untuk mengonfirmasi pengaturan. Pilih Uji Sumber Data untuk mengonfirmasi koneksi.

  5. Anda mungkin perlu masuk ke database tersebut. Dalam kotak dialog Masuk ke SQL Server, masukkan ID masuk dan kata sandi. Untuk mengubah pengaturan lainnya, pilih Opsi.

Tahap 4: Memilih Tabel untuk menautkan atau mengimpor

  1. Dalam kotak dialog Tautkan Tabel atau Impor Objek, di bawah Tabel, pilih setiap tabel atau tampilan yang ingin Anda tautkan atau impor, lalu klik OK.

    Daftar tabel untuk menautkan atau mengimpor
  2. Dalam operasi penautan, tentukan untuk memilih Simpan Kata Sandi.

    Keamanan    Memilih opsi ini akan menyingkirkan keperluan memasukkan kredensial setiap kali Anda membuka Access dan mengakses data. Namun, opsi ini akan menyimpan kata sandi tanpa enkripsi dalam database Access, yang berarti orang-orang yang dapat mengakses konten sumber juga dapat melihat nama pengguna dan kata sandi. Jika memilih opsi ini, kami sangat menyarankan Anda menyimpan database Access di lokasi yang tepercaya dan membuat kata sandi database Access. Untuk informasi selengkapnya, lihat Memutuskan untuk memercayai database dan Mengenkripsi database menggunakan kata sandi database.

Tahap 5: Membuat spesifikasi dan tugas (Hanya impor)

Hasil

Ketika operasi penautan atau pengimporan selesai, tabel akan muncul di Panel Navigasi dengan nama yang sama dengan tampilan atau tabel SQL Server yang digabungkan dengan nama pemilik. Misalnya, jika nama SQL adalah dbo.Produk, nama Access akan menjadi dbo_Produk. Jika nama tersebut sudah digunakan, Access akan menambahkan "1" ke nama tabel baru, misalnya, dbo_Produk1. Jika dbo_Produk1 juga sudah digunakan, Access akan membuat dbo_Produk2, dan seterusnya. Namun, Anda dapat mengganti nama tabel tersebut dengan yang lebih bermakna.

Dalam operasi impor, Access tidak pernah menimpa tabel dalam database. Meskipun tidak dapat langsung menambahkan data SQL Server ke tabel yang sudah ada, Anda dapat membuat kueri penambahan ke data penambahan setelah mengimpor data dari tabel yang serupa.

Dalam operasi penautan, jika kolom bersifat baca-saja dalam tabel SQL Server, kolom juga akan bersifat baca-saja di Access.

Tips    Untuk melihat string koneksi, arahkan mouse ke tabel di panel navigasi Access.

Memperbarui desain tabel tertaut

Anda tidak dapat menambahkan, menghapus, atau mengubah kolom maupun mengubah tipe data dalam tabel tertaut. Jika ingin membuat perubahan desain, lakukan dalam database SQL Server. Untuk melihat perubahan desainnya di Access, perbarui tabel tertaut:

  1. Pilih Data Eksternal > Manajer Tabel Tertaut.

  2. Pilih setiap tabel tertaut yang ingin Anda perbarui, pilih OK, lalu pilih Tutup.

Membandingkan tipe data

Tipe data Access diberi nama yang berbeda dengan tipe data SQL Server. Misalnya, kolom SQL Server dari tipe data bit akan diimpor atau ditautkan ke Access dengan tipe data Ya/Tidak. Tabel berikut ini membandingkan tipe data SQL Server dan Access.

Tipe data SQL Server

Tipe data Access

Ukuran bidang Access

bigint

Angka Besar

Lihat Menggunakan tipe data Angka Besar.

binary (ukuran bidang)

Biner

Sama seperti ukuran bidang SQL Server

bit

Ya/Tidak

char (ukuran bidang), saat ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

char (ukuran bidang), saat ukuran bidang lebih besar dari 255

Memo

datetime

Tanggal/Waktu

decimal (presisi, skala)

Angka

Desimal (Properti Presisi dan Skala Access cocok dengan presisi dan skala SQL Server.)

float

Angka

Ganda

image

Objek OLE

int

Angka

Bilangan Bulat Panjang

money

Mata Uang

nchar (ukuran bidang), saat ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

nchar (ukuran bidang), saat ukuran bidang lebih besar dari 255

Memo

ntext

Memo

numeric (presisi, skala)

Angka

Desimal (Properti Presisi dan Skala Access cocok dengan presisi dan skala SQL Server.)

nvarchar (ukuran bidang), saat ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

nvarchar (ukuran bidang), saat ukuran bidang lebih besar dari 255

Memo

nvarchar(MAX)

Memo

real

Angka

Tunggal

smalldatetime

Tanggal/Waktu

smallint

Angka

Integer

smallmoney

Mata Uang

sql_variant

Teks

255

text

Memo

timestamp

Biner

8

tinyint

Angka

Byte

uniqueidentifier

Angka

ID replikasi

varbinary

Biner

Sama seperti ukuran bidang SQL Server

varbinary (MAX)

Objek OLE

varchar (ukuran bidang), saat ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

varchar (ukuran bidang), saat ukuran bidang lebih besar dari 255

Memo

varchar(MAX)

Memo

xml

Memo

Anda dapat bekerja dengan data yang disimpan di SQL Server, baik dengan menautkan atau mengimpornya ke database Access. Penautan adalah opsi terbaik untuk berbagi data dengan orang lain, karena data disimpan dalam lokasi terpusat dan Anda dapat melihat data yang paling baru, menambahkan atau mengedit data, serta menjalankan kueri atau laporan di Access.

Langkah 1: Persiapan penautan

  1. Temukan database Server SQL yang ingin Anda tautkan. Jika perlu, hubungi administrator database untuk informasi koneksi.

  2. Identifikasi tabel dan tampilan yang akan Anda tautkan dalam database SQL. Anda bisa menautkan ke beberapa objek sekaligus.

Meninjau data sumber untuk pertimbangan berikut:

  • Access mendukung sampai 255 bidang (kolom) dalam tabel, sehingga tabel tertaut hanya akan menyertakan 255 bidang pertama dari objek yang Anda tautkan.

  • Kolom baca saja di tabel Server SQL juga akan bersifat baca saja di Access.

  1. Untuk membuat tabel tertaut dalam database baru: Klik File > Baru >Database desktop kosong. Untuk membuat tabel tertaut dalam database Access yang sudah ada, pastikan Anda memiliki izin yang diperlukan untuk menambahkan data ke database tersebut.

    Catatan:  Sebuah tabel tertaut yang dibuat dalam database Access yang sudah ada, mendapatkan nama yang sama seperti dalam objek sumber. Jadi, jika Anda telah mempunyai tabel dengan nama yang sama, tabel tertaut yang baru akan diberi akhiran “1” — sebagai contoh, Kontak1. (Jika Kontak1 juga telah digunakan, Access akan membuat Kontak2, dan seterusnya.)

Langkah 2: Menautkan ke data

Ketika menautkan ke tabel atau menampilkan dalam database Server SQL, Access membuat tabel baru (dikenal sebagai tabel tertaut) yang menggambarkan struktur dan konten tabel sumber. Anda bisa mengubah data baik di Server SQL, atau dalam tampilan Lembar Data atau tampilan Formulir dari Access dan perubahan terlihat pada SQL maupun Access. Perubahan struktural apa pun terhadap tabel tertaut seperti menghapus atau mengubah kolom, harus dilakukan dari Server SQL dan bukan Access.

  1. Buka database Access tujuan.

  2. Pada tab Data Eksternal, klik Database ODBC.

  3. Klik Tautkan ke sumber data dengan membuat tabel tertaut > OK dan ikuti langkah-langkah dalam panduan. Dalam kotak Pilih Sumber Data, jika file .dsn yang ingin digunakan sudah ada, klik file tersebut dalam daftar.

    Untuk membuat file .dsn baru:

    Dalam kotak Pilih Sumber Data, klik Baru > SQL Server > Berikutnya.

    1. Ketikkan nama untuk file .dsn, atau klik Telusuri.

      Catatan: Anda memerlukan izin penulisan pada folder untuk menyimpan file .dsn tersebut.

    2. Klik Berikutnya untuk meninjau informasi ringkasan, kemudian klik Selesai.

      Ikuti langkah dalam Panduan Membuat Sumber Data Baru ke SQL Server.

  4. Klik OK dan di bawah Tabel, klik setiap tabel atau tampilan yang ingin Anda tautkan, lalu klik OK.

Jika Anda melihat Pilih Pengidentifikasi Rekaman Unik, ini berarti Access tidak dapat menentukan bidang yang mengidentifikasi setiap baris dari data sumber secara unik. Cukup pilih bidang atau kombinasi bidang yang unik untuk setiap baris, dan jika Anda tidak yakin, periksa dengan administrator database Server SQL.

Ketika operasi penautan selesai, Anda bisa melihat tabel tertaut yang baru dalam Panel Navigasi.

Menerapkan struktur objek Server SQL terbaru

Ketika Anda membuka tabel tertaut maupun objek sumber, Anda melihat data yang terbaru. Namun, jika perubahan struktural dilakukan terhadap objek Server SQL, Anda akan perlu memperbarui tabel tertaut untuk melihat perubahan itu.

  1. Klik kanan tabel di Panel Navigasi, lalu klik Manajer Tabel Tertaut pada menu pintasan.

  2. Pilih kotak centang di samping setiap tabel tertaut yang ingin Anda perbarui, atau klik Pilih Semua untuk memilih seluruh tabel tertaut.

  3. Klik OK > Tutup.

Catatan: Karena tipe data Access berbeda dari tipe data SQL Server, Access menautkan ke tipe data yang paling tepat untuk setiap kolom. Anda hanya bisa meninjau, bukan mengubah tipe data yang ditetapkan di Access.

Untuk informasi selengkapnya, baca cara berbagi database desktop Access.

Atas Halaman

Jika departemen atau grup kerja Anda menggunakan Microsoft SQL Server untuk menyimpan data, Anda mungkin harus bekerja dengan beberapa data SQL Server di Access.

Anda dapat membawa data dari objek SQL Server (tabel atau tampilan) ke Access dalam dua cara: dengan pengimporan atau penautan. Perbedaan antara kedua proses tersebut adalah sebagai berikut:

  • Saat mengimpor data, Access akan membuat salinan data SQL Server dan setiap perubahan yang selanjutnya dibuat pada data dalam database Access tidak akan terlihat dalam database SQL Server. Demikian juga, setiap perubahan terbaru yang dibuat dalam tabel atau tampilan SQL Server tidak akan terlihat di Access.

  • Saat menautkan ke data SQL Server, Anda tersambung secara langsung ke sumber data sehingga semua perubahan terbaru yang dibuat pada data di Access akan terlihat di SQL Server, dan sebaliknya.

Artikel ini menjelaskan cara mengimpor atau menautkan ke data SQL Server.

Menentukan apakah akan mengimpor atau menautkan

Situasi ketika pengimporan adalah cara yang tepat

Biasanya, Anda mengimpor data SQL Server ke database Access untuk alasan berikut:

  • Untuk memindahkan data SQL Server ke database Access secara permanen karena tidak lagi memerlukan data dalam database SQL Server tersebut. Setelah mengimpor data ke Access, Anda dapat menghapus data dari database SQL Server.

  • Departemen atau kelompok kerja Anda menggunakan Access, namun terkadang Anda diarahkan ke database SQL Server untuk data tambahan yang harus digabungkan ke salah satu database Access.

Karena mengimpor data SQL Server akan membuat salinan data dalam database Access, tentukan tabel atau tampilan yang ingin disalin saat proses pengimporan.

Situasi ketika penautan adalah cara yang tepat

Biasanya, Anda menautkan ke data SQL Server untuk alasan berikut:

  • Untuk langsung menyambungkan ke sumber data agar dapat menampilkan dan mengedit informasi terbaru baik dalam database SQL Server maupun database Access.

  • Database SQL Server berisi banyak tabel berukuran besar, dan Anda tidak dapat mengimpor semuanya ke dalam satu file .accdb. Ukuran maksimal database Access adalah 2 gigabyte, minus ruang yang diperlukan untuk objek sistem.

  • Anda ingin menjalankan kueri dan menghasilkan laporan yang didasarkan pada data dari SQL Server tanpa harus membuat salinan datanya. Pertimbangkan untuk menautkan ke SQL Server.

  • Departemen atau kelompok kerja Anda menggunakan Access untuk pelaporan dan pembuatan kueri, serta menggunakan SQL Server untuk penyimpanan data. Tim individu dapat membuat tabel dan tampilan SQL Server untuk penyimpanan terpusat, tetapi seringkali data ini harus dibawa ke program desktop untuk agregasi dan pelaporan. Penautan adalah pilihan yang tepat, karena memungkinkan pengguna database SQL Server dan database Access untuk menambahkan dan memperbarui data, juga untuk selalu menampilkan dan bekerja dengan data terbaru.

  • Anda adalah pengguna Access yang baru menggunakan SQL Server. Anda memindahkan beberapa database ke SQL Server, dan sebagian besar tabel dalam database ini adalah tabel tertaut. Mulai saat ini, daripada membuat tabel Access, buatlah tabel dan tampilan dalam SQL Server, kemudian tautkan dari database Access.

  • Anda ingin terus menyimpan data di SQL Server, tetapi juga ingin bekerja dengan data yang paling baru di Access untuk menjalankan kueri dan mencetak laporan yang dirancang di Access.

Atas Halaman

Mengimpor data dari SQL Server

Persiapan untuk mengimpor

Selama operasi impor, Access akan membuat tabel dan menyalin data dari database SQL Server ke dalam tabel tersebut. Di akhir operasi impor, Anda dapat memilih untuk menyimpan detail operasi impor sebagai spesifikasi.

Catatan: Spesifikasi impor membantu Anda mengulangi operasi impor ini di lain waktu tanpa harus mengikuti Panduan Impor lagi.

  1. Temukan database SQL Server berisi data yang ingin diimpor. Hubungi administrator database untuk informasi koneksi.

  2. Identifikasi tabel atau tampilan yang ingin diimpor. Anda dapat mengimpor beberapa objek dalam sekali operasi impor.

  3. Tinjau data sumber dan ingat pertimbangan berikut ini:

    • Access tidak mendukung lebih dari 255 bidang dalam tabel, sehingga hanya akan mengimpor 255 kolom pertama.

    • Ukuran maksimal database Access adalah 2 gigabyte, minus ruang yang diperlukan untuk objek sistem. Jika database SQL Server berisi banyak tabel yang berukuran besar, Anda mungkin tidak dapat mengimpor semuanya ke satu file .accdb. Dalam hal ini, pertimbangkan untuk menautkan data ke database Access sebagai gantinya.

    • Access tidak secara otomatis membuat hubungan antar tabel terkait di akhir operasi impor. Anda harus membuat hubungan antara tabel-tabel baru dan yang sudah ada secara manual menggunakan opsi di jendela Hubungan. Untuk menampilkan jendela Hubungan:

      • Klik Alat Database > Hubungan.

  4. Identifikasi database Access yang akan menjadi tujuan pengimporan data SQL Server.

    Pastikan Anda memiliki izin yang diperlukan untuk menambahkan data ke database Access. Buat database kosong baru jika tidak ingin menyimpan data ke dalam database yang sudah ada.

  5. Tinjau tabel, jika sudah ada dalam database Access.

    Operasi pengimporan akan membuat tabel dengan nama yang sama seperti objek SQL Server. Jika nama tersebut sudah digunakan, Access akan menambahkan "1" ke nama tabel yang baru, misalnya Kontak1. (Jika Kontak 1 juga sudah digunakan, Access akan membuat Kontak2, dan seterusnya.)

    Catatan: Access tidak pernah menimpa tabel dalam database sebagai bagian dari operasi impor, dan Anda tidak dapat menambahkan data SQL Server ke tabel yang sudah ada.

Mengimpor data

  1. Buka database tujuan.

    Di tab Data Eksternal, dalam grup Impor & Tautan, klik Database ODBC.

  2. Klik Impor data sumber ke tabel baru dalam database saat ini, lalu klik OK.

  3. Dalam kotak dialog Pilih Sumber Data, jika file .dsn yang ingin digunakan sudah ada, klik file tersebut dalam daftar.

    Saya perlu membuat file .dsn baru

    Catatan: Langkah-langkah dalam prosedur ini mungkin sedikit berbeda, tergantung pada perangkat lunak yang diinstal di komputer Anda.

    1. Klik Baru untuk membuat nama sumber data (DSN) baru.

      Panduan Pembuatan Sumber Data Baru akan dimulai.

    2. Dalam panduan, pilih SQL Server dalam daftar driver, lalu klik Berikutnya.

    3. Ketikkan nama file .dsn, atau klik Telusuri untuk menyimpan file ke lokasi lain.

      Catatan: Anda harus memiliki izin penulisan pada folder untuk menyimpan file .dsn tersebut.

    4. Klik Berikutnya, tinjau informasi ringkasan, lalu klik Selesai untuk menyelesaikan panduan.

      Kotak dialog Buat Sumber Data Baru ke SQL Server akan muncul.

    5. Ketikkan deskripsi sumber data dalam kotak Deskripsi. Langkah ini bersifat opsional.

    6. Di bawah SQL Server mana yang ingin Anda sambungkan, dalam kotak Server, ketik atau pilih nama SQL Server yang ingin disambungkan, lalu klik Berikutnya untuk melanjutkan.

    7. Anda mungkin memerlukan informasi dari administrator database SQL Server, seperti harus menggunakan autentikasi Microsoft Windows NT atau autentikasi SQL Server. Klik Berikutnya untuk melanjutkan.

    8. Jika ingin menyambungkan ke database tertentu, pastikan untuk mencentang kotak Ubah database default ke. Kemudian, pilih database yang ingin Anda kerjakan, lalu klik Berikutnya.

    9. Klik Selesai.

    10. Tinjau informasi ringkasan, kemudian klik Uji Sumber Data.

    11. Tinjau hasil uji tersebut, lalu klik OK untuk menutup kotak dialog.

      Jika pengujian berhasil, klik OK lagi, atau klik Batalkan untuk mengubah pengaturan Anda.

  4. Klik OK untuk menutup kotak dialog Pilih Sumber Data.

    Access akan menampilkan kotak dialog Impor Objek.

  5. Di bawah Tabel, klik setiap tabel atau tampilan yang ingin diimpor, kemudian klik OK.

  6. Jika kotak dialog Pilih Pengidentifikasi Rekaman Unik muncul, artinya Access tidak dapat menentukan bidang yang mengidentifikasi setiap baris objek tertentu secara unik. Cukup pilih bidang atau kombinasi bidang yang bersifat unik untuk setiap baris, lalu klik OK. Jika Anda tidak yakin, hubungi administrator database SQL Server.

    Akses akan mengimpor data tersebut. Jika berencana untuk mengulangi operasi impor di lain waktu, simpan langkah pengimporan sebagai spesifikasi impor untuk menjalankannya kembali dengan mudah. Untuk membuat tugas, Microsoft Office Outlook harus sudah terinstal di komputer Anda.

  7. Klik Tutup di bawah Simpan Langkah Pengimporan dalam kotak dialog Dapatkan Data Eksternal - Database ODBC. Access menyelesaikan operasi impor dan menampilkan tabel yang baru di Panel Navigasi.

Jika ingin menyimpan pengimporan sebagai tugas untuk digunakan kembali, lanjutkan ke bagian berikutnya.

Atas Halaman

Menautkan ke data SQL Server

Karena data disimpan dalam tabel, saat Anda menautkan ke tabel atau tampilan dalam database SQL Server, Access akan membuat tabel baru (biasanya disebut dengan tabel tertaut) yang menampilkan struktur dan konten objek sumber. Anda dapat mengubah data di SQL Server maupun dalam tampilan Lembar Data atau tampilan Formulir dari Access. Perubahan yang dibuat pada data di satu lokasi akan ditampilkan dalam data lainnya. Namun, jika ingin membuat perubahan struktural, seperti menghapus atau mengubah kolom, Anda harus melakukannya dari database SQL Server atau proyek Access yang tersambung ke database tersebut. Anda tidak dapat menambahkan, menghapus, atau mengubah bidang dalam tabel tertaut saat sedang bekerja di Access.

Persiapan untuk menautkan

  1. Temukan database SQL Server berisi data yang ingin ditautkan. Hubungi administrator database untuk informasi koneksi.

  2. Identifikasi tabel dan tampilan yang ingin ditautkan. Anda dapat menautkan ke beberapa objek dalam sekali operasi penautan.

  3. Tinjau data sumber dan ingat pertimbangan berikut ini:

    • Access tidak mendukung lebih dari 255 bidang dalam tabel, sehingga tabel tertaut hanya akan menyertakan 255 bidang pertama dari objek yang ditautkan.

    • Kolom yang bersifat baca-saja dalam objek SQL Server akan tetap bersifat demikian di Access.

    • Anda tidak akan dapat menambahkan, menghapus, atau mengubah kolom dalam tabel tertaut di Access.

  4. Identifikasi database Access yang diinginkan untuk membuat tabel tertaut. Pastikan Anda memiliki izin yang diperlukan untuk menambahkan data ke database tersebut. Jika tidak ingin menyimpan data dalam database yang sudah ada, buat database kosong yang baru dengan mengklik tab File, lalu pada tab Baru, klik Database Kosong

  5. Tinjau tabel dalam database Access. Ketika Anda menautkan ke tabel atau tampilan SQL Server, Access akan membuat tabel tertaut dengan nama yang sama seperti objek sumber. Jika nama tersebut sudah digunakan, Access akan menambahkan "1" ke nama tabel tertaut yang baru, misalnya, Kontak1. (Jika Kontak1 juga sudah digunakan, Access akan membuat Kontak2, dan seterusnya.)

  6. Untuk menautkan ke data, buka database tujuan.

  7. Di tab Data Eksternal, dalam grup Impor & Tautan, klik Database ODBC.

  8. Klik Tautkan ke sumber data dengan membuat tabel tertaut, kemudian klik OK.

  9. Dalam kotak dialog Pilih Sumber Data, klik file .dsn yang ingin digunakan, atau klik Baru untuk membuat nama sumber data (DSN) baru.

  10. Dalam kotak dialog Pilih Sumber Data, jika file .dsn yang ingin digunakan sudah ada, klik file tersebut dalam daftar.

    Saya perlu membuat file .dsn baru

    Catatan: Langkah-langkah dalam prosedur ini mungkin sedikit berbeda, tergantung pada perangkat lunak yang diinstal di komputer Anda.

    1. Klik Baru untuk membuat nama sumber data (DSN) baru.

      Panduan Pembuatan Sumber Data Baru akan dimulai.

    2. Dalam panduan, pilih SQL Server dalam daftar driver, lalu klik Berikutnya.

    3. Ketikkan nama file .dsn, atau klik Telusuri untuk menyimpan file ke lokasi lain.

      Catatan: Anda harus memiliki izin penulisan pada folder untuk menyimpan file .dsn tersebut.

    4. Klik Berikutnya, tinjau informasi ringkasan, lalu klik Selesai untuk menyelesaikan Panduan Pembuatan Sumber Data Baru.

      Panduan Pembuatan Sumber Data Baru ke SQL Server akan dimulai.

    5. Dalam panduan, ketikkan deskripsi sumber data di kotak Deskripsi. Langkah ini bersifat opsional.

    6. Di bawah SQL Server mana yang ingin Anda sambungkan, dalam kotak Server, ketik atau pilih nama komputer SQL Server yang ingin disambungkan, lalu klik Berikutnya untuk melanjutkan.

    7. Di halaman panduan ini, Anda mungkin perlu mendapatkan informasi dari administrator database SQL Server, seperti harus menggunakan autentikasi Windows NT atau autentikasi SQL Server. Klik Berikutnya untuk melanjutkan.

    8. Pada halaman panduan berikutnya, Anda mungkin perlu mendapatkan informasi selengkapnya dari administrator database SQL Server. Jika ingin menyambungkan ke database tertentu, pastikan untuk mencentang kotak Ubah database default ke, pilih database SQL Server yang ingin dikerjakan, lalu klik Berikutnya.

    9. Klik Selesai. Tinjau informasi ringkasan, lalu klik Uji Sumber Data.

    10. Tinjau hasil uji tersebut, lalu klik OK untuk menutup kotak dialog Uji Sumber Data ODBC SQL Server.

      Jika pengujian berhasil, klik OK lagi untuk menyelesaikan panduan, atau klik Batal untuk kembali ke panduan dan mengubah pengaturan Anda.

  11. Klik OK.

    Access akan menampilkan kotak dialog Tautkan Tabel.

  12. Di bawah Tabel, klik setiap tabel atau tampilan yang ingin ditautkan, kemudian klik OK.

    1. Jika kotak dialog Pilih Pengidentifikasi Rekaman Unik muncul, artinya Access tidak dapat menentukan bidang yang mengidentifikasi setiap baris data sumber secara unik. Cukup pilih bidang atau kombinasi bidang yang bersifat unik untuk setiap baris, lalu klik OK. Jika Anda tidak yakin, hubungi administrator database SQL Server.

Access menyelesaikan operasi penautan dan menampilkan tabel tertaut yang baru di Panel Navigasi.

Penting: Setiap kali membuka tabel tertaut atau objek sumber, data yang paling baru akan ditampilkan di dalamnya. Namun, perubahan struktural yang dibuat pada objek SQL Server tidak secara otomatis terlihat dalam tabel yang tertaut.

Memperbarui tabel tertaut dengan menerapkan struktur objek SQL Server terbaru

  1. Klik kanan tabel di Panel Navigasi, lalu klik Manajer Tabel Tertaut pada menu pintasan.

  2. Pilih kotak centang di samping setiap tabel tertaut yang ingin Anda perbarui, atau klik Pilih Semua untuk memilih seluruh tabel tertaut.

  3. Klik OK.

    Jika pembaruan berhasil, Access akan menampilkan pesan terkait. Jika tidak, Access akan menampilkan pesan kesalahan.

  4. Klik Tutup untuk menutup Manajer Tabel Tertaut.

Atas Halaman

Apa lagi yang perlu saya ketahui?

Atas Halaman

Bagaimana Access melihat tipe data SQL Server

Karena tipe data Access berbeda dari tipe data SQL Server, Access harus menentukan tipe data yang paling sesuai untuk digunakan pada masing-masing kolom dari setiap tabel atau tampilan SQL Server yang diimpor atau ditautkan. Misalnya, kolom SQL Server dari tipe data bit akan diimpor atau ditautkan ke Access dengan tipe data Ya/Tidak. Contoh lain, kolom SQL Server dari tipe data nvarchar(255) (atau yang lebih kecil) akan diimpor atau ditautkan dengan tipe data Teks, tetapi kolom tipe data nvarchar(256) (atau yang lebih besar) diimpor sebagai bidang Memo di Access. Setelah menyelesaikan operasi pengimporan atau penautan, Anda dapat membuka tabel dalam tampilan Desain dan mengonfirmasi jenis data mana yang ditetapkan oleh Access ke bidangnya. Anda dapat mengubah tipe data bidang dalam tabel yang diimpor. Namun, Anda tidak dapat mengubah tipe data bidang dalam tabel tertaut, kecuali dengan mengubahnya dari database SQL Server sendiri atau dalam proyek Access yang tersambung ke database tersebut.

Tabel berikut ini mencantumkan tipe data utama SQL Server. Kolom kedua dan ketiga memperlihatkan cara Access menginterpretasikan setiap tipe.

Tipe data SQL Server

Tipe data Access

Ukuran bidang Access

bigint

Teks

255

binary( ukuran bidang )

Biner

Sama seperti ukuran bidang SQL Server

bit

Ya/Tidak

char( ukuran bidang ), ketika ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

char( ukuran bidang ), ketika ukuran bidang lebih besar dari 255

Memo

datetime

Tanggal/Waktu

decimal( presisi , skala )

Angka

Desimal (Properti Presisi dan Skala Access sesuai dengan presisi dan skala SQL Server.)

float

Angka

Ganda

image

Objek OLE

int

Angka

Bilangan Bulat Panjang

money

Mata Uang

nchar ( ukuran bidang ), ketika ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

nchar ( ukuran bidang ), ketika ukuran bidang lebih besar dari 255

Memo

ntext

Memo

numeric( presisi , skala )

Angka

Desimal (Properti Presisi dan Skala Access sesuai dengan presisi dan skala SQL Server.)

nvarchar ( ukuran bidang ), ketika ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

nvarchar ( ukuran bidang ), ketika ukuran bidang lebih besar dari 255

Memo

nvarchar(MAX)

Memo

real

Angka

Tunggal

smalldatetime

Tanggal/Waktu

smallint

Angka

Integer

smallmoney

Mata Uang

sql_variant

Teks

255

text

Memo

timestamp

Biner

8

tinyint

Angka

Byte

uniqueidentifier

Angka

ID Replikasi

varbinary

Biner

Sama seperti ukuran bidang SQL Server

varbinary(MAX)

Objek OLE

varchar( ukuran bidang ), ketika ukuran bidang kurang dari atau sama dengan 255

Teks

Sama seperti ukuran bidang SQL Server

varchar( ukuran bidang), ketika ukuran bidang lebih besar dari 255

Memo

varchar(MAX)

Memo

xml

Memo

Atas Halaman

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×