Mengimpor XML data

Penting: Artikel ini adalah terjemahan mesin, lihat penafian. Temukan versi bahasa Inggris artikel di sini sebagai rujukan Anda.

Jika Anda sebelumnya telah dibuat peta XML, Anda bisa menggunakannya untuk mengimpor XML data ke sel yang dipetakan, tapi juga ada beberapa metode dan perintah untuk mengimpor data XML tanpa peta XML.

Jika Anda memiliki peta XML, lakukan ini untuk mengimpor XML data ke sel yang dipetakan:

  1. Dalam peta XML, pilih salah satu sel yang dipetakan.

  2. Klik pengembang > impor.

    Jika Anda tidak melihat tab pengembang , lihat memperlihatkan tab pengembang.

  3. Di kotak dialog Impor XML , temukan dan pilih file data XML (.xml) yang ingin Anda impor, lalu klik impor.

Cara lain untuk mengimpor XML data

Untuk informasi selengkapnya tentang masalah, lihat masalah umum dalam mengimpor XML data di akhir artikel ini.

Mengimpor XML data file sebagai tabel XML

  1. Klik pengembang > impor.

    Jika Anda tidak melihat tab pengembang , lihat memperlihatkan tab pengembang.

  2. Di kotak dialog Impor XML , temukan dan pilih file data XML (.xml) yang ingin Anda impor, lalu klik impor.

    Jika XML data file tidak merujuk ke skema, Excel menyimpulkan skema dari XML data file.

  3. Dalam kotak dialog Impor Data , lakukan salah satu hal berikut ini:

    1. Pilih tabel XML di lembar kerja yang sudah ada untuk mengimpor konten XML data file ke tabel XML di lembar kerja Anda di lokasi sel tertentu.

    2. Pilih tabel XML di lembar kerja baru untuk mengimpor konten file ke tabel XML dalam lembar kerja baru yang dimulai pada sel A1. Skema XML data file ditampilkan di panel tugas Sumber XML .

  4. Jika XML data file tidak merujuk ke skema, lalu Excel menyimpulkan skema dari XML data file.

  5. Untuk mengontrol perilaku data XML (seperti pengikatan data, format, dan tata letak), klik properti, yang menampilkan kotak dialog properti peta XML . Sebagai contoh, data yang sudah ada di dalam rentang yang dipetakan akan ditimpa ketika Anda mengimpor data secara default, tetapi Anda bisa mengubah ini.

Mengimpor file data XML

  1. Pilih sel yang dipetakan untuk mengimpor beberapa file XML ke dalam satu set sel yang dipetakan.

    Jika Anda ingin mengimpor beberapa file XML ke beberapa set sel yang dipetakan, klik sel di mana saja pada lembar kerja yang tidak dipetakan.

  2. Klik pengembang > impor.

    Jika Anda tidak melihat tab pengembang , lihat memperlihatkan tab pengembang.

  3. Dalam kotak dialog Impor XML , temukan dan pilih file data XML (.xml) yang ingin Anda impor.

    • Jika file yang berdekatan, tekan Shift, dan klik pertama dan terakhir file dalam daftar. Semua data dari file XML yang akan diimpor dan ditambahkan ke sel yang dipetakan.

    • Jika file yang tidak berdekatan, tekan dan tahan Ctrl, dan klik setiap file yang ingin Anda impor dalam daftar.

  4. Klik Impor.

    Jika Anda memilih file yang tidak bersebelahan, kotak dialog mengimpor < namafile > .xml muncul. Pilih peta XML yang terkait dengan file data XML yang sedang Anda impor untuk setiap file.

    Untuk menggunakan peta tunggal untuk semua file yang dipilih yang belum tidak diimpor, pilih gunakan peta XML ini untuk semua file yang dipilih dari skema ini.

Mengimpor file data XML beberapa sebagai data eksternal

Untuk mengimpor beberapa file XML yang menggunakan ruang nama sama tapi skema XML yang berbeda, Anda bisa menggunakan perintah Dari XML impor Data . Excel membuat peta XML yang unik untuk setiap file data XML yang Anda impor.

Catatan: Jika Anda mengimpor beberapa file XML yang tidak menentukan ruang nama, file XML ini diperlakukan seolah-olah mereka menggunakan ruang nama yang sama.

  1. Jika Anda menggunakan Excel dengan langganan Office 365, klik Data > Dapatkan Data > Dari File > Dari XML.

    Jika Anda menggunakan Excel 2016 atau versi yang lebih lama, klik Data > Dari sumber lain > Dari impor Data XML.

  2. Masuk ke drive, folder, atau lokasi Internet yang memiliki file data XML (.xml) yang ingin Anda impor.

  3. Pilih file dan klik Buka.

  4. Dalam kotak dialog Impor Data , lakukan salah satu hal berikut ini:

    • Tabel XML di lembar kerja yang sudah ada    Konten file yang diimpor ke tabel XML yang baru dalam lembar kerja baru. Jika XML data file tidak merujuk ke skema, Excel menyimpulkan skema dari XML data file.

    • Lembar kerja yang ada    XML data yang diimpor dalam dua dimensi tabel dengan baris dan kolom yang memperlihatkan Tag XML sebagai judul kolom, dan data dalam baris di bawah judul kolom. Elemen pertama (node akar) digunakan seperti judul dan ditampilkan di lokasi sel tertentu. Sisa Tag diurutkan menurut abjad di baris kedua. Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan peta XML.

    • Lembar kerja baru    Excel menambahkan lembar kerja baru ke buku kerja Anda dan secara otomatis menempatkan XML data di sudut kiri atas lembar kerja baru. Jika XML data file tidak merujuk ke skema, Excel menyimpulkan skema dari XML data file.

  5. Untuk mengontrol perilaku data XML, seperti pengikatan data, format, dan tata letak, klik properti, yang menampilkan kotak dialog properti peta XML . Sebagai contoh, data yang sudah ada di dalam rentang yang dipetakan ditimpa ketika Anda mengimpor data secara default, tetapi Anda bisa mengubah ini.

Membuka file data XML untuk mengimpor data tersebut

  1. Klik File > Buka.

    Jika Anda menggunakan Excel 2007, klik Tombol Microsoft Office Gambar tombol Office > buka.

  2. Dalam kotak dialog buka , klik drive, folder, atau lokasi Internet yang memiliki file yang ingin Anda buka.

  3. Pilih file dan klik Buka.

  4. Jika kotak dialog Impor XML muncul, file yang Anda buka mengacu ke satu atau beberapa Extensible Stylesheet Language transformasi (XSLT) lembar gaya, sehingga Anda bisa mengklik salah satu opsi berikut ini:

    • Buka file tanpa menerapkan lembar gaya    data XML yang diimpor dalam dua dimensi tabel dengan baris dan kolom yang memperlihatkan Tag XML sebagai judul kolom, dan data dalam baris di bawah judul kolom. Elemen pertama (node akar) digunakan seperti judul dan ditampilkan di lokasi sel tertentu. Sisa Tag diurutkan menurut abjad di baris kedua. Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan peta XML.

    • Buka file dengan berikut lembar gaya diterapkan (pilih satu)    Pilih lembar gaya yang ingin Anda terapkan, dan lalu klik OK. XML data diformat sesuai dengan lembar gaya yang Anda pilih.

      Catatan: XML data dibuka sebagai baca-saja di Excel sehingga Anda tidak sengaja menyimpan file sumber asli Anda dalam format file buku kerja Excel makro aktif (.xlsm). Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan peta XML.

  5. Jika kotak dialog Buka XML muncul, XML file tidak memiliki referensi lembar gaya XSLT apa pun. Untuk membuka file, klik salah satu opsi berikut ini:

    • Klik sebagai tabel XML untuk membuat tabel XML dalam buku kerja baru.

      Konten file diimpor ke tabel XML. Jika XML data file tidak merujuk ke skema, Excel menyimpulkan skema dari XML data file.

    • Klik sebagai buku kerja baca-saja.

      XML data yang diimpor dalam dua dimensi tabel dengan baris dan kolom yang memperlihatkan Tag XML sebagai judul kolom, dan data dalam baris di bawah judul kolom. Elemen pertama (node akar) digunakan seperti judul dan ditampilkan di lokasi sel tertentu. Sisa Tag diurutkan menurut abjad di baris kedua. Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan peta XML.

      XML data dibuka sebagai baca-saja di Excel sehingga Anda tidak sengaja menyimpan file sumber asli Anda dalam format file buku kerja Excel makro aktif (.xlsm). Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan peta XML.

    • Klik gunakan panel tugas sumber XML.

      Skema XML data file ditampilkan di panel tugas Sumber XML . Anda bisa menyeret elemen skema ke lembar kerja untuk memetakan elemen-elemen tersebut ke lembar kerja.

      Jika XML data file tidak merujuk ke skema, Excel menyimpulkan skema dari XML data file.

Masalah umum dalam mengimpor XML data

Excel menampilkan kotak dialog Impor XML kesalahan saat tidak bisa memvalidasi data berdasarkan peta XML. Dalam kotak dialog ini, klik detail untuk informasi tambahan tentang masing-masing kesalahan. Tabel berikut mencantumkan beberapa kesalahan impor umum:

Kesalahan

Apa yang terjadi

Skema gagal validasi

Ketika Anda mengklik validasi data berdasarkan skema untuk impor dan ekspor di kotak dialog Properti peta XML , data yang diimpor, tapi data tidak divalidasi terhadap peta XML yang ditentukan.

Beberapa data diimpor sebagai teks

Beberapa atau semua data yang Anda impor dikonversi dari tipe data yang menyatakan ke teks. Untuk menggunakan data ini dalam penghitungan, Anda harus mengubah data dari teks menjadi angka atau tanggal. Sebagai contoh, nilai tanggal yang dikonversi menjadi teks tidak akan berfungsi seperti yang dimaksudkan dalam fungsi YEAR hingga Anda mengubahnya menjadi tipe data tanggal. Excel mengonversi data ke teks ketika:

  • Data yang berada dalam format Excel tidak mendukung.

  • Data yang tidak kompatibel dengan Excel internal representasi XSD tipe data. Untuk memperbaiki masalah ini, centang setiap deklarasi tipe data untuk memastikan bahwa XML data valid berdasarkan skema XML.

XML urai kesalahan

XML parser tidak bisa membuka file XML yang ditentukan. Pastikan bahwa XML file tidak ada kesalahan sintaks dan XML dibentuk.

Tidak bisa menemukan peta XML yang terkait dengan data

Masalah ini bisa terjadi saat Anda memilih lebih dari satu file data XML untuk mengimpor, dan Excel tidak bisa menemukan peta XML yang cocok untuk salah satu file. Untuk file yang bernama di bilah judul di kotak dialog, mengimpor skema yang tepat terlebih dahulu, dan lalu Cobalah mengimpor file lagi.

Tabel XML tidak bisa diubah ukurannya untuk mengakomodasi data

Anda mencoba menambahkan baris dengan mengimpor atau menambahkan data ke tabel XML, tetapi tidak ada ruang untuk tabel untuk memperluas. Tabel XML hanya bisa memperluas dari bawah ke bawah. Misalnya, mungkin ada objek, seperti gambar atau tabel yang lain, tepat di bawah tabel XML yang mencegah memperluas tabel XML. Atau, untuk tabel XML untuk memperluas, akan lebih dari Excel batas baris 1,048,576. Untuk memperbaiki masalah ini, menyusun ulang tabel dan objek pada lembar kerja untuk memperbolehkan tabel XML untuk memperluas dari bawah ke bawah.

File XML yang ditentukan tidak merujuk ke skema

Anda mencoba membuka file XML tidak merujuk ke skema XML. Untuk bekerja dengan data XML yang berada dalam file, Excel kebutuhan skema berdasarkan konten XML file. Jika skema yang tidak benar atau sudah cukup, menghapusnya dari buku kerja Anda. Lalu membuat file skema XML dan mengedit XML data file sehingga XML data file yang merujuk ke skema. Untuk informasi selengkapnya, lihat elemen peta XML ke sel dalam peta XML.

Catatan: Anda tidak bisa mengekspor skema Excel disimpulkan sebagai terpisah skema file data XML (.xsd). Meskipun ada editor skema XML dan metode lain untuk membuat file skema XML, Anda mungkin tidak memiliki akses yang mudah untuk mereka atau mengetahui cara menggunakannya.

Ikuti langkah-langkah ini untuk menghapus skema yang dibuat Excel dari buku kerja Anda:

  1. Klik Pengembang > Sumber.

    Perintah XML pada tab Pengembang

    Jika Anda tidak melihat tab pengembang , lihat memperlihatkan tab pengembang.

  2. Di panel tugas Sumber XML , klik Peta XML.

  3. Dalam kotak dialog Peta XML , klik Excel peta XML yang dibuat, dan klik Hapus.

Mengimpor file XML yang menggunakan ruang nama sama tapi skema yang berbeda tidak berfungsi sebagaimana diharapkan

Ketika Anda bekerja dengan beberapa file data XML dan skema XML, Anda biasanya membuat peta XML untuk setiap skema, memetakan elemen yang Anda inginkan, dan lalu mengimpor file data XML setiap ke peta XML yang sesuai. Menggunakan perintah impor untuk membuka file XML dengan ruang-nama yang sama, Anda hanya bisa menggunakan satu skema XML. Saat Anda menggunakan perintah ini untuk membuka file XML yang menggunakan ruang nama sama tapi skema yang berbeda, Anda bisa mendapatkan hasil yang tidak diharapkan. Sebagai contoh, data mungkin tertimpa, atau file yang tidak akan terbuka.

Untuk mengimpor beberapa file XML yang menggunakan ruang nama sama tapi skema XML yang berbeda, coba gunakan perintah Dari XML impor Data (klik Data > Dari sumber lain). Perintah ini memungkinkan beberapa file XML dengan ruang nama sama untuk menggunakan beberapa skema XML. Excel membuat peta XML yang unik untuk setiap file data XML yang ingin Anda impor.

Catatan: Jika Anda mengimpor beberapa file XML yang tidak menentukan ruang nama, file XML ini diperlakukan seolah-olah mereka menggunakan ruang nama yang sama.

Memperlihatkan tab Pengembang

Jika Anda tidak melihat tab Pengembang, lakukan hal berikut untuk menampilkannya:

  • Pada Excel 2013 dan Excel 2010:

    1. Klik File > Opsi.

    2. Klik kategori Kustomisasi Pita.

    3. Di bawah Tab Utama, centang kotak Pengembang, dan klik OK.

  • Di Excel 2007:

    1. Klik Microsoft Office Button Gambar tombol Office > Opsi Excel.

    2. Klik kategori Populer.

    3. Di bawah Opsi terbaik untuk bekerja dengan Excel, centang kotak Perlihatkan tab Pengembang di Pita, dan klik OK.

Catatan: Penafian Terjemahan Mesin: Artikel ini telah diterjemahan oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan terjemahan mesin ini untuk membantu pengguna yang bukan penutur bahasa Inggris agar dapat menikmati konten tentang produk, layanan, dan teknologi Microsoft. Karena artikel ini diterjemahkan oleh mesin, mungkin akan terdapat kesalahan kosa kata, sintaksis, atau tata bahasa.

Lihat Juga

Atas tampilan XML di Excel

Elemen peta XML ke sel dalam peta XML

Ekspor XML data

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×