Menambahkan koneksi data ke daftar atau pustaka dokumen SharePoint

Penting: Artikel ini adalah terjemahan mesin, lihat penafian. Temukan versi bahasa Inggris artikel di sini sebagai rujukan Anda.

Anda bisa menambahkan satu atau beberapa koneksi data sekunder ke Templat formulir yang bisa salah satu kueri data dari pustaka dokumen atau daftar, atau mengirimkan data ke pustaka dokumen di server yang menjalankan Microsoft Windows SharePoint Services.

Di artikel ini

Gambaran Umum

Sebelum Anda mulai

Menambahkan koneksi data kueri

Menambahkan koneksi data kirim

Gambaran umum

Koneksi data sekunder adalah koneksi data apa pun ke sumber data eksternal yang Anda tambahkan ke Templat formulir. Koneksi data ini berbeda dari koneksi data utama yang dibuat saat Anda mendesain Templat formulir yang didasarkan pada database, Layanan Web, atau pengaturan di pustaka koneksi. Anda menambahkan koneksi data sekunder hanya jika Anda tidak bisa kueri atau mengirim data melalui koneksi data utama.

Saat Anda menambahkan koneksi data sekunder untuk Templat formulir yang kueri data, Microsoft Office InfoPath membuat sekunder sumber data dengan bidang data dan grup yang terkait dengan cara data disimpan di pustaka dokumen atau daftar. Hubungan antara sumber data eksternal dan sumber data di templat formulir.

Karena struktur data di sumber data sekunder harus cocok dengan cara data disimpan dalam pustaka dokumen atau daftar, Anda tidak bisa mengubah bidang yang ada atau grup di sumber data sekunder.

Koneksi data kueri data dari SharePoint dokumen pustaka atau daftar secara otomatis mengembalikan semua item dalam pustaka dokumen atau daftar. Jika Anda menggunakan koneksi data kueri untuk mengisi daftar kotak, kotak Daftar turun bawah, atau kontrol kotak kombo dan kontrol berisi terlalu banyak item atau Anda ingin menampilkan hanya item yang memenuhi kriteria tertentu, Anda bisa menggunakan filter dalam kontrol untuk membatasi jumlah item. Temukan link untuk informasi selengkapnya tentang memfilter data yang ditampilkan di kontrol di bagian Lihat juga .

Anda juga bisa mengonfigurasi setiap koneksi data kueri untuk menyimpan hasil sehingga pengguna memiliki akses ke data saat bentuk yang tidak tersambung ke jaringan. Bergantung pada jenis data, Anda mungkin ingin menampilkan hasil kueri hanya ketika pengguna tersambung ke jaringan.

Catatan Keamanan : Jika Anda menggunakan koneksi data sekunder untuk mengambil data sensitif dari sumber data eksternal, Anda mungkin ingin menonaktifkan fitur ini untuk membantu melindungi data penggunaan seandainya komputer yang hilang atau dicuri. Jika Anda menonaktifkan fitur ini, data akan tersedia hanya jika pengguna tersambung ke jaringan.

Saat Anda menambahkan koneksi data kueri ke Templat formulir, secara default formulir yang didasarkan pada Templat formulir ini menggunakan koneksi data saat dibuka oleh pengguna. Anda juga bisa mengonfigurasi Templat formulir Anda untuk menggunakan koneksi data kueri dalam salah satu cara berikut ini:

  • Tambahkan aturan    Anda dapat mengonfigurasi aturan untuk menggunakan koneksi data kueri saat terjadi kondisi di aturan.

  • Tombol Tambahkan    Anda bisa menambahkan tombol ke Templat formulir yang bisa diklik pengguna untuk mendapatkan data dengan menggunakan koneksi data kueri.

  • Gunakan kode kustom    Jika Anda tidak bisa menambahkan aturan atau tombol, Anda bisa menggunakan kode kustom untuk mendapatkan data dengan menggunakan koneksi data kueri. Menggunakan kode kustom memerlukan pengembang untuk membuat kode kustom.

Saat Anda menambahkan koneksi data kirim ke Templat formulir Anda, Anda bisa mengonfigurasi Templat formulir untuk memperbolehkan pengguna untuk mengirimkan formulir data, dan Anda bisa mengonfigurasi opsi Kirim untuk formulir yang didasarkan pada Templat formulir Anda.

Atas Halaman

Sebelum Anda mulai

Sebelum Anda menambahkan koneksi data sekunder ke Templat formulir Anda, Anda memerlukan informasi berikut ini dari administrator situs Anda:

  • Lokasi situs SharePoint dan izin yang diperlukan untuk mengaksesnya

  • Verifikasi bahwa situs dikonfigurasikan agar pengguna Anda bisa mendapatkan data dari pustaka dokumen atau daftar

  • Verifikasi bahwa Anda bisa menyimpan data dari pustaka dokumen atau daftar di komputer pengguna Anda untuk penggunaan offline

Atas Halaman

Menambahkan koneksi data kueri

Untuk memperbolehkan pengguna untuk kueri data dari pustaka dokumen atau daftar di situs yang berada di server yang menjalankan Microsoft Windows SharePoint Services, Anda perlu melakukan hal berikut ini di Templat formulir:

  1. Menambahkan koneksi data sekunder.

  2. Mengonfigurasi Templat formulir untuk menggunakan koneksi data sekunder.

Langkah 1: Menambahkan koneksi data sekunder

  1. Pada menu alat , klik Koneksi Data.

  2. Dalam kotak dialog Koneksi Data , klik Tambahkan.

  3. Di panduan koneksi Data, klik membuat koneksi baru ke, klik terima data, dan lalu klik berikutnya.

  4. Pada halaman berikutnya panduan, klik Daftar atau pustaka SharePoint, dan lalu klik berikutnya.

    Halaman di Panduan Koneksi Data untuk menentukan situs SharePoint sebagai sumber data.

  5. Pada halaman berikutnya panduan, ketikkan URL situs SharePoint dengan dokumen pustaka atau daftar, dan lalu klik berikutnya. Sebagai contoh, untuk menggunakan daftar dokumen di situs SharePoint dengan URL http://www.adventureworks.com/EmployeeList, Anda ketik http://www.adventureworks.com/EmployeeList.

  6. Pada halaman berikutnya panduan tersebut, di daftar pilih daftar atau pustaka , klik Daftar atau Pustaka yang ingin Anda gunakan, dan lalu klik berikutnya.

  7. Pada halaman berikutnya panduan, pilih kotak centang di samping nilai yang ingin Anda terima. Jika Templat formulir yang akan diterbitkan ke pustaka dokumen, dan Anda ingin formulir yang didasarkan pada Templat formulir ini untuk mendapatkan metadata tentang formulir, pilih kotak centang sertakan data untuk formulir aktif saja .

  8. Klik Berikutnya.

  9. Jika Anda ingin menyimpan hasil kueri dengan Templat formulir, pilih kotak centang Simpan salinan data di Templat formulir . Memilih kotak centang ini menyimpan hasil kueri di Templat formulir. Karena data yang disimpan di Templat formulir, data tersedia di formulir yang pengguna isi, bahkan jika komputer mereka tidak tersambung ke jaringan.

    Catatan Keamanan : Memilih kotak centang ini menyimpan hasil kueri di Templat formulir. Karena data yang disimpan di Templat formulir, tersedia di formulir yang pengguna isi, bahkan jika komputer mereka tidak tersambung ke jaringan. Jika Anda mendapatkan data sensitif dari koneksi data ini, Anda mungkin ingin menonaktifkan fitur ini untuk membantu melindungi data seandainya komputer yang hilang atau dicuri.

  10. Klik Berikutnya.

  11. Pada halaman berikutnya panduan tersebut, dalam kotak Masukkan nama untuk koneksi data ini , ketikkan nama deskriptif untuk sambungan data sekunder ini. Ini adalah nama yang muncul di daftar sumber Data di panel tugas sumber Data . Jika Anda ingin kueri ini untuk berjalan secara otomatis setiap kali formulir dibuka oleh pengguna, pilih kotak centang secara otomatis mengambil data saat formulir dibuka .

Langkah 2: Mengonfigurasi Templat formulir untuk menggunakan koneksi data sekunder

Jika Anda ingin formulir yang didasarkan pada Templat formulir Anda untuk menggunakan koneksi data ini setelah pengguna membuka formulir, Anda bisa menambahkan aturan untuk Templat formulir yang menggunakan koneksi data ini dalam kondisi tertentu, atau Anda bisa menambahkan tombol ke Templat formulir yang bisa diklik pengguna untuk menggunakan koneksi data.

Menambahkan aturan

Anda bisa menambahkan aturan untuk Templat formulir untuk mendapatkan data dari koneksi data kueri setiap kali kondisi untuk aturan terpenuhi. Prosedur berikut ini mengasumsikan bahwa Anda telah membuat koneksi data kueri untuk Templat formulir Anda, dan bahwa Anda telah mengonfigurasi kontrol pada Templat formulir Anda untuk menampilkan data dari koneksi data tersebut.

  1. Jika Templat formulir memiliki beberapa tampilan, klik nama tampilan pada menu tampilan untuk masuk ke tampilan dengan kontrol tempat Anda ingin menampilkan data dari sumber data sekunder.

  2. Klik ganda kontrol yang ingin Anda Tampilkan hasil kueri.

  3. Klik tab Data.

  4. Di bawah aturan validasi dan, klik aturan.

  5. Dalam kotak dialog aturan , klik Tambahkan.

  6. Dalam kotak nama , ketikkan nama untuk aturan.

  7. Untuk menentukan kondisi saat aturan harus berjalan, klik Atur kondisi, dan lalu masukkan kondisi. Aturan yang akan berjalan saat terjadi kondisi. Jika Anda tidak menentukan kondisi, aturan akan berjalan setiap kali pengguna mengubah nilai dalam kontrol, dan lalu menggerakkan kursor miliknya menjauh dari kontrol tersebut.

  8. Klik Tambahkan tindakan.

  9. Di daftar tindakan , klik kueri menggunakan koneksi data.

  10. Di daftar koneksi Data , klik koneksi data kueri yang ingin Anda gunakan, dan lalu klik OK untuk menutup setiap kotak dialog buka.

  11. Untuk menguji perubahan, klik Pratinjau pada toolbar Standar, atau tekan CTRL+SHIFT+B.

Menambahkan tombol

Anda bisa menambahkan kontrol tombol ke Templat formulir yang bisa diklik pengguna Anda untuk menggunakan koneksi data kueri ini. Prosedur berikut ini mengasumsikan bahwa Anda telah membuat koneksi data kueri untuk Templat formulir Anda.

  1. Jika Templat formulir memiliki beberapa tampilan, klik nama tampilan pada menu tampilan untuk masuk ke tampilan dengan kontrol tempat Anda ingin menampilkan data dari sumber data sekunder.

  2. Jika panel tugas Kontrol tidak terlihat, klik Kontrol Lainnya pada menu Sisipkan, atau tekan ALT+I, C.

  3. Seret kontrol tombol ke Templat formulir Anda.

  4. Klik ganda tombol kontrol yang baru saja Anda tambahkan ke Templat formulir Anda.

  5. Klik tab umum .

  6. Di daftar tindakan , klik Refresh.

  7. Dalam kotak Label , ketikkan nama yang Anda inginkan muncul pada tombol di Templat formulir Anda.

  8. Klik Pengaturan.

  9. Dalam kotak dialog Refresh , klik salah satu sumber data sekunder.

  10. Di daftar pilih sumber data sekunder , klik sumber data sekunder yang terkait dengan koneksi data kueri, dan lalu klik OK untuk menutup setiap kotak dialog buka.

  11. Untuk menguji perubahan, klik Pratinjau pada toolbar Standar, atau tekan CTRL+SHIFT+B.

Atas Halaman

Menambahkan koneksi data kirim

Untuk memperbolehkan pengguna untuk mengirimkan formulir yang didasarkan pada Templat formulir Anda ke pustaka dokumen, Anda perlu melakukan hal berikut ini:

  1. Menambahkan koneksi data sekunder yang mengirimkan data ke Templat formulir Anda.

  2. Mengonfigurasi Templat formulir untuk memperbolehkan pengguna Anda untuk mengirim data formulir ke pustaka dokumen.

Langkah 1: Menambahkan koneksi data sekunder

  1. Pada menu alat , klik Koneksi Data.

  2. Dalam kotak dialog Koneksi Data , klik Tambahkan.

  3. Di panduan koneksi Data, klik membuat koneksi baru ke, klik kirim data, dan lalu klik berikutnya.

  4. Di bawah bagaimana Anda ingin mengirim data Anda, klik ke pustaka dokumen di situs SharePoint, dan lalu klik berikutnya.

  5. Di panduan koneksi Data, dalam kotak pustaka dokumen , ketikkan URL pustaka dokumen SharePoint.

  6. Dalam kotak nama File , ketikkan nama yang akan digunakan untuk mengidentifikasi formulir di pustaka dokumen.

    Tips: Anda juga bisa menggunakan rumus untuk memastikan bahwa setiap nama formulir unik.

    Bagaimana?

    1. Klik sisipkan rumus Tombol Rumus .

    2. Dalam kotak dialog Sisipkan rumus , lakukan salah satu hal berikut ini:

      • Untuk menggunakan bidang dalam rumus, klik sisipkan bidang atau grup, klik bidang yang ingin Anda gunakan dalam kotak dialog pilih bidang atau grup , dan lalu klik OK.

      • Untuk menggunakan fungsi dalam rumus, klik Sisipkan fungsi, pilih fungsi yang ingin Anda gunakan dalam kotak dialog Sisipkan fungsi , dan lalu klik OK.

        Tips: Jika fungsi memerlukan parameter, pilih fungsi dalam kotak dialog Sisipkan fungsi , klik OK dan lalu, dalam kotak rumus dalam kotak dialog Sisipkan rumus , klik ganda fungsi yang Anda tambahkan, dan klik bidang atau grup. Temukan link untuk informasi selengkapnya tentang fungsi di bagian Lihat juga .

      • Untuk menyisipkan nilai atau operator matematika ke rumus, ketik simbol operasi matematika atau nilai dalam kotak rumus .

    Operasi

    Simbol

    Tambahkan

    +

    Kurangi

    -

    Kalikan

    *

    Bagi

    /

    • Catatan: Jika rumus Anda menggunakan operator pembagian (/), pastikan bahwa ada spasi sebelum dan sesudah pembagian operator. Jika operator pembagian tidak memiliki spasi sebelum dan sesudah, InfoPath mungkin menafsirkan "/" pemisah untuk XPath lokasi langkah-langkah dan bukan operator pembagian.

    • Untuk memeriksa rumus untuk sintaks yang benar, dalam kotak dialog Sisipkan rumus , klik Memverifikasi rumus.

      Temukan link untuk informasi selengkapnya tentang rumus di bagian Lihat juga .

  7. Untuk menimpa formulir apa pun yang sudah ada di pustaka dokumen dengan nama yang sama, pilih kotak centang Perbolehkan menimpa jika file ada .

  8. Klik Berikutnya.

  9. Pada halaman berikutnya panduan tersebut, dalam kotak Masukkan nama untuk koneksi data ini , ketikkan nama deskriptif untuk mengirimkan koneksi data.

Setelah Anda menambahkan sekunder mengirimkan koneksi data, Anda harus mengonfigurasi Templat formulir Anda untuk memungkinkan pengguna untuk mengirim data formulir dengan menggunakan ini mengirimkan koneksi data.

Langkah 2: Aktifkan mengirimkan pada Templat formulir

Saat Anda mengonfigurasi Templat formulir untuk memperbolehkan pengguna untuk mengirimkan formulir data, InfoPath menambahkan tombol kirim pada toolbar standar dan kirim perintah pada menu File pada formulir. Anda juga bisa mengkustomisasi opsi Kirim untuk Templat formulir Anda dalam cara-cara berikut ini:

  • Mengubah teks yang muncul pada tombol kirim .

  • Mengubah pintasan keyboard untuk tombol kirim .

  • Membuat pesan kustom untuk menampilkan untuk pengguna Anda saat mereka mengirim formulir mereka.

  • Menentukan apakah ingin biarkan formulir terbuka, tutup formulir, atau buka formulir kosong lain setelah formulir dikirimkan.

  • Pada menu alat , klik Opsi mengirimkan.

  • Dalam kotak dialog Opsi mengirimkan , pilih kotak centang Perbolehkan pengguna untuk mengirim formulir ini , klik kirim data formulir ke tujuan tunggal dan lalu, di daftar, klik pustaka dokumen SharePoint.

  • Di daftar pilih koneksi data untuk kirim , klik nama koneksi kirim data ke pustaka SharePoint.

    1. Untuk mengubah nama tombol kirim yang muncul pada Bar alat standar dan perintah kirim yang muncul pada File menu saat pengguna mengisi formulir, ketikkan nama baru di kotak keterangan di dalam kotak dialog Opsi mengirimkan .

      Tips: Jika Anda ingin menetapkan pintasan keyboard untuk tombol dan perintah, ketik simbol ampersand (&) sebelum karakter yang ingin Anda gunakan sebagai pintasan keyboard. Sebagai contoh, untuk menetapkan ALT + B sebagai pintasan keyboard untuk tombol kirim dan perintah, ketik Su & bmit.

  • Jika Anda tidak ingin orang-orang untuk menggunakan perintah kirim atau tombol kirim pada toolbar standar saat mereka mengisi formulir Anda, kosongkan kotak centang Perlihatkan kirim item menu dan toolbar tombol Kirim .

    1. Secara default, setelah pengguna mengirimkan formulir, InfoPath membuat formulir terbuka dan menampilkan pesan untuk menunjukkan jika formulir berhasil dikirim. Untuk mengubah perilaku default, klik tingkat lanjut, dan lalu lakukan salah satu hal berikut ini:

      • Tutup formulir atau membuat formulir kosong baru setelah pengguna mengirimkan formulir selesai, klik opsi yang Anda inginkan di daftar setelah mengirim .

      • Untuk membuat pesan kustom untuk menunjukkan jika formulir berhasil dikirim, pilih kotak centang gunakan kustom pesan , dan lalu ketik pesan Anda dalam kotak di keberhasilan dan kegagalan .

        Tips: Gunakan pesan di kotak di kegagalan untuk memberi tahu pengguna apa yang harus dilakukan jika mereka tidak bisa mengirim formulir mereka. Misalnya, Anda dapat menyarankan bahwa pengguna menyimpan bentuk dan menghubungi seseorang untuk instruksi lebih lanjut.

      • Jika Anda tidak ingin menampilkan pesan setelah pengguna mengirimkan formulir, kosongkan kotak centang Perlihatkan pesan keberhasilan dan kegagalan .

Atas Halaman

Catatan: Penafian Terjemahan Mesin: Artikel ini telah diterjemahan oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan terjemahan mesin ini untuk membantu pengguna yang bukan penutur bahasa Inggris agar dapat menikmati konten tentang produk, layanan, dan teknologi Microsoft. Karena artikel ini diterjemahkan oleh mesin, mungkin akan terdapat kesalahan kosa kata, sintaksis, atau tata bahasa.

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×