Membuat tabel dan menambahkan bidang

Membuat tabel dan menambahkan bidang

Ketika membuat database Access, Anda menyimpan data dalam tabel, daftar berbasis subjek berisi baris dan kolom. Sebagai contoh, Anda dapat membuat tabel Kontak untuk menyimpan daftar nama, alamat, dan nomor telepon, atau tabel Produk untuk menyimpan informasi tentang produk. Artikel ini menjelaskan tentang cara membuat tabel, menambahkan bidang ke tabel, mengatur kunci utama tabel, dan cara mengatur properti bidang dan tabel.

Sebelum membuat tabel dan menambahkan bidang, pastikan Anda paham konsep yang mendasarinya. Untuk informasi selengkapnya, lihat Pengenalan tabel.

Di artikel ini

Membuat tabel
Membuat dalam database baru
Membuat dalam database yang sudah ada
Mengimpor atau menautkan
— — Menggunakan data eksternal
— — Menggunakan situs SharePoint
— — Menggunakan layanan Web
Mengatur properti tabel
Menyimpan tabel

Menetapkan kunci primer
Menentukan bidang yang akan digunakan
Menetapkan atau mengubah kunci primer
Menghapus kunci primer

Memindahkan bidang

Menambahkan bidang
Menambahkan dengan memasukkan data
Menambahkan menggunakan templat bidang
Mengatur properti bidang
Mengatur dalam tampilan Lembar Data
— — Mengganti nama bidang
— — Mengubah tipe data
— — Mengubah format
— — Mengatur properti lainnya
Mengatur properti dalam tampilan Desain
— — Mengubah tipe data
— — Mengatur properti lainnya

Membuat tabel

Database sederhana, seperti daftar kontak, mungkin hanya menggunakan satu tabel. Namun, jika banyak database mungkin menggunakan beberapa tabel. Saat membuat database baru, Anda membuat file baru pada komputer yang bertindak sebagai wadah untuk semua objek dalam database, termasuk dalam tabel.

Anda dapat membuat tabel dengan membuat database baru, dengan menyisipkan tabel ke database yang sudah ada, atau dengan mengimpor maupun menautkan ke tabel dari sumber data lain, seperti buku kerja Microsoft Excel, dokumen Microsoft Word, file teks, atau database lain. Ketika membuat database baru yang kosong, tabel kosong baru secara otomatis dimasukkan untuk Anda. Selanjutnya Anda bisa memasukkan data dalam tabel untuk memulai menentukan bidang Anda.

Atas Halaman

Membuat tabel baru dalam database baru

  1. Klik File > baru, lalu pilih Database desktop kosong.

  2. Dalam kotak Nama file, ketik nama file untuk database baru.

  3. Untuk menelusuri lokasi yang berbeda dan menyimpan database, klik ikon folder.

  4. Klik Buat.

    Database baru terbuka, dan tabel baru yang bernama Tabel1 dibuat dan dibuka dalam tampilan Lembardata.

Atas Halaman

Membuat tabel baru dalam database yang sudah ada

  1. Klik File > Buka, lalu klik database jika tercantum di bawah Terkini. Jika tidak, pilih salah satu opsi penelusuran untuk menemukan database.

  2. Dalam kotak dialog Buka, pilih database yang ingin dibuka, lalu klik Buka.

  3. Pada tab Buat, di grup Tabel,klik Tabel.

    Tabel baru telah dimasukkan ke dalam database dan tabel terbuka di tampilan Lembardata

Atas Halaman

Mengimpor atau menautkan untuk membuat tabel

Anda dapat membuat tabel dengan mengimpor atau menautkan data yang disimpan di tempat lain. Anda dapat mengimpor atau menautkan ke data dalam lembar kerja Excel, daftar SharePoint, file XML, database Access lain, folder Microsoft Outlook, dan lainnya.

Ketika mengimpor data, Anda membuat salinan data di tabel baru dalam database saat ini. Perubahan selanjutnya terhadap data tidak berpengaruh terhadap data yang diimpor, dan perubahan terhadap data yang diimpor tidak mempengaruhi data sumber. Setelah menghubungkan ke sumber data dan mengimpor datanya, selanjutnya Anda dapat menggunakan data yang diimpor tanpa menghubungkan ke sumber. Anda dapat mengubah desain tabel yang diimpor.

Ketika menautkan data, Anda membuat tabel yang ditautkan dalam database saat ini yang menggambarkan tautan langsung ke informasi yang sudah ada, yang tersimpan di tempat lain. Ketika mengubah data dalam tabel terkait, Anda mengubah di sumbernya. Setiap kali sumber data diubah, perubahan itu diperlihatkan dalam tabel yang ditautkan. Anda harus dapat terhubung ke sumber data setiap kali menggunakan tabel yang ditautkan. Anda tidak dapat mengubah desain tabel yang ditautkan.

Catatan: Anda tidak bisa mengedit data dalam lembar kerja Excel menggunakan tabel yang ditautkan. Sebagai solusinya, impor data sumber ke dalam database Access lalu tautkan ke database dari Excel.

Atas Halaman

Membuat tabel baru dengan mengimpor atau menautkan ke data eksternal

  1. Klik File > Buka.

  2. Dalam kotak dialog Buka, pilih dan buka database di mana Anda ingin membuat tabel baru.

  3. Di tab Data Eksternal, dalam grup Impor & Tautkan, klik salah satu sumber data yang tersedia. 

    Gambar Pita Access

  4. Ikuti petunjuk dalam kotak dialog yang muncul di setiap langkah.

    Access membuat tabel baru dan menampilkannya dalam Panel Navigasi.

Atas Halaman

Menggunakan situs SharePoint untuk membuat tabel.

Tabel dapat dibuat dalam database yang diimpor dari atau ditautkan ke daftar SharePoint. Anda juga dapat membuat daftar SharePoint baru menggunakan templat yang sudah ditentukan sebelumnya. Templat yang sudah ditentukan sebelumnya dalam Access menyertakan Kontak, Tugas, Masalah, dan Acara.

  1. Klik File > Buka.

  2. Dalam kotak dialog Buka, pilih database tempat Anda akan membuat tabel baru, kemudian klik Buka.

  3. Pada tab Buat, di grup Tabel,klik Daftar SharePoint.

  4. Lakukan salah satu hal berikut ini:

    Membuat daftar SharePoint yang didasarkan pada templat

    1. Klik baik Kontak, Tugas, Masalah, maupun Acara.

    2. Dalam kotak dialog Buat Daftar Baru, ketik URL untuk situs SharePoint tempat Anda ingin membuat daftar.

    3. Masukkan nama dan deskripsi untuk daftar baru di kotak Tentukan nama untuk daftar baru dan Deskripsi.

    4. Untuk membuka tabel yang ditautkan setelah dibuat, pilih kotak centang Buka daftar bila sudah selesai (dipilih secara default).

    Membuat daftar kustom

    1. Klik Kustom.

    2. Dalam kotak dialog Buat Daftar Baru, ketik URL untuk situs SharePoint tempat Anda ingin membuat daftar.

    3. Masukkan nama dan deskripsi untuk daftar baru di kotak Tentukan nama untuk daftar baru dan Deskripsi.

    4. Untuk membuka tabel yang ditautkan setelah dibuat, pilih kotak centang Buka daftar bila sudah selesai (dipilih secara default).

    Mengimpor data dari daftar yang sudah ada

    1. Klik Daftar SharePoint yang Ada.

    2. Dalam kotak dialog Dapatkan Data Eksternal, ketik URL untuk situs SharePoint yang berisi data yang ingin Anda impor.

    3. Klik Impor data sumber ke tabel yang baru di database saat ini, lalu klik Berikutnya.

    4. Pilih kotak centang di samping setiap daftar SharePoint yang ingin Anda impor.

    Menautkan ke daftar

    1. Klik Daftar SharePoint yang Ada.

    2. Dalam kotak dialog Dapatkan Data Eksternal - Situs SharePoint, ketik URL untuk situs SharePoint yang berisi daftar yang ingin Anda tautkan.

    3. Klik Tautkan ke sumber data dengan membuat tabel yang dikaitkan, lalu klik Berikutnya.

    4. Pilih kotak centang di samping setiap daftar SharePoint yang ingin Anda tautkan.

Atas Halaman

Menggunakan layanan web untuk membuat tabel

Anda bisa membuat tabel dalam database Anda yang menyambungkan data di situs web yang menyediakan antarmuka layanan web. Tabel layanan web bersifat baca saja.

  1. Pada tab Data Eksternal, di grup Impor & Tautkan, klik Lainnya lalu klik Layanan Data.

  2. Jika sambungan yang Anda inginkan telah terinstal, lewati ke langkah 5. Jika tidak, lanjutkan dengan langkah berikutnya.

  3. Klik Instal koneksi baru.

  4. Pilih file sambungan yang ingin Anda gunakan, lalu klik OK.

  5. Dalam kotak Buat Link ke Data Layanan Web, perluas sambungan yang ingin Anda gunakan.

  6. Pilih tabel yang ingin Anda tautkan. Access menampilkan bidang di sisi kanan kotak dialog.

  7. Secara opsional, ketik nama untuk tabel yang ditautkan dalam kotak Tentukan nama link. Access akan menggunakan nama ini untuk tabel yang ditautkan di Panel Navigasi.

  8. Klik OK. Access membuat tabel yang ditautkan.

Atas Halaman

Mengatur properti tabel

Selain mengatur properti bidang, Anda juga dapat mengatur properti yang diterapkan ke seluruh tabel atau ke seluruh catatan.

  1. Pilih tabel yang propertinya ingin Anda atur.

  2. Pada tab Beranda, di grup Tampilan, klik Tampilkan, lalu klik Tampilan Desain.

  3. Pada tab Desain, dalam grup Perlihatkan/Sembunyikan, klik Lembar Properti.

    Grup Perlihatkan/Sembunyikan pada tab Desain di Access

    Lembar properti tabel diperlihatkan.

  4. Pada lembar properti, klik tab Umum.

  5. Klik kotak di sebelah kiri properti yang ingin diatur, lalu masukkan pengaturan untuk properti.

    Jangan lupa tekan CTRL+S untuk menyimpan perubahan Anda.

    Gunakan properti tabel ini

    Untuk

    Menampilkan Tampilan Pada Situs SharePoint

    Tentukan apakah tampilan yang didasarkan pada tabel dapat ditampilkan pada situs SharePoint.

    Catatan: Dampak pengaturan ini bergantung pada pengaturan properti database Menampilkan Semua Tampilan Pada Situs SharePoint.

    Perluasan Sublembar Data

    Memperluas semua sublembar data ketika Anda membuka tabel.

    Tinggi Sublembar Data

    Lakukan salah satu hal berikut ini:

    • Jika Anda ingin memperluas jendela lembarsubdata agar menampilkan seluruh baris, atur properti pada 0”.

    • Jika Anda ingin mengontrol tinggi sublembar data, masukkan tinggi yang diinginkan dalam satuan inci.

    Orientasi

    Mengatur orientasi tampilan, bergantung pada apakah bahasa Anda dibaca kiri ke kanan, atau kanan ke kiri.

    Deskripsi

    Menyediakan deskripsi tabel. Deskripsi ini akan muncul dalam tip alat untuk tabel.

    Tampilan Default

    Mengatur Lembar Data, PivotTable, atau PivotChart sebagai tampilan default ketika Anda membuka tabel. Opsi PivotTable dan PivotChart dihapus dari Access dimulai di Access 2013.

    Aturan Validasi

    Masukkan ekspresi yang harus benar setiap kali Anda menambah atau mengubah rekaman.

    Teks Validasi

    Masukkan pesan yang ditampilkan ketika rekaman melanggar ekspresi dalam properti Aturan Validasi.

    Filter

    Menentukan kriteria untuk menampilkan baris yang cocok saja di dalam tampilan Lembar Data.

    Urutkan Menurut

    Pilih satu bidang atau lebih untuk menentukan urutan sortir baris default dalam tampilan Lembar Data.

    Nama Sublembar Data

    Menentukan apakah sublembar data harus muncul dalam tampilan Lembar Data, dan jika ya, tabel atau kueri mana yang harus memasok baris dalam sublembar data.

    Tautkan Bidang Anak

    Membuat daftar bidang dalam tabel atau kueri yang digunakan untuk sublembar data yang cocok dengan properti Tautkan Bidang Master, yang ditentukan untuk tabel.

    Tautkan Bidang Master

    Membuat daftar bidang dalam tabel yang cocok dengan properti Tautkan Bidang Anak, yang ditentukan untuk tabel.

    Filter Saat Dimuat

    Secara otomatis menerapkan kriteria filter dalam properti Filter (dengan mengatur ke Ya) ketika tabel dibuka dalam tampilan Lembar Data.

    Urutkan Menurut Saat Dimuat

    Secara otomatis menerapkan kriteria urutkan dalam properti Urutkan Menurut (dengan mengatur ke Ya) ketika tabel dibuka dalam tampilan Lembar Data.

    Tips    Untuk memberikan lebih banyak ruang guna memasukkan atau mengedit pengaturan dalam kotak properti, tekan SHIFT+F2 untuk menampilkan kotak Perbesar. Jika Anda akan menetapkan properti Aturan Validasi ke suatu ekspresi dan memerlukan bantuan untuk menyusunnya, klik Tombol Penyusun di samping kotak properti ValidationRule untuk menampilkan Penyusun Ekspresi.

Atas Halaman

Menyimpan tabel

Setelah membuat atau memodifikasi tabel, Anda harus menyimpan desainnya. Ketika Anda menyimpan tabel untuk kali pertama, beri nama yang menjelaskan isi data. Anda juga dapat menggunakan hingga 64 karakter alfanumerik, termasuk spasi. Misalnya, Anda dapat memberi nama tabel sebagai Pelanggan, Bagian Inventaris, atau Produk.

Access menyediakan banyak fleksibilitas dalam hal penamaan tabel. Namun, ada beberapa batasan yang perlu diketahui. Panjang nama tabel maksimal 64 karakter, dapat menyertakan semua kombinasi huruf, angka, spasi, dan karakter khusus, kecuali tanda titik (.), tanda seru (!), kurung siku ([]), spasi ekstra di awal, tanda sama dengan di awal (=), atau karakter yang tidak dapat dicetak seperti karakter kembali ke awal. Nama juga tidak boleh berisi salah satu karakter berikut ini:` / \ : ; * ? " ' < > | # <TAB> { } % ~ &.

Tips: Anda harus memutuskan aturan penamaan untuk objek dalam database dan menggunakannya secara konsisten.

  1. Pilih File > Simpan, atau tekan CTRL+S.

  2. Jika menyimpan tabel untuk pertama kali, ketikkan nama untuk tabel, lalu klik OK.

Atas Halaman

Mengatur kunci utama

Kecuali jika Anda memiliki alasan tertentu untuk tidak menggunakannya, kunci utama harus ditentukan untuk tabel. Access membuat indeks secara otomatis untuk kunci utama, yang dapat membantu meningkatkan kinerja database. Access juga memastikan bahwa setiap catatan memiliki nilai dalam bidang kunci utama, dan bahwa nilai tersebut selalu unik. Nilai unik sangat penting, karena jika tidak, tidak ada cara untuk membedakan baris tertentu dari baris lainnya.

Ketika membuat tabel baru dalam tampilan Lembardata, Access membuat kunci utama secara otomatis untuk Anda dan menetapkan nama bidang ID dan tipe data AutoNumber.

Dalam tampilan Desain, Anda dapat mengubah atau menghapus kunci utama, atau mengatur kunci utama untuk tabel yang tidak memilikinya.

Atas Halaman

Menentukan bidang yang digunakan sebagai kunci utama

Terkadang, Anda mungkin sudah memiliki data yang ingin digunakan sebagai kunci utama. Misalnya, Anda mungkin memiliki nomor ID yang sudah ada untuk karyawan. Jika membuat tabel untuk melacak informasi pegawai, Anda mungkin memutuskan untuk menggunakan ID karyawan yang sudah ada sebagai kunci utama untuk tabel. Atau, mungkin ID karyawan unik hanya dalam kombinasi dengan ID departemen, mengharuskan agar menggunakan kedua bidang bersamaan sebagai kunci utama. Kandidat yang baik untuk kunci utama memiliki karakteristik berikut:

  • Setiap catatan memiliki nilai yang unik untuk bidang atau kombinasi bidang.

  • Bidang atau kombinasi bidang tidak pernah kosong atau null — selalu ada nilai.

  • Nilainya tidak berubah.

Jika tidak ada data yang cocok untuk digunakan sebagai kunci utama, Anda dapat membuat bidang baru untuk digunakan sebagai kunci utama. Saat Anda membuat bidang baru untuk digunakan sebagai kunci utama, atur tipe data bidang menjadi AutoNumber guna membantu memastikan kunci utama tersebut memenuhi tiga karakteristik dalam daftar sebelumnya.

Atas Halaman

Mengatur atau mengubah kunci utama

  1. Pilih tabel yang kunci utamanya ingin Anda atur atau ubah.

  2. Pada tab Beranda, di grup Tampilan, klik Tampilkan, lalu klik Tampilan Desain.

  3. Di kisi desain tabel, pilih bidang yang ingin digunakan sebagai kunci utama.

    Untuk memilih satu bidang, klik pemilih baris untuk bidang yang diinginkan.

    Untuk memilih lebih dari satu bidang, tahan CTRL, lalu klik pemilih baris untuk setiap bidang.

  4. Pada tab Desain, di grup Alat, klik Kunci Utama.

    Grup Alat pada tab Desain

    Indikator penting muncul di sebelah kiri bidang atau bidang yang Anda tentukan sebagai kunci utama.

Atas Halaman

Menghapus kunci utama

  1. Pilih tabel yang kunci utamanya ingin diatur atau diubah.

  2. Pada tab Beranda, di grup Tampilan, klik Tampilkan, lalu klik Tampilan Desain.

  3. Klik pemilih baris untuk kunci utama saat ini. Jika kunci utama terdiri dari beberapa bidang, tahan CTRL, kemudian klik pemilih baris untuk setiap bidang.

  4. Pada tab Desain, di grup Alat, klik Kunci Utama.

    Grup Alat pada tab Desain

    Indikator kunci dihapus dari bidang atau beberapa bidang yang Anda tentukan sebelumnya sebagai kunci utama.

Ketika menyimpan tabel baru tanpa mengatur kunci utama, Access meminta Anda untuk membuat bidang baru untuk kunci utama. Jika Anda mengklik Ya, Access membuat bidang ID yang menggunakan tipe data AutoNumber untuk memberikan nilai yang unik pada setiap catatan. Jika tabel Anda sudah berisi bidang AutoNumber, Access menggunakannya sebagai kunci utama. Jika Anda mengklik Tidak, Access tidak menambahkan bidang, dan tidak ada kunci utama yang diatur.

Atas Halaman

Menambahkan bidang

Untuk menyimpan data baru mengenai sesuatu yang sudah dimiliki tabel Accessnya, pertimbangkan untuk menambahkan bidang ke tabel tersebut. Misalnya, Anda memiliki tabel yang menyimpan nama belakang, nama depan, alamat email, nomor telepon, dan alamat surat pelanggan. Jika ingin memulai pelacakan metode komunikasi pilihan setiap pelanggan, cukup tambahkan bidang untuk menyimpan data tersebut.

Anda menyimpan setiap bagian data yang ingin Anda telusuri dalam sebuah bidang. Sebagai contoh, dalam tabel kontak Anda membuat bidang untuk Nama Belakang, Nama Depan, Nomor Telepon, dan Alamat. Dalam tabel produk Anda membuat bidang untuk Nama Produk, ID Produk dan Harga.

Setiap bidang memiliki karakteristik penting tertentu, seperti nama yang mengidentifikasi bidang di dalam tabel, tipe data yang menentukan sifat data, operasi yang bisa dijalankan dalam data, dan seberapa besar ruang penyimpanan menyediakan tempat untuk tiap nilai.

Sebelum Anda membuat bidang, cobalah untuk memisahkan data ke bagian terkecilnya yang berguna. Jauh lebih mudah untuk mengombinasikan data nanti daripada memisahkannya nanti. Sebagai contoh, daripada bidang Nama Lengkap, pertimbangkan untuk membuat bidang terpisah untuk Nama Belakang dan Nama Depan. Kemudian, Anda dapat dengan mudah mencari atau mengurutkan menurut Nama Depan, Nama Belakang, atau keduanya. Jika berencana untuk melaporkan, mengurutkan, atau menghitung item data, letakkan item tersebut dalam bidangnya sendiri.

Setelah membuat bidang, Anda juga dapat mengatur properti bidang untuk mengontrol kemunculan dan perilakunya. Misalnya, properti Format menentukan bagaimana data ditampilkan di lembar data atau formulir yang berisi bidang tersebut.

Atas Halaman

Menambahkan bidang dengan memasukkan data

Ketika membuat tabel baru atau membuka tabel yang sudah ada dalam tampilan Lembar Data, Anda dapat menambahkan bidang ke tabel dengan memasukkan data dalam kolom lembar data Tambahkan Bidang Baru(1). Access menentukan tipe data untuk bidang tersebut secara otomatis berdasarkan nilai yang Anda masukkan. Jika tidak ada tipe data yang dinyatakan oleh input Anda, Access menetapkan tipe data itu Teks, tetapi Anda bisa mengubah tipe data itu.

Lembar Data di Access dengan kolom Tambahkan Bidang Baru

Untuk memasukkan data dalam kolom Tambahkan Bidang Baru:

  1. Buat atau buka tabel dalam tampilan Lembar Data dengan mengklik kanan tabel yang Anda inginkan di Panel Navigasi, lalu klik tampilan Lembar Data dari menu pintasan.

  2. Dalam kolom Tambahkan Bidang Baru, masukkan nama bidang yang ingin dibuat.

    Gunakan nama deskriptif agar bidang tersebut mudah untuk diidentifikasi.

  3. Masukkan data ke dalam bidang baru.

Atas Halaman

Menambahkan bidang dengan menggunakan templat bidang

Terkadang lebih mudah untuk memilih dari daftar yang sudah ditentukan sebelumnya yang sesuai dengan kebutuhan daripada membuat bidang secara manual. Anda dapat menggunakan daftar Bidang Lainnya untuk memilih dari daftar templat bidang. Templat bidang adalah sekumpulan karakteristik dan properti yang sudah ditentukan sebelumnya yang menjelaskan sebuah bidang. Definisi templat bidang menyertakan nama bidang, tipe data, pengaturan untuk properti Format bidang, dan properti bidang lainnya.

  1. Pada tab Beranda, di grup Tampilan, klik Tampilkan, lalu klik Tampilan Lembardata.

  2. Di tab Bidang, dalam grup Tambahkan & Hapus, klik Bidang Lainnya.

    Cuplikan layar grup Tambahkan & Hapus di tab pita Bidang.

  3. Pilih bidang dalam daftar Bidang Lainnya untuk menyisipkan kolom baru. Access menempatkan bidang di sebelah kanan kolom tempat kursor saat ini berada. Jika memilih salah satu opsi bidang di bawah judul Mulai Cepat, seperti Alamat, Access membuat beberapa bidang dalam tabel Anda yang berisi berbagai bagian alamat.

Atas Halaman

Mengatur properti bidang

Setelah membuat bidang, Anda dapat mengatur properti bidang untuk mengontrol kemunculan dan perilakunya.

Sebagai contoh, dengan mengatur properti bidang, Anda dapat:

  • Mengontrol kemunculan data dalam bidang

  • Membantu mencegah masukan data yang salah dalam bidang

  • Menentukan nilai default untuk bidang

  • Membantu mempercepat pencarian dan pengurutan pada bidang

Beberapa properti bidang yang tersedia dapat diatur ketika bekerja dalam tampilan Lembar Data. Namun, untuk mendapatkan akses dan mengatur daftar properti bidang secara lengkap, Anda harus menggunakan tampilan Desain.

Properti yang dapat diatur tergantung pada tipe data bidang.

Atas Halaman

Mengatur properti bidang dalam tampilan Lembar Data

Anda dapat mengubah nama bidang, mengganti tipe data tersebut, mengganti properti Format, dan mengganti beberapa properti di bidang lainnya saat bekerja dalam tampilan Lembardata.

  1. Dalam Panel Navigasi, klik kanan pada tabel yang ingin Anda buka.

  2. Pada menu pintasan, klik Tampilan Lembardata.

Atas Halaman

Mengubah nama bidang

Saat Anda menambahkan bidang dengan memasukkan data dalam tampilan Lembardata, Access secara otomatis menetapkan nama generik ke bidang. Access menetapkan nama Bidang1 ke bidang baru pertama, Bidang2 untuk bidang baru kedua, dan seterusnya. Secara default, nama bidang digunakan sebagai labelnya setiap kali bidang ditampilkan, seperti judul kolom pada lembar data. Mengganti nama bidang dengan nama yang lebih deskriptif akan membantu ketika Anda menampilkan atau mengedit data karena bidang akan lebih mudah digunakan.

  1. Klik kanan judul bidang yang ingin Anda ganti namanya (sebagai contoh, Bidang1).

  2. Di menu pintasan, klik Ganti Nama Bidang.

  3. Masukkan nama baru dalam judul bidang.

    Nama bidang dapat terdiri sampai 64 karakter (huruf atau nomor), termasuk spasi.

Atas Halaman

Mengubah tipe data bidang

Ketika membuat bidang dengan memasukkan data dalam tampilan Lembar Data, Access menguji data tersebut untuk menentukan tipe data yang benar untuk bidang. Sebagai contoh, jika memasukkan 1/1/2017, Access mengenali data itu sebagai tanggal dan mengatur tipe data untuk bidang ke Tanggal/Waktu. Jika Access tidak dapat menentukan tipe data secara pasti, tipe data secara default diatur ke Teks (Teks Pendek jika Anda menggunakan Access 2016).

Tipe data bidang menentukan properti bidang lain yang dapat diatur. Sebagai contoh, Anda hanya dapat mengatur properti Tambahkan Saja untuk bidang yang memiliki tipe data Hyperlink atau tipe data Memo (Teks Panjang jika Anda menggunakan Access 2016).

Mungkin terdapat kasus ketika ingin mengubah tipe data bidang secara manual. Sebagai contoh, anggap Anda mempunyai nomor kamar yang menyerupai tanggal seperti 10/2017. Jika memasukkan 10/2017 ke dalam bidang baru dalam tampilan Lembar Data, fitur deteksi tipe data otomatis memilih tipe data Tanggal/Waktu untuk bidang tersebut. Karena nomor kamar merupakan label, dan bukan tanggal, nomor kamar tersebut harus menggunakan tipe data Teks. Gunakan prosedur berikut untuk mengubah tipe data bidang.

  1. Di Pita, klik tab Bidang.

  2. Dalam daftar Tipe Data, di grup Pemformatan, pilih tipe data yang Anda inginkan.

    Gambar Pita Access grup Tipe Data dan Pemformatan

    Tipe data apa yang tersedia?

    Lihat Tipe data untuk database desktop Access untuk daftar lengkap tipe data yang tersedia di database Access.

    Tips tentang tipe data

    • Ukuran maksimum file database Access adalah 2 gigabyte.

    • Untuk mengoptimalkan kinerja, Anda harus menggunakan Ukuran Bidang yang paling tepat ketika membuat bidang Teks atau Angka. Misalnya, jika ingin menyimpan kode pos dengan panjang yang dapat diperkirakan, tentukan panjangnya sebagai ukuran bidang. Anda dapat menentukan ukuran bidang dengan mengatur nilai dalam kotak properti Ukuran Bidang. Untuk informasi selengkapnya, lihat bagian, Mengatur properti bidang lainnya.

    • Nomor telepon, nomor bagian, dan angka lain yang tidak dimaksudkan untuk digunakan dalam penghitungan matematika, Anda harus memilih tipe data Teks dan bukan tipe data Angka. Nilai numerik yang disimpan sebagai teks dapat diurutkan dan difilter secara lebih logis.

Atas Halaman

Mengubah format bidang

Selain untuk menentukan tipe data dari bidang baru, Access mungkin juga mengatur properti Format untuk bidang, bergantung pada apa yang Anda masukkan. Sebagai contoh, jika Anda memasukkan 10:50 a.m., Access mengatur tipe data ke Tanggal/Waktu dan properti Format ke Waktu Menengah. Untuk mengubah properti Format bidang, lakukan hal berikut:

  1. Di Pita, klik tab Bidang

  2. Dalam daftar Format, di grup Pemformatan, masukkan format yang Anda inginkan. 

    Catatan: Daftar Format mungkin tidak tersedia untuk beberapa bidang (sebagai contoh, Teks), bergantung pada tipe data dari bidang.

Atas Halaman

Mengatur properti bidang lain

  1. Dalam tampilan Lembar Data, klik bidang yang ingin Anda atur propertinya.

  2. Di tab Bidang, dalam grup Properti, Pemformatan, atau Validasi Bidang, pilih properti yang Anda inginkan.

Atas Halaman

Mengatur properti bidang dalam tampilan Desain

Anda dapat mengatur properti bidang apa pun saat bekerja dengan tabel dalam tampilan Desain. Dalam tampilan Desain, Anda mengatur tipe data bidang dalam kisi desain tabel, dan mengatur properti lainnya dalam panel Properti Bidang.

  1. Dalam Panel Navigasi, klik kanan pada tabel.

  2. Pada menu pintasan, klik Tampilan Desain.

Atas Halaman

Mengubah tipe data bidang

Anda dapat mengubah beragam aspek bidang setelah Anda membuatnya.

Peringatan: Anda juga dapat mengubah aspek bidang selain yang baru Anda buat. Bagaimana pun juga, jika data sudah ada di bidang, beberapa tindakan tidak akan tersedia, atau dapat menyebabkan hilangnya data.

  1. Di kisi desain tabel, temukan bidang yang Anda inginkan untuk mengatur tipe data.

  2. Dalam kolom Tipe Data, pilih tipe data dari daftar.

    Tipe data apa yang tersedia?

    Lihat Tipe data untuk database desktop Access untuk daftar lengkap tipe data yang tersedia di database Access.

    Tips tentang tipe data

    • Ukuran maksimum file database Access adalah 2 gigabyte.

    • Nomor telepon, nomor bagian, dan angka lain yang tidak dimaksudkan untuk digunakan dalam penghitungan matematika, Anda harus memilih tipe data Teks dan bukan tipe data Angka. Nilai numerik yang disimpan sebagai teks dapat diurutkan dan difilter secara lebih logis, tetapi tidak dapat digunakan dengan mudah dalam penghitungan.

    • Untuk tipe data Teks dan Angka, Anda dapat menentukan ukuran bidang atau tipe data secara lebih tepat dengan mengatur nilai dalam kotak properti Ukuran Bidang.

Atas Halaman

Mengatur properti bidang lain

Catatan: Tidak semua format tersedia untuk semua tipe data. Pertama, atur tipe data, lalu jika diperlukan, atur format.

  1. Dalam kisi desain tabel, pilih bidang yang propertinya ingin Anda atur. Access menampilkan properti untuk bidang ini di panel Properti Bidang.

    Tipe data dari bidang yang menentukan properti yang dapat Anda atur.

  2. Dalam panel Properti Bidang, masukkan pengaturan yang Anda inginkan untuk masing-masing properti, atau tekan F6 lalu gunakan tombol panah untuk memilih properti.

    Properti bidang apa yang tersedia?

    Lihat Pengenalan tipe data dan properti bidang untuk daftar lengkap properti bidang yang tersedia untuk setiap tipe data di database Access.

    Catatan: Tidak semua properti tersedia untuk setiap bidang. Tipe data bidang menentukan properti mana yang dimiliki.

  3. Untuk menyediakan lebih banyak ruang guna memasukkan atau mengedit pengaturan properti di kotak properti, tekan SHIFT+F2 untuk menampilkan kotak Perbesar.

    Tips: Jika Anda akan memasukkan masker input atau ekspresi validasi dan memerlukan bantuan untuk menyusunnya, klik Tombol Penyusun di samping kotak properti untuk menampilkan penyusun yang sesuai.

  4. Untuk menyimpan perubahan Anda: tekan CTRL+S.

Atas Halaman

Memindahkan bidang

Untuk memindahkan bidang, seret bidang ke posisi yang Anda inginkan. Untuk memilih beberapa bidang yang bersebelahan untuk dipindahkan, klik bidang pertama, tahan tombol SHIFT lalu pilih bidang terakhir. Setelahnya, Anda dapat menyeret grup bidang yang dipilih ke posisi baru.

Menyeret bidang akan mengubah posisinya di Lembar Data, tapi tidak mengubah urutan bidang di desain tabel. Jika Anda mengakses bidang secara progamatik, urutan asli akan berlaku. Sebagai contoh, jika Anda menyeret bidang ke posisi baru di Lembar Data, lalu membuat formulir dari tabel dengan menggunakan tombol Formulir, bidang akan berada di posisi aslinya.

Atas Halaman

Lihat Juga

Menambahkan bidang terhitung ke tabel

Menambahkan bidang ke formulir atau laporan

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×