Gunakan Microsoft Query untuk mengambil data eksternal

Penting: Artikel ini adalah terjemahan mesin, lihat penafian. Temukan versi bahasa Inggris artikel di sini sebagai rujukan Anda.

Anda bisa menggunakan Microsoft Query untuk mengambil data dari sumber eksternal. Dengan menggunakan Microsoft Query untuk mengambil data dari database korporat dan file, Anda tidak harus mengetikkan ulang data yang ingin Anda analisis di Excel. Anda juga dapat merefresh laporan Excel dan ringkasan secara otomatis dari database sumber asli Anda setiap kali database diperbarui dengan informasi baru.

Menggunakan Microsoft Query, Anda bisa menyambungkan ke sumber data eksternal, pilih data dari sumber eksternal tersebut, mengimpor data ke lembar kerja Anda, dan me-refresh data yang diperlukan untuk mempertahankan data lembar kerja Anda yang disinkronkan dengan data di sumber eksternal.

Tipe database yang dapat Anda akses     Anda bisa mengambil data dari beberapa tipe database, termasuk Microsoft Office Access, Microsoft SQL Server, dan layanan Microsoft SQL Server OLAP. Anda juga bisa mengambil data dari buku kerja Excel dan dari file teks.

Microsoft Office menyediakan driver yang bisa Anda gunakan untuk mengambil data dari sumber data berikut:

  • Microsoft SQL Server Analysis Services (penyedia OLAP)

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradoks

  • Teks file database

Anda bisa menggunakan juga driver ODBC atau driver sumber data dari pabrikan lain untuk mengambil informasi dari sumber data yang tidak tercantum di sini, termasuk jenis database OLAP. Untuk informasi tentang menginstal ODBC driver atau driver sumber data yang tidak tercantum di sini, lihat dokumentasi untuk database, atau menghubungi vendor database Anda.

Memilih data dari database     Anda mengambil data dari database dengan membuat kueri, yang merupakan pertanyaan yang Anda tanya tentang data yang disimpan dalam database eksternal. Misalnya, jika data Anda disimpan dalam Access database, Anda mungkin ingin mengetahui angka penjualan produk tertentu dengan kawasan. Anda bisa mengambil bagian data dengan memilih hanya data untuk produk dan kawasan yang ingin Anda analisis.

Dengan Microsoft Query, Anda bisa memilih kolom data yang Anda inginkan dan mengimpor data itu ke dalam Excel.

Memperbarui lembar kerja Anda di satu operasi     Begitu Anda memiliki data eksternal di buku kerja Excel, setiap kali perubahan database Anda, Anda bisa refresh data untuk memperbarui analisis Anda — tanpa harus membuat ulang laporan ringkasan dan bagan. Misalnya, Anda bisa membuat ringkasan penjualan bulanan dan refresh setiap bulan ketika angka penjualan baru datang.

Bagaimana Microsoft kueri menggunakan sumber data     Setelah Anda menyetel sumber data untuk database tertentu, Anda bisa menggunakannya kapan pun Anda ingin membuat kueri untuk memilih dan mengambil data dari database tersebut — tanpa harus mengetik ulang semua informasi koneksi. Microsoft Query menggunakan sumber data untuk menyambungkan ke database eksternal dan untuk memperlihatkan data apa tersedia. Setelah Anda membuat kueri Anda dan kembali data ke Excel, Microsoft Query menyediakan buku kerja Excel dengan informasi sumber kueri dan data sehingga Anda bisa menyambungkan kembali ke database saat Anda ingin me-refresh data.

Diagram tentang cara Kueri menggunakan sumber data

Menggunakan Microsoft kueri untuk mengimpor data    untuk mengimpor data eksternal ke Excel dengan Microsoft Query, ikuti langkah-langkah dasar ini, masing-masing dijelaskan secara lebih mendetail di bagian berikut ini.

Apa sumber data?     Sumber data adalah sekumpulan disimpan informasi yang memungkinkan Excel dan Microsoft Query untuk menyambungkan ke database eksternal. Saat Anda menggunakan Microsoft Query untuk menyiapkan sumber data, Anda beri nama untuk sumber data, dan lalu memasukkan nama dan lokasi database atau server, tipe database, dan informasi masuk dan kata sandi Anda. Informasi ini juga menyertakan nama OBDC driver atau driver sumber data, yang merupakan program yang membuat koneksi ke tipe khusus dari database.

Untuk menyetel sumber data dengan menggunakan Microsoft Query:

  1. Pada tab Data , di grup Dapatkan Data eksternal , klik Dari sumber lain, dan lalu klik Dari Microsoft Query.

  2. Lakukan salah satu hal berikut ini:

    • Untuk menentukan sumber data untuk database, file teks, atau buku kerja Excel, klik tab database .

    • Untuk menentukan sumber data OLAP kubus, klik tab Kubik OLAP . Tab ini hanya tersedia hanya jika Anda menjalankan Microsoft Query dari Excel.

  3. Klik ganda < sumber Data baru >.

    -atau-

    Klik < sumber Data baru >, dan lalu klik OK.

    Kotak dialog Buat sumber Data baru ditampilkan.

  4. Di langkah 1, ketik nama untuk mengidentifikasi sumber data.

  5. Di langkah 2, klik driver untuk tipe database yang Anda gunakan sebagai sumber data Anda.

    Catatan: 

    • Jika database eksternal yang ingin Anda akses tidak didukung oleh driver ODBC yang diinstal dengan Microsoft Query, maka Anda perlu mendapatkan dan menginstal driver ODBC Microsoft Office-kompatibel dari vendor pihak ketiga, seperti pabrikan database. Menghubungi database vendor untuk instruksi instalasi.

    • Database OLAP tidak memerlukan driver ODBC. Saat Anda menginstal Microsoft Query, driver diinstal untuk database yang dibuat dengan menggunakan Microsoft SQL Server Analysis Services. Untuk menyambungkan ke database OLAP lain, Anda perlu menginstal data sumber driver dan klien perangkat lunak.

  6. Klik Sambungkan, dan lalu berikan informasi yang diperlukan untuk menyambungkan ke sumber data Anda. Untuk database, buku kerja Excel, dan file teks, informasi yang Anda sediakan bergantung pada tipe sumber data yang Anda pilih. Anda mungkin diminta untuk memasukkan nama masuk, kata sandi, versi database yang Anda gunakan, lokasi database, atau informasi spesifik untuk tipe database.

    Penting: 

    • Gunakan kata sandi kuat yang menggabungkan huruf besar, huruf kecil, angka, dan simbol. Kata sandi yang lemah tidak menggabungkan elemen ini. Kata sandi kuat: Y6dh!et5. Kata sandi lemah: House27. Kata sandi harus memiliki 8 karakter atau lebih. Frasa sandi akan lebih baik jika menggunakan 14 karakter atau lebih.

    • Penting bagi Anda untuk mengingat kata sandi Anda. Jika Anda lupa kata sandi Anda, Microsoft tidak dapat mengembalikannya. Simpan kata sandi yang Anda tulis di tempat yang jauh dari informasi yang diproteksi.

  7. Setelah Anda memasukkan informasi yang diperlukan, klik OK atau selesai untuk kembali ke kotak dialog Buat sumber Data baru .

  8. Jika database Anda memiliki tabel dan Anda ingin tabel tertentu untuk menampilkan secara otomatis dalam panduan kueri, klik kotak untuk langkah 4, dan lalu klik tabel yang Anda inginkan.

  9. Jika Anda tidak ingin mengetik nama masuk dan kata sandi ketika Anda menggunakan sumber data, pilih kotak centang Simpan saya ID pengguna dan kata sandi di definisi sumber data . Kata sandi disimpan tidak dienkripsi. Jika kotak centang tidak tersedia, lihat administrator database untuk menentukan apakah opsi ini dapat dibuat tersedia.

    Catatan Keamanan : Hindari menyimpan informasi masuk saat menyambungkan ke sumber data. Informasi ini mungkin disimpan sebagai teks biasa, dan pengguna berbahaya bisa mengakses informasi untuk membahayakan keamanan sumber data.

Setelah Anda menyelesaikan langkah-langkah ini, nama sumber data Anda muncul dalam kotak dialog Pilih sumber Data .

Menggunakan panduan kueri untuk sebagian besar kueri     Panduan kueri memudahkan untuk memilih dan menyatukan data dari tabel dan bidang di database Anda. Menggunakan panduan kueri, Anda bisa memilih tabel dan bidang yang ingin Anda sertakan. Gabungan (operasi kueri yang menentukan bahwa baris dari dua tabel digabungkan berdasarkan nilai bidang identik) dibuat secara otomatis saat panduan mengenali bidang kunci utama dalam satu tabel dan bidang dengan nama yang sama di kedua tabel.

Anda juga bisa menggunakan panduan untuk mengurutkan kumpulan hasil dan melakukan pemfilteran sederhana. Pada langkah terakhir panduan, Anda bisa memilih untuk kembali data ke Excel, atau menyempurnakan kueri di Microsoft Query. Setelah Anda membuat kueri, Anda dapat menjalankannya di Excel salah satu atau di Microsoft Query.

Untuk memulai panduan kueri, melakukan langkah-langkah berikut ini.

  1. Pada tab Data , di grup Dapatkan Data eksternal , klik Dari sumber lain, dan lalu klik Dari Microsoft Query.

  2. Dalam kotak dialog Pilih sumber Data , pastikan bahwa kotak centang gunakan panduan kueri untuk membuat/edit kueri yang dipilih.

  3. Klik ganda sumber data yang ingin Anda gunakan.

    -atau-

    Klik sumber data yang ingin Anda gunakan, dan lalu klik OK.

Bekerja secara langsung dalam Microsoft kueri untuk jenis kueri     Jika Anda ingin membuat kueri lebih kompleks dari panduan kueri memungkinkan, Anda bisa bekerja secara langsung dalam Microsoft Query. Anda bisa menggunakan Microsoft Query untuk menampilkan dan mengubah kueri yang Anda mulai membuat di panduan kueri, atau Anda bisa membuat kueri baru tanpa menggunakan panduan. Bekerja secara langsung di Microsoft Query saat Anda ingin membuat kueri yang lakukan hal berikut ini:

  • Pilih data tertentu dari sebuah bidang     Dalam database besar, Anda mungkin ingin memilih beberapa data dalam bidang dan menghilangkan data yang tidak Anda perlukan. Misalnya, jika Anda memerlukan data untuk dua produk dalam bidang yang berisi informasi produk, Anda bisa menggunakan kriteria untuk memilih data untuk hanya dua produk yang Anda inginkan.

  • Mengambil data berdasarkan kriteria yang berbeda setiap kali Anda menjalankan kueri     Jika Anda perlu membuat laporan Excel atau ringkasan untuk beberapa area yang sama di data eksternal yang sama — seperti laporan penjualan terpisah untuk setiap wilayah — Anda bisa membuat kueri parameter. Saat Anda menjalankan kueri parameter, Anda diminta untuk nilai untuk digunakan sebagai kriteria saat kueri memilih catatan. Sebagai contoh, kueri parameter mungkin meminta Anda untuk memasukkan kawasan tertentu, dan Anda bisa menggunakan kembali kueri ini untuk membuat setiap laporan penjualan kawasan Anda.

  • Bergabung dalam data dengan cara berbeda     Gabungan yang membuat panduan kueri yang paling umum tipe gabungan yang digunakan dalam pembuatan kueri. Kadang-kadang, namun, Anda ingin menggunakan tipe gabungan. Misalnya, jika Anda memiliki tabel informasi penjualan produk dan tabel pelanggan informasi, gabungan (tipe yang dibuat oleh panduan kueri) akan mencegah pengambilan catatan pelanggan untuk pelanggan yang tidak melakukan pembelian. Menggunakan Microsoft Query, Anda bisa ikut tabel ini sehingga semua catatan pelanggan yang diambil, bersama dengan data penjualan untuk pelanggan yang telah dibuat pembelian.

Untuk memulai Microsoft Query, lakukan langkah berikut ini.

  1. Pada tab Data , di grup Dapatkan Data eksternal , klik Dari sumber lain, dan lalu klik Dari Microsoft Query.

  2. Dalam kotak dialog Pilih sumber Data , pastikan bahwa kotak centang gunakan panduan kueri untuk membuat/edit kueri dicentang.

  3. Klik ganda sumber data yang ingin Anda gunakan.

    -atau-

    Klik sumber data yang ingin Anda gunakan, dan lalu klik OK.

Reusing dan berbagi kueri     Di panduan kueri dan Microsoft Query, Anda bisa menyimpan kueri yang Anda sebagai file .dqy yang bisa Anda ubah, menggunakan kembali, dan berbagi. Excel membuka .dqy file secara langsung, yang memungkinkan Anda atau pengguna lain untuk membuat rentang data eksternal tambahan dari kueri yang sama.

Untuk membuka kueri disimpan dari Excel:

  1. Pada tab Data , di grup Dapatkan Data eksternal , klik Dari sumber lain, dan lalu klik Dari Microsoft Query. Kotak dialog Pilih sumber Data ditampilkan.

  2. Dalam kotak dialog Pilih sumber Data , klik tab kueri .

  3. Klik ganda kueri disimpan yang ingin Anda buka. Kueri ditampilkan di Microsoft Query.

Jika Anda ingin membuka kueri disimpan dan Microsoft Query belum terbuka, klik menu Microsoft Query File , dan lalu klik buka.

Jika Anda mengklik ganda .dqy file, Excel terbuka, menjalankan kueri, dan lalu menyisipkan hasil ke lembar kerja baru.

Jika Anda ingin berbagi ringkasan Excel atau laporan yang didasarkan pada data eksternal, Anda bisa memberi pengguna lain buku kerja yang berisi rentang data eksternal, atau Anda bisa membuat templat. Templat memungkinkan Anda untuk menyimpan ringkasan atau laporan tanpa menyimpan data eksternal sehingga file lebih kecil. Data eksternal diambil bila pengguna membuka Templat laporan.

Setelah Anda membuat kueri dalam panduan kueri atau Microsoft Query, Anda bisa kembali data ke lembar kerja Excel. Data lalu menjadi rentang data eksternal atau laporan PivotTable yang bisa Anda memformat dan me-refresh.

Pemformatan diambil data     Di Excel, Anda bisa menggunakan alat, seperti bagan atau subtotal otomatis, untuk menyajikan dan meringkas data yang diambil oleh Microsoft Query. Anda bisa memformat data, dan pemformatan Anda dipertahankan ketika Anda me-refresh data eksternal. Anda bisa menggunakan label kolom Anda sendiri sebagai ganti nama bidang, dan menambahkan nomor baris secara otomatis.

Excel secara otomatis bisa memformat data baru yang Anda ketikkan di akhir dari rentang yang sesuai dengan baris sebelumnya. Excel juga secara otomatis bisa menyalin rumus yang telah diulang di baris sebelumnya dan memperluas mereka ke baris tambahan.

Catatan: Untuk diperluas untuk baris baru dalam rentang tersebut, format dan rumus harus muncul dalam setidaknya tiga lima baris sebelumnya.

Anda bisa mengaktifkan opsi ini (atau menonaktifkan lagi) Kapan saja:

  1. Klik File > Opsi > Tingkat Lanjut.

    Di Excel 2007: klik Tombol Microsoft Office Gambar tombol Office , klik Opsi Excel, dan lalu klik kategori tingkat lanjut .

  2. Di bagian opsi pengeditan , pilih Periksa data Perluas rentang format dan rumus . Untuk menonaktifkan pemformatan otomatis data rentang lagi, kosongkan kotak centang ini.

Melakukan refresh data eksternal     Saat Anda melakukan refresh data eksternal, Anda menjalankan kueri untuk mengambil data baru atau yang diubah yang cocok dengan spesifikasi Anda. Anda bisa melakukan refresh kueri di Microsoft Query dan Excel. Excel menyediakan beberapa opsi untuk me-refresh kueri, termasuk melakukan refresh data setiap kali Anda membuka buku kerja dan refresh secara otomatis pada interval berwaktu;. Anda bisa terus bekerja di Excel saat data sedang refresh, dan Anda juga bisa memeriksa status saat data sedang direfresh. Untuk informasi selengkapnya, lihat merefresh data tersambung (diimpor).

Atas halaman

Catatan: Penafian Terjemahan Mesin: Artikel ini telah diterjemahan oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan terjemahan mesin ini untuk membantu pengguna yang bukan penutur bahasa Inggris agar dapat menikmati konten tentang produk, layanan, dan teknologi Microsoft. Karena artikel ini diterjemahkan oleh mesin, mungkin akan terdapat kesalahan kosa kata, sintaksis, atau tata bahasa.

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×