PivotTable

Membuat PivotTable untuk menganalisis data lembar kerja

Buat PivotTable untuk menganalisis data lembar kerja

Catatan: Kami ingin secepatnya menyediakan konten bantuan terbaru dalam bahasa Anda. Halaman ini diterjemahkan menggunakan mesin dan mungkin terdapat kesalahan tata bahasa atau masalah keakuratan. Kami bertujuan menyediakan konten yang bermanfaat untuk Anda. Dapatkah Anda memberi tahu kami apakah informasi ini bermanfaat untuk Anda di bagian bawah halaman ini? Berikut artikel dalam bahasa Inggris untuk referensi.

PivotTable adalah alat yang hebat untuk menghitung, meringkas dan menganalisis data yang memungkinkan Anda melihat perbandingan, pola dan tren dalam data Anda.

Browser Anda tidak mendukung video. Menginstal Microsoft Silverlight, Adobe Flash Player, atau Internet Explorer 9.

Membuat PivotTable

  1. Pilih sel yang Anda inginkan untuk membuat PivotTable.

    Catatan:  Data Anda tidak boleh memiliki baris atau kolom kosong. Data hanya boleh memiliki judul baris tunggal.

  2. Pilih Sisipkan > PivotTable.

    Pivot Table

  3. Dalam Pilih data yang ingin Anda analisis, pilih Pilih sebuah tabel atau rentang

    PivotTable

  4. Dalam Tabel/Rentang, verifikasikan rentang sel Anda.

  5. Di bawah Pilih tempat Anda ingin meletakkan laporan PivotTable, pilih lembar kerja baru untuk meletakkan PivotTable di lembar kerja baru atau lembar kerja yang ada , lalu pilih lokasi yang Anda inginkan PivotTable muncul.

  6. Pilih OK.

Mengembangkan PivotTable

  1. Untuk menambahkan bidang ke PivotTable, centang kotak nama bidang di panel Bidang PivotTable.

    Catatan: Bidang yang dipilih akan ditambahkan ke area default: bidang non-numerik akan ditambahkan ke Baris, hierarki tanggal dan waktu akan ditambahkan ke Kolom, dan bidang numerik ditambahkan ke Nilai.

    PivotTable

  2. Untuk memindahkan bidang dari satu area ke yang lain, seret bidang ke area target.

Sebelum Anda memulai:

  • Data harus diatur dalam format tabel dan pastikan tidak satu pun baris atau kolom yang kosong. Idealnya, Anda dapat menggunakan tabel Excel seperti contoh kami di atas.

  • Tabel merupakan sumber data PivotTable yang hebat karena baris yang ditambahkan ke tabel secara otomatis disertakan dalam PivotTable ketika merefresh data, dan setiap kolom baru akan disertakan dalam Daftar Bidang PivotTable. Jika tidak, Anda perlu memperbarui rentang sumber data secara manual atau menggunakan rumus rentang bernama dinamis.

  • Tipe data dalam kolom harus sama. Misalnya, Anda tidak boleh mencampur tanggal dan teks di kolom yang sama.

  • PivotTable berfungsi pada jepretan layar data, yang disebut dengan cache, sehingga data aktual Anda tidak diubah dengan cara apa pun.

Membuat PivotTable

Jika Anda memiliki pengalaman yang terbatas dengan PivotTable atau tidak yakin tentang cara memulainya, PivotTable yang Dianjurkan adalah pilihan yang baik. Dengan fitur ini, Excel akan menentukan tata letak yang tepat dengan mencocokkan data ke area yang paling pas dalam PivotTable. Hal ini membantu memberikan gambaran awal bagi Anda untuk eksperimen selanjutnya. Setelah PivotTable yang dianjurkan dibuat, Anda dapat menjelajahi berbagai orientasi dan menyusun ulang bidang untuk mendapatkan hasil yang diinginkan.

Anda juga dapat mengunduh tutorial interaktif kami untuk Membuat PivotTable pertama Anda.

PivotTable yang Direkomendasikan

Membuat PivotTable secara manual

  1. Klik sel dalam sumber data atau rentang tabel.

  2. Masuk ke Sisipkan > PivotTable yang Dianjurkan.

    Masuk ke Sisipkan > PivotTable yang Direkomendasikan untuk meminta Excel membuatkan PivotTable untuk Anda

  3. Excel menganalisis data Anda dan memberikan beberapa opsi, seperti dalam contoh ini yang menggunakan data pengeluaran rumah tangga.

    Dialog PivotTable Excel yang Direkomendasikan
  4. Pilih PivotTable yang terlihat paling sesuai untuk Anda lalu tekan OK. Excel akan membuat PivotTable di lembar baru, dan menampilkan Daftar Bidang PivotTable .

  1. Klik sel dalam sumber data atau rentang tabel.

  2. Masuk ke Sisipkan > PivotTable.

    Jika Anda menggunakan Excel untuk Mac 2011 dan versi sebelumnya, tombol PivotTable berada di tab Data dalam grup Analisis.

    Tab Data, grup Analisis

  3. Excel akan menampilkan dialog Buat PivotTable dengan nama rentang Anda atau tabel yang dipilih. Dalam hal ini, kami menggunakan tabel yang disebut "tbl_HouseholdExpenses".

  4. Di bagian Pilih tempat Anda ingin meletakkan laporan PivotTable, pilih Lembar Kerja Baru, atau Lembar Kerja yang Ada. Untuk Lembar Kerja yang Ada, pilih sel yang diinginkan untuk meletakkan PivotTable.

  5. Klik OK, lalu Excel akan membuat PivotTable kosong, dan menampilkan daftar Bidang PivotTable .

Dalam area Nama Bidang di bagian atas, centang kotak untuk setiap bidang yang ingin ditambahkan ke PivotTable. Secara default, bidang non-numerik ditambahkan ke area Baris, bidang tanggal dan waktu ditambahkan ke area Kolom, dan bidang numerik ditambahkan ke area Nilai. Anda juga dapat secara manual menyeret dan menjatuhkan setiap item yang tersedia ke dalam setiap bidang PivotTable, atau jika tidak lagi menginginkan suatu item di PivotTable, cukup seret keluar dari daftar Bidang atau hapus centangnya. Kemampuan dalam menyusun ulang item Bidang merupakan salah satu fitur PivotTable yang mempermudah pengubahan tampilan dengan cepat.

Daftar Bidang PivotTable

Bidang terkait di PivotTable

Contoh dari dialog daftar Bidang PivotTable Excel



Contoh PivotTable dan bagaimana Bidang terhubung dengan daftar Bidang.

  • Ringkas menurut

    Secara default, bidang PivotTable yang diletakkan di area Nilai akan ditampilkan sebagai rumus SUM. Jika Excel menerjemahkan data Anda sebagai teks, data tersebut akan ditampilkan sebagai rumus COUNT. Inilah mengapa Anda harus benar-benar memastikan untuk tidak mencampur tipe data bidang nilai. Anda dapat mengubah penghitungan default dengan mengklik panah di sisi kanan nama bidang terlebih dahulu, lalu memilih opsi Pengaturan Bidang.

    Berikutnya, ubah penghitungan di bagian Ringkas menurut. Harap diingat bahwa saat Anda mengubah metode penghitungan, Excel akan otomatis menambahkannya di bagian Nama Kustom, seperti "Jumlah dari FieldName", tetapi Anda dapat mengubahnya. Jika mengklik tombol Angka..., Anda dapat mengubah format angka untuk seluruh bidang.

    Tips: Mengubah penghitungan di bagian Ringkas menurut akan mengubah nama bidang PivotTable, oleh karena itu, sebaiknya jangan ganti nama bidang PivotTable sampai Anda selesai menyiapkan PivotTable. Salah satu triknya adalah dengan mengklik Ganti (pada menu Edit) >Temukan apa > "Jumlah dari", lalu Ganti dengan > biarkan kosong untuk mengganti semuanya sekaligus dan bukan mengetik ulang secara manual.

  • Perlihatkan data sebagai

    Anda tidak hanya dapat menggunakan perhitungan untuk merangkum data, tetapi juga dapat menampilkannya sebagai persentase dari bidang. Dalam contoh berikut ini, kami mengubah jumlah pengeluaran rumah tangga untuk ditampilkan sebagai % Total Akhir, dan bukan jumlah nilainya.

    Contoh PivotTable dengan Nilai yang ditampilkan sebagai persentase dari Total Akhir

    Setelah membuka dialog Pengaturan Bidang, Anda dapat membuat pilihan dari tab Perlihatkan data sebagai.

  • Menampilkan nilai sebagai perhitungan dan persentase.

    Cukup seret item ke bagian Nilai dua kali, klik kanan nilai, kemudian pilih Pengaturan Bidang, lalu atur opsi Ringkas menurut dan Perlihatkan data sebagai untuk setiap item.

Jika data baru ditambahkan ke sumber data PivotTable, setiap PivotTable yang dibuat berdasarkan sumber data tersebut perlu direfresh. Untuk merefresh hanya satu PivotTable, klik kanan di mana saja dalam rentang PivotTable, lalu pilih Refresh. Jika memiliki beberapa PivotTable, pilih sel mana saja dalam salah satu PivotTable, kemudian di Pita, masuk ke Analisis PivotTable > klik panah di bawah tombol Refresh, lalu pilih Refresh Semua.

Jika Anda membuat PivotTable lalu memutuskan untuk menghapusnya, cukup pilih seluruh rentang PivotTable, lalu tekan Hapus. Hal ini tidak akan berpengaruh pada data lain, PivotTable lain, atau bagan di sekitarnya. Jika PivotTable berada di lembar yang terpisah dan tidak mempunyai data lain yang ingin disimpan, menghapus lembar tersebut merupakan cara tercepat untuk menghapus PivotTable.

Kini Anda dapat menyisipkan PivotTable dalam lembar bentang di Excel Online.

Penting: Tidak disarankan untuk membuat atau mengerjakan PivotTable dalam lembar bentang saat pengguna lain juga sedang mengerjakannya.

  1. Pilih tabel atau rentang dalam lembar bentang Anda.

  2. Masuk ke Sisipkan > PivotTable.

  3. Excel akan menampilkan dialog Buat PivotTable dengan rentang Anda atau nama tabel yang dipilih.

    Membuat PivotTable
  4. Di bagian Pilih tempat Anda ingin meletakkan laporan PivotTable, pilih Lembar Kerja Baru, atau Lembar Kerja yang Ada. Untuk Lembar Kerja yang Ada, pilih sel yang diinginkan untuk meletakkan PivotTable.

    Catatan: Sel yang Anda rujuk harus berada di luar tabel atau rentang.

  5. Klik OK, lalu Excel akan membuat PivotTable kosong, dan menampilkan daftar Bidang PivotTable .

Dalam area Bidang PivotTable di bagian atas, centang kotak untuk setiap bidang yang ingin ditambahkan ke PivotTable. Secara default, bidang non-numerik ditambahkan ke area Baris, bidang tanggal dan waktu ditambahkan ke area Kolom, dan bidang numerik ditambahkan ke area Nilai. Anda juga dapat secara manual menyeret dan meletakkan item yang tersedia ke bidang PivotTable mana pun, atau jika tidak menginginkan item apa pun dalam PivotTable, cukup seret item keluar dari daftar Bidang atau hapus centangnya. Kemampuan untuk menyusun ulang item Bidang merupakan salah satu fitur PivotTable yang memudahkan Anda mengubah tampilannya dengan cepat.

Daftar Bidang PivotTable

Bidang terkait di PivotTable

Contoh dari dialog daftar Bidang PivotTable Excel



Contoh PivotTable dan bagaimana Bidang terhubung dengan daftar Bidang.

  • Meringkas Nilai Berdasarkan

    Secara default, bidang PivotTable yang diletakkan di area Nilai akan ditampilkan sebagai JUMLAH. Jika Excel menerjemahkan data Anda sebagai teks, data tersebut akan ditampilkan sebagai HITUNGAN. Inilah sebabnya sangat penting untuk memastikan bahwa Anda tidak mencampur tipe data untuk nilai bidang. Anda dapat mengubah perhitungan default dengan terlebih dahulu mengklik panah di sebelah kanan nama bidang, lalu memilih opsi Pengaturan Bidang Nilai.

    Dialog Pengaturan Bidang Nilai Excel

    Berikutnya, ubah perhitungan dalam bagian Rangkum Nilai Berdasarkan. Perhatikan bahwa saat Anda mengubah metode penghitungan, Excel akan secara otomatis menambahkannya di bagian Nama Kustom, seperti "Sum of FieldName", tetapi Anda dapat mengubahnya. Jika mengklik tombol Format Angka, Anda dapat mengubah format angka untuk seluruh bidang.

    Dialog Pengaturan Bidang Nilai Excel untuk Ringkas Nilai Menurut opsi

    Tips: Karena mengubah perhitungan dalam bagian Rangkum Nilai Berdasarkan akan mengubah nama bidang PivotTable, lebih baik untuk tidak mengganti nama bidang PivotTable sampai Anda selesai menyiapkan PivotTable. Salah satu triknya adalah menggunakan Temukan & Ganti (Ctrl + H) >Temukan apa > "Jumlah dari", lalu Ganti dengan > biarkan kosong untuk mengganti semuanya sekaligus, dan bukan mengetik ulang secara manual.

  • Perlihatkan Nilai Sebagai

    Anda tidak hanya dapat menggunakan perhitungan untuk merangkum data, tetapi juga dapat menampilkannya sebagai persentase dari bidang. Dalam contoh berikut ini, kami mengubah jumlah pengeluaran rumah tangga untuk ditampilkan sebagai % Total Akhir, dan bukan jumlah nilainya.

    Contoh PivotTable dengan Nilai yang ditampilkan sebagai persentase dari Total Akhir

    Setelah membuka dialog Pengaturan Bidang Nilai, Anda dapat membuat pilihan dari tab Perlihatkan Nilai Sebagai.

    Dialog Pengaturan Bidang Nilai PivotTable > Perlihatkan Nilai Sebagai
  • Tampilkan nilai sebagai perhitungan dan persentase.

    Cukup seret item ke dalam bagian Nilai dua kali, lalu atur masing-masing opsi Rangkum Nilai Berdasarkan dan Perlihatkan Nilai Sebagai.

Jika data baru ditambahkan ke sumber data PivotTable, setiap PivotTable yang dibuat berdasarkan sumber data tersebut perlu direfresh. Untuk merefresh PivotTable, Anda dapat mengklik kanan di mana saja dalam rentang PivotTable dan memilih Refresh.

Merefresh PivotTable

Jika Anda membuat PivotTable lalu memutuskan untuk menghapusnya, cukup pilih seluruh rentang PivotTable, lalu tekan Hapus. Hal ini tidak akan berpengaruh pada data lain, PivotTable lain, atau bagan di sekitarnya. Jika PivotTable berada di lembar yang terpisah dan tidak mempunyai data lain yang ingin disimpan, menghapus lembar tersebut merupakan cara tercepat untuk menghapus PivotTable.

Perlu bantuan lainnya?

Anda selalu dapat bertanya kepada pakar di Komunitas Teknologi Excel, mendapatkan dukungan di Komunitas Jawaban, atau menyarankan fitur maupun fitur baru di Suara Pengguna Excel.

Lihat Juga

Membuat PivotChart

Gunakan pemotong untuk memfilter PivotTable data

Membuat garis waktu PivotTable untuk memfilter tanggal

Membuat PivotTable dengan Model Data untuk menganalisis data dalam beberapa tabel

Menggunakan daftar bidang untuk menyusun bidang dalam PivotTable

Mengubah data sumber untuk PivotTable

Menghitung nilai di PivotTable

Menghapus PivotTable

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×