Access 2010: tugas database

Penting: Artikel ini adalah terjemahan mesin, lihat penafian. Temukan versi bahasa Inggris artikel di sini sebagai rujukan Anda.

Berikut adalah beberapa tugas dasar database yang bisa Anda lakukan untuk membantu Anda mempelajari cara menggunakan Microsoft Access 2010.

 

Di artikel ini

Apa itu Access?

Database relasional di Access

Ketika Anda membuka akses

Menemukan dan menerapkan Templat

Membuat database dari awal

Buka database Access yang sudah ada

Mulai menggunakan database baru Anda

Menambahkan tabel

Menempelkan data dari sumber lain ke dalam tabel Access

Mengimpor atau menautkan ke data dari sumber lain

Langkah berikutnya

Mengimpor data dari lembar bentang atau program lain

Mengimpor lembar kerja Excel ke Access

Mengimpor lembar kerja Excel sebagai tabel dalam database baru

Menggunakan panduan Penganalisis tabel untuk menata data Anda

Bekerja dengan data dari program lain

Menggunakan database versi yang lebih lama di beberapa versi Access

Menggunakan file database Access di beberapa versi Access

Langkah 1: Buat salinan database yang sudah ada, dan Simpan dalam format baru

Langkah 2: Memisahkan database Salin, dan menggunakan file asli sebagai database back-end

Langkah 3: Menyambungkan baru front-end ke database asli

Menggunakan aplikasi front-akhir/back-end dalam beberapa versi Access

Apa itu Access?

Access 2010 adalah aplikasi database desain dan penggunaan alat yang bisa Anda gunakan untuk melacak informasi penting. Anda bisa menyimpan data Anda di komputer Anda, atau Anda bisa menerbitkan ke Web — sehingga orang lain bisa menggunakan database Anda dengan web browser.

Banyak orang mulai menggunakan Access saat program yang mereka gunakan untuk melacak sesuatu yang secara bertahap menjadi lebih pas untuk tugas. Sebagai contoh, anggaplah Anda perencana acara, dan Anda ingin untuk melacak semua detail yang diperlukan untuk mengelola acara Anda agar berhasil. Jika Anda menggunakan word prosesor atau program lembar bentang untuk melakukan ini, Anda bisa dengan mudah mengalami masalah dengan data duplikat dan tidak konsisten. Anda bisa menggunakan perangkat lunak kalender, tapi pelacakan informasi keuangan di kalender tidak cocok.

Database relasional di Access

Terkadang Anda perlu database relasional untuk melacak informasi tersebut — perbendaharaan data yang telah dipisahkan menjadi lebih kecil kumpulan data (disebut tabel) untuk menghilangkan redundansi, dan kemudian terkait bersama-sama berdasarkan umum penggalan informasi (disebut bidang). Misalnya, perencanaan database relasional acara mungkin berisi tabel dengan pelanggan informasi, tabel dengan vendor informasi dan tabel dengan informasi kejadian. Tabel dengan informasi kejadian mungkin memiliki bidang untuk menghubungkan ke tabel pelanggan, dan bidang untuk menghubungkan ke tabel vendor. Itu, misalnya, jika nomor telepon vendor berubah, informasi yang bisa diubah sekali dalam tabel vendor, bukan dalam setiap kejadian yang terlibat vendor.

Akses adalah alat yang bisa Anda gunakan untuk dengan cepat dan mudah mengembangkan aplikasi database relasional yang membantu Anda mengelola informasi. Anda bisa membuat database untuk membantu Anda melacak apa saja jenis informasi, seperti inventaris, profesional kontak atau proses bisnis. Bahkan, Access dilengkapi dengan Templat yang bisa Anda gunakan segera untuk melacak berbagai informasi, membuat hal-hal yang mudah bahkan bagi pemula.

Ketika Anda membuka akses

Saat Anda mulai Access 2010, Anda melihat tampilan Backstage Microsoft Office, di mana Anda bisa mendapatkan informasi tentang database saat ini, membuat database baru, buka database yang sudah ada, dan lihat menampilkan konten dari Office.com.

Tampilan Backstage Access 2010

Tampilan Backstage juga berisi banyak perintah yang bisa Anda gunakan untuk menyesuaikan, mempertahankan, atau berbagi database Anda. Perintah di tampilan Backstage biasanya berlaku untuk seluruh database, bukan ke objek dalam database.

Catatan: Anda dapat mengakses tampilan Backstage setiap saat dengan mengklik File tab.

Atas halaman

Menemukan dan menerapkan Templat

Access menyediakan Anda dengan berbagai Templat yang bisa Anda gunakan untuk mempercepat proses pembuatan database Anda. Templat adalah database siap pakai yang berisi semua tabel, kueri, formulir, dan laporan yang diperlukan untuk menjalankan tugas tertentu. Sebagai contoh, ada Templat yang bisa digunakan untuk melacak masalah, mengelola kontak, atau menyimpan pengeluaran. Beberapa Templat berisi beberapa contoh catatan untuk membantu menunjukkan penggunaan mereka. Templat database bisa digunakan sebagai, atau Anda bisa mengkustomisasi mereka untuk lebih sesuai kebutuhan Anda.

Untuk menemukan dan menerapkan Templat ke database Anda, lakukan hal berikut:

  1. Pada tab File, klik Baru.

  2. Di bawah Templat yang tersedia, lakukan salah satu hal berikut ini:

    • Untuk menggunakan templat yang baru saja Anda gunakan kembali, klik Templat terbaru, dan lalu pilih Templat yang Anda inginkan.

    • Untuk menggunakan templat yang Anda sudah diinstal, klik Template saya, dan lalu pilih Templat yang Anda inginkan.

    • Untuk menemukan Templat di Office.com, di bawah Templat Office.com, klik kategori Templat, pilih Templat yang Anda inginkan, dan lalu klik Unduh untuk mengunduh Templat dari Office .com ke komputer Anda.

      Anda juga bisa mencari Templat di Office.com dari dalam Access. Dalam kotak Cari Office.com untuk Templat , ketikkan satu atau beberapa istilah pencarian, dan lalu klik tombol panah untuk mencari.

  3. Secara opsional, klik ikon folder di samping kotak Nama File untuk menelusuri ke lokasi tempat Anda ingin membuat database. Jika Anda tidak menunjukkan lokasi tertentu, Access membuat database di lokasi default yang ditampilkan di bawah kotak Nama File .

  4. Klik Buat.

Access membuat database dan membukanya untuk digunakan.

Atas halaman

Membuat database dari awal

Jika Anda ingin lebih menyeluruh pengenalan konsep di balik menggunakan Access untuk membuat database, lihat artikel dasar-dasar desain Database.

Jika tidak ada Templat yang sesuai dengan kebutuhan Anda, atau jika Anda memiliki data di program lain yang ingin Anda gunakan di Access, Anda mungkin memutuskan yang lebih baik untuk membuat database dari awal. Dalam Access 2010, Anda memiliki pilihan: database desktop standar, atau web database.

Untuk informasi selengkapnya tentang database web, lihat artikel membangun database untuk berbagi di Web.

Untuk membuat database baru, lakukan hal berikut:

  1. Buka Access.

  2. Pada tab baru di tampilan Backstage, klik Database kosong atau Database Web kosong.

    Penting: Pilihan yang Anda buat di sini akan menentukan fitur apa tersedia dalam database. Database desktop tidak diterbitkan ke Web, dan database web tidak mendukung beberapa fitur desktop, seperti Total kueri.

  3. Di sebelah kanan, ketik nama untuk database Anda dalam kotak Nama File .

    Untuk mengubah lokasi di mana Anda membuat file, klik Telusuri Gambar tombol di samping kotak Nama File , telusuri ke dan pilih lokasi baru, dan lalu klik OK.

  4. Klik Buat.

    Access membuat database, dan kemudian membuka tabel kosong (bernama Table1) dalam tampilan lembar data.

  5. Access menempatkan kursor di sel kosong pertama di kolom Klik untuk menambahkan tabel baru.

    Untuk menambahkan data, mulailah mengetik — atau Anda bisa menempelkan data dari sumber lain, seperti yang dijelaskan di bagian menempelkan data dari sumber lain ke dalam tabel Access, selanjutnya di artikel ini.

    Catatan: 

    • Memasukkan data dalam tampilan lembar data dirancang untuk menjadi sangat mirip dengan memasukkan data di lembar kerja Excel. Pembatasan utama adalah bahwa data harus dimasukkan dalam bersebelahan baris dan kolom, dimulai di sudut kiri atas lembar data. Anda tidak harus mencoba untuk memformat data Anda dengan menyertakan baris kosong atau kolom sebagai Anda mungkin melakukan dalam lembar kerja Excel, karena melakukan sehingga akan membuang ruang dalam tabel Anda. Tabel hanya berisi data Anda. Semua presentasi visual data yang akan dilakukan dalam formulir dan laporan yang Anda desain nanti.

    • Struktur tabel yang dibuat saat Anda memasukkan data. Setiap kali Anda menambahkan kolom baru ke lembar data, bidang baru ditentukan dalam tabel. Akses mengatur tipe data bidang yang didasarkan pada tipe data yang Anda masukkan. Misalnya, jika Anda memiliki kolom di mana Anda telah memasukkan nilai tanggal saja, Access akan menetapkan tipe data bidang tersebut ke tanggal/waktu. Jika Anda nanti berusaha untuk memasukkan nilai non-tanggal (seperti nama atau nomor telepon) di bidang itu, Access menampilkan pesan yang memberitahu Anda bahwa nilai yang tidak cocok dengan tipe data kolom. Jika mungkin, Anda harus merencanakan tabel Anda sehingga setiap kolom yang berisi tipe sama data, apakah itu teks, tanggal, angka, atau beberapa tipe lain. Ini yang membuatnya lebih mudah untuk menyusun kueri, formulir, dan laporan yang pilih hanya data yang Anda inginkan.

Jika Anda tidak ingin memasukkan data yang belum, klik tutup Gambar tombol .

Catatan: Akses akan menghapus Table1 jika Anda menutup tanpa menyimpan.

Atas halaman

Buka database Access yang sudah ada

Tips: Untuk membuka salah satu terakhir dengan cepat beberapa database Anda yang terbuka, pada File tab, klik terbaru, dan lalu klik nama file.

  1. Pada tab File, klik Buka.

  2. Klik pintasan dalam kotak dialog buka — atau, dalam kotak lihat di , klik drive atau folder yang berisi database yang Anda inginkan.

  3. Di daftar folder, klik ganda folder hingga Anda membuka folder yang berisi database.

  4. Saat Anda menemukan database, lakukan salah satu hal berikut ini:

    • Untuk membuka database di mode terbuka default, klik dua kali.

    • Untuk membuka database untuk akses bersama dalam suatu lingkungan Multipengguna, sehingga Anda dan pengguna lain dapat baik membaca dan menulis ke database pada saat yang sama, klik buka.

    • Untuk membuka database untuk akses baca-saja, sehingga Anda bisa menampilkannya tapi tidak bisa mengedit file, klik panah di samping tombol buka , dan lalu klik buka baca-saja.

    • Untuk membuka database untuk akses eksklusif, sehingga tidak ada orang lain bisa terbuka saat Anda harus terbuka, klik panah di samping tombol buka , dan lalu klik Buka eksklusif.

    • Untuk membuka database untuk akses baca-saja, klik panah di samping tombol buka , lalu klik Buka eksklusif Read-Only pengguna lain masih bisa membuka database, tapi mereka hanya memiliki akses baca-saja.

Jika Anda tidak bisa menemukan database yang ingin Anda buka   

  1. Dalam kotak dialog yang terbuka , klik pintasan Komputer saya — atau, dalam kotak lihat di , klik Komputer saya.

  2. Di daftar drive, klik kanan drive yang menurut Anda mungkin berisi database, dan lalu klik pencarian.

  3. Memasukkan kriteria pencarian Anda, dan tekan ENTER untuk mencari database.

  4. Jika database yang ditemukan, buka dengan mengkliknya dalam kotak dialog Hasil pencarian .

    Karena pencarian dimulai dari kotak dialog buka , Anda harus mengklik Batalkan di kotak dialog sebelum database akan terbuka.

Anda bisa langsung membuka data file dalam format file eksternal (seperti dBASE, paradoks, Microsoft Exchange, atau Excel). Anda juga bisa membuka apa pun sumber data ODBC, seperti Microsoft SQL Server atau Microsoft FoxPro. Access secara otomatis membuat database Access yang baru dalam folder yang sama sebagai data file, dan menambahkan link ke setiap tabel di database eksternal.

Atas halaman

Mulai menggunakan database baru Anda

Bergantung pada Templat yang Anda gunakan, Anda mungkin perlu melakukan salah satu atau beberapa hal berikut ini untuk memulai database baru:

  • Jika Access menampilkan kotak dialog masuk dengan daftar kosong pengguna, gunakan prosedur berikut ini untuk memulai:

    1. Klik pengguna baru.

    2. Isi formulir Detail pengguna .

    3. Klik Simpan & Tutup.

    4. Pilih nama pengguna yang baru Anda masukkan, dan lalu klik masuk.

  • Jika Access menampilkan lembar data kosong, Anda bisa mulai mengetik data secara langsung ke dalam lembar data tersebut, atau klik tombol dan tab lainnya untuk menelusuri database.

  • Jika Access menampilkan halaman Memulai , Anda bisa klik link di halaman itu untuk mempelajari selengkapnya tentang database, atau klik tombol dan tab lainnya untuk menelusuri database.

  • Jika Access menampilkan pesan Peringatan keamanan di bilah pesan, dan Anda mempercayai sumber Templat tersebut, klik Aktifkan konten. Jika database memerlukan masuk, Anda akan perlu masuk lagi.

Untuk database desktop dan web, Anda juga ingin untuk memulai dengan salah satu hal berikut langkah-langkah:

Atas halaman

Menambahkan tabel

Anda bisa menambahkan tabel baru ke database yang sudah ada dengan menggunakan alat di grup tabel pada tab buat .

Grup Tabel pada tab Buat

Catatan: Dalam web database, hanya perintah tabel tidak tersedia di grup tabel .

Terlepas dari tampilan yang Anda mulai di, Anda selalu bisa beralih ke tampilan lain dengan menggunakan tombol tampilan pada bilah status di jendela Access.

Membuat tabel kosong dalam tampilan lembar data    Dalam tampilan lembar data, Anda bisa memasukkan data yang tepat, dan biarkan Access membuat struktur tabel di balik layar. Nama bidang yang ditetapkan numerik (bidang1, Field2, dan lain-lain), dan akses kumpulan bidang tipe data, berdasarkan tipe data yang Anda masukkan.

  1. Pada tab buat , di grup tabel , klik tabel Gambar tombol .

  2. Access membuat tabel, dan kemudian menempatkan kursor di sel kosong pertama di kolom Klik untuk Tambahkan .

  3. Untuk menambahkan data, mulailah mengetik di sel kosong pertama — atau Anda bisa menempelkan data dari sumber lain, seperti yang dijelaskan selanjutnya di artikel ini.

    • Untuk mengubah nama kolom (bidang), klik ganda judul kolom, lalu ketikkan nama baru.

      Tips: Beri nama yang bermakna untuk tiap bidang, sehingga Anda bisa mengetahui apa yang berisi tanpa harus melihat data.

    • Untuk memindahkan kolom, pilih dengan mengklik judul kolom tersebut, lalu seret ke tempat yang Anda inginkan. Anda juga bisa memilih beberapa kolom yang bersebelahan dan seret semua ke lokasi baru bersama-sama.

      Untuk menambahkan lebih banyak bidang ke tabel Anda, Anda juga bisa mulai mengetik di kolom Klik untuk menambahkan dalam tampilan lembar data, atau Anda bisa menambahkan bidang baru dengan menggunakan perintah di grup Tambahkan & Hapus pada tab bidang .

Memulai membuat tabel dalam tampilan desain    Dalam tampilan desain, Anda terlebih dahulu membuat struktur tabel baru. Lalu Anda baik beralih ke tampilan lembar data untuk memasukkan data, atau Anda memasukkan data Anda dengan menggunakan beberapa metode lain, seperti dengan formulir.

Tampilan Desain ini tidak tersedia untuk tabel dalam web database.

  1. Pada tab buat , di grup tabel , klik Desain tabel. Gambar tombol

  2. Untuk setiap bidang dalam tabel Anda, ketik nama di kolom Nama bidang , dan lalu pilih tipe data dari daftar Tipe Data .

  3. Anda bisa memasukkan informasi tambahan untuk setiap bidang dalam kolom Deskripsi . Deskripsi yang Anda masukkan ditampilkan di bilah status saat titik penyisipan dalam bidang itu, dan digunakan sebagai teks bilah status untuk setiap kontrol yang Anda buat dengan menyeret bidang dari panel Daftar bidang ke formulir atau laporan, dan untuk setiap kontrol yang dibuat untuk bidang itu dengan panduan formulir atau laporan panduan.

  4. Setelah Anda menambahkan semua bidang Anda, menyimpan tabel:

    • Pada tab File, klik Simpan.

  5. Anda bisa mulai memasukkan data ke tabel Kapan saja dengan beralih ke tampilan lembar data, mengklik di sel kosong pertama, dan mengetik. Anda juga bisa menempelkan data dari sumber lain, seperti yang dijelaskan di bagian berikutnya.

Buat tabel berdasarkan pada daftar SharePoint    Dengan daftar SharePoint, data Anda bisa digunakan oleh orang-orang yang tidak memiliki akses. Selain itu, daftar data disimpan di server, yang biasanya menawarkan perlindungan yang lebih baik terhadap kehilangan data dari file yang disimpan di komputer desktop. Anda bisa baik mulai dengan daftar baru, atau Anda bisa menautkan ke daftar yang sudah ada. Anda harus memiliki izin yang memadai di situs SharePoint tempat Anda ingin membuat daftar; ini bisa berbeda-beda dengan situs hubungilah administrator SharePoint Anda untuk detail tentang opsi Anda.

Fitur ini tidak tersedia dalam Web database.

  1. Pada tab buat, di grup tabel, klik daftar SharePoint.

  2. Anda bisa menggunakan salah satu dari daftar Templat untuk membuat daftar SharePoint standar, seperti kontak atau acara.

    Anda juga bisa memilih untuk membuat daftar kustom, atau untuk menautkan ke atau mengimpor daftar yang sudah ada. Klik opsi yang Anda inginkan.

  3. Jika Anda memilih salah satu dari daftar Templat atau untuk membuat daftar kustom, dalam kotak dialog Buat daftar baru terbuka untuk memandu Anda melalui proses. Jika Anda memilih untuk menggunakan daftar yang sudah ada, kotak dialog Dapatkan Data eksternal terbuka untuk membantu Anda.

Untuk informasi selengkapnya tentang tabel, lihat artikel pengenalan tabel.

Atas halaman

Menempelkan data dari sumber lain ke dalam tabel Access

Jika data Anda saat ini disimpan di program lain, seperti Excel, Anda bisa menyalin dan menempelkan data ke dalam tabel Access. Secara umum, ini berfungsi baik jika data Anda sudah dipisahkan ke dalam kolom, seperti dalam lembar kerja Excel. Jika data Anda di dokumen word pemrosesan program, Anda harus pertama-tama Pisahkan kolom data dengan menggunakan tab, atau mengonversi data ke tabel di word pemrosesan program, dan Salin data. Jika data Anda memerlukan pengeditan atau manipulasi (misalnya, dipisahkan nama lengkap ke dalam nama depan dan belakang), Anda mungkin ingin melakukan hal ini sebelum Anda menyalin data, terutama jika Anda tidak terbiasa dengan akses.

Bila Anda menempelkan data ke tabel kosong, Access mengatur tipe data dari setiap bidang yang sesuai dengan apa jenis data ia menemukan di sana. Misalnya, jika bidang ditempelkan berisi apa-apa tapi nilai tanggal, Access berlaku data tanggal/waktu tipe untuk bidang itu. Jika bidang ditempelkan berisi hanya kata "ya" dan "tidak", Access berlaku ya/tidak ada data type ke bidang.

Akses nama bidang bergantung pada apa yang ditemukan di baris pertama data yang ditempel. Jika baris pertama data yang ditempel tipe sama dengan baris yang diikuti, Access menentukan bahwa baris pertama adalah bagian dari data dan menetapkan bidang nama generik (bidang1, Field2, dan seterusnya). Jika baris pertama data yang ditempel tidak sama dengan baris yang diikuti, Access menggunakan baris pertama sebagai nama bidang, dan mengeluarkan baris pertama di data aktual.

Jika Access menetapkan nama bidang generik, Anda harus mengganti nama bidang sesegera mungkin untuk menghindari kebingungan. Gunakan prosedur berikut ini:

  1. Pada File tab, klik Simpan untuk menyimpan tabel.

  2. Dalam tampilan lembar data, klik ganda tiap judul kolom, dan lalu ketikkan nama untuk kolom.

  3. Simpan tabel lagi.

Atas halaman

Mengimpor atau menautkan ke data dari sumber lain

Anda mungkin memiliki data yang telah Anda mengumpulkan di program lain yang ingin Anda gunakan di Access. Mungkin Anda bekerja dengan orang-orang yang menyimpan data mereka di program lain, dan Anda ingin bekerja dengan data di Access. Atau, mungkin Anda memiliki beberapa sumber data yang berbeda, dan memerlukan "pendaratan pad" di mana Anda bisa membawa mereka bersama-sama untuk analisis lebih mendalam.

Access memudahkan untuk mengimpor atau menautkan data dari program lain. Anda bisa membawa data dari lembar kerja Excel, dari tabel di database Access yang lain, dari daftar SharePoint, atau dari salah satu dari berbagai sumber lain. Proses agak berbeda bergantung pada sumber data, tapi instruksi ini akan membantu Anda memulai:

  1. Pada tab Data eksternal , di grup impor & tautkan , klik perintah untuk tipe file yang Anda impor dari.

    Misalnya, jika Anda mengimpor data dari lembar kerja Excel, klik Excel. Jika Anda tidak melihat program yang benar tipe, klik lainnya.

    Catatan: Jika Anda tidak bisa menemukan tipe format yang benar di grup impor & tautkan , Anda mungkin perlu memulai program yang Anda awalnya buat data, dan lalu gunakan program itu untuk menyimpan data dalam format file yang didukung Access (seperti file teks dipisahkan), dan lalu mengimpor atau menautkan ke data.

  2. Dalam kotak dialog Dapatkan Data eksternal , klik Telusuri untuk menelusuri ke file data sumber, atau ketikkan jalur lengkap file sumber data di kotak nama File .

  3. Klik opsi yang Anda inginkan di bawah Tentukan bagaimana dan di mana Anda ingin menyimpan data di database saat ini. Anda bisa membuat tabel baru dengan menggunakan data yang diimpor, atau membuat sebuah tabel tertaut yang mempertahankan link ke sumber data.

  4. Klik OK.

    Bergantung pada pilihan Anda, dalam kotak dialog Link objek atau Mengimpor objek kotak dialog terbuka.

  5. Menggunakan kotak dialog untuk menyelesaikan proses. Anda mengikuti prosedur yang tepat bergantung pada opsi impor atau link yang Anda pilih.

  6. Pada halaman terakhir panduan, klik Selesai.

    Jika Anda memilih untuk mengimpor, Access menanyakan apakah Anda ingin menyimpan rincian operasi impor yang baru saja Anda selesai.

  7. Jika Anda merasa bahwa Anda akan melakukan operasi impor ini sama lagi, klik Simpan langkah impor, dan lalu masukkan detail.

    Anda bisa lalu dengan mudah reproduksi operasi impor dengan mengklik Impor yang disimpan dalam mengimpor grup pada tab Data eksternal , mengklik spesifikasi impor, lalu mengklik Jalankan.

  8. Jika Anda tidak ingin menyimpan rincian operasi, klik tutup.

Access mengimpor data ke tabel baru, dan lalu menampilkan tabel di bawah tabel di panel navigasi.

Untuk mempelajari selengkapnya tentang cara mengimpor data ke dalam Access, ikuti link di bagian Lihat juga dari artikel ini.

Atas halaman

Langkah berikutnya

Proses desain berbeda-beda berdasarkan pada tujuan Anda, tapi Anda mungkin ingin mempertimbangkan untuk membuat kueri, formulir, laporan, dan makro. Artikel ini tidak menyediakan informasi tentang membuat objek database tambahan.

Untuk informasi selengkapnya, lihat artikel berikut ini:

Atas halaman

Mengimpor data dari lembar bentang atau program lain

Jika Anda terbiasa dengan program lain database atau lembar bentang, Anda mungkin mengetahui dasar-dasar cara kerja aplikasi ini dan database apa yang digunakan untuk. Akses berbeda dari banyak aplikasi database lain dengan memungkinkan Anda untuk membuat database relasional, dan selanjutnya berbeda dari sebagian besar program lembar bentang dengan menawarkan alat untuk mengembangkan canggih kueri, formulir, dan laporan. Access juga menyediakan banyak opsi untuk bekerja dengan program database lain, seperti SQL Server.

Mengimpor lembar kerja Excel ke Access

Banyak orang mulai menjelajahi akses setelah pertama menyusun daftar di Excel. Excel adalah tempat yang bagus untuk memulai daftar, tapi sebagai daftar bertumbuh, menjadi lebih sulit untuk menata dan mempertahankan diperbarui. Memindahkan daftar untuk mengakses biasanya adalah logika langkah berikutnya.

Tabel database ini dalam struktur mirip dengan lembar kerja, di mana data disimpan dalam baris dan kolom. Hasilnya, itu biasanya mudah untuk mengimpor lembar kerja ke dalam tabel database. Perbedaan utama antara menyimpan data Anda dalam lembar kerja dan menyimpannya di database berada di penataan data. Hanya mengimpor seluruh lembar kerja sebagai tabel baru di database tidak mengatasi masalah yang terkait dengan menata dan memperbarui data Anda, terutama jika lembar kerja Anda berisi data yang berlebihan. Untuk mengatasi masalah tersebut, Anda harus memisahkan data lembar bentang menjadi tabel terpisah, masing-masing berisi data terkait. Untuk informasi selengkapnya tentang cara menyusun data dalam tabel Anda, lihat artikel dasar-dasar desain Database.

Mengakses fitur panduan Penganalisis tabel, yang bisa membantu Anda menyelesaikan proses. Setelah mengimpor data ke tabel, panduan membantu Anda untuk memisahkan tabel menjadi tabel terpisah, masing-masing berisi data yang tidak diduplikasi di salah satu dari tabel lainnya. Panduan juga membuat diperlukan hubungan antara tabel.

Atas halaman

Mengimpor lembar kerja Excel sebagai tabel dalam database baru

  1. Pada File tab, klik baru, dan kemudian klik Database kosong.

  2. Ketik nama untuk database baru di kotak Nama File , dan lalu klik buat.

    Database baru akan terbuka, dan Access membuat tabel kosong yang baru, Table1.

  3. Tutup Table1.

    Ketika ditanya apakah Anda ingin menyimpan perubahan ke desain Table1, klik tidak.

  4. Pada tab Data eksternal , di grup impor & tautkan , klik Excel. Gambar tombol

  5. Dalam kotak dialog Dapatkan Data eksternal , klik Telusuri.

  6. Gunakan kotak dialog Buka File untuk menemukan file Anda.

  7. Pilih file, lalu klik Buka.

  8. Dalam kotak dialog Dapatkan Data eksternal , pastikan bahwa opsi impor data sumber ke tabel baru di database saat ini dipilih.

  9. Klik OK.

    Panduan impor lembar bentang dimulai, dan menanyakan beberapa pertanyaan tentang data Anda.

  10. Ikuti instruksi, mengklik berikutnya atau kembali untuk menavigasi melalui halaman. Pada halaman terakhir panduan, klik selesai.

    Catatan: Akses menanyakan apakah Anda ingin menyimpan rincian operasi impor yang baru saja Anda selesai. Jika Anda merasa bahwa Anda akan melakukan ini sama mengimpor operasi lagi, klik ya, dan lalu masukkan detail. Anda bisa lalu dengan mudah reproduksi operasi di masa yang akan datang dengan mengklik Impor yang disimpan di grup impor pada tab Data eksternal . Jika Anda tidak ingin menyimpan rincian operasi, klik tutup.

Akses mengimpor data ke tabel baru, dan lalu menampilkannya di bawah Semua tabel dalam panel navigasi.

Atas halaman

Menggunakan panduan Penganalisis tabel untuk menata data Anda

Setelah data Anda telah diimpor ke dalam tabel Access, Anda bisa menggunakan panduan Penganalisis tabel untuk dengan cepat mengidentifikasi data berlebihan. Panduan lalu menyediakan cara untuk menata data menjadi tabel terpisah, yang disimpan dalam cara paling efisien. Access mempertahankan tabel asli sebagai cadangan, dan lalu membuat tabel baru yang bisa Anda gunakan sebagai basis untuk aplikasi database Anda.

  1. Buka database Access yang berisi tabel yang ingin Anda analisis.

  2. Pada tab Alat Database , di grup analisis , klik Analisis tabel.

    Panduan Penganalisis tabel dimulai.

    Dua halaman pertama panduan berisi tutorial singkat — lengkap dengan tombol yang bisa Anda klik untuk melihat contoh. Jika Anda tidak melihat halaman pengantar, tetapi sebagai gantinya melihat kotak centang berlabel memperlihatkan halaman pengantar?, pilih kotak centang, dan kemudian klik kembali dua kali untuk melihat pengenalan. Jika Anda tidak ingin melihat halaman pengantar lagi setelah membaca pengenalan, Anda dapat menghapus memperlihatkan halaman pengantar? kotak centang.

  3. Pada tabel yang berisi bidang dengan nilai yang diulang di banyak rekaman? halaman, pilih tabel yang ingin Anda analisis, dan lalu klik berikutnya.

  4. Anda bisa membiarkan panduan memutuskan bidang mana masuk dalam tabel mana, atau Anda bisa membuat keputusan itu sendiri. Jika Anda mengikuti panduan saran, Anda masih bisa membuat perubahan pada tata letak tabel pada halaman berikutnya panduan.

    Catatan: Jika Anda memperbolehkan panduan memutuskan bidang mana untuk dimasukkan ke dalam tabel mana, pilihan yang selalu mungkin tidak sesuai untuk data Anda, terutama jika tidak ada banyak data untuk dikerjakan. Anda harus memeriksa panduan hasil hati-hati. Di sisi lain, panduan mungkin menyarankan organisasi lebih efisien dari yang Anda berpikir tentang, jadi sangatlah ide yang baik untuk setidaknya satu kali mencoba keputusan panduan tersebut. Jika Anda tidak menyukai saran, Anda masih bisa menyusun bidang secara manual, dan Anda bisa selalu klik kembali dan menyusun semua bidang.

  5. Klik berikutnya. Di Halaman ini, Anda menentukan tabel mana yang berisi bidang mana. Jika Anda memilih untuk membiarkan memutuskan panduan, Anda akan melihat beberapa tabel yang tersambung dengan garis hubungan. Jika tidak, Access membuat hanya satu tabel yang berisi semua bidang. Dalam kedua hal tersebut, Anda bisa membuat perubahan pada Halaman ini.

    • Anda bisa menyeret bidang dari tabel ke sebuah area kosong halaman untuk membuat tabel baru yang berisi bidang tersebut. Access meminta Anda untuk nama tabel.

    • Anda bisa menyeret bidang dari satu tabel ke tabel lain jika Anda merasa bahwa mereka akan disimpan secara lebih efisien ada.

    • Sebagian besar tabel akan diberi ID atau bidang ID unik yang dihasilkan . Untuk mempelajari selengkapnya tentang bidang ID, klik Tips di sudut kanan atas panduan.

    • Untuk membatalkan perubahan, klik tombol Batalkan .

    • Untuk mengganti nama tabel, klik ganda dengan bilah judul, ketikkan nama baru, dan lalu klik OK.

  6. Setelah Anda memiliki bidang yang disusun dengan cara yang Anda inginkan, klik berikutnya.

  7. Jika panduan menemukan rekaman yang memiliki nilai sangat mirip, itu akan mengidentifikasi nilai tersebut sebagai kemungkinan kesalahan ketik dan menyajikan layar tempat Anda bisa mengonfirmasi apa yang harus dilakukan tentang mereka. Gulir daftar untuk menemukan apa pun yang memiliki nilai di kolom koreksi , lalu klik item yang sesuai di daftar turun bawah. Pilih (biarkan sebagai-adalah) untuk mencegah panduan membuat perubahan apa pun ke nilai. Bila sudah selesai, klik berikutnya.

  8. Panduan menanyakan apakah Anda ingin membuat kueri yang terlihat seperti tabel asli Anda. Jika Anda telah membangun formulir dan laporan yang didasarkan pada tabel asli, membuat kueri seperti ide yang bagus. Jika Anda memilih ya, membuat kueri, panduan mengganti nama tabel asli dengan menambahkan "_OLD" untuk nama tabel, dan lalu nama kueri baru dengan menggunakan nama tabel asli. Formulir dan laporan yang didasarkan pada tabel sekarang menggunakan kueri untuk data mereka, dan mereka terus berfungsi seperti sebelumnya.

  9. Klik Selesai.

    Panduan membuat tabel baru seperti yang ditentukan, dan lalu terbuka mereka. Tutup mereka saat Anda selesai memeriksa hasil.

Atas halaman

Bekerja dengan data dari program lain

Access 2010 menyediakan fitur untuk bekerja dengan data yang disimpan di program lain.

Membuat database Access baru yang menghubungkan ke data dalam format file lain    Anda bisa menggunakan Access untuk membuka file dalam format file lain seperti teks, dBASE atau lembar bentang. Access secara otomatis membuat Access database dan link file untuk Anda.

  1. Buka Access.

  2. Pada tab File, klik Buka.

  3. Dalam kotak dialog buka , klik tipe file yang ingin Anda buka dalam daftar. Jika Anda tidak yakin tipe file, klik semua file (*. *).

  4. Jika diperlukan, telusuri ke folder yang berisi file yang ingin Anda buka. Saat Anda menemukan file, klik ganda untuk membukanya.

  5. Ikuti instruksi di panduan. Pada halaman terakhir panduan, klik selesai.

Mengimpor atau menautkan data ke database Access yang sudah ada    Anda bisa baik mengimpor data dari sumber dan program lainnya ke dalam tabel Access agar data terdapat di dalam Access file, atau Anda bisa menautkan ke data dari Access sehingga data tetap berada di file asli (luar Access file).

  1. Pada tab Data eksternal , di grup impor & tautkan , klik format di mana data disimpan.

    Anda bisa mengimpor atau menautkan ke data dari sumber berikut:

    • Excel    Anda bisa membawa data dari lembar kerja atau rentang bernama dalam buku kerja Excel. Setiap lembar kerja atau rentang bernama harus diimpor atau ditautkan secara terpisah.

    • Access    Ini sangat berguna untuk memisahkan proses Anda dari data Anda, membuat database terpisah. Yaitu, Anda bisa menggunakan satu database untuk memuat semua formulir, laporan, dan makro, dan mempertahankan data Anda di database lain. Anda dapat mengembangkan penyempurnaan tanpa mengganggu kantor seseorang. Anda juga bisa menggabungkan data dari banyak database Access yang berbeda, sehingga lebih mudah untuk meringkas data di departemen atau antara mitra bisnis.

    • ODBC database    Banyak program yang mendukung format ini, termasuk produk server database. Ini akan membantu Anda membuat database "pendaratan pad", di mana Anda menggabungkan data dari sistem yang berbeda.

    • File teks    Anda bisa menyambungkan ke file teks sederhana, dan bahkan dapat menggunakan Access untuk mengubah konten file tersebut. Ini bisa membantu membuat Access data mudah menggunakan dengan beragam program.

    • XML file    Format ini juga menawarkan kompatibilitas dengan beragam program lainnya, termasuk beberapa server web.

    • Daftar SharePoint    Ini membuat data Anda dapat digunakan dengan browser web, cara standar untuk menggunakan daftar SharePoint.

    • Layanan data    Anda bisa menyambungkan ke data layanan web di dalam perusahaan Anda.

    • Dokumen HTML   

    • Outlook folder    Anda bisa menyambungkan ke folder Outlook, sehingga Anda lebih mudah mengintegrasikan informasi kontak Anda dengan data Anda.

    • dBase file    dBase adalah sistem populer alternatif database yang didukung oleh Access

      Kotak dialog Dapatkan Data eksternal muncul.

  2. Ikuti instruksi dalam kotak dialog.

    Akses akan mengimpor atau menautkan data ke database Anda. Untuk sebagian besar format, Anda harus menentukan lokasi data, dan lalu pilih bagaimana Anda ingin data disimpan dalam database Anda.

Atas halaman

Menggunakan database versi yang lebih lama di beberapa versi Access

Jika proyek Access atau Access database Anda dibuat di Access 2000 atau yang lebih baru, Anda bisa menggunakan database atau proyek di versi akses di mana yang dibuat atau di versi yang lebih baru — bahkan jika file berada keamanan yang diaktifkan. Misalnya, file Access 2000 bisa digunakan di Access 2000, Access 2002, Access 2003, Access 2007 dan Access 2010.

Anda mungkin memiliki situasi di mana Anda ingin menyimpan data Anda dalam versi Access yang lebih lama, tapi Anda memiliki pengguna dengan versi Access yang ingin Anda tautkan data tapi masih memanfaatkan beberapa fitur versi yang lebih baru. Solusi adalah untuk membuat database baru "front-end" di versi yang lebih baru (berisi formulir, laporan, kueri, makro, tapi tabel tidak ada), dan menautkannya ke tabel dalam file versi yang lebih lama. Gunakan salah satu prosedur berikut ini, bergantung pada apakah database Anda terdapat dalam satu file, atau telah dibagi menjadi aplikasi terdepan/terbelakang.

Menggunakan file database Access di beberapa versi Access

Jika semua tabel, formulir, dan objek lain dari database Access versi yang lebih lama Anda terdapat dalam satu file, dan Anda ingin menggunakan database di Access beberapa versi, Anda bisa membuat database front-end yang baru dalam versi yang lebih baru dan menautkannya ke file asli. Pengguna yang memiliki versi Access lebih lama masih dapat menggunakan database asli. Pengguna yang memiliki versi yang lebih baru bisa menggunakan database front-end baru untuk menautkan ke data yang sama. Anda bisa membuat beberapa versi front-end jika Anda perlu untuk mengakomodasi beberapa versi Access.

Atas halaman

Langkah 1: Buat salinan database yang sudah ada, dan Simpan dalam format baru

Gunakan prosedur berikut ini untuk mengonversi database ke salah satu dari tiga format terbaru: Access 2000, Access 2002-2003, atau Access 2007. Perintah ini mempertahankan database asli dalam format aslinya, dan membuat salinan dalam format yang Anda tentukan.

  1. Tutup Access file. Jika file database Access Multipengguna yang terletak di server atau di folder bersama, pastikan bahwa tidak ada orang lain memiliki terbuka.

  2. Mulai Access 2010.

  3. Pada tab File, klik Buka.

  4. Telusuri ke lokasi file yang ingin Anda konversi, dan lalu klik ganda untuk membukanya.

    Jika kotak dialog Database penyempurnaan muncul, menanyakan apakah Anda ingin menyempurnakan database, klik tidak.

  5. Jika formulir terbuka ketika Anda memulai database, tutup formulir.

  6. Pada File tab, klik Simpan Database sebagai.

  7. Dalam kotak dialog Simpan sebagai , ketik nama untuk database baru.

    Catatan: Kecuali Anda akan menyimpan database baru di lokasi berbeda, nama harus berbeda dari database asli. Dalam kedua hal tersebut, biasanya terbaik untuk menggunakan nama yang berbeda, sehingga Anda bisa dengan mudah membedakan antara front-end database dan database back-end. Namun, jika Anda mengonversi ke format Access 2007, ekstensi nama file berubah dari .mdb menjadi .accdb, sehingga Anda bisa menggunakan nama file yang sama.

  8. Klik Simpan.

Atas halaman

Langkah 2: Memisahkan database Salin, dan menggunakan file asli sebagai database back-end

Memisahkan database dikonversi dengan menggunakan prosedur berikut ini:

  • Pada tab Alat Database , di grup Pindahkan Data , klik Access Database. Gambar tombol

  • Di kotak dialog Database pembagi , klik Database terpisah.

    Anda bisa membuat cadangan jika Anda ingin, namun Anda juga bisa kembali membuat salinan dengan menggunakan database asli.

  • Ketik nama untuk database back-end, dan lalu klik Pisahkan.

Atas halaman

Langkah 3: Menyambungkan baru front-end ke database asli

  1. Menghapus database back-end yang dibuat alat Database pemisah — berhati-hati tidak untuk menghapus database asli Anda.

  2. Menautkan database front-end baru ke tabel dalam database asli: pada tab Data eksternal , di grup impor & tautkan , klik Manajer tabel tertaut. Gambar tombol

  3. Klik Pilih Semua, dan lalu pilih kotak centang selalu meminta lokasi baru .

  4. Klik OK, telusuri ke database versi yang lebih lama, dan lalu klik ganda.

    Jika semua berjalan lancar, Access menampilkan pesan yang mengatakan bahwa semua tabel tertaut dipilih berhasil direfresh.

Sekarang, Anda bisa meningkatkan database front-end baru untuk mendukung fitur baru untuk pengguna yang memiliki versi Access yang lebih baru. Pengguna yang memiliki versi yang lebih lama bisa terus menggunakan database versi yang lebih lama.

Atas halaman

Menggunakan aplikasi front-akhir/back-end dalam beberapa versi Access

Jika database Access Anda sudah aplikasi terdepan/terbelakang, Anda bisa mengonversi ujung depan ke format file baru. Tidak ada perubahan diperlukan untuk database back-end.

Prosedur berikut ini memperlihatkan kepada Anda cara menggunakan perintah Simpan Database sebagai untuk mengonversi front-end database ke salah satu dari tiga format terbaru: Access 2000, Access 2002-2003, atau Access 2007. Perintah ini mempertahankan database asli dalam format aslinya dan membuat salinan dalam format yang Anda tentukan.

  1. Tutup front-end database. Jika file database Access Multipengguna yang terletak di server atau di folder bersama, pastikan bahwa tidak ada orang lain memiliki terbuka.

  2. Mulai Access 2010.

  3. Pada tab File, klik Buka.

  4. Telusuri ke lokasi front-end database, dan lalu klik ganda untuk membukanya.

    Jika kotak dialog Database penyempurnaan muncul, menanyakan apakah Anda ingin menyempurnakan database, klik tidak.

  5. Jika formulir muncul saat Anda membuka database, tutup formulir.

  6. Pada File tab, klik Simpan Database sebagai.

  7. Dalam kotak dialog Simpan sebagai , ketik nama untuk database baru.

  8. Klik Simpan.

Sekarang, Anda bisa meningkatkan database front-end baru untuk mendukung fitur baru.

Atas halaman

Catatan: Penafian Terjemahan Mesin: Artikel ini telah diterjemahan oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan terjemahan mesin ini untuk membantu pengguna yang bukan penutur bahasa Inggris agar dapat menikmati konten tentang produk, layanan, dan teknologi Microsoft. Karena artikel ini diterjemahkan oleh mesin, mungkin akan terdapat kesalahan kosa kata, sintaksis, atau tata bahasa.

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

Terima kasih atas umpan balik Anda!

Terima kasih atas umpan balik Anda! Sepertinya menghubungkan Anda ke salah satu agen dukungan Office kami akan sangat membantu.

×