Képletek és függvények

SZUM függvény

SZUM függvény

Megjegyzés: Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja.

A matematikai függvények közé tartozó SZUM függvény értékek összeadására szolgál. Összeadhat egyedi értékeket, cellahivatkozásokat, tartományokat vagy akár a három kombinációját is.

Például:

  • =SZUM(A2:A10)

  • =SZUM(A2:A10; C2:C10)

Ez a böngésző nem támogatja a videók lejátszását. Telepítse a Microsoft Silverlightot, az Adobe Flash Playert vagy az Internet Explorer 9-es verzióját.

SZUM(szám1;[szám2];...)

Argumentum neve

Leírás

szám1    (Kötelező)

Az összeadás első tagja. A szám lehet például a 4, lehet egy cellahivatkozás, például B6 vagy egy cellatartomány, például B2:B8.

szám2–255    (Nem kötelező)

Az összeadás második tagja. Ily módon megadhat legfeljebb 255 további számot.

Ebben a szakaszban megismerhet néhány ajánlott eljárást a SZUM függvény használatára vonatkozóan. Az eljárások többségének a más függvényekkel való munka során is hasznát veheti.

Az =1+2 vagy =A+B módszer – Még ha az „=1+2+3” vagy az „=A1+B1+C2” képlet egyszerűen beírhatónak és pontosnak is tűnik, ez a módszer több szempontból is problematikus:

  1. Elírások – Gondoljon bele, hogy mi lenne, ha sokkal több vagy nagyobb értékeket kellene beírnia, például:

    • =14598,93+65437,90+78496,23

    Nem könnyű ilyen esetben ellenőrizni az értékek helyességét. Sokkal egyszerűbb, ha elhelyezi ezeket az értékeket egy-egy cellában, és a SZUM függvénnyel adja őket össze. A cellában elhelyezett értékeket emellett formázhatja is, és így sokkal olvashatóbbá teheti őket, mintha közvetlenül a képletben szerepelnének.

    A képletekben fixen kódolt értékek helyett használja a SZUM függvényt.  A D5 cellában szereplő képlet a következő: =SZUM(D2:D4)
  2. #ÉRTÉK! hiba – Ha szövegre hivatkozik számok helyett.

    Ha például az alábbi képletet használja:

    • =A1+B1+C1 vagy =A1+A2+A3

    Nem megfelelő képletszerkesztés példája.  A képlet a D2 cellában =A2+B2+C2

    A képlete #ÉRTÉK! hibát adhat, ha a hivatkozott cellákban akár egyetlen nem szám (vagyis szöveges) érték is szerepel. A SZUM függvény ezzel szemben figyelmen kívül hagyja a szöveges értékeket, és csak a számértékeket adja össze.

    Helyes képletszerkesztés.  Az =A2+B2+C2 helyett a D2 cellában szereplő képlet a következő: =SZUM(A2:C2)
  3. #HIV! hiba – Ha sorokat vagy oszlopokat töröl.

    Oszlop törlésével okozott #HIV! hiba.  A képlet a következőre változott: =A2+#HIV!+B2

    Ha töröl egy sort vagy oszlopot, a képlet nem fog frissülni a törölt elem kizárásához, és ezért #HIV! hibát ad, míg a SZUM függvény automatikusan képes igazodni az ilyen változásokhoz.

    A SZUM függvény automatikusan módosul a beszúrt vagy törölt soroknak és oszlopoknak megfelelően
  4. Nem frissülő hivatkozások sorok vagy oszlopok beszúrásakor

    =A+B+C képletek nem frissülnek, ha sorokat vesz fel

    Ha beszúr egy sort vagy oszlopot, a képlet nem fog frissülni a hozzáadott sor vagy oszlop belefoglalásához, míg a SZUM függvény automatikusan igazodik az ilyen változásokhoz (kivéve, ha a változás a képletben hivatkozott tartományon kívül történik). Ezt fontos észben tartani, mert ha azt feltételezi, hogy a képlet frissül, akkor előfordulhat, hogy észre sem veszi, amikor hiányos eredményt kap.

    A példa egy oszlop beszúrásakor a =SZUM(A2:C2) képletről automatikusan a =SZUM(A2:D2) képletre bővülő SZUM képletet szemléltet
  5. SZUM egyéni cellahivatkozásokkal vagy tartományokkal

    Vessen egy pillantást az alábbi képletre:

    • =SZUM(A1;A2;A3;B1;B2;B3)

    Ez a képlet ugyanannyi hibalehetőséget rejt sorok hozzáadásakor vagy törlésekor, ugyanazon okból kifolyólag. Biztonságosabb, ha tartományokat használ:

    • =SZUM(A1:A3;B1:B3)

    Ezek frissülnek sorok hozzáadásakor és törlésekor.

Probléma

A probléma oka

A SZUM függvényem a ##### értéket mutatja az eredmény helyett.

Ellenőrizze az oszlop szélességét. A ##### érték általában azt jelzi, hogy az oszlop túl keskeny a képlet eredményének megjelenítéséhez.

A SZUM függvényem magát a beírt képletet mutatja szövegként az eredmény helyett.

Győződjön meg arról, hogy a cella nem szövegként van formázva. Jelölje ki a szóban forgó cellát vagy tartományt, a Ctrl+1 billentyűkombinációval nyissa meg a Cellák formázása párbeszédpanelt, és válassza ki a megfelelő formátumot a Szám lapon. Ha a cella szövegként volt formázva, és nem lát változást a formátum módosítása után, akkor előfordulhat, hogy az F2 > Enter billentyű lenyomásával kell kényszerítenie a formátum frissítését.

A SZUM függvényem nem frissül.

Győződjön meg arról, hogy a Számítás beállítás Automatikus értékre van állítva. A képlet lapon válassza a számítási beállítások lehetőséget. Az F9 billentyű lenyomásával is kényszerítheti a munkafüzet kiszámítását.

Győződjön meg róla, hogy a Számítás beállítás Automatikus értékre van állítva.  Ezt a Képlet lap Számolási beállítások menüjében ellenőrizheti.

Egyes értékek kimaradnak a számításból.

Csak a hivatkozásban vagy a tartományban szereplő számértékek adhatók össze. Az üres cellákat, a logikai értékeket (például IGAZ) és a szöveget a függvény figyelmen kívül hagyja.

A várt eredmény helyett a #NÉV? hiba jelenik meg.

Ez általában azt jelzi, hogy a függvény neve hibásan lett beírva, például „=szumm(A1:A10)” a „=SZUM(A1:A10)” helyett.

A SZUM függvényem egész számot jelenít meg tizedesek helyett

Ellenőrizze, hogy a Cellaformázás a tizedesjegyek megjelenítését jelenti-e. Jelölje ki a kérdéses cellát vagy cellatartományt, és a CTRL + 1 billentyűkombinációval nyissa meg a Cellák formázása párbeszédpanelt, majd kattintson a szám fülre , és válassza ki a kívánt formátumot, és adja meg, hogy hány tizedesjegyet szeretne használni.

  1. Most szeretnék összeadni/kivonni, szorozni vagy osztani a számokat Ebből a videóból megTudhatja, hogyan használhatja az Excelben az alapvető matematikai elemeket, illetve hogyan használhatja a számológépet az Excelben.

  2. <c0>Hogyan jeleníthetek meg több vagy kevesebb tizedeshelyet?</c0> – Módosíthatja a számformátumot. Jelölje ki a szóban forgó cellát vagy tartományt, a Ctrl+1 billentyűkombinációval nyissa meg a Cellák formázása párbeszédpanelt, és válassza a megfelelő formátumot a Szám lapon. Ezzel jelezheti a kívánt tizedeshelyek számát.

  3. Hogyan vehetem fel vagy vonjuk ki az időPontokat? Az időpontokat többféle módon is hozzáadhatja és kivonja. Ha például a 8:00 AM-12:00 PM közötti különbséget szeretné használni a bérlista szempontjából, akkor a következőt kell használnia: = ("12:00 PM"-"8:00") * 24, a befejezési időpontot levonva a kezdési időpontot. Felhívjuk a figyelmét arra, hogy az Excel a napok töredékei szerint számítja ki az időpontokat, ezért 24 értékkel kell szorozni a teljes óraszámmal. Az első példában a = ((B2-a2) + (D2-C2)) * 24 érték esetén a kezdéstől az elejétől a végéig tartó órák számát adja meg (8,50 óra összesen).

    Ha csak órákat és perceket ad hozzá, és így szeretné megjeleníteni őket, akkor egyszerű összeadást végezhet a 24-gyel való szorzás nélkül. Ezért a második példában a =SZUM(A6:C6) képletet használjuk, mivel csak a hozzárendelt feladatok összes órájának és percének a számára van szükségünk (5:36, illetve 5 óra, 36 perc).

    Idő számítása

    További információ: Időértékek összegzése és kivonása.

  4. Hogyan számíthatom ki dátumok különbségét? Az időpontokhoz hasonlóan a dátumokat is összeadhatja és kivonhatja egymásból. Az alábbi példa kiszámítja, hogy hány napnyi különbség van két dátum között. A képlet itt egyszerűen =B2-A2. A legfontosabb szempont a dátumok és az időpontok számításával kapcsolatban, hogy a befejező dátummal vagy időponttal kell kezdeni, és abból kell kivonni a kezdő dátumot vagy időpontot.

    Dátumok közötti különbségek számítása

    Ha többet szeretne tudni a dátumokkal végzett munkáról, olvassa el a következő témakört: két dátum közötti különbség kiszámítása.

  5. Hogyan adhatom össze csak a látható cellákat? Néha, amikor manuálisan rejt el sorokat, vagy az AutoSzűrő használatával jelenít meg csak bizonyos adatokat, csak a látható cellákat is összegezni szeretné. Ehhez a RÉSZÖSSZEG függvényt használhatja. Ha összegsort használ egy Excel-táblázatban, a program az összegeket tartalmazó legördülő listában Ön által kiválasztott függvényt írja be automatikusan részösszegként. Erről bővebben az Adatok összegzése Excel-táblázatban című témakörben olvashat.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

További tudnivalók az ÖSSZEGZÉSről

A SZUMHA függvény csak a megadott feltételnek megfelelő értékeket adja össze

A SZUMHATÖBB függvény csak a több feltételnek megfelelő értékeket adja össze

A DARABTELI függvény csak a megadott feltételnek megfelelő értékeket számolja meg

A DARABHATÖBB függvény csak a megadott összes feltételnek megfelelő értékeket számolja meg

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

Képletekben lévő hibák keresése és javítása

A Windows Excel billentyűparancsai

A Mac Excel billentyűparancsai

Matematikai és trigonometriai függvények

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×