HAHIBA függvény

A HAHIBA függvénnyel csapdába rendezheti és kezelheti a képletek hibáit. A HAHIBA függvény egy megadott értéket ad eredményül, ha egy képlet hibát ad ki; Ellenkező esetben a képlet eredményét adja eredményül.

Szintaxis

HAHIBA(érték; érték_ha_hiba)

A HAHIBA függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • érték    Megadása kötelező. Argumentum, amelyet a függvény ellenőriz, hogy hibát eredményez-e.

  • value_if_error    Kötelező megadni. A visszaadott érték, ha a képlet hibát ad vissza. A program kiértékeli az alábbi típusú hibakódokat: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? vagy #NULL!.

Megjegyzések

  • Ha az érték vagy a value_if_error egy üres cella, a HAHIBA üres karakterláncként ("") kezeli.

  • Ha az érték egy tömbképlet, a HAHIBA az érték mezőben megadott tartományban lévő összes cella eredményének tömbjét adja eredményül. Ezt szemlélteti az alább található második példa.

Példák

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja meg az F2, majd az Enter billentyűt.

Kvóta

Eladott egység

210

35

55

0

23

Képlet

Leírás

Eredmény

=HAHIBA(A2/B2;"Számítási hiba")

Hibát keres a képlet első argumentumában (210 osztva 35-tel); nem talál hibát, ezért a képlet eredményét adja vissza.

6

=HAHIBA(A3/B3;"Számítási hiba")

Hibát keres a képlet első argumentumában (55 osztva 0-val); 0-val való osztási hibát talál, ezért az érték_ha_hiba argumentum értékét adja eredményül.

Számítási hiba

=HAHIBA(A4/B4;"Számítási hiba")

Hibát keres a képlet első argumentumában ("" osztva 23-mal); nem talál hibát, ezért a képlet eredményét adja vissza.

0

2. példa

Kvóta

Eladott egység

Arány

210

35

6

55

0

Számítási hiba

23

0

Képlet

Leírás

Eredmény

=C2

Hibát keres a képlet első argumentumaként megadott tömbképlet első elemében (A2/B2, vagyis 210 osztva 35-tel); nem talál hibát, ezért a képlet eredményét adja vissza.

6

=C3

Hibát keres a képlet első argumentumaként megadott tömbképlet második elemében (A3/B3, vagyis 55 osztva 0-val); 0-val való osztási hibát talál, ezért az érték_ha_hiba argumentum értékét adja eredményül.

Számítási hiba

=C4

Hibát keres a képlet első argumentumaként megadott tömbképlet harmadik elemében (A4/B4, vagyis "" osztva 23-mal); nem talál hibát, ezért a képlet eredményét adja vissza.

0

Megjegyzés: Ha az Office 365jelenlegi verziójával rendelkezik, a képletet a kimeneti tartományban a bal felső cellába írhatja be, majd az ENTER billentyűt lenyomva erősítse meg a képlet dinamikus tömbképletként való megerősítését. Máskülönben a képletet örökölt tömbképletként kell beírnia, először ki kell választania a kimeneti cellatartományt, be kell írnia a képletet a kimeneti értéktartomány bal felső cellájába, majd a CTRL + SHIFT + ENTER billentyűkombinációt lenyomva erősítse meg. Az Excel a képlet elejére és végére beszúrja Ön helyett a kapcsos zárójeleket. A tömbképletekről további információt az Útmutatások és példák tömbképletek használatához című cikkben talál.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Megjegyzés:  Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Hasznos volt ez az információ az Ön számára? Itt találja az eredeti angol nyelvű cikket.

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×