Képletek és függvények

HA függvény

HA függvény

A HA függvény az Excel egyik legnépszerűbb függvénye, és segítségével logikai összehasonlításokat végezhet egy érték és az elvárások között.

Tehát a HA utasításoknak két eredménye lehet. Az első eredmény akkor áll elő, ha az összehasonlítás igaz, a második pedig akkor, ha az összehasonlítás hamis.

Például az =HA(C2="Igen",1,2) a következőt jelenti: HA(C2 = Igen, akkor 1, ellenkező esetben 2 értéket ad vissza).

Ez a böngésző nem támogatja a videók lejátszását. Telepítse a Microsoft Silverlightot, az Adobe Flash Playert vagy az Internet Explorer 9-es verzióját.

A HA függvénnyel, amely egy logikai függvény, aszerint adhat vissza értéket, hogy egy feltétel teljesül-e.

HA(logikai_vizsgálat; érték_ha_igaz; [érték_ha_hamis])

Például:

  • =HA(A2>B2;"Költségvetést meghaladó";"OK")

  • =HA(A2=B2,B4-A4,"")

Argumentum neve

Leírás

logikai_vizsgálat    (kötelező)

A vizsgálni kívánt feltétel.

érték_ha_igaz    (kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye IGAZ.

érték_ha_hamis    (nem kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye HAMIS.

Példák a HA függvényre

A D2 cellában szereplő képlet a következő: =HA(C2="Igen",1,2)
  • =HA(C2=”Igen”,1,2)

A fenti példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 = Igen, akkor 1, ellenkező esetben 2 értéket ad vissza)

A D2 cellában szereplő képlet a következő_ =HA(C2=1,"IGEN","NEM")
  • =HA(C2=1,”Igen”,”Nem”)

Ebben a példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 = 1, akkor Igen, ellenkező esetben Nem értéket ad vissza)Ahogyan az látható, a HA függvény szöveg és értékek kiértékelésére is használható. Ezenkívül hibákat is kiértékelhet vele. Nemcsak azt ellenőrizheti, hogy valami egyenlő-e valami mással (egyetlen eredményt kapva), hanem matematikai operátorokat is használhat, és további számításokat is végrehajthat a feltételektől függően. Több HA függvényt is egymásba ágyazhat, és így több összehasonlítást is végezhet.

A D2 cellában szereplő képlet a következő: =HA(C2>B2,”Költségvetést meghaladó”,”Költségvetésen belüli”)
  • =HA(C2>B2,”Költségvetésen belül”,”Költségvetést meghaladó”)

A fenti példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 nagyobb mint B2, akkor a „Költségvetést meghaladó”, ellenkező esetben a „Költségvetésen belüli” értéket adja vissza)

Az E2 cellában szereplő képlet a következő: =HA(C2>B2,C2-B2,"")
  • =HA(C2>B2;C2-B2;0)

A fenti ábrán szereplő képlet szöveges eredmény helyett egy matematikai számítást ad vissza. Tehát az E2 cellában lévő képlet a következőt jelenti: HA(A Tényleges nagyobb mint a Tervezett, akkor kivonja a tervezett összeget a tényleges összegből, ellenkező esetben nem ad vissza eredményt).

Az F7 cellában szereplő képlet a következő: HA(E7=”Igen”,F5*0.0825,0)
  • =HA(E7=”Igen”,F5*0.0825,0)

Ebben a példában az F7 cellában szereplő képlet a következőt jelenti: HA(E7 = “Igen”, akkor a teljes összeget kiszámítja az F5 * 8,25% számításban, ellenkező esetben nem esedékes értékesítési adó, ezért 0 az eredmény)

Megjegyzés: Ha szöveget szeretne használni a képletekben, a szöveget idézőjelekbe kell foglalni (például: "Szöveg"). Az egyetlen kivétel az IGAZ és a HAMIS érték használata, amelyet az Excel automatikusan megért.

Gyakori problémák

Probléma

A probléma oka

0 (nulla) egy cellában

Nincs megadva az érték_ha_igaz vagy az érték_ha_hamis argumentum. Ahhoz, hogy a megfelelő értéket adja vissza a képlet, adja meg mindkét argumentum szövegét, vagy adja meg az IGAZ vagy HAMIS értéket az argumentumban.

#NÉV? hiba egy cellában

Ez általában azt jelenti, hogy a képletben elírás van.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Műveleti jelek és elsőbbségi sorrend az Excelben

Függvények egymásba ágyazása a képletekben

A HA használata annak vizsgálatára, hogy egy cella üres-e

A HA használata annak vizsgálatára, hogy egy cella üres-e

Videó: HA függvények haladóknak

HAELSŐIGAZ függvény (Office 365, Excel 2016 és újabb)

HA függvények haladóknak – Munka egymásba ágyazott képletekkel, és a gyakori hibák elkerülése

Tanfolyamok videón: HA függvények haladóknak

DARABTELI függvény egyetlen feltételnek megfelelő értékek megszámlálásához

DARABHATÖBB függvény több feltételnek megfelelő értékek megszámlálásához

SZUMHA függvény egy feltételnek megfelelő értékek összesítéséhez

SZUMHATÖBB függvény több feltételnek megfelelő értékek összesítéséhez

ÉS függvény

VAGY függvény

FKERES függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

A képlethibák feltárása

Logikai függvények

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×