Függvények és beágyazott függvények használata Excel-képletekben

A függvények olyan előre definiált képletek, amelyek argumentumnak nevezett különleges értékek használatával számításokat hajtanak végre adott sorrendben vagy felépítés szerint. A függvények segítségével egyszerű vagy összetett számításokat is végezhet. Az Excel összes függvényét megtalálja a menüszalag Képletek lapján:

Az Excel Képletek lapja a menüszalagon
  • Az Excel függvényszintaxisa

    Az alábbi példa egy függvény szintaxisát szemlélteti. A példában a KEREKÍTÉS függvény az A10 cella értékét kerekíti.

    A függvény felépítése

    1. Struktúra. A függvény egyenlőségjellel (=) kezdődik, ezt követi a függvény neve, a nyitó zárójel, a függvény argumentumai egymástól pontosvesszővel elválasztva és a záró zárójel.

    2. A függvény neve. A függvények listájának megjelenítéséhez jelöljön ki egy cellát, és nyomja le a SHIFT+F3 billentyűkombinációt. Ezzel megnyitja a Függvény beszúrása párbeszédpanelt.

    Excel-képletek – Függvény beszúrása párbeszédpanel

    3. Argumentumok. Az argumentum lehet szám, szöveg, logikai érték (IGAZ vagy HAMIS), tömb, hibaérték (például #HIÁNYZIK) vagy cellahivatkozás. A megadott argumentumnak az adott argumentum számára érvényes értéket kell adnia. Az argumentumok lehetnek állandók, képletek vagy más függvények is.

    4. Argumentummagyarázat. A képlet beírásakor megjelenik a képlet szintaxisát és argumentumait összefoglaló elemleírás. A =KEREKÍTÉS( beírásakor például megjelenik az elemleírás. Az elemleírások csak a beépített függvényeknél jelennek meg.

    Megjegyzés: A függvényeket nem kell nagybetűvel beírnia (például =KEREKÍTÉS), mivel az Excel automatikusan nagybetűssé alakítja a függvény nevét, amint Ön lenyomja az Enter billentyűt. Ha elgépel valamit a függvény nevében, például a =SZUME(A1:A10) képletet írja be a =SZUM(A1:A10) helyett, az Excel #NÉV? hibát ad vissza.

  • Excel-függvények beírása

    Függvényt tartalmazó képlet létrehozásakor a Függvény beszúrása párbeszédpanel segítségével adhat meg munkalapfüggvényeket. Ha kiválaszt egy függvényt a Függvény beszúrása párbeszédpanelről, az Excel elindít egy függvényvarázslót, amely megjeleníti a függvény nevét, összes argumentumát, a függvény és argumentumai leírását, valamint a függvény és a teljes képlet aktuális eredményét.

    Az Excel függvényvarázslója

    A képletek egyszerűbb létrehozása és szerkesztése, illetve a beírási és szintaxishibák minimális szintre csökkentése érdekében érdemes bejelölni a Képletek automatikus kiegészítése jelölőnégyzetet. Amikor beír egy = jelet (egyenlőségjelet), majd megadja egy függvény kezdőbetűit, az Excel egy dinamikus legördülő listában megjeleníti a beírt betűknek megfelelő, érvényes függvényeket, argumentumokat és neveket. Ezután Ön választhat a legördülő listából egy elemet, amelyet az Excel beír Ön helyett.

    Az Excel automatikus képletkiegészítésének használata

  • Excel-függvények egymásba ágyazása

    Egyes esetekben a függvények argumentumaként más függvényeket is használhat. A következő képlet például beágyazott ÁTLAG függvényt használ, és az eredményt az 50 értékkel hasonlítja össze.

    Beágyazott függvény

    1. Az ÁTLAG és a SZUM függvény a HA függvénybe van ágyazva.

    Érvényes visszaadott értékek:    Amikor beágyazott függvényt argumentumként használ, a beágyazott függvénynek ugyanolyan típusú értéket kell adnia, amilyet az argumentum használ. Ha például az argumentum IGAZ vagy HAMIS értéket ad, a beágyazott függvénynek is IGAZ vagy HAMIS értéket kell visszaadnia. Ha a függvény nem ezt teszi, az Excel az #ÉRTÉK! hibaértéket jeleníti meg.

    A beágyazási szint határértéke:    Egy képlet legfeljebb hét egymásba ágyazott függvényszintet tartalmazhat. Amikor az egyik függvényt (a továbbiakban: B függvény) egy másik függvény (a továbbiakban: A függvény) argumentumaként használja, akkor a B függvény második szintű függvényként viselkedik. Az ÁTLAG és a SZUM függvény például második szintű, ha mindkettő a HA függvény argumentuma. Az ÁTLAG függvénybe ágyazott újabb függvény ennek megfelelően harmadik szintű függvény, és így tovább.

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×