Adatkapcsolat hozzáadása egy webszolgáltatásból

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

Az űrlapsablon, válassza a lekérdezés vagy webszolgáltatás adatok elküldése egy vagy több másodlagos adatkapcsolat vehet.

A témakör tartalma

– Áttekintés

Kompatibilitási kapcsolatos szempontok

Első lépések

Lekérdezés adatkapcsolat hozzáadása

Küldés adatkapcsolat hozzáadása

Áttekintés

Másodlagos adatkapcsolat bármely adatkapcsolat űrlapsablon hozzáadni kívánt külső adatforrás. Az adatkapcsolat eltér a fő adatkapcsolat adatbázis, webes szolgáltatás vagy adatkapcsolat beállításai alapján űrlapsablon tervezésekor létrehozott. Csak akkor, ha nem a lekérdezés és a legfontosabb adatok kapcsolaton keresztül adatok küldése másodlagos adatkapcsolat hozzáadása.

Ha egy másodlagos adatkapcsolat rendel az űrlapsablont, amelyet lekérdezések adatokat, a Microsoft Office InfoPath létrehoz egy másodlagos adatforrás adatmezők és a csoportok, amely megfelel a XML-séma webszolgáltatás. Másodlagos adatforrás az adatok struktúrájának meg kell egyeznie az XML-sémát, mert már meglévő mezők vagy a másodlagos adatforrás csoportok nem módosíthatók. Ha Küldés adatkapcsolat hozzáadása az űrlapsablonhoz, beállíthatja, hogy a felhasználók saját űrlapadatok az űrlapsablon, és a Küldés beállítását az űrlapsablon alapuló űrlapok.

Vissza a lap tetejére

Kompatibilitási kapcsolatos szempontok

Egy böngészőkompatibilis űrlapsablon engedélyezése a felhasználóknak, hogy a Küldés információkat űrlap adataik együtt átállítása fogadja el a Microsoft ADO.NET DataSet webszolgáltatás, nem lehet beállítani az adatkapcsolatot a Küldés gombra. Adatainak módosítása, ahol a felhasználó módosít egy adatbázisban tárolt adatokat a módosítások. Az adatbázis webes szolgáltatást használ, csatlakozott felhasználók az adatbázishoz. ADO.NET adatainak módosítása segítségével határozza meg, hogyan frissítheti az adatokat az adatbázisban. Kérje meg a webes szolgáltatás-rendszergazda, ha a webszolgáltatás szükséges-e frissíteni az adatbázis adatainak módosítása. Ha igen, tervezheti meg egy űrlapsablon, amelynek űrlapok kitölthető csak az InfoPath alkalmazással.

Vissza a lap tetejére

Előzetes tennivalók

Másodlagos adatkapcsolat hozzáadása az űrlapsablonhoz, mielőtt van szüksége a webes szolgáltatás-rendszergazda az alábbi adatokat:

  • A webszolgáltatás helyét.

  • A tartomány ellenőrzéséhez a webszolgáltatás, hogy a dokumentum/literál stílus kódolást használ. Az InfoPath igénybe vehet, csak a dokumentum/literál stílus webszolgáltatásokhoz.

  • A webszolgáltatási műveletet, amely elküldi az adatok vagy adatokat fogadjon ezen a sablonon alapuló űrlapok neve.

Vissza a lap tetejére

Lekérdezés adatkapcsolat hozzáadása

Felhasználói engedélyezéséhez lekérdezés adatok webszolgáltatásból űrlapsablon használatával kell az űrlapsablon az alábbiak:

  1. Másodlagos adatkapcsolat hozzáadásához.

  2. A másodlagos adatkapcsolat használata az űrlapsablon konfigurálása.

Lépés: 1: Adja hozzá a másodlagos adatkapcsolat

  1. Kattintson az eszközök menü Adatkapcsolatokat.

  2. Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadásgombra.

  3. Az Adatkapcsolat varázsló kattintson az Új kapcsolat létrehozása, kattintson az adatok fogadása, és kattintson a Tovább gombra.

  4. Csoportban, hogy honnan szeretne kapni az adatokkattintson a webes szolgáltatás , és kattintson a Tovább gombra.

  5. A varázsló következő lapján írja be a webszolgáltatás helyét, és kattintson a Tovább gombra.

    Megjegyzés: Ha-kiszolgálóval való univerzális leírás automatikus észlelés és Integration (UDDI) webszolgáltatás keresni szeretne, kattintson a Keresés UDDI, és írja be a használni kívánt szeretne keresni, adja meg, hogy szolgáltató vagy egy szolgáltatást keresés UDDI kiszolgáló URL adni, írja be a keresett szót, és kattintson a Keresésgombra. Webszolgáltatások, amelyek megegyeznek a keresett szót a Keresés eredménye listában fog megjelenni. Jelölje ki a használni kívánt webszolgáltatás, és kattintson az OKgombra.

  6. A varázsló következő lapján Válassza ki a műveletet listájában kattintson a webszolgáltatási műveletet, amely visszaadja a adatok az űrlapra, és kattintson a Tovább gombra.

  7. Az Adatkapcsolat varázsló ütközik a séma webszolgáltatás ismeretlen eleme, ha a varázsló következő lapján kérhetik adja meg az egyes paraméterek kattintva megállapíthatja, hogy mely mezők vagy csoportok hozzáadása a fő adatforrás mintaértékekre.

    Hogyan?

    1. Jelöljön ki egy paramétert a Paraméterek táblában, és kattintson a Minta érték beállításagombra.

    2. A minta érték mezőbe írja be egy értéket, hogy a felhasználó lehet használni ezt a mezőt, és kattintson az OKgombra.

    3. Ismételje meg az egyes paraméterek a Paraméterek táblában, és kattintson a Továbbgombra.

    Műszaki információk

    Az Adatkapcsolat varázslóból származó adatok webszolgáltatás konfigurálásakor a Microsoft Office InfoPath a webszolgáltatás csatlakozik, és kéri a Web Service leírás Language (WSDL) fájlt. WSDL fájl tartalmaz a séma a webes szolgáltatás által használt. A webszolgáltatás válaszol a kérést küld a InfoPath ezt a fájlt. Az InfoPath az adatokat használja ezt a fájlt a megfelelő mezők és csoportok hozzáadása a másodlagos adatforrás az űrlapsablon. Az InfoPath-ismeretlen elemtípus talál a WSDL-fájl, ha az InfoPath mintaadatok használja az ismeretlen elemtípus definícióját határozza meg, és hozzáadja a megfelelő mezőkre, és a csoportok a másodlagos adatforrás.

  8. Ha szeretné elérhetővé tenni, ha az űrlap nem hálózathoz csatlakozik a lekérdezés eredményeit, jelölje be a a tárolóban lévő adatok az űrlapsablon másolatának jelölőnégyzetet.

    Biztonsági megjegyzés: A lekérdezés eredményében a jelölőnégyzet bejelölésével az űrlapsablon tárol. Mivel az űrlapsablon tárolja az adatokat, érhető el a felhasználók kitöltése, a űrlapokat, ha a számítógépére nem kapcsolódik a hálózathoz. Ha bizalmas adatokat az adatkapcsolat származó, érdemes az adatok abban az esetben a számítógép elvész vagy ellopják védelme a funkció kikapcsolásához.

  9. Kattintson a Tovább gombra.

  10. A varázsló következő lapján írja be a lekérdezés adatkapcsolat leíró jellegű nevét.

  11. Ahhoz, hogy az adatok automatikusan fogadásához, amikor megnyitja őket az űrlapsablon alapuló űrlapokat, jelölje be a automatikusan beolvashatja az adatokat az űrlap ismételt megnyitásakor jelölőnégyzetet.

  12. Ellenőrizze, hogy az összefoglaló szakaszában helyes információk találhatók, és kattintson a Befejezésgombra.

  13. Kattintson a Bezárás gombra.

Lépés: 2: A másodlagos adatkapcsolat használata az űrlapsablon konfigurálása

Lekérdezés adatkapcsolat űrlapsablon beállításakor alapértelmezés szerint az ezen a sablonon alapuló űrlapok az Adatkapcsolat használata a felhasználó megnyitásakor. Beállíthatja, hogy az űrlapsablon a lekérdezés adatkapcsolat használata a következő módszerek egyikét:

  • Szabály hozzáadása    Beállíthatja, hogy egy szabályt, amely adatkapcsolattal a lekérdezési szabály a feltétel bekövetkezik.

  • A felvétele gombra    Az űrlapsablont, amelyet kattintva a felhasználók adatok beolvasása a lekérdezés adatkapcsolata vehet egy gombot.

  • Egyéni kód használata    Ha egy szabályt, vagy a gomb nem vehet fel, egyéni kódot segítségével adatok beolvasása a lekérdezés adatkapcsolata. Egyéni kódot használatához a fejlesztők egyéni kódot szeretne létrehozni.

Add a rule

Adatok beolvasása a lekérdezés adatkapcsolat, amikor a szabály a feltétel nem teljesül az űrlapsablont szabály vehet. A következő eljárás feltételezi, hogy egy lekérdezési kapcsolatot létrehozott űrlapsablonhoz, és a beállított egy vezérlőt az űrlapon megjeleníteni az adatokat az adott adatkapcsolat.

  1. Ha az űrlapsablon több nézet van, kattintson a Nézet menü megnyitásához a nézet és a vezérlő, amelyre a másodlagos adatforrás adatainak megjelenítéséhez kattintson a nézet nevére .

  2. Kattintson duplán a vezérlő, amely egy szabályt, amely a hozzáadni kívánt.

  3. Kattintson az Adatok fülre.

  4. Az Érvényesítés és szabályokcsoportban kattintson a szabályokelemre.

  5. A szabályok párbeszédpanelen kattintson a Hozzáadásgombra.

  6. A név mezőbe írja be a szabály nevét.

  7. A szabály futnia kell a megadott feltétel megadásához kattintson a Feltétel megadása, és írja be a feltétel. A szabály a feltétel bekövetkezésekor fog futni. Ha nem állít be egy feltétel, valahányszor a felhasználó megváltoztatja a vezérlő értékét, és kattintson a vezérlő távolabb partnerlistájukra kurzor áthelyezése a szabály futtathatók.

  8. Kattintson a művelet hozzáadásagombra.

  9. A művelet listában kattintson a lekérdezés adatkapcsolat használatával.

  10. Az Adatkapcsolat listában válassza a lekérdezés adatkapcsolatot, amely a használni kívánt, és kattintson az OK gombra kattintva zárja be az összes megnyitott párbeszédpanelen.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Gomb felvétele

Egy vezérlő is adhat az űrlapsablon erre kattintva a felhasználók adatok beolvasása a lekérdezés adatkapcsolat. A következő eljárás feltételezi, hogy az űrlapsablon lekérdezés adatkapcsolat létrehozott.

  1. Ha az űrlapsablon több nézet van, kattintson a Nézet menü megnyitásához a nézet és a vezérlő, amelyre a másodlagos adatforrás adatainak megjelenítéséhez kattintson a nézet nevére .

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. Húzzon egy vezérlő űrlapsablon.

  4. Kattintson duplán a közvetlenül a felvétele után az űrlapsablonon gombra.

  5. Kattintson az Általános fülre.

  6. A művelet listában kattintson a frissítésparancsra.

  7. A címke mezőbe írja be a nevet, amelyet meg szeretné jeleníteni a az űrlapon gombra.

  8. Kattintson a Beállítások ikonra.

  9. Kattintson egy másodlagos adatforrásfrissítése párbeszédpanelen.

  10. A másodlagos adatforrás kiválasztása listában kattintson a lekérdezés adatkapcsolat társított másodlagos adatforrás, és kattintson az OK gombra kattintva zárja be az összes megnyitott párbeszédpanelen.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Küldés adatkapcsolat hozzáadása

Ahhoz, hogy a felhasználók elküldése webszolgáltatásnak űrlapsablon alapuló űrlapok, először másodlagos adatkapcsolat hozzáadása űrlapsablonhoz elküldi az adatokat, és lehetővé teszi a felhasználóknak, hogy az adatok elküldése az űrlapsablont konfigurálnia.

Lépés: 1: Adja hozzá a másodlagos adatkapcsolat

  1. Kattintson az eszközök menü Adatkapcsolatokat.

  2. Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadásgombra.

  3. Az Adatkapcsolat varázsló kattintson az Új kapcsolat létrehozása, kattintson a Küldés adatok, és kattintson a Tovább gombra.

  4. A hogyan szeretné az adatokat küldenikattintson a webszolgáltatással , és kattintson a Tovább gombra.

  5. A varázsló következő lapján írja be a helyét a webes szolgáltatás, ahol a felhasználók fog elküldése adataikat, és kattintson a Tovább gombra.

    Megjegyzés: Ha-kiszolgálóval való univerzális leírás automatikus észlelés és Integration (UDDI) webszolgáltatás keresni szeretne, kattintson a Keresés UDDI, és írja be a használni kívánt szeretne keresni, adja meg, hogy szolgáltató vagy egy szolgáltatást keresés UDDI kiszolgáló URL adni, írja be a keresett szót, és kattintson a Keresésgombra. Webszolgáltatások, amelyek megegyeznek a keresett szót a Keresés eredménye listában fog megjelenni. Jelölje ki a használni kívánt webszolgáltatás, és kattintson az OKgombra.

  6. Válassza ki a műveletet listájában válassza a webszolgáltatási műveletet, amely az űrlap adatok fogadásához, majd kattintson a Továbbgombra.

  7. A varázsló következő lapján az űrlap elküldése az egyes paraméterek a webszolgáltatás az adatok kijelöléséhez tegye az alábbiak egyikét:

    Mező vagy csoport adatainak elküldése

    1. A Paraméterek listában kattintson a webszolgáltatási paraméter, amely az űrlapról származó adatokat kapja.

    2. A paraméter beállításokcsoportban kattintson a mező vagy csoport.

    3. Kattintson a Gombkép módosításagombra.

    4. A mező vagy csoport kijelölése párbeszédpanelen kattintson a mező vagy csoport, amelynek adatait el szeretné küldeni, és kattintson az OKgombra.

    5. Csak a szöveg és a gyermek elemek elküldése csak ez a mező és a gyermekelemek a mező vagy csoport adatait, vagy kattintson a XML-részfa, többek között a kijelölt elem elküldése a mező neve mezőben az adatokat a mezőben kattintson a jelölőnégyzetet, és a kijelölt csoport vagy a mező gyermekelemek.

    Az összes az űrlap adatainak elküldése

    1. A Paraméterek listában kattintson a webszolgáltatási paraméter, amely az űrlapról származó adatokat kapja.

    2. A paraméter beállításokcsoportban kattintson a teljes űrlap (XML-dokumentum, beleértve a feldolgozási utasítások).

    Az adatok elküldése karakterláncként

    1. A Paraméterek listában kattintson a webszolgáltatási paraméter, amely az űrlapról származó adatokat kapja.

    2. A paraméter beállításokcsoportban kattintson a teljes űrlap (XML-dokumentum, beleértve a feldolgozási utasítások).

    3. Jelölje be az adatok küldése karakterláncként jelölőnégyzetet.

      Megjegyzés: A szokásos jelölje be ezt a jelölőnégyzetet a digitálisan aláírt adatok elküldése. A legtöbb esetben törölje a jelet a jelölőnégyzetből.

    ADO.NET adatkészlet objektumokról műszaki megjegyzés

    Ha a webszolgáltatás ADO.NET adatkészlet objektum van szüksége, jelölje ki a adatkészlet csomópontot, ez az adatkapcsolat konfigurálásakor. Ha más típusú csomópont ADO.NET adatkészlet objektum igénylő webszolgáltatás adatkapcsolatot használ, a Küldés művelet sikertelen lesz.

  8. Kattintson a Tovább gombra.

  9. A varázsló következő lapján írja be a nevét az adatkapcsolatot a Küldés gombra.

  10. Ellenőrizze, hogy az összefoglaló szakaszában helyes információk találhatók, és kattintson a Befejezésgombra.

  11. Kattintson a Bezárás gombra.

Miután felvette a másodlagos elküldése származó adatok kell ahhoz, hogy a felhasználónak ennek használatával űrlap adataikat elküldése származó adatok elküldése űrlapsablon konfigurálása.

Lépés: 2: Az űrlapsablonon elküldése engedélyezése

Ha engedélyezni szeretné a űrlapadatok felhasználóknak az űrlapsablon állítja be, az InfoPath hozzáadja a szokásos eszköztár és a Küldés parancs a fájl menü az űrlapon Küldés gomb. Az alábbi módokon űrlapsablonhoz is szabhatja a küldési beállításokat:

  • Módosítsa a szöveget, amely akkor jelenik meg a Küldés gomb és a Küldés parancsot.

  • Módosítsa a billentyűparancsot, a Küldés gomb és a Küldés parancsot.

  • Hozzon létre egyéni üzenetek megjelenítése a felhasználóknak, ha az azok küldheti el a.

  • Adja meg, hogy az űrlap nyitva hagyja, zárja be az űrlapot, vagy nyisson meg egy másik üres űrlap, az űrlap elküldése után.

  • Kattintson az eszközök menü Beállítások elküldése.

  • Küldés beállításai párbeszédpanelen jelölje be a engedélyezése a felhasználóknak az űrlap elküldése jelölőnégyzetet, kattintson a Küldés célhelyének egyetlen űrlap adatainakgombra, és listájában válassza a Webszolgáltatás.

  • A Küldés gombra az Adatkapcsolat kiválasztása listában kattintson a Küldés gombra a webszolgáltatás az előző lépésekben létrehozott adatkapcsolatot nevére.

    1. A Küldés gomb, amely akkor jelenik meg a szokásos eszköztár és a Küldés parancs, amely megjelenik a fájl menü, ha az űrlapot kitöltő felhasználó nevét, írja be az új nevet a felirat mezőbe, kattintson a Küldés Beállítások párbeszédpanel.

      Tipp: Ha szeretne Billentyűparancs hozzárendelése gomb és a parancsot, írja be az egy és jel (&) billentyűparancs használni kívánt karakter elé. ALT + B hozzárendelni, a billentyűparancs: a Küldés gomb és a parancsot, írja be például a & Küldés.

  • Ha nem szeretné, hogy melyikkel a Küldés parancs vagy a Küldés gombra a szokásos eszköztáron az űrlap kitöltésére személyek, törölje a jelet a Küldés parancsot, és a Küldés gombot megjelenítése jelölőnégyzetet.

    1. Alapértelmezés szerint, űrlap elküldése után a InfoPath továbbra is nyissa meg az űrlapot, és jelezheti, ha az űrlap sikerült elküldeni az üzenetet jeleníti meg. Ha módosítani szeretné az elrendezést, kattintson a Speciálisgombra, és végezze el az alábbiak egyikét:

      • Zárja be az űrlapot, vagy hozzon létre egy új üres űrlap, a kész űrlap elküldése után, kattintson a elküldése után listában a kívánt beállításra.

      • Hozzon létre egy egyéni üzenet jelzi, ha az űrlap sikerült elküldeni, jelölje be az egyéni üzenetek használata jelölőnégyzetet, és írja be üzeneteit a sikeres és sikertelen a mezőben.

        Tipp: A hiba esetén mezőben üzenetet használni állapítható meg, hogy a felhasználók Mi a teendő, ha az azok nem tudja elküldeni az űrlapot. Ha például, hogy a felhasználók mentse az űrlapot, és további utasításokért névjegy is javasolja.

      • Ha nem szeretne megjeleníteni egy üzenetet, az űrlap elküldése után, törölje a jelet a sikeres és sikertelen üzenetek megjelenítése jelölőnégyzetből.

Vissza a lap tetejére

Office-ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×