Adatkapcsolat hozzáadása a Microsoft SQL Server-adatbázishoz

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

Másodlagos adatkapcsolat vehet űrlapsablonhoz kérdezi le a Microsoft SQL Server-adatbázishoz. Másodlagos adatkapcsolat nem hozzáadása űrlapsablonhoz elküld űrlap adatainak egy adatbázist. Ha szeretne egy másodlagos adatkapcsolat használata űrlapadatok adatbázishoz, használja a másodlagos adatkapcsolat elküldése webszolgáltatásnak az adott adatbázis használható. További információt a másodlagos adatkapcsolat hozzáadása egy webszolgáltatásból a Lásd még szakasz hivatkozásait.

Másodlagos adatkapcsolat hozzáadása az adatbázishoz, hogy el kell végeznie az alábbiakat:

Lépés 1: másodlagos adatkapcsolat hozzáadása az űrlapsablonhoz    Ebben a lépésben a másodlagos adatforrás hoz létre a megfelelő mezőket és a csoportok a úgy, hogy az adatbázisban tárolt-e a adatok alapján. Az adatkapcsolat használatára, amikor először nyitja meg a képernyő űrlapok engedélyezése az űrlapsablont is beállítható.

2 lépés: az Adatkapcsolat használata az űrlapsablon konfigurálása    Ha azt szeretné, hogy a felhasználók az adatkapcsolat használatára, az űrlap megnyitása után, vehet egy szabályt, vagy a gomb az űrlapsablont felhasználóimnak, hogy az adatok beolvasása az adatkapcsolat.

A témakör tartalma

– Áttekintés

Első lépések

Lépés: 1: Adja hozzá a másodlagos adatkapcsolat

Lépés: 2: Az Adatkapcsolat használata az űrlapsablon konfigurálása

Áttekintés

Ha egy külső adatforrással alapuló űrlapsablon, a Microsoft Office InfoPath hoz létre fő adatkapcsolat adott külső adatforráshoz. Az InfoPath létrehozza a fő adatforrás az űrlapsablon a úgy, hogy adatokat tárolja a külső adatforrás alapján. A külső adatforrás használt fő adatkapcsolat azonban nem lehet az űrlapsablonon található vezérlősablon a vezérlők elhelyezni kívánt értékeket. Ezek az értékek egy másik külső adatforrásból, például SQL Server-adatbázishoz is szerepel. Úgy juthat az értékek egy másik külső adatforrásból, felveheti az űrlapsablon másodlagos adatkapcsolat.

Másodlagos adatkapcsolat egy űrlapsablon hozzáadni kívánt kapcsolatot. Az adatkapcsolat lekérdezés adatkapcsolat vagy a Küldés adatkapcsolat lehet. Lekérdezés adatkapcsolat csak a másodlagos adatkapcsolat SQL Server-adatbázishoz, felveheti az űrlapsablon. Az adatkapcsolat csak akkor, ha nem a fő adatkapcsolat egy külső adatforrásból származó adatokat kell hozzá. Másodlagos adatkapcsolat, Küldés adatkapcsolat nem hozzáadása az SQL Server-adatbázishoz.

Lekérdezés adatkapcsolat-adatbázishoz való hozzáadásakor InfoPath létrehoz egy másodlagos adatforrás adatmezők és a csoportok, amely megfelel módon, hogy az adatokat az adatbázisban vannak tárolva. Másodlagos adatforrás az adatok struktúrájának meg kell egyeznie a úgy, hogy az adatok az adatbázistáblák van tárolva, mert a mezők és a másodlagos adatforrás csoportok nem módosíthatók. Beállíthatja, hogy minden lekérdezés származó adatok mentse az eredményeket, hogy a felhasználó fér hozzá az adatokat az űrlap kapcsolat nélkül hálózathoz. Attól függően, hogy az adatok jellegét érdemes a lekérdezés eredményének megjelenítése, csak akkor, amikor a felhasználók a hálózathoz csatlakozik.

Biztonsági megjegyzés: Másodlagos adatkapcsolat használatával külső adatforrásból kényes adatok beolvasásához, ha ez a funkció védelmet az adatok jogosulatlanul felhasználja abban az esetben a számítógép elvész vagy ellopják letiltása érdemes. Ha letiltja ezt a szolgáltatást, az adatok érhetők el csak akkor, ha a felhasználó a hálózathoz csatlakozik.

Lekérdezés adatkapcsolat űrlapsablon beállításakor alapértelmezés szerint az ezen a sablonon alapuló űrlapok az Adatkapcsolat használata a felhasználó megnyitásakor. Beállíthatja, hogy az űrlapsablon a lekérdezés adatkapcsolat használata a következő módszerek egyikét:

  • Szabály hozzáadása    Beállíthatja, hogy egy szabályt, amely adatkapcsolattal a lekérdezési szabály a feltétel bekövetkezik.

  • A felvétele gombra    Az űrlapsablont, amelyet kattintva a felhasználók adatok beolvasása a lekérdezés adatkapcsolata vehet egy gombot.

  • Egyéni kód használata    Ha egy szabályt, vagy a gomb nem vehet fel, egyéni kódot segítségével adatok beolvasása a lekérdezés adatkapcsolata. Egyéni kódot használatához a fejlesztők egyéni kódot szeretne létrehozni.

Vissza a lap tetejére

Előzetes tennivalók

Mielőtt SQL Server-adatbázis másodlagos adatkapcsolat hozzáadása az űrlapsablonhoz, az adatbázis-rendszergazdától kell az alábbi adatokat:

  • Ezzel a sablonnal használni kívánt adatbázis-kezelő kiszolgáló neve.

  • Az ezzel a sablonnal használni kívánt adatbázis neve.

  • A hitelesítés követel meg az adatbázist. Az adatbázis segítségével a Microsoft Windows-hitelesítés vagy SQL Server-hitelesítés határozza meg, hogyan felhasználók hozzá tudnak férni az adatbázist.

  • Az űrlaphoz elküldeni kívánt adatokat tartalmazó tábla neve. Ez az elsődleges táblához. Ha egynél több táblázat használata az adatbázisban, a személyek neve más, a gyermek táblák van szükség. A mezők a gyermek táblázatokban, amelynek van kapcsolata, a mezőkre, az elsődleges tábla nevét is szükséges.

  • E biztonságosan tárolhatja a lekérdezés eredményében a kapcsolat nélküli használatra a képernyőn.

Vissza a lap tetejére

Lépés: 1: Adja hozzá a másodlagos adatkapcsolat

  1. Kattintson az eszközök menü Adatkapcsolatokat.

  2. Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadásgombra.

  3. Az Adatkapcsolat varázsló kattintson az Új kapcsolat létrehozása, kattintson az adatok fogadása, és kattintson a Tovább gombra.

  4. A varázsló következő lapján kattintson az adatbázis (Microsoft SQL Server vagy a Microsoft Office Access), és kattintson a Tovább gombra.

  5. A varázsló következő lapján az Adatbázis kijelölésegombra.

  6. Az adatforrás kijelölése párbeszédpanelen kattintson az Új forrás.

  7. Milyen típusú adatforrás szeretne csatlakozni listájában kattintson A Microsoft SQL Serverparancsra, és kattintson a Tovább gombra.

  8. A kiszolgáló neve mezőbe írja be az adatbázis-kezelő kiszolgáló neve.

  9. Jelentkezzen be a hitelesítő adatokcsoportban tegye az alábbiak egyikét:

    • Ha az adatbázis határozza meg, hogy kik férhetnek hozzá a használt Microsoft Windows hálózati hitelesítő adatok alapján, kattintson a Windows-hitelesítés használata.

    • Ha az adatbázis határozza meg, hogy kinek van hozzáférése egy megadott felhasználónevet és jelszót, amely az adatbázis-adminisztrátorhoz el alapján, jelölje be az alábbi felhasználónév és jelszó használata, és írja be felhasználónevét és jelszavát a Felhasználónév és a Jelszó jelölőnégyzetét.

  10. Kattintson a Tovább gombra.

  11. A varázsló a listájában Jelölje ki a kívánt adatokat tartalmazó adatbázist , a következő lapon kattintson az adatbázist, amely azt szeretné, jelölje be a Csatlakozás az adott táblázat jelölőnégyzetet, kattintson az elsődleges tábla nevére, és kattintson a Tovább gombra .

  12. A Fájlnév mezőbe, a varázsló következő lapján írja be egy nevet a fájlnak, amely a kapcsolat adatait tárolja.

  13. Ezek a beállítások mentéséhez kattintson a Befejezés gombra.

  14. Adja hozzá a táblázatokat, a lekérdezés adatkapcsolat használni kívánt.

    Hogyan?

    1. Kattintson a táblázat hozzáadásagombra.

    2. Tábla vagy lekérdezés hozzáadása párbeszédpanelen kattintson a gyermek táblázat nevére, és kattintson a Tovább gombra. Az InfoPath próbálja meg a kapcsolatok mindkét táblát Mezőnevek egyeztetése. Ha nem szeretné, hogy a javasolt kapcsolat használni, jelölje ki a kapcsolatot, és válassza a Kapcsolat eltávolítása. Kapcsolat hozzáadásához kattintson a Kapcsolat hozzáadásaelemre. Kapcsolat hozzáadása párbeszédpanelen kattintson a megfelelő oszlopban minden kapcsolódó mező nevét, és kattintson az OKgombra.

    3. Kattintson a Befejezés gombra.

    4. További alárendelt táblák hozzáadásához ismételje meg ezeket a lépéseket.

  15. Kattintson a Tovább gombra.

  16. Elérhetővé szeretné tenni az adatkapcsolatot a lekérdezés eredményeit, amikor a képernyőn nem hálózathoz csatlakozik, jelölje be a tárolóban lévő adatok az űrlapsablon másolatának jelölőnégyzetet.

    Biztonsági megjegyzés: A felhasználó számítógépén a jelölőnégyzet bejelölésével az adatokat tárolja, amikor a képernyő használja az adatkapcsolat. Ha az űrlap kényes adatok lekérése az adatkapcsolat, érdemes letiltani ezt a funkciót, az adatok abban az esetben a számítógép elvész vagy ellopják védelmet.

  17. Kattintson a Tovább gombra.

  18. A varázsló következő lapján írja be a másodlagos adatkapcsolat leíró neve. Ha azt szeretné, hogy az űrlap az űrlap megnyitásakor automatikusan letöltse a szükséges adatokat, jelölje be a automatikusan beolvashatja az adatokat az űrlap ismételt megnyitásakor jelölőnégyzetet.

Vissza a lap tetejére

Lépés: 2: Az Adatkapcsolat használata az űrlapsablon konfigurálása

Ha azt szeretné, hogy a az űrlapsablon után a felhasználó megnyitja az űrlapot az adatkapcsolat használandó alapuló űrlapokat, szabály hozzáadása az űrlapsablont, amelyet az adatkapcsolat feltételek teljesülése esetén használja, vagy gomb felvétele az, hogy a felhasználók is cli űrlapsablon az adatkapcsolat használatára CK.

Add a rule

Adatok beolvasása a lekérdezés adatkapcsolat, amikor a szabály a feltétel nem teljesül az űrlapsablont szabály vehet. A következő eljárás feltételezi, hogy egy lekérdezési kapcsolatot létrehozott űrlapsablonhoz, és a beállított egy vezérlőt az űrlapon megjeleníteni az adatokat az adott adatkapcsolat.

  1. Ha az űrlapsablon több nézet van, kattintson a Nézet menü megnyitásához a nézet és a vezérlő, amelyre a másodlagos adatforrás adatainak megjelenítéséhez kattintson a nézet nevére .

  2. Kattintson duplán a vezérlő, amely egy szabályt, amely a hozzáadni kívánt.

  3. Kattintson az Adatok fülre.

  4. Az Érvényesítés és szabályokcsoportban kattintson a szabályokelemre.

  5. A szabályok párbeszédpanelen kattintson a Hozzáadásgombra.

  6. A név mezőbe írja be a szabály nevét.

  7. A szabály futnia kell a megadott feltétel megadásához kattintson a Feltétel megadása, és írja be a feltétel. A szabály a feltétel bekövetkezésekor fog futni. Ha nem állít be egy feltétel, valahányszor a felhasználó megváltoztatja a vezérlő értékét, és kattintson a vezérlő távolabb partnerlistájukra kurzor áthelyezése a szabály futtathatók.

  8. Kattintson a művelet hozzáadásagombra.

  9. A művelet listában kattintson a lekérdezés adatkapcsolat használatával.

  10. Az Adatkapcsolat listában válassza a lekérdezés adatkapcsolatot, amely a használni kívánt, és kattintson az OK gombra kattintva zárja be az összes megnyitott párbeszédpanelen.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Gomb felvétele

Egy vezérlő is adhat az űrlapsablon erre kattintva a felhasználók adatok beolvasása a lekérdezés adatkapcsolat.

  1. Ha az űrlapsablon több nézet van, kattintson a Nézet menü megnyitásához a nézet és a vezérlő, amelyre a másodlagos adatforrás adatainak megjelenítéséhez kattintson a nézet nevére .

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. Húzzon egy vezérlő űrlapsablon.

  4. Kattintson duplán a közvetlenül a felvétele után az űrlapsablon ikonja.

  5. Kattintson az Általános fülre.

  6. A művelet listában kattintson a frissítésparancsra.

  7. A címke mezőbe írja be a nevet, amelyet meg szeretné jeleníteni a az űrlapon gombra.

  8. Kattintson a Beállítások ikonra.

  9. Kattintson egy másodlagos adatforrásfrissítése párbeszédpanelen.

  10. A másodlagos adatforrás kiválasztása listában kattintson a lekérdezés adatkapcsolat társított másodlagos adatforrás.

  11. Kattintson az OK gombra az összes megnyitott párbeszédpanel bezárásához.

  12. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×