VAGY függvény

A logikai függvények közé tartozó VAGY függvénnyel megállapítható, hogy a feltételek bármelyike IGAZ értékű-e.

Példa

Példák a VAGY függvény használatára.

A VAGY függvény az IGAZ értéket adja vissza, ha bármely argumentumának IGAZ az értéke, és a HAMIS értéket adja vissza, ha az összes argumentum HAMIS értékű.

A VAGY függvény egyik leggyakoribb szerepe más, logikai vizsgálatokat végrehajtó függvények hasznosságának kiterjesztése. A HA függvény például egy logikai vizsgálatot végez, és IGAZ eredmény esetén egy adott értéket, HAMIS eredmény esetén pedig egy másik értéket ad vissza. Ha a VAGY függvényt használja fel a HA függvény logikai_vizsgálat argumentumaként, akkor nem csak egy, hanem egyszerre több különböző feltételt vizsgálhat.

Szintaxis

VAGY(logikai1; [logikai2]; ...)

A VAGY függvény szintaxisa az alábbi argumentumokat foglalja magában:

Argumentum

Leírás

logikai1

Megadása kötelező. Az első vizsgálandó feltétel, amelynek IGAZ vagy HAMIS értéket kell adnia.

logikai2; ...

Megadása nem kötelező. További vizsgálandó feltételek, amelyeknek IGAZ vagy HAMIS értéket kell adniuk. Legfeljebb 255 feltétel adható meg.

Megjegyzések

  • Az argumentumok kiértékelésének eredménye csak logikai érték (például IGAZ vagy HAMIS), illetve logikai értékeket tartalmazó tömb vagy hivatkozás lehet.

  • Ha egy tömb vagy hivatkozás argumentum szöveget vagy üres cellát tartalmaz, akkor ezeket az értékeket figyelmen kívül hagyja a program.

  • Ha a megadott tartomány egyetlen logikai értéket sem tartalmaz, akkor a VAGY függvény visszatérési értéke az #ÉRTÉK! hibaérték lesz.

  • A VAGY függvényt tömbképletben használva megvizsgálhatja, hogy egy érték előfordul-e a tömbben. Tömbképletet a CTRL+SHIFT+ENTER billentyűkombinációval írhat be.

Példák

Az alábbiakban általános jellegű példákat adunk a VAGY függvény önálló, illetve HA függvénnyel együttes használatára.

Példák a VAGY függvény HA függvénnyel való használatára.

Képlet

Leírás

=VAGY(A2>1;A2<100)

Eredménye akkor IGAZ, ha az A2 cella értéke 1-nél nagyobb VAGY 100-nál kisebb. Minden más esetben a HAMIS értéket adja eredményül.

=HA(VAGY(A2>1;A2<100);A3,"Az érték tartományon kívül esik")

Az A3 cellában lévő értéket jeleníti meg, ha az nagyobb 1-nél VAGY kisebb 100-nál. Ellenkező esetben „Az érték a tartományon kívül esik” üzenetet jeleníti meg.

=HA(VAGY(A2<0;A2>50);A2,"Az érték tartományon kívül esik")

Az A2 cellában lévő értéket jeleníti meg, ha az kisebb 0-nál VAGY nagyobb 50-nél. Ellenkező esetben „Az érték a tartományon kívül esik” üzenetet jeleníti meg.

Értékesítési jutalék kiszámítása

A következő példa azt szemlélteti, hogy miként számítható ki az értékesítők jutaléka a HA és a VAGY függvénnyel.

Példa a HA és a VAGY függvény együttes használatára értékesítési jutalék kiszámításához.
  • =HA(VAGY(B14>=$B$4;C14>=$B$5);B14*$B$6;0)HA az összforgalom nagyobb vagy egyenlő (>=), mint az értékesítési célérték VAGY az ügyfélszerzések száma nagyobb vagy egyenlő (>=), mint az ügyfélszerzési célérték, akkor az összforgalom szorzása a jutalék százalékos értékével, minden más esetben a 0 érték visszaadása.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Kapcsolódó témakörök

Videó: HA függvények haladóknak
Függvények egymásba ágyazása a képletekben
HA függvény
ÉS függvény
NEM függvény
Az Excel képleteinek áttekintése
Hibás képletek kiküszöbölése
A képlethibák feltárása az Excel 2016-ban
A Windows Excel 2016 billentyűparancsai
A Mac Excel 2016 billentyűparancsai
Logikai függvények (segédlet)
Az Excel függvényeinek betűrendes listája
Az Excel függvényeinek kategória szerinti listája

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×